# Support

**URL:** https://meta.discourse.org/c/support/6.md?page=895

[Latest](https://meta.discourse.org/latest.md) · [Categories](https://meta.discourse.org/categories.md) · [Tags](https://meta.discourse.org/tags.md)

**Page:** 896

---

## [Pups failure when rebuilding with Adsense plugin](https://meta.discourse.org/t/pups-failure-when-rebuilding-with-adsense-plugin/28783)

<div class="topic-metadata">

**Author:** [@jamesmarkcook](https://meta.discourse.org/u/jamesmarkcook)\
**Replies:** 4\
**Last updated:** [May 13, 2015, 8:02pm UTC](https://meta.discourse.org/t/pups-failure-when-rebuilding-with-adsense-plugin/28783 "2015-05-13T20:02:02Z")

</div>

I encountered an error when trying to upgrade my forum yesterday from the admin panel so tried rebuilding the container just now from the command line. I’m getting a failure with rake assets:precompile and it tells me th…

---

## [Email domain blacklist with wildcards](https://meta.discourse.org/t/email-domain-blacklist-with-wildcards/28627)

<div class="topic-metadata">

**Author:** [@Alex\_Harrington](https://meta.discourse.org/u/Alex_Harrington)\
**Replies:** 8\
**Last updated:** [May 13, 2015, 12:21pm UTC](https://meta.discourse.org/t/email-domain-blacklist-with-wildcards/28627 "2015-05-13T12:21:37Z")

</div>

Hi I’m trying to block email addresses from a particular domain - from which we seem to receive multiple spam user accounts per hour sigining up. They come from .jil.kr where can be one of some 20 or so names I’ve see…

---

## [Redundant Discourse Hosting on AWS](https://meta.discourse.org/t/redundant-discourse-hosting-on-aws/28358)

<div class="topic-metadata">

**Author:** [@bboyle1234](https://meta.discourse.org/u/bboyle1234)\
**Replies:** 14\
**Last updated:** [May 13, 2015, 11:56am UTC](https://meta.discourse.org/t/redundant-discourse-hosting-on-aws/28358 "2015-05-13T11:56:59Z")

</div>

I initially intended to host my forum in a way that is protected against server hardware failure by having it hosted in AWS in the following way: RDS for PostGres, Elasticache for Redis, S3 for user uploads 2 docker …

---

## [Broken link in documentation?](https://meta.discourse.org/t/broken-link-in-documentation/28756)

<div class="topic-metadata">

**Author:** [@brucellino](https://meta.discourse.org/u/brucellino)\
**Replies:** 1\
**Last updated:** [May 13, 2015, 10:01am UTC](https://meta.discourse.org/t/broken-link-in-documentation/28756 "2015-05-13T10:01:04Z")

</div>

Hi all, I’m trying to find out how to configure the upload of various kinds of files ( something which we will need ), and I followed the docs in docker/docker to https://github.com/discourse/discourse/blob/master/admin…

---

## [Migration failure PG::UndefinedObject: ERROR: type "json" does not exist](https://meta.discourse.org/t/migration-failure-pg-error-type-json-does-not-exist/28751)

<div class="topic-metadata">

**Author:** [@mugli](https://meta.discourse.org/u/mugli)\
**Replies:** 5\
**Last updated:** [May 13, 2015, 9:37am UTC](https://meta.discourse.org/t/migration-failure-pg-error-type-json-does-not-exist/28751 "2015-05-13T09:37:09Z")

</div>

Hi, I’m still on a non-docker discourse. I was trying to upgrade to v1.3.0.beta9 from v1.3.0.beta3 (following this guide: https://github.com/discourse/discourse/blob/master/docs/INSTALL-ubuntu.md) and facing this error …

---

## [Upgraded but admin page says out of date](https://meta.discourse.org/t/upgraded-but-admin-page-says-out-of-date/28672)

<div class="topic-metadata">

**Author:** [@multicam](https://meta.discourse.org/u/multicam)\
**Replies:** 21\
**Last updated:** [May 12, 2015, 10:33pm UTC](https://meta.discourse.org/t/upgraded-but-admin-page-says-out-of-date/28672 "2015-05-12T22:33:52Z")

</div>

Hi there, I just received the email for the upgrade to 1.3.0.beta8. Followed the procedure, and now the admin panel still shows that an upgrade is available, but the upgrade page states that it’s all OK. See attached s…

---

## [A red smile means upgrade?](https://meta.discourse.org/t/a-red-smile-means-upgrade/28676)

<div class="topic-metadata">

**Author:** [@watchmanmonitor](https://meta.discourse.org/u/watchmanmonitor)\
**Replies:** 1\
**Last updated:** [May 12, 2015, 4:07am UTC](https://meta.discourse.org/t/a-red-smile-means-upgrade/28676 "2015-05-12T04:07:05Z")

</div>

Continuing the discussion from Upgraded but admin page says out of date: Anyone else think a red “meh” is better than a red smile here: https://github.com/discourse/discourse/pull/3436

---

## [Emails sent from discourse are mis-categorized as "Promotional" in gmail](https://meta.discourse.org/t/emails-sent-from-discourse-are-mis-categorized-as-promotional-in-gmail/28524)

<div class="topic-metadata">

**Author:** [@phi](https://meta.discourse.org/u/phi)\
**Replies:** 3\
**Last updated:** [May 12, 2015, 1:55am UTC](https://meta.discourse.org/t/emails-sent-from-discourse-are-mis-categorized-as-promotional-in-gmail/28524 "2015-05-12T01:55:04Z")

</div>

Hello, email sent from our (hosted) discourse instance seem to always appear in the “Promotion” tab of our user’s gmail account which ends up being confusing for most of them. There have been a few topics about this iss…

---

## [Don't claim support for Ruby 2.0](https://meta.discourse.org/t/dont-claim-support-for-ruby-2-0/28595)

<div class="topic-metadata">

**Author:** [@palant](https://meta.discourse.org/u/palant)\
**Replies:** 5\
**Last updated:** [May 11, 2015, 11:21am UTC](https://meta.discourse.org/t/dont-claim-support-for-ruby-2-0/28595 "2015-05-11T11:21:26Z")

</div>

Install document currently says: Ruby 2.0+ (we recommend 2.0.0-p353 or higher) Actually, Ruby 2.0.0 won’t work. When I tried I got an error from the Sidekiq gem: uninitialized constant Sidekiq::Sinatra This was c…

---

## [Average 'payload' size per pageview (to calculate bandwidth needs)](https://meta.discourse.org/t/average-payload-size-per-pageview-to-calculate-bandwidth-needs/28600)

<div class="topic-metadata">

**Author:** [@purldator](https://meta.discourse.org/u/purldator)\
**Replies:** 3\
**Last updated:** [May 11, 2015, 1:26am UTC](https://meta.discourse.org/t/average-payload-size-per-pageview-to-calculate-bandwidth-needs/28600 "2015-05-11T01:26:09Z")

</div>

I, in my constant yak shaving, have mentally conjured a hypothetical formula to ballpark a possible bandwidth figure. This is so I can anticipate bandwidth costs. For me, it’s better to get some idea of what I may be u…

---

## [Which IP should I point in \`containers/app.yml\` for installing on a local host?](https://meta.discourse.org/t/which-ip-should-i-point-in-containers-app-yml-for-installing-on-a-local-host/28534)

<div class="topic-metadata">

**Author:** [@diff](https://meta.discourse.org/u/diff)\
**Replies:** 6\
**Last updated:** [May 9, 2015, 10:19pm UTC](https://meta.discourse.org/t/which-ip-should-i-point-in-containers-app-yml-for-installing-on-a-local-host/28534 "2015-05-09T22:19:44Z")

</div>

I’m going to install Discourse on my machine to test and customize it. I want it to be installed on my machine and run from it. I don’t need it be on the internet somewhere. Now, I’m confused in this step: When it…

---

## [Empty page with strange entries in logs](https://meta.discourse.org/t/empty-page-with-strange-entries-in-logs/28511)

<div class="topic-metadata">

**Author:** [@staticinvocation](https://meta.discourse.org/u/staticinvocation)\
**Replies:** 5\
**Last updated:** [May 9, 2015, 2:38am UTC](https://meta.discourse.org/t/empty-page-with-strange-entries-in-logs/28511 "2015-05-09T02:38:54Z")

</div>

Hi, I’ve had a Discourse forum running for about a month now, but today I woke up with the forum returning a completely blank page. Restarting the docker instance did not fix the issue. I tried running ./launcher rebu…

---

## [Edit Category Button and New Category Button not working](https://meta.discourse.org/t/edit-category-button-and-new-category-button-not-working/28475)

<div class="topic-metadata">

**Author:** [@Eric\_Hoxworth](https://meta.discourse.org/u/Eric_Hoxworth)\
**Replies:** 12\
**Last updated:** [May 8, 2015, 7:28pm UTC](https://meta.discourse.org/t/edit-category-button-and-new-category-button-not-working/28475 "2015-05-08T19:28:32Z")

</div>

I have a production instance and testing instance, both at 1.3.0.beta7, and on both, as an admin, I cannot edit a category or create a new category. When the edit category or create category buttons are clicked, the tra…

---

## [Bulk file uploads (for migration)](https://meta.discourse.org/t/bulk-file-uploads-for-migration/28402)

<div class="topic-metadata">

**Author:** [@4ZM](https://meta.discourse.org/u/4ZM)\
**Replies:** 2\
**Last updated:** [May 8, 2015, 6:17am UTC](https://meta.discourse.org/t/bulk-file-uploads-for-migration/28402 "2015-05-08T06:17:12Z")

</div>

We almost managed to migrate from Vanilla to discourse. Unfortunately the migration script didn’t handle attachments. Manually uploading all files and creating a “here is a list of all old attachments”-post with links t…

---

## [Cheapest Hosting Option?](https://meta.discourse.org/t/cheapest-hosting-option/28484)

<div class="topic-metadata">

**Author:** [@nahtnam](https://meta.discourse.org/u/nahtnam)\
**Replies:** 3\
**Last updated:** [May 8, 2015, 7:49am UTC](https://meta.discourse.org/t/cheapest-hosting-option/28484 "2015-05-08T07:49:58Z")

</div>

Hey! I was wondering what the cheapest option is to host Discourse. I have seen a lot of sites that say 6gb of ram for $5-10 per month (http://vpsdime.com/) but they never end up having the correct version of kernel. T…

---

## [Have url for creating topic with specific title](https://meta.discourse.org/t/have-url-for-creating-topic-with-specific-title/28327)

<div class="topic-metadata">

**Author:** [@Rene](https://meta.discourse.org/u/Rene)\
**Replies:** 7\
**Last updated:** [May 7, 2015, 5:13am UTC](https://meta.discourse.org/t/have-url-for-creating-topic-with-specific-title/28327 "2015-05-07T05:13:32Z")

</div>

Hey guys, When we release a new version of our software we need to post an announcement to our forum like I did now manually at Gradle 2.4 released - Build Tool - Gradle Forums Before moving to discourse we used getsat…

---

## [What's wrong with this CSS?](https://meta.discourse.org/t/whats-wrong-with-this-css/28391)

<div class="topic-metadata">

**Author:** [@Erik\_Manger](https://meta.discourse.org/u/Erik_Manger)\
**Replies:** 4\
**Last updated:** [May 6, 2015, 8:31pm UTC](https://meta.discourse.org/t/whats-wrong-with-this-css/28391 "2015-05-06T20:31:51Z")

</div>

Hi, I have a CSS code for Discourse backgrounds. The problem is, when I scroll down, the image doesn’t scroll down - rather, a white background appears and covers the wallpaper… html, body { height: 100%; } //…

---

## [How to enable private messages?](https://meta.discourse.org/t/how-to-enable-private-messages/28394)

<div class="topic-metadata">

**Author:** [@Alex\_Flom](https://meta.discourse.org/u/Alex_Flom)\
**Replies:** 4\
**Last updated:** [May 6, 2015, 7:25pm UTC](https://meta.discourse.org/t/how-to-enable-private-messages/28394 "2015-05-06T19:25:27Z")

</div>

On meta.discourse.org when clicking on a user’s avatar, there is a blue button called ‘message’ , but there is no such message on my installation, and couldn’t find where to enable it…

---

## [Setting up sub-domain in cPanel](https://meta.discourse.org/t/setting-up-sub-domain-in-cpanel/28354)

<div class="topic-metadata">

**Author:** [@Erik\_Manger](https://meta.discourse.org/u/Erik_Manger)\
**Replies:** 3\
**Last updated:** [May 5, 2015, 8:11pm UTC](https://meta.discourse.org/t/setting-up-sub-domain-in-cpanel/28354 "2015-05-05T20:11:32Z")

</div>

Hi, I have a dedicated server from Namecheap and am trying to pair the forum.domain.com within cPanel. How would I do this through DNS editor? I have a Digital Hosting plan hosting the forum itself.

---

## [Redacted sensitive data - still visible in post history?](https://meta.discourse.org/t/redacted-sensitive-data-still-visible-in-post-history/28079)

<div class="topic-metadata">

**Author:** [@dandv](https://meta.discourse.org/u/dandv)\
**Replies:** 9\
**Last updated:** [May 5, 2015, 5:41pm UTC](https://meta.discourse.org/t/redacted-sensitive-data-still-visible-in-post-history/28079 "2015-05-05T17:41:55Z")

</div>

The ability to see a post’s edit history is great for ensuring credibility, as defined in the Muut manifesto. However, if a user has mistakenly included sensitive data (real names, accounts, passwords etc.) in a post an…

---

## [Error in installing](https://meta.discourse.org/t/error-in-installing/28299)

<div class="topic-metadata">

**Author:** [@Erik\_Manger](https://meta.discourse.org/u/Erik_Manger)\
**Replies:** 2\
**Last updated:** [May 4, 2015, 9:55pm UTC](https://meta.discourse.org/t/error-in-installing/28299 "2015-05-04T21:55:45Z")

</div>

Hi, Error response from daemon: Cannot start container app: Error starting userland proxy: listen tcp 0.0.0.0:80: bind: address already in use What does this mean? I got it after trying to run the application.

---

## [SQL Error during import](https://meta.discourse.org/t/sql-error-during-import/27793)

<div class="topic-metadata">

**Author:** [@cocojoe](https://meta.discourse.org/u/cocojoe)\
**Replies:** 18\
**Last updated:** [May 3, 2015, 4:53pm UTC](https://meta.discourse.org/t/sql-error-during-import/27793 "2015-05-03T16:53:06Z")

</div>

Trying to import a discourse backup ~ 3GB from version v1.3.0.beta5 +97 to latest-release +87. During the import the following sql issue \[2015-04-21 08:34:05\] psql:/var/www/discourse/tmp/restores/default/2015-04-21-083…

---

## [Test emails work fine but nothing else](https://meta.discourse.org/t/test-emails-work-fine-but-nothing-else/28214)

<div class="topic-metadata">

**Author:** [@norbauer](https://meta.discourse.org/u/norbauer)\
**Replies:** 6\
**Last updated:** [May 2, 2015, 4:56am UTC](https://meta.discourse.org/t/test-emails-work-fine-but-nothing-else/28214 "2015-05-02T04:56:09Z")

</div>

Hi all! Discourse is awesome, but I’m having trouble getting emails working. I have installed to Azure using a Bitnami VM. I’m on Discourse v1.2.3, and I’m using Mandrill for mail delivery. I went through all the email…

---

## [Bootstrap failed after rebuild - changed domain name](https://meta.discourse.org/t/bootstrap-failed-after-rebuild-changed-domain-name/28206)

<div class="topic-metadata">

**Author:** [@wcr](https://meta.discourse.org/u/wcr)\
**Replies:** 8\
**Last updated:** [May 2, 2015, 1:53am UTC](https://meta.discourse.org/t/bootstrap-failed-after-rebuild-changed-domain-name/28206 "2015-05-02T01:53:41Z")

</div>

I have attempted to follow the instructions listed here to change the domain name of the installation. All went well until the rebuild. Here are the results of the rebuild app: BTW I know only a tiny bit about ssh… roo…

---

## [Programmatic configuration of a new Discourse site](https://meta.discourse.org/t/programmatic-configuration-of-a-new-discourse-site/24499)

<div class="topic-metadata">

**Author:** [@ahuling](https://meta.discourse.org/u/ahuling)\
**Replies:** 9\
**Last updated:** [April 30, 2015, 10:32pm UTC](https://meta.discourse.org/t/programmatic-configuration-of-a-new-discourse-site/24499 "2015-04-30T22:32:17Z")

</div>

Is it possible to programmatically configure a new site via the API?

---

## [Integrated Discourse with Wordpress but the URL to 'continue the discussion' doesn't work](https://meta.discourse.org/t/integrated-discourse-with-wordpress-but-the-url-to-continue-the-discussion-doesnt-work/26863)

<div class="topic-metadata">

**Author:** [@mikeem](https://meta.discourse.org/u/mikeem)\
**Replies:** 6\
**Last updated:** [April 30, 2015, 9:44pm UTC](https://meta.discourse.org/t/integrated-discourse-with-wordpress-but-the-url-to-continue-the-discussion-doesnt-work/26863 "2015-04-30T21:44:01Z")

</div>

Hey. So installed the Wordpress plugin and configured it, so this where comments were this now appears below new posts: But the link looks incomplete: http://discourse.example.com/session/sso?return\_path= Here’s t…

---

## [Re-bootstrap data container in a split setup?](https://meta.discourse.org/t/re-bootstrap-data-container-in-a-split-setup/27893)

<div class="topic-metadata">

**Author:** [@calmh](https://meta.discourse.org/u/calmh)\
**Replies:** 4\
**Last updated:** [April 29, 2015, 5:02am UTC](https://meta.discourse.org/t/re-bootstrap-data-container-in-a-split-setup/27893 "2015-04-29T05:02:34Z")

</div>

I’m running a split setup (data and web\_only containers). This makes it easy and quick to update the web container with minimal downtime. :+1: However, I noticed today that the web container I’m running is based on sams…

---

## [Disable creating new topics](https://meta.discourse.org/t/disable-creating-new-topics/28018)

<div class="topic-metadata">

**Author:** [@rhulse](https://meta.discourse.org/u/rhulse)\
**Replies:** 2\
**Last updated:** [April 28, 2015, 8:53am UTC](https://meta.discourse.org/t/disable-creating-new-topics/28018 "2015-04-28T08:53:32Z")

</div>

Is there are way to limit the creation of new topics to staff and the embedding script?

---

## [Bootstrapping Discourse hangs on Redis "ready to accept connections" on Amazon EC2](https://meta.discourse.org/t/bootstrapping-discourse-hangs-on-redis-ready-to-accept-connections-on-amazon-ec2/27950)

<div class="topic-metadata">

**Author:** [@dgs](https://meta.discourse.org/u/dgs)\
**Replies:** 9\
**Last updated:** [April 27, 2015, 9:08pm UTC](https://meta.discourse.org/t/bootstrapping-discourse-hangs-on-redis-ready-to-accept-connections-on-amazon-ec2/27950 "2015-04-27T21:08:19Z")

</div>

Hello, First timer here, have been following the instructions here: discourse/docs/INSTALL-cloud.md at main · discourse/discourse · GitHub but I’m doing it on an Amazon EC2 instance instead of a Digital Ocean droplet. I…

---

## [Discourse not showing up at specified hostname](https://meta.discourse.org/t/discourse-not-showing-up-at-specified-hostname/27969)

<div class="topic-metadata">

**Author:** [@PopsRocker](https://meta.discourse.org/u/PopsRocker)\
**Replies:** 6\
**Last updated:** [April 27, 2015, 5:16am UTC](https://meta.discourse.org/t/discourse-not-showing-up-at-specified-hostname/27969 "2015-04-27T05:16:33Z")

</div>

Hello, I just ran through the installation steps and all appears to be fine in the server terminal. However when I go to the URL I added for the DISCOURSE\_HOSTNAME I am getting the default splash page when I set up a ne…

[Previous page](https://meta.discourse.org/c/support/6.md?page=894)

[Next page](https://meta.discourse.org/c/support/6.md?page=896)
