# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=108

[Latest](https://meta.discourse.org/latest.md) · [Categories](https://meta.discourse.org/categories.md) · [Tags](https://meta.discourse.org/tags.md)

**Page:** 109

---

## [Discourse with Traefik 2.0](https://meta.discourse.org/t/discourse-with-traefik-2-0/130357)

<div class="topic-metadata">

**Author:** [@SvenC56](https://meta.discourse.org/u/SvenC56)\
**Replies:** 42\
**Last updated:** [February 22, 2020, 12:27pm UTC](https://meta.discourse.org/t/discourse-with-traefik-2-0/130357 "2020-02-22T12:27:16Z")

</div>

Hi all, I’m migrating to a new server and I want to use Traefik 2.0 as a reverse proxy. I’m currently struggling with the new configuration. I added a section at the bottom of the app.yml file. (Source: Discourse behind…

---

## [Only "welcome to nginx" can be displayed after installation](https://meta.discourse.org/t/only-welcome-to-nginx-can-be-displayed-after-installation/142206)

<div class="topic-metadata">

**Author:** [@cxj16888](https://meta.discourse.org/u/cxj16888)\
**Replies:** 5\
**Last updated:** [February 21, 2020, 5:20pm UTC](https://meta.discourse.org/t/only-welcome-to-nginx-can-be-displayed-after-installation/142206 "2020-02-21T17:20:54Z")

</div>

I have installed docker with Ubuntu 18.04 and installed discover to run normally. However, only “welcome to nginx” can appear when accessing IP or domain name I am a junior user, how should I proceed to the next step, t…

---

## [Remove (or merge) Elastic email Unsubscribe](https://meta.discourse.org/t/remove-or-merge-elastic-email-unsubscribe/70236)

<div class="topic-metadata">

**Author:** [@mmiada](https://meta.discourse.org/u/mmiada)\
**Replies:** 32\
**Last updated:** [February 20, 2020, 12:52pm UTC](https://meta.discourse.org/t/remove-or-merge-elastic-email-unsubscribe/70236 "2020-02-20T12:52:06Z")

</div>

hi, i’m using elastic email for delivery (from your recom.) but i can’t remove unsubscribe link from elastic email (i think because is mandatory) from what i read is a way to merge some how. they give this doc how ca…

---

## [Upgrading Discourse on Bitnami Google Cloud Platform (2020)](https://meta.discourse.org/t/upgrading-discourse-on-bitnami-google-cloud-platform-2020/141649)

<div class="topic-metadata">

**Author:** [@Alan\_Foster](https://meta.discourse.org/u/Alan_Foster)\
**Replies:** 5\
**Last updated:** [February 15, 2020, 3:51pm UTC](https://meta.discourse.org/t/upgrading-discourse-on-bitnami-google-cloud-platform-2020/141649 "2020-02-15T15:51:35Z")

</div>

Hi everyone, I need some help figuring out the proper steps to configure Repo Sync with Discourse using the Bitnami Google Cloud stack. https://docs.bitnami.com/google/apps/discourse/administration/upgrade/ The problem…

---

## [Looking for Production Discourse Instructions](https://meta.discourse.org/t/looking-for-production-discourse-instructions/68096)

<div class="topic-metadata">

**Author:** [@Dan\_Healy](https://meta.discourse.org/u/Dan_Healy)\
**Replies:** 9\
**Last updated:** [February 18, 2020, 8:39pm UTC](https://meta.discourse.org/t/looking-for-production-discourse-instructions/68096 "2020-02-18T20:39:20Z")

</div>

Hi, I’m already running the following and need to understand how to configure a Discource container with a production environment: -Postgres Server -Nginx (reverse proxy for all sites) -Redis -Docker cluster My int…

---

## [How to install discourse without ssl?](https://meta.discourse.org/t/how-to-install-discourse-without-ssl/141817)

<div class="topic-metadata">

**Author:** [@eextra](https://meta.discourse.org/u/eextra)\
**Replies:** 17\
**Last updated:** [February 18, 2020, 7:17pm UTC](https://meta.discourse.org/t/how-to-install-discourse-without-ssl/141817 "2020-02-18T19:17:35Z")

</div>

Is it possible to install without https and then implement your own ssl from hosting ?

---

## [Host of discourse](https://meta.discourse.org/t/host-of-discourse/141753)

<div class="topic-metadata">

**Author:** [@sams\_sams](https://meta.discourse.org/u/sams_sams)\
**Replies:** 14\
**Last updated:** [February 17, 2020, 12:48pm UTC](https://meta.discourse.org/t/host-of-discourse/141753 "2020-02-17T12:48:43Z")

</div>

Hello i am download discours on my Ubuntu and i woud like host discourse in my computer bu i have problème when i go in my website discourse discourse dont works !

---

## [How to recover my broken (not web-accessible) Discourse installation after failed upgrade](https://meta.discourse.org/t/how-to-recover-my-broken-not-web-accessible-discourse-installation-after-failed-upgrade/141760)

<div class="topic-metadata">

**Author:** [@joa](https://meta.discourse.org/u/joa)\
**Replies:** 3\
**Last updated:** [February 16, 2020, 10:54pm UTC](https://meta.discourse.org/t/how-to-recover-my-broken-not-web-accessible-discourse-installation-after-failed-upgrade/141760 "2020-02-16T22:54:33Z")

</div>

I just attempted to upgrade my Discourse installation to the latest beta (2.4.0 beta 11) via the web update and now it is inaccessible (try for yourself, returns HTTP 500 errors). Context My installed version was still …

---

## [Can't get discourse working again](https://meta.discourse.org/t/cant-get-discourse-working-again/141736)

<div class="topic-metadata">

**Author:** [@Juan\_Carlos\_B](https://meta.discourse.org/u/Juan_Carlos_B)\
**Replies:** 8\
**Last updated:** [February 16, 2020, 11:47am UTC](https://meta.discourse.org/t/cant-get-discourse-working-again/141736 "2020-02-16T11:47:16Z")

</div>

Hi: I’ve been running a Discourse for the last months with no problems. I had to reset the host and now I can not get discourse working again. /var/discourse# ./launcher rebuild app Ensuring launcher is up to date F…

---

## [Improve my DO droplet setup](https://meta.discourse.org/t/improve-my-do-droplet-setup/141665)

<div class="topic-metadata">

**Author:** [@Fausto\_Dassenno](https://meta.discourse.org/u/Fausto_Dassenno)\
**Replies:** 4\
**Last updated:** [February 15, 2020, 2:19pm UTC](https://meta.discourse.org/t/improve-my-do-droplet-setup/141665 "2020-02-15T14:19:45Z")

</div>

Hi all, I am running my discourse on a single droplet on DO and I would like to create a more redundant setup. All the resources I found online points me in the direction of load balancer but for doing so I need to crea…

---

## [Saving Trial config and settings](https://meta.discourse.org/t/saving-trial-config-and-settings/141437)

<div class="topic-metadata">

**Author:** [@G.CoCo](https://meta.discourse.org/u/G.CoCo)\
**Replies:** 1\
**Last updated:** [February 12, 2020, 8:54pm UTC](https://meta.discourse.org/t/saving-trial-config-and-settings/141437 "2020-02-12T20:54:01Z")

</div>

Is there a way to save our Trial instance to then apply to our Prod environment (whether hosted on prem or with Discourse)? i.e. Config, Settings, Theme, Branding - everything. Thanks, Glen

---

## [Discourse not working after installation](https://meta.discourse.org/t/discourse-not-working-after-installation/141385)

<div class="topic-metadata">

**Author:** [@weidox](https://meta.discourse.org/u/weidox)\
**Replies:** 2\
**Last updated:** [February 12, 2020, 2:18pm UTC](https://meta.discourse.org/t/discourse-not-working-after-installation/141385 "2020-02-12T14:18:07Z")

</div>

installed on AWS EC2 using official launcher, bootstrapped, docker launched and it’s failing to work on port 80. Looks like this \[\*\*\*\*\*\*\*\]# telnet localhost 80 Trying 127.0.0.1… Connected to localhost. Escape charact…

---

## [\`uploads:migrate\_to\_s3\` fails with 'Seahorse::Client::NetworkingError: certificate verify failed' on Digital Ocean Spaces](https://meta.discourse.org/t/uploads-migrate-to-s3-fails-with-seahorse-certificate-verify-failed-on-digital-ocean-spaces/141158)

<div class="topic-metadata">

**Author:** [@md-misko](https://meta.discourse.org/u/md-misko)\
**Replies:** 1\
**Last updated:** [February 11, 2020, 11:29pm UTC](https://meta.discourse.org/t/uploads-migrate-to-s3-fails-with-seahorse-certificate-verify-failed-on-digital-ocean-spaces/141158 "2020-02-11T23:29:03Z")

</div>

I need help with moving the existing uploads to Digital Ocean Spaces (S3 is properly configured and new uploads are successfully uploaded). I ran rake uploads:migrate\_to\_s3 with: DISCOURSE\_S3\_ACCESS\_KEY\_ID="id" \\ DISCO…

---

## [Nginx page instead of Congratulations page](https://meta.discourse.org/t/nginx-page-instead-of-congratulations-page/141250)

<div class="topic-metadata">

**Author:** [@DaleKramer](https://meta.discourse.org/u/DaleKramer)\
**Replies:** 5\
**Last updated:** [February 11, 2020, 9:32pm UTC](https://meta.discourse.org/t/nginx-page-instead-of-congratulations-page/141250 "2020-02-11T21:32:56Z")

</div>

I followed these 30 minute instructions: I am able to TelNet a successfull login to my smtp server. My subdomain redirects properly to the IP that DigitalOcean assigned me ( 167.172.31.228 ). But whenever I go to th…

---

## [Bootstrap error on maximum files](https://meta.discourse.org/t/bootstrap-error-on-maximum-files/141291)

<div class="topic-metadata">

**Author:** [@weidox](https://meta.discourse.org/u/weidox)\
**Replies:** 0\
**Last updated:** [February 11, 2020, 1:33pm UTC](https://meta.discourse.org/t/bootstrap-error-on-maximum-files/141291 "2020-02-11T13:33:44Z")

</div>

During bootstrap on AWS linux, noticed an error saying something like that there was permission violation in trying to set maximum files. It disappeared quickly so could not copy it. Is this supposed to happen and what i…

---

## [Uploading a file to the web root](https://meta.discourse.org/t/uploading-a-file-to-the-web-root/35626)

<div class="topic-metadata">

**Author:** [@enry](https://meta.discourse.org/u/enry)\
**Replies:** 24\
**Last updated:** [February 11, 2020, 3:47am UTC](https://meta.discourse.org/t/uploading-a-file-to-the-web-root/35626 "2020-02-11T03:47:56Z")

</div>

I need to upload a file to the web root, specifically, some SSL certificate activation file. On every other webapp I’ve ever used in my 15+ years of working in web, I could relatively easily do this with varying degree…

---

## [Trying to validate with mailjet, needs txt file or DNS entry](https://meta.discourse.org/t/trying-to-validate-with-mailjet-needs-txt-file-or-dns-entry/138508)

<div class="topic-metadata">

**Author:** [@ctmoore](https://meta.discourse.org/u/ctmoore)\
**Replies:** 4\
**Last updated:** [February 11, 2020, 3:14am UTC](https://meta.discourse.org/t/trying-to-validate-with-mailjet-needs-txt-file-or-dns-entry/138508 "2020-02-11T03:14:03Z")

</div>

OK, so i am using mailjet for the smtp and am runnign into a problem with validation. Firstly i can’t validate the individual email noreply@discourse.example.com easily. I’d rather validate the domain discourse.example…

---

## [Please explain how hosting photos within the forum works. Does that get crazy expensive?](https://meta.discourse.org/t/please-explain-how-hosting-photos-within-the-forum-works-does-that-get-crazy-expensive/141018)

<div class="topic-metadata">

**Author:** [@AvidLearner](https://meta.discourse.org/u/AvidLearner)\
**Replies:** 4\
**Last updated:** [February 7, 2020, 8:55pm UTC](https://meta.discourse.org/t/please-explain-how-hosting-photos-within-the-forum-works-does-that-get-crazy-expensive/141018 "2020-02-07T20:55:20Z")

</div>

I’m concerned about the cost to host photos. (I’ve set up my forum in a droplet with Digital Ocean’s $10 plan - the forum doesn’t have any users yet.) I assume photos are stored within my Digital Ocean droplet. So does…

---

## [DISCOURSE\_CDN\_URL causes content security policy violations?](https://meta.discourse.org/t/discourse-cdn-url-causes-content-security-policy-violations/140935)

<div class="topic-metadata">

**Author:** [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**Replies:** 4\
**Last updated:** [February 6, 2020, 11:23pm UTC](https://meta.discourse.org/t/discourse-cdn-url-causes-content-security-policy-violations/140935 "2020-02-06T23:23:21Z")

</div>

I don’t know how I’m screwing this up. I can’t see how I’m the only one facing what looks like a bug. If I define DISCOURSE\_CDN\_URL: https://lcsupport-92e2.kxcdn.com in the env: stanza in my yml for a fairly standar…

---

## [Upgrade / Rebuilds Fail due to MaxMind DB EOL](https://meta.discourse.org/t/upgrade-rebuilds-fail-due-to-maxmind-db-eol/137387)

<div class="topic-metadata">

**Author:** [@iczster](https://meta.discourse.org/u/iczster)\
**Replies:** 14\
**Last updated:** [February 5, 2020, 10:12pm UTC](https://meta.discourse.org/t/upgrade-rebuilds-fail-due-to-maxmind-db-eol/137387 "2020-02-05T22:12:58Z")

</div>

Guys, Hope somebody can help here. Ive not had a problem for over 12 months with upgrades to my forum that is running in a docker container on EC2 Ive tried: launcher cleanup but no issues with disk space latest git …

---

## [Am I able to buy Discourse or, am I forced to pay the “cloud” pricing?](https://meta.discourse.org/t/am-i-able-to-buy-discourse-or-am-i-forced-to-pay-the-cloud-pricing/140737)

<div class="topic-metadata">

**Author:** [@franciscom](https://meta.discourse.org/u/franciscom)\
**Replies:** 4\
**Last updated:** [February 5, 2020, 2:31pm UTC](https://meta.discourse.org/t/am-i-able-to-buy-discourse-or-am-i-forced-to-pay-the-cloud-pricing/140737 "2020-02-05T14:31:24Z")

</div>

Hi Discourse community! I discovered this place today. I’m confused about the pricing of Discourse software… I mean, am I able to buy Discourse or, am I just forced to pay the “cloud” pricing? Thanks in advance to thos…

---

## [Multiple container setup problems](https://meta.discourse.org/t/multiple-container-setup-problems/140680)

<div class="topic-metadata">

**Author:** [@Silvanus](https://meta.discourse.org/u/Silvanus)\
**Replies:** 2\
**Last updated:** [February 5, 2020, 1:55pm UTC](https://meta.discourse.org/t/multiple-container-setup-problems/140680 "2020-02-05T13:55:37Z")

</div>

Hi all! After trying to figure out multisite setup but failing miserably, I ended up doing three separate containers, one for my current forum and two for the archive forums. I went with socketed, managed to get NGINX wo…

---

## [Failing to bootstrap on DO droplet w/mailjet](https://meta.discourse.org/t/failing-to-bootstrap-on-do-droplet-w-mailjet/140660)

<div class="topic-metadata">

**Author:** [@bifterx](https://meta.discourse.org/u/bifterx)\
**Replies:** 12\
**Last updated:** [February 5, 2020, 1:32pm UTC](https://meta.discourse.org/t/failing-to-bootstrap-on-do-droplet-w-mailjet/140660 "2020-02-05T13:32:01Z")

</div>

Hi Im pulling my hair out a bit here. I following the standard install instructions, have setup mailjet etc but the bootstrap fails every time. heres the setup, I just cant see what Im missing Any ideas? Thanks Doe…

---

## [Rake migrate\_to\_s3 errors](https://meta.discourse.org/t/rake-migrate-to-s3-errors/129528)

<div class="topic-metadata">

**Author:** [@markersocial](https://meta.discourse.org/u/markersocial)\
**Replies:** 3\
**Last updated:** [February 4, 2020, 8:54pm UTC](https://meta.discourse.org/t/rake-migrate-to-s3-errors/129528 "2020-02-04T20:54:31Z")

</div>

So I tested the waters migrating a smaller Discourse forum to s3 successfully. I’m having issues migrating this larger forum however. I might end up resorting to using this method shared by @marcozambi Migrate\_to\_s3 task…

---

## [Fail rebuild app](https://meta.discourse.org/t/fail-rebuild-app/79088)

<div class="topic-metadata">

**Author:** [@ozgurkuru](https://meta.discourse.org/u/ozgurkuru)\
**Replies:** 5\
**Last updated:** [February 3, 2020, 9:24am UTC](https://meta.discourse.org/t/fail-rebuild-app/79088 "2020-02-03T09:24:58Z")

</div>

Hello When I try to rebuild system give an error like; /pups/lib/pups/config.rb:106:in \`block (2 levels) in run\_commands': Invalid run command cd (SyntaxError) from /pups/lib/pups/config.rb:100:in \`each' from /pups/lib/…

---

## [Rake posts:remap - 0 posts remapped!](https://meta.discourse.org/t/rake-posts-remap-0-posts-remapped/140364)

<div class="topic-metadata">

**Author:** [@Amethi](https://meta.discourse.org/u/Amethi)\
**Replies:** 4\
**Last updated:** [February 1, 2020, 6:17pm UTC](https://meta.discourse.org/t/rake-posts-remap-0-posts-remapped/140364 "2020-02-01T18:17:56Z")

</div>

I’m trying to find and replace some broken images left over from our forum migration to Discourse and have had great success (love the remap command!) but it’s not finding anything to replace for these examples and I can…

---

## [IP does not redirect to domain, domain shows white page](https://meta.discourse.org/t/ip-does-not-redirect-to-domain-domain-shows-white-page/140112)

<div class="topic-metadata">

**Author:** [@Jacob\_Peebles](https://meta.discourse.org/u/Jacob_Peebles)\
**Replies:** 7\
**Last updated:** [January 31, 2020, 6:18pm UTC](https://meta.discourse.org/t/ip-does-not-redirect-to-domain-domain-shows-white-page/140112 "2020-01-31T18:18:49Z")

</div>

Hi All, I’ve installed the bitnami discourse marketplace app on Google Cloud Platform. Everything seems to have worked as planned and I am now at the step where I am trying to assign my domain to the site. In summary …

---

## [At what point should I consider increasing RAM on the VPS hosting my Discourse instance?](https://meta.discourse.org/t/at-what-point-should-i-consider-increasing-ram-on-the-vps-hosting-my-discourse-instance/140233)

<div class="topic-metadata">

**Author:** [@jonwgeorge](https://meta.discourse.org/u/jonwgeorge)\
**Replies:** 1\
**Last updated:** [January 31, 2020, 2:35am UTC](https://meta.discourse.org/t/at-what-point-should-i-consider-increasing-ram-on-the-vps-hosting-my-discourse-instance/140233 "2020-01-31T02:35:29Z")

</div>

Right now I have it running on a VPS at 2GB RAM. For the last week, I see it sitting between 70-100% utilization. Thoughts on when to push to more RAM?

---

## [Install Discourse on a droplet with WordPress served by Apache?](https://meta.discourse.org/t/install-discourse-on-a-droplet-with-wordpress-served-by-apache/139931)

<div class="topic-metadata">

**Author:** [@BlackBelt35](https://meta.discourse.org/u/BlackBelt35)\
**Replies:** 5\
**Last updated:** [January 29, 2020, 12:35pm UTC](https://meta.discourse.org/t/install-discourse-on-a-droplet-with-wordpress-served-by-apache/139931 "2020-01-29T12:35:55Z")

</div>

Hello everyone ! :slight\_smile: I’m really puzzled by a little problem with my personnal website project : I can’t manage to install any Discourse instance on my DigitalOcean droplet, with already WordPress and Apache …

---

## [Error connecting to Redis on localhost - Rebuilt](https://meta.discourse.org/t/error-connecting-to-redis-on-localhost-rebuilt/107457)

<div class="topic-metadata">

**Author:** [@Nopsled](https://meta.discourse.org/u/Nopsled)\
**Replies:** 14\
**Last updated:** [January 29, 2020, 11:45am UTC](https://meta.discourse.org/t/error-connecting-to-redis-on-localhost-rebuilt/107457 "2020-01-29T11:45:17Z")

</div>

Hello. Here are the error logs. I had to re-enable the email account, but even after doing so and tripple checking the app.yml settings, I’m still getting the following error. Error connecting to Redis on localhost:63…

[Previous page](https://meta.discourse.org/c/support/self-hosting/31.md?page=107)

[Next page](https://meta.discourse.org/c/support/self-hosting/31.md?page=109)
