# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=110

[Latest](https://meta.discourse.org/latest.md) · [Categories](https://meta.discourse.org/categories.md) · [Tags](https://meta.discourse.org/tags.md)

**Page:** 111

---

## [Rake uploads:migrate\_to\_s3 error](https://meta.discourse.org/t/rake-uploads-migrate-to-s3-error/137806)

<div class="topic-metadata">

**Author:** [@wanghaisheng](https://meta.discourse.org/u/wanghaisheng)\
**Replies:** 8\
**Last updated:** [January 6, 2020, 9:06am UTC](https://meta.discourse.org/t/rake-uploads-migrate-to-s3-error/137806 "2020-01-06T09:06:41Z")

</div>

2.4.0.beta9 discourse latest-release +35 \> rake uploads:migrate\_to\_s3 rake aborted! NoMethodError: undefined method \`name' for :vapid\_public\_key:Symbol /var/www/discourse/plugins/procourse-custom-homepage/lib/dl\_custom\_…

---

## [Discourse setup halted by apparent website hijack](https://meta.discourse.org/t/discourse-setup-halted-by-apparent-website-hijack/137680)

<div class="topic-metadata">

**Author:** [@Paul\_King](https://meta.discourse.org/u/Paul_King)\
**Replies:** 16\
**Last updated:** [January 4, 2020, 5:04am UTC](https://meta.discourse.org/t/discourse-setup-halted-by-apparent-website-hijack/137680 "2020-01-04T05:04:59Z")

</div>

Hi, I am in the process of setting up Discourse on a Digital Ocean droplet I completed the one-click install steps successfully, (no errors at least), but on completion of that script, typing the url of my new installat…

---

## [Could Discourse run on 000webhost?](https://meta.discourse.org/t/could-discourse-run-on-000webhost/137720)

<div class="topic-metadata">

**Author:** [@Samivan\_911](https://meta.discourse.org/u/Samivan_911)\
**Replies:** 1\
**Last updated:** [January 4, 2020, 3:37am UTC](https://meta.discourse.org/t/could-discourse-run-on-000webhost/137720 "2020-01-04T03:37:21Z")

</div>

Could 000webhost host Discourse? I think it might because they have a Mail Server, Bandwidth, and Storage so it must be able to run Discourse, right?

---

## [Can't restore to external DB](https://meta.discourse.org/t/cant-restore-to-external-db/137696)

<div class="topic-metadata">

**Author:** [@NotAnonymous](https://meta.discourse.org/u/NotAnonymous)\
**Replies:** 6\
**Last updated:** [January 3, 2020, 11:54pm UTC](https://meta.discourse.org/t/cant-restore-to-external-db/137696 "2020-01-03T23:54:07Z")

</div>

I’m trying to change my install to use an external postgres database. I have it set up to connect to the database with a new install, which seems to work fine. But when I try and do a restore from the old internal datab…

---

## [\[GER\] How do I install the Forum via Linux?](https://meta.discourse.org/t/ger-wie-installiere-ich-das-forum-per-linux/137013)

<div class="topic-metadata">

**Author:** [@Andydeluxe9797](https://meta.discourse.org/u/Andydeluxe9797)\
**Replies:** 30\
**Last updated:** [January 2, 2020, 1:50pm UTC](https://meta.discourse.org/t/ger-wie-installiere-ich-das-forum-per-linux/137013 "2020-01-02T13:50:45Z")

</div>

Hi, Can someone give me a tutorial on how to install this on Linux? I'd rather not buy it. I don't know how much it costs in hand. So, converted to Euros instead of Dollars. Regards, Andy

---

## [Discourse-doctor Error 503 AUTH command used when not advertised - but email works fine from admin CP](https://meta.discourse.org/t/discourse-doctor-error-503-auth-command-used-when-not-advertised-but-email-works-fine-from-admin-cp/137302)

<div class="topic-metadata">

**Author:** [@Queth](https://meta.discourse.org/u/Queth)\
**Replies:** 4\
**Last updated:** [January 1, 2020, 2:10am UTC](https://meta.discourse.org/t/discourse-doctor-error-503-auth-command-used-when-not-advertised-but-email-works-fine-from-admin-cp/137302 "2020-01-01T02:10:24Z")

</div>

edit: it seems to be an issue only in the discourse-doctor, thus title changed. hello, i am trying to figure out how to get the email to work so discourse can send mail to authorize users… I have successfully installed…

---

## [Does the forum for development start up 24 hours\*?](https://meta.discourse.org/t/does-the-forum-for-development-start-up-24-hours/137461)

<div class="topic-metadata">

**Author:** [@lijo](https://meta.discourse.org/u/lijo)\
**Replies:** 1\
**Last updated:** [December 31, 2019, 7:01pm UTC](https://meta.discourse.org/t/does-the-forum-for-development-start-up-24-hours/137461 "2019-12-31T19:01:52Z")

</div>

Trying to run a discourse locally on ubuntu. I ran everything like in this guide: . the last command is: bundle exec rails server And now I’ve been waiting 1.5 hours and it’s still loading ??? Is this supposed to t…

---

## [Installing Discourse for the First Time Using Vultr Hosting](https://meta.discourse.org/t/installing-discourse-for-the-first-time-using-vultr-hosting/57016)

<div class="topic-metadata">

**Author:** [@elmurph](https://meta.discourse.org/u/elmurph)\
**Replies:** 12\
**Last updated:** [December 30, 2019, 11:31pm UTC](https://meta.discourse.org/t/installing-discourse-for-the-first-time-using-vultr-hosting/57016 "2019-12-30T23:31:07Z")

</div>

Hey guys, I want to start a forum and I have chosen vultr for cloud compute. But am still confused on some details I read on this forum and online too. I use windows 10 and I don’t know if it relates to installing dicou…

---

## [Unable to rebuild, 'bundle exec rake assets:precompile' failed](https://meta.discourse.org/t/unable-to-rebuild-bundle-exec-rake-assets-precompile-failed/137386)

<div class="topic-metadata">

**Author:** [@trusktr](https://meta.discourse.org/u/trusktr)\
**Replies:** 3\
**Last updated:** [December 30, 2019, 7:31pm UTC](https://meta.discourse.org/t/unable-to-rebuild-bundle-exec-rake-assets-precompile-failed/137386 "2019-12-30T19:31:31Z")

</div>

I have a discourse installation, installed with standard install steps. For the first time, I tried modifying app.yml to update SMTP settings, and then I ran ./launcher rebuild app and it fails with: FAILED ------------…

---

## [How I could restart the web server in docker](https://meta.discourse.org/t/how-i-could-restart-the-web-server-in-docker/27890)

<div class="topic-metadata">

**Author:** [@berniegao](https://meta.discourse.org/u/berniegao)\
**Replies:** 11\
**Last updated:** [December 30, 2019, 7:27pm UTC](https://meta.discourse.org/t/how-i-could-restart-the-web-server-in-docker/27890 "2019-12-30T19:27:39Z")

</div>

by manual installation, I could cease the rails server to reload the config files. Is there something like the rails server within docker? @sam

---

## [Running 3 container for 3 domain in one installation with SSL](https://meta.discourse.org/t/running-3-container-for-3-domain-in-one-installation-with-ssl/137283)

<div class="topic-metadata">

**Author:** [@wanghaisheng](https://meta.discourse.org/u/wanghaisheng)\
**Replies:** 5\
**Last updated:** [December 30, 2019, 2:48am UTC](https://meta.discourse.org/t/running-3-container-for-3-domain-in-one-installation-with-ssl/137283 "2019-12-30T02:48:48Z")

</div>

after tweaking with lets encrypt several days ,here is for anyone who interested in running multible 1 purpose assume you have a domain like this ,and you want 3 forums bbs.antivte.com cp.antivte.com ytb.antivte.com…

---

## [Cannot access Discourse installation](https://meta.discourse.org/t/cannot-access-discourse-installation/130812)

<div class="topic-metadata">

**Author:** [@koltl](https://meta.discourse.org/u/koltl)\
**Replies:** 25\
**Last updated:** [December 29, 2019, 5:05pm UTC](https://meta.discourse.org/t/cannot-access-discourse-installation/130812 "2019-12-29T17:05:18Z")

</div>

I spun up a free tier VM with AWS to solely run Discourse. First setup went fine, I could view the success page, but I needed to redo it as I made a mistake with setting it up. Anyway, after making a new VPS, I followed …

---

## [Vbulletin 4 import -](https://meta.discourse.org/t/vbulletin-4-import/137293)

<div class="topic-metadata">

**Author:** [@steven\_so](https://meta.discourse.org/u/steven_so)\
**Replies:** 5\
**Last updated:** [December 29, 2019, 1:15pm UTC](https://meta.discourse.org/t/vbulletin-4-import/137293 "2019-12-29T13:15:22Z")

</div>

Hi, (I don’t have ROR experience) I have been following the guide and in the last step when I run “bundle exec rails server”, there are “MiniScheduler::Stat Create …” and " MiniScheduler::Stat Update" commands running …

---

## [Aws getsockopt: connection refused](https://meta.discourse.org/t/aws-getsockopt-connection-refused/137236)

<div class="topic-metadata">

**Author:** [@saius](https://meta.discourse.org/u/saius)\
**Replies:** 2\
**Last updated:** [December 29, 2019, 10:49am UTC](https://meta.discourse.org/t/aws-getsockopt-connection-refused/137236 "2019-12-29T10:49:58Z")

</div>

I followed this installation guide discourse/docs/INSTALL-cloud.md at main · discourse/discourse · GitHub. Everything is deployed on to a AWS EC2 instance running Ubuntu 18. The installation went fine, but when I open th…

---

## [Difference between socket- and port-based connection to outer NGINX?](https://meta.discourse.org/t/difference-between-socket-and-port-based-connection-to-outer-nginx/60071)

<div class="topic-metadata">

**Author:** [@tophee](https://meta.discourse.org/u/tophee)\
**Replies:** 10\
**Last updated:** [December 28, 2019, 1:31pm UTC](https://meta.discourse.org/t/difference-between-socket-and-port-based-connection-to-outer-nginx/60071 "2019-12-28T13:31:57Z")

</div>

If I understand things correctly there are two ways of configuring your discourse instance behind an NGINX server: with a socket connection (as described here) by exposing some port of the container and telling the out…

---

## [Discourse docker images are not signed](https://meta.discourse.org/t/discourse-docker-images-are-not-signed/137181)

<div class="topic-metadata">

**Author:** [@jenslauterbach](https://meta.discourse.org/u/jenslauterbach)\
**Replies:** 16\
**Last updated:** [December 28, 2019, 5:50am UTC](https://meta.discourse.org/t/discourse-docker-images-are-not-signed/137181 "2019-12-28T05:50:25Z")

</div>

Hello, I am currently trying to set up Discourse on a new machine. I checked out the discourse\_docker repository and ran ./launcher rebuild app. (I skipped bootstrapping because I had configurations from before). Rebui…

---

## [Latest rebuild broken](https://meta.discourse.org/t/latest-rebuild-broken/134962)

<div class="topic-metadata">

**Author:** [@zsero](https://meta.discourse.org/u/zsero)\
**Replies:** 22\
**Last updated:** [December 27, 2019, 3:21pm UTC](https://meta.discourse.org/t/latest-rebuild-broken/134962 "2019-12-27T15:21:52Z")

</div>

I have a long running system, never had any problems before. I always upgrade using a full rebuild, never using the built-in upgrade. I recently did an apt-get upgrade, docker upgrade to 19.03.5 and tried a rebuild but …

---

## [No activation email Elastic Email](https://meta.discourse.org/t/no-activation-email-elastic-email/128636)

<div class="topic-metadata">

**Author:** [@chfcb](https://meta.discourse.org/u/chfcb)\
**Replies:** 6\
**Last updated:** [December 27, 2019, 2:07am UTC](https://meta.discourse.org/t/no-activation-email-elastic-email/128636 "2019-12-27T02:07:13Z")

</div>

Hi first of all : sorry for my bad english . i’m not a native speaker. I installed discourse on my root server i have/had some problems with the subdomain discourse.mydomain.de1 … but know it works …more or less i ch…

---

## [Discourse slave instance with offline access](https://meta.discourse.org/t/discourse-slave-instance-with-offline-access/104052)

<div class="topic-metadata">

**Author:** [@antulik](https://meta.discourse.org/u/antulik)\
**Replies:** 3\
**Last updated:** [December 26, 2019, 9:18pm UTC](https://meta.discourse.org/t/discourse-slave-instance-with-offline-access/104052 "2019-12-26T21:18:28Z")

</div>

Background We have cloud hosted discourse instance for the Australian Ruby community (I’ll refer to it as Master). Twice a year we host RailsCamp events. That’s when we spend a full weekend together at a remote location…

---

## [Fresh installation with Let’s Encrypt errors](https://meta.discourse.org/t/fresh-installation-with-let-s-encrypt-errors/137064)

<div class="topic-metadata">

**Author:** [@wanghaisheng](https://meta.discourse.org/u/wanghaisheng)\
**Replies:** 18\
**Last updated:** [December 26, 2019, 6:02pm UTC](https://meta.discourse.org/t/fresh-installation-with-let-s-encrypt-errors/137064 "2019-12-26T18:02:59Z")

</div>

succesfully enter app container, is this saying my domain restricted by Encrypt? root@docker-s-1vcpu-2gb-sgp1-01-app:/shared/letsencrypt# ./acme.sh --issue -d bbs.antivte.com -k 4096 -w /var/www/discourse/public --debu…

---

## [I can't receive email by using G suite](https://meta.discourse.org/t/i-cant-receive-email-by-using-g-suite/137092)

<div class="topic-metadata">

**Author:** [@wonmew](https://meta.discourse.org/u/wonmew)\
**Replies:** 3\
**Last updated:** [December 26, 2019, 3:35pm UTC](https://meta.discourse.org/t/i-cant-receive-email-by-using-g-suite/137092 "2019-12-26T15:35:55Z")

</div>

DISCOURSE\_DEVELOPER\_EMAILS: me@mydomain.com DISCOURSE\_SMTP\_ADDRESS: smtp.gmail.com DISCOURSE\_SMTP\_PORT: 587 DISCOURSE\_SMTP\_USER\_NAME: me@mydomain.com DISCOURSE\_SMTP\_PASSWORD: my password it doesn’t work, I am stuck here …

---

## [Problem Sending Activation Email](https://meta.discourse.org/t/problem-sending-activation-email/136997)

<div class="topic-metadata">

**Author:** [@nparab](https://meta.discourse.org/u/nparab)\
**Replies:** 4\
**Last updated:** [December 25, 2019, 11:44pm UTC](https://meta.discourse.org/t/problem-sending-activation-email/136997 "2019-12-25T23:44:00Z")

</div>

I have installed Discourse using the 1-click app install on DigitalOcean with LetsEncrypt HTTPS support. I’m not receiving the activation email on my admin email account. When I run ./discourse-doctor, on the Email Send …

---

## [Unable to setup Discourse CLI on AWS Bitnami hosted instance](https://meta.discourse.org/t/unable-to-setup-discourse-cli-on-aws-bitnami-hosted-instance/137024)

<div class="topic-metadata">

**Author:** [@ashishsecdev](https://meta.discourse.org/u/ashishsecdev)\
**Replies:** 2\
**Last updated:** [December 25, 2019, 2:59pm UTC](https://meta.discourse.org/t/unable-to-setup-discourse-cli-on-aws-bitnami-hosted-instance/137024 "2019-12-25T14:59:43Z")

</div>

Hi All, I am trying to configure the AWS hosted Discourse CLI and the API is needed to be called at http://{ip}:3000 I have setup the “Inbound TCP” rule on AWS but it isn’t working. Is there anyone who can help with th…

---

## [Can't reach new install via IP or DNS](https://meta.discourse.org/t/cant-reach-new-install-via-ip-or-dns/137001)

<div class="topic-metadata">

**Author:** [@Kubib](https://meta.discourse.org/u/Kubib)\
**Replies:** 8\
**Last updated:** [December 24, 2019, 10:12pm UTC](https://meta.discourse.org/t/cant-reach-new-install-via-ip-or-dns/137001 "2019-12-24T22:12:20Z")

</div>

When I try to install discourse on Ubuntu 18.04 x86\_64 vps 2gb ram i got this error. I cant reach my forum with ip and the dns. I dont know that to do.

---

## [How much is Discourse affected by a faster CPU?](https://meta.discourse.org/t/how-much-is-discourse-affected-by-a-faster-cpu/58407)

<div class="topic-metadata">

**Author:** [@codinghorror](https://meta.discourse.org/u/codinghorror)\
**Replies:** 42\
**Last updated:** [December 24, 2019, 3:10pm UTC](https://meta.discourse.org/t/how-much-is-discourse-affected-by-a-faster-cpu/58407 "2019-12-24T15:10:46Z")

</div>

I recently moved my own Discourse from Digital Ocean to a colocated mini-PC I purchased from Ali Express. This is a good apples to apples of increasing CPU performance with the exact same Discourse instance. Digital Oce…

---

## [More than one site as different container running on the same do server](https://meta.discourse.org/t/more-than-one-site-as-different-container-running-on-the-same-do-server/136911)

<div class="topic-metadata">

**Author:** [@wanghaisheng](https://meta.discourse.org/u/wanghaisheng)\
**Replies:** 3\
**Last updated:** [December 24, 2019, 2:01am UTC](https://meta.discourse.org/t/more-than-one-site-as-different-container-running-on-the-same-do-server/136911 "2019-12-24T02:01:17Z")

</div>

I have installed successfully site 1 and run it over a month.today I follow the instruction here https://meta.discourse.org/t/running-other-websites-on-the-same-machine-as-discourse/17247,I have edited the first discours…

---

## [Discourse Email Failure](https://meta.discourse.org/t/discourse-email-failure/136899)

<div class="topic-metadata">

**Author:** [@Gronkhou](https://meta.discourse.org/u/Gronkhou)\
**Replies:** 1\
**Last updated:** [December 23, 2019, 4:08pm UTC](https://meta.discourse.org/t/discourse-email-failure/136899 "2019-12-23T16:08:13Z")

</div>

Ive noticed that i dont recieve emails (ive created my admin account with rake sience i cant get the email for the Set-Up account) then i noticed the following in my Panel Logs 553 5.7.1 \<noreply@forum.speargaming.de\>:…

---

## [Rake error during update (not fatal)](https://meta.discourse.org/t/rake-error-during-update-not-fatal/136823)

<div class="topic-metadata">

**Author:** [@Ed\_S](https://meta.discourse.org/u/Ed_S)\
**Replies:** 4\
**Last updated:** [December 23, 2019, 4:53pm UTC](https://meta.discourse.org/t/rake-error-during-update-not-fatal/136823 "2019-12-23T16:53:26Z")

</div>

I saw this go by in the logs, but the upgrade continued with apparent success: Waiting for Unicorn to reload........................................................... $ bundle exec rake assets:flush\_sw rake aborted! Do…

---

## [Discourse Setup](https://meta.discourse.org/t/discourse-setup/136852)

<div class="topic-metadata">

**Author:** [@RCOfficial](https://meta.discourse.org/u/RCOfficial)\
**Replies:** 3\
**Last updated:** [December 23, 2019, 11:53am UTC](https://meta.discourse.org/t/discourse-setup/136852 "2019-12-23T11:53:35Z")

</div>

Hello, I was wondering if somebody can setup Discourse for me. I have no idea how to do it and yes i have a Linux Ubuntu Server VPS.

---

## [Discourse-docker run with unicorn memory issue](https://meta.discourse.org/t/discourse-docker-run-with-unicorn-memory-issue/136569)

<div class="topic-metadata">

**Author:** [@marvin-min](https://meta.discourse.org/u/marvin-min)\
**Replies:** 6\
**Last updated:** [December 23, 2019, 1:16am UTC](https://meta.discourse.org/t/discourse-docker-run-with-unicorn-memory-issue/136569 "2019-12-23T01:16:19Z")

</div>

Run docker with the latest version discourse-docker, Mem: 2GB, 3 unicorn thread. There tons of log error as below. I, \[2019-12-17T22:44:47.722151 #19487\] INFO -- : listening on addr=0.0.0.0:3000 fd=13 I, \[2019-12-17T2…

[Previous page](https://meta.discourse.org/c/support/self-hosting/31.md?page=109)

[Next page](https://meta.discourse.org/c/support/self-hosting/31.md?page=111)
