# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=112

[Latest](https://meta.discourse.org/latest.md) · [Categories](https://meta.discourse.org/categories.md) · [Tags](https://meta.discourse.org/tags.md)

**Page:** 113

---

## [SSL Error during OAuth2](https://meta.discourse.org/t/ssl-error-during-oauth2/135257)

<div class="topic-metadata">

**Author:** [@Wurzelseppi](https://meta.discourse.org/u/Wurzelseppi)\
**Replies:** 4\
**Last updated:** [December 9, 2019, 7:20am UTC](https://meta.discourse.org/t/ssl-error-during-oauth2/135257 "2019-12-09T07:20:03Z")

</div>

This post about it has been closed, but I still encounter this problem in version 2.4.0.beta8 It´s happening during oauth2 authentication Excon::Error::Socket (SSL\_connect returned=1 errno=0 state=error: dh key too…

---

## [No received mails in new Discourse installation](https://meta.discourse.org/t/no-received-mails-in-new-discourse-installation/135372)

<div class="topic-metadata">

**Author:** [@Jakira](https://meta.discourse.org/u/Jakira)\
**Replies:** 4\
**Last updated:** [December 9, 2019, 5:13am UTC](https://meta.discourse.org/t/no-received-mails-in-new-discourse-installation/135372 "2019-12-09T05:13:51Z")

</div>

Hi, I have setup new discourse installation in Linux server. Why I don’t have any received mails? How can I sent a mail to this server? /Jakira Alao I can’t understand this :frowning: 2. Pushing emails via the Di…

---

## [CDN causes white screen](https://meta.discourse.org/t/cdn-causes-white-screen/79070)

<div class="topic-metadata">

**Author:** [@Vencent](https://meta.discourse.org/u/Vencent)\
**Replies:** 9\
**Last updated:** [December 8, 2019, 1:16pm UTC](https://meta.discourse.org/t/cdn-causes-white-screen/79070 "2019-12-08T13:16:02Z")

</div>

White screen often happens to my site with CDN. And clearing CDN cache manually can solve the problem. Does anybody run into the same problem? The errors in browser Console is like ‘unexpected token’ or something like t…

---

## [Let's Encrypt- empty \*.cer files](https://meta.discourse.org/t/lets-encrypt-empty-cer-files/135241)

<div class="topic-metadata">

**Author:** [@Mark\_Schmucker](https://meta.discourse.org/u/Mark_Schmucker)\
**Replies:** 2\
**Last updated:** [December 6, 2019, 11:21pm UTC](https://meta.discourse.org/t/lets-encrypt-empty-cer-files/135241 "2019-12-06T23:21:42Z")

</div>

I can’t connect to a new standard 30-minute install. AWS Lightsail, 2GB memory, Ubuntu 18.04 LTS x64 with :443 open. The problem is that the Let’s Encrypt \*.cer files are empty. Why? nginx logs root:/var/log/nginx# ls…

---

## [How to increase disk space](https://meta.discourse.org/t/how-to-increase-disk-space/135276)

<div class="topic-metadata">

**Author:** [@Jakira](https://meta.discourse.org/u/Jakira)\
**Replies:** 7\
**Last updated:** [December 6, 2019, 5:36pm UTC](https://meta.discourse.org/t/how-to-increase-disk-space/135276 "2019-12-06T17:36:32Z")

</div>

I have installed discourse & when I log into admin panel I can see free space is 4.7 GB which seems quite small to me. Server is host in my local machine & I have 50 GB total my current disk drive. I have another disk w…

---

## [Forum dead after docker\_manager upgrade](https://meta.discourse.org/t/forum-dead-after-docker-manager-upgrade/135214)

<div class="topic-metadata">

**Author:** [@Wingtip](https://meta.discourse.org/u/Wingtip)\
**Replies:** 2\
**Last updated:** [December 5, 2019, 9:35pm UTC](https://meta.discourse.org/t/forum-dead-after-docker-manager-upgrade/135214 "2019-12-05T21:35:37Z")

</div>

For those not reading to the bottom, rebooting the VM fixed the problem when nothing else would! Edit: Sigh, didn’t realize this before-- the frontpage of the forum works fine, but going into any topic just sits there …

---

## [Manually Migration Guidelines (from WebWiz)](https://meta.discourse.org/t/manually-migration-guidelines-from-webwiz/135159)

<div class="topic-metadata">

**Author:** [@wlandgraf](https://meta.discourse.org/u/wlandgraf)\
**Replies:** 6\
**Last updated:** [December 5, 2019, 8:10pm UTC](https://meta.discourse.org/t/manually-migration-guidelines-from-webwiz/135159 "2019-12-05T20:10:57Z")

</div>

Hi all. I have an existing forum in WebWiz and I’d like to migrate to Discourse. It’s a big forum with lots of specific stuff. It doesn’t look there is an automatic WebWiz to Discourse migration tool, and even if it exis…

---

## [Feature Request: Less updates to Docker](https://meta.discourse.org/t/feature-request-less-updates-to-docker/135127)

<div class="topic-metadata">

**Author:** [@vel](https://meta.discourse.org/u/vel)\
**Replies:** 2\
**Last updated:** [December 5, 2019, 2:18pm UTC](https://meta.discourse.org/t/feature-request-less-updates-to-docker/135127 "2019-12-05T14:18:11Z")

</div>

When Discourse prompts to upgrade I see a message like this: Your Discourse installation is out of date. \[Click here to upgrade.\] I’m guessing maybe 1 in 3 times it requests to upgrade it also says to upgrade Docker …

---

## [Discourse Database Socket information](https://meta.discourse.org/t/discourse-database-socket-information/135007)

<div class="topic-metadata">

**Author:** [@yousefa](https://meta.discourse.org/u/yousefa)\
**Replies:** 3\
**Last updated:** [December 5, 2019, 2:40pm UTC](https://meta.discourse.org/t/discourse-database-socket-information/135007 "2019-12-05T14:40:35Z")

</div>

While i am trying to establish Discourse on AWS EC2, i faced a problem to find the information of DISCOURSE\_DB\_SOCKET that should be found in app.yml. Can anyone tell me from where could i get this information of DISCO…

---

## [Updating Likes in \`user\_stats\` in the database via SQL](https://meta.discourse.org/t/updating-likes-in-user-stats-in-the-database-via-sql/135283)

<div class="topic-metadata">

**Author:** [@pgr](https://meta.discourse.org/u/pgr)\
**Replies:** 2\
**Last updated:** [December 4, 2019, 1:47pm UTC](https://meta.discourse.org/t/updating-likes-in-user-stats-in-the-database-via-sql/135283 "2019-12-04T13:47:40Z")

</div>

Hey everyone! Is there somewhere where I can find a ready-made query to update likes\_given and likes\_received in the user\_stats table? I’m not sure where that is supposed to come from, probably something based on what i…

---

## [Problem in installing Let's Encrypt SSL for www and non-www](https://meta.discourse.org/t/problem-in-installing-lets-encrypt-ssl-for-www-and-non-www/88515)

<div class="topic-metadata">

**Author:** [@Gulshan\_Kumar](https://meta.discourse.org/u/Gulshan_Kumar)\
**Replies:** 10\
**Last updated:** [December 3, 2019, 7:00pm UTC](https://meta.discourse.org/t/problem-in-installing-lets-encrypt-ssl-for-www-and-non-www/88515 "2019-12-03T19:00:08Z")

</div>

TLDR: Only one version is working with SSL, either www or non-www, as same as hostname provided while installation. It’s related to Let’s Encrypt SSL installation as written at Docs. So, after launching setup it was as…

---

## [Staging instance on same Production instance Docker Server?](https://meta.discourse.org/t/staging-instance-on-same-production-instance-docker-server/134990)

<div class="topic-metadata">

**Author:** [@mreach](https://meta.discourse.org/u/mreach)\
**Replies:** 1\
**Last updated:** [December 3, 2019, 6:42pm UTC](https://meta.discourse.org/t/staging-instance-on-same-production-instance-docker-server/134990 "2019-12-03T18:42:27Z")

</div>

Any recommendations or steps to follow in setting up a staging Discord instance on the host that’s also hosting a production instance of Discourse? I am thinking about standard things you’d do with a Rails app, but due …

---

## [Server requirements expectations](https://meta.discourse.org/t/server-requirements-expectations/134760)

<div class="topic-metadata">

**Author:** [@bchesneau](https://meta.discourse.org/u/bchesneau)\
**Replies:** 4\
**Last updated:** [December 3, 2019, 5:58pm UTC](https://meta.discourse.org/t/server-requirements-expectations/134760 "2019-12-03T17:58:45Z")

</div>

Is there any metrics around to estimate the server requirements? What should I expect for a core of 2.4 GHz, 1 GB of RAM in term of concurrent users & co?

---

## [Failed upgrade from 2.3.2 to 2.3.6 due to discourse assign plugin](https://meta.discourse.org/t/failed-upgrade-from-2-3-2-to-2-3-6-due-to-discourse-assign-plugin/134841)

<div class="topic-metadata">

**Author:** [@nahimov](https://meta.discourse.org/u/nahimov)\
**Replies:** 5\
**Last updated:** [December 2, 2019, 2:02pm UTC](https://meta.discourse.org/t/failed-upgrade-from-2-3-2-to-2-3-6-due-to-discourse-assign-plugin/134841 "2019-12-02T14:02:48Z")

</div>

When I try to upgrade from 2.3.2 to 2.3.6 I see this error: I, \[2019-12-02T07:43:47.773465 #1\] INFO -- : \> cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' rake aborted! ArgumentError: Unknown mig…

---

## [Fixing SSL mixed content errors with external NGINX proxy via UNIX socket](https://meta.discourse.org/t/fixing-ssl-mixed-content-errors-with-external-nginx-proxy-via-unix-socket/134683)

<div class="topic-metadata">

**Author:** [@kmm](https://meta.discourse.org/u/kmm)\
**Replies:** 1\
**Last updated:** [November 29, 2019, 6:32am UTC](https://meta.discourse.org/t/fixing-ssl-mixed-content-errors-with-external-nginx-proxy-via-unix-socket/134683 "2019-11-29T06:32:19Z")

</div>

Howdy, I recently deployed a Discourse instance behind my pre-existing NGINX server using the “socketed” template. It works fine, except that I’m getting mixed content warnings originating from the web worker process re…

---

## [NGINX is Broken?](https://meta.discourse.org/t/nginx-is-broken/134493)

<div class="topic-metadata">

**Author:** [@BobHill74](https://meta.discourse.org/u/BobHill74)\
**Replies:** 32\
**Last updated:** [November 28, 2019, 3:51pm UTC](https://meta.discourse.org/t/nginx-is-broken/134493 "2019-11-28T15:51:13Z")

</div>

Alright so I’m on my Ubuntu 18.04 LTS VPS, and I’m building the app and everything. After it’s done, I go to the website, and it just says Welcome to NGINX! I have no idea what made it do this, the app.yml looks norm…

---

## [How to setup okta authentication with discourse](https://meta.discourse.org/t/how-to-setup-okta-authentication-with-discourse/134534)

<div class="topic-metadata">

**Author:** [@annakulaachyuth](https://meta.discourse.org/u/annakulaachyuth)\
**Replies:** 5\
**Last updated:** [November 27, 2019, 4:31pm UTC](https://meta.discourse.org/t/how-to-setup-okta-authentication-with-discourse/134534 "2019-11-27T16:31:38Z")

</div>

We are using okta as identity provider for our application. Can we enable users to log in to our discourse community with the same credentials via okta and even they need to be auto logged in if they were logged in my ap…

---

## [Email jobs failing due to smtpserverbusy](https://meta.discourse.org/t/email-jobs-failing-due-to-smtpserverbusy/94526)

<div class="topic-metadata">

**Author:** [@Olag](https://meta.discourse.org/u/Olag)\
**Replies:** 9\
**Last updated:** [November 27, 2019, 10:52am UTC](https://meta.discourse.org/t/email-jobs-failing-due-to-smtpserverbusy/94526 "2019-11-27T10:52:16Z")

</div>

Recently upgraded to v2.1.0.beta4 +16 On entering admin today I get the message Some problems have been found with your installation of Discourse: There are 32 email jobs that failed. Check your app.yml and ensure th…

---

## [Serverless Discourse](https://meta.discourse.org/t/serverless-discourse/103726)

<div class="topic-metadata">

**Author:** [@rootsh3ll](https://meta.discourse.org/u/rootsh3ll)\
**Replies:** 2\
**Last updated:** [November 25, 2019, 10:45pm UTC](https://meta.discourse.org/t/serverless-discourse/103726 "2019-11-25T22:45:48Z")

</div>

I am quite new to this buzzword “serverless”. All that I understand is that at minimum you need one server for any deployment. In serverless you just don’t have to manage the server side of things and only focus on code…

---

## [Discourse forum hangs and times out, doesn't load](https://meta.discourse.org/t/discourse-forum-hangs-and-times-out-doesnt-load/132450)

<div class="topic-metadata">

**Author:** [@mholt](https://meta.discourse.org/u/mholt)\
**Replies:** 10\
**Last updated:** [November 25, 2019, 3:48am UTC](https://meta.discourse.org/t/discourse-forum-hangs-and-times-out-doesnt-load/132450 "2019-11-25T03:48:24Z")

</div>

As of recently, our Discourse forum started timing out on most requests: https://caddy.community No updates or changes were made when it started happening a few days ago. Sometimes it loads fine, but a few minutes later…

---

## [New to Discourse: rebulding Discourse means loosing all Mysql data?](https://meta.discourse.org/t/new-to-discourse-rebulding-discourse-means-loosing-all-mysql-data/134331)

<div class="topic-metadata">

**Author:** [@kenaddams](https://meta.discourse.org/u/kenaddams)\
**Replies:** 1\
**Last updated:** [November 25, 2019, 12:45am UTC](https://meta.discourse.org/t/new-to-discourse-rebulding-discourse-means-loosing-all-mysql-data/134331 "2019-11-25T00:45:46Z")

</div>

Hi I am new to Discourse and after a few hours, my Discourse is now all setup and my old BBpress forum imported. Just a question - I am also new to Docker :slight\_smile: If I want to change one SMTP setting, when rebu…

---

## [Monitor: Best solutions for keeping track of uptime?](https://meta.discourse.org/t/monitor-best-solutions-for-keeping-track-of-uptime/13807)

<div class="topic-metadata">

**Author:** [@hunterowens](https://meta.discourse.org/u/hunterowens)\
**Replies:** 3\
**Last updated:** [November 25, 2019, 12:10am UTC](https://meta.discourse.org/t/monitor-best-solutions-for-keeping-track-of-uptime/13807 "2019-11-25T00:10:41Z")

</div>

Does anybody know or has written anything about monitoring a discourse site: Ie, - DB uptime/Site Uptime/Redis Uptime response times, etc. I’ve used New Relic in the past but have no strong preferences.

---

## [How to optimize storage?](https://meta.discourse.org/t/how-to-optimize-storage/134237)

<div class="topic-metadata">

**Author:** [@bck055](https://meta.discourse.org/u/bck055)\
**Replies:** 1\
**Last updated:** [November 23, 2019, 12:34am UTC](https://meta.discourse.org/t/how-to-optimize-storage/134237 "2019-11-23T00:34:03Z")

</div>

My server is 55GBs, We are running a small community. I have 5 backup files, each file est. 100 MBs. I dont know why the docker occupancy over 30GB storage? Could you help me to remove unused files or cleaning old upd…

---

## [Discourse docker rebuild failed with Unknown Migration Version](https://meta.discourse.org/t/discourse-docker-rebuild-failed-with-unknown-migration-version/134109)

<div class="topic-metadata">

**Author:** [@dhsathiya](https://meta.discourse.org/u/dhsathiya)\
**Replies:** 5\
**Last updated:** [November 22, 2019, 11:29am UTC](https://meta.discourse.org/t/discourse-docker-rebuild-failed-with-unknown-migration-version/134109 "2019-11-22T11:29:40Z")

</div>

I was rebuilding with ./launcher rebuild myapp and got following error : I, \[2019-11-22T04:39:11.739534 #1\] INFO -- : \> cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' rake aborted! ArgumentError…

---

## [Getting YAML syntax error while adding plugins](https://meta.discourse.org/t/getting-yaml-syntax-error-while-adding-plugins/134105)

<div class="topic-metadata">

**Author:** [@Nikhil\_Darji](https://meta.discourse.org/u/Nikhil_Darji)\
**Replies:** 1\
**Last updated:** [November 22, 2019, 3:05am UTC](https://meta.discourse.org/t/getting-yaml-syntax-error-while-adding-plugins/134105 "2019-11-22T03:05:53Z")

</div>

Hello, i’m trying to install plugins with this code ## Plugins go here ## see https://meta.discourse.org/t/19157 for details hooks: after\_code: - exec: cd: $home/plugins cmd: - git clon…

---

## [New setup - errors when trying to send emails through gmail](https://meta.discourse.org/t/new-setup-errors-when-trying-to-send-emails-through-gmail/133670)

<div class="topic-metadata">

**Author:** [@yacineSmartly](https://meta.discourse.org/u/yacineSmartly)\
**Replies:** 14\
**Last updated:** [November 21, 2019, 9:07pm UTC](https://meta.discourse.org/t/new-setup-errors-when-trying-to-send-emails-through-gmail/133670 "2019-11-21T21:07:22Z")

</div>

Hello, I’ve set up discourse on my private cloud in ubuntu server 16.04. All installed were fine. I have a problem now when trying to test email part. I entered the correct informations but i don’t receive the emails. …

---

## [Discourse + Web Application Firewall (WAF) mod\_security](https://meta.discourse.org/t/discourse-web-application-firewall-waf-mod-security/133612)

<div class="topic-metadata">

**Author:** [@maltfield](https://meta.discourse.org/u/maltfield)\
**Replies:** 8\
**Last updated:** [November 20, 2019, 11:07pm UTC](https://meta.discourse.org/t/discourse-web-application-firewall-waf-mod-security/133612 "2019-11-20T23:07:20Z")

</div>

What is the recommended WAF to run in-front of Discourse? I recently succeeded in modifying the nginx config installed in the Discourse docker container to include ModSecurity and the OWASP (Open Web Application Securit…

---

## [502 Bad Gateway - nginx/1.14.0 (Ubuntu): Unable to find image locally + Error response from daemon](https://meta.discourse.org/t/502-bad-gateway-nginx-1-14-0-ubuntu-unable-to-find-image-locally-error-response-from-daemon/133392)

<div class="topic-metadata">

**Author:** [@naupe](https://meta.discourse.org/u/naupe)\
**Replies:** 9\
**Last updated:** [November 18, 2019, 2:53am UTC](https://meta.discourse.org/t/502-bad-gateway-nginx-1-14-0-ubuntu-unable-to-find-image-locally-error-response-from-daemon/133392 "2019-11-18T02:53:35Z")

</div>

Recently I moved my Dell Server from one location to another. Its Main OS/VM Manager is Proxmox VE 5.3. I got an Nginx VM that is Reverse Proxying several other VMs, one of which is a Discourse VM. After configuring my …

---

## [How to run Discourse in Apache vhost, not Nginx](https://meta.discourse.org/t/how-to-run-discourse-in-apache-vhost-not-nginx/133112)

<div class="topic-metadata">

**Author:** [@maltfield](https://meta.discourse.org/u/maltfield)\
**Replies:** 28\
**Last updated:** [November 17, 2019, 1:41pm UTC](https://meta.discourse.org/t/how-to-run-discourse-in-apache-vhost-not-nginx/133112 "2019-11-17T13:41:24Z")

</div>

Has anyone successfully setup Discourse running on an Apache vhost, instead of the default nginx? It looks like most of the chatter around apache on these forums is about running Discourse on a host that already runs ap…

---

## [Direct-delivery: incoming mail LetsEncrypt failure (prop.ltcmp.net.key is wrong) & nondelivery due to this?](https://meta.discourse.org/t/direct-delivery-incoming-mail-letsencrypt-failure-prop-ltcmp-net-key-is-wrong-nondelivery-due-to-this/133525)

<div class="topic-metadata">

**Author:** [@mreach](https://meta.discourse.org/u/mreach)\
**Replies:** 3\
**Last updated:** [November 16, 2019, 7:30pm UTC](https://meta.discourse.org/t/direct-delivery-incoming-mail-letsencrypt-failure-prop-ltcmp-net-key-is-wrong-nondelivery-due-to-this/133525 "2019-11-16T19:30:00Z")

</div>

When I use the direct-delivery email receivership setup as per this, I end up with the following errors in logs that consist of both a failure with LetsEncrypt and an incoming test to “nobody@discourse.domain.tld” from a…

[Previous page](https://meta.discourse.org/c/support/self-hosting/31.md?page=111)

[Next page](https://meta.discourse.org/c/support/self-hosting/31.md?page=113)
