# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=122

[最新版本](https://meta.discourse.org/latest.md) · [分類](https://meta.discourse.org/categories.md) · [標簽](https://meta.discourse.org/tags.md)

**Page:** 123

---

## [How to configure redis with password in case of stand alone redis server](https://meta.discourse.org/t/how-to-configure-redis-with-password-in-case-of-stand-alone-redis-server/51781)

<div class="topic-metadata">

**Author:** [@irshad\_discource](https://meta.discourse.org/u/irshad_discource)\
**回覆:** 1\
**Last updated:** [2016年十月21日 00:11 UTC](https://meta.discourse.org/t/how-to-configure-redis-with-password-in-case-of-stand-alone-redis-server/51781 "2016-10-21T00:11:33Z")

</div>

My discourse app need to connect to central redis server which has auth enabled.Right now I am connecting this server by setting DISCOURSE\_REDIS\_HOST: $MyRedisIP in web\_only.yml. Is there a way I can configure a password…

---

## [在清理空间和重新填充空间之间陷入循环](https://meta.discourse.org/t/stuck-in-a-loop-of-freeing-up-space-and-filling-it-up-again-when-rebuilding/96044)

<div class="topic-metadata">

**Author:** [@tophee](https://meta.discourse.org/u/tophee)\
**回覆:** 30\
**Last updated:** [2019年三月20日 00:39 UTC](https://meta.discourse.org/t/stuck-in-a-loop-of-freeing-up-space-and-filling-it-up-again-when-rebuilding/96044 "2019-03-20T00:39:21Z")

</div>

我的重建失败了，因为磁盘空间不足，所以我需要释放一些空间。但我陷入一个循环：./launcher cleanup 可以释放足够的空间，使其超过5 GB。所以我开始重建，但那又填满了空间……

---

## [将 Discourse 备份导入 PostGreSQL 数据库](https://meta.discourse.org/t/importing-a-discourse-backup-into-a-postgresql-db/110861)

<div class="topic-metadata">

**Author:** [@Alexandra\_Diehl](https://meta.discourse.org/u/Alexandra_Diehl)\
**回覆:** 2\
**Last updated:** [2019年三月19日 18:45 UTC](https://meta.discourse.org/t/importing-a-discourse-backup-into-a-postgresql-db/110861 "2019-03-19T18:45:28Z")

</div>

尊敬的 Discourse 团队， 请问如何导入备份到 PostgreSQL 数据库？ 我使用的是： psql --username=xx --password=xx mydb \< C:\\...\\backup.tar 但我收到一条奇怪的错误信息： orden \\Y¾³s'ìfu7}Ø$M²ÏñT…

---

## [外部系统字母头像下载失败](https://meta.discourse.org/t/external-system-letter-avatars-fail-to-download/111919)

<div class="topic-metadata">

**Author:** [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**回覆:** 8\
**Last updated:** [2019年三月19日 12:58 UTC](https://meta.discourse.org/t/external-system-letter-avatars-fail-to-download/111919 "2019-03-19T12:58:24Z")

</div>

我有一个高流量网站（每月约 200 万页面浏览量），刚刚从托管服务迁移过来。没有使用任何非官方插件。 我遇到了一些 Rails 日志，例如： 无法正确处理劫持的响应：und…

---

## [How to configure static IP for discourse container](https://meta.discourse.org/t/how-to-configure-static-ip-for-discourse-container/51616)

<div class="topic-metadata">

**Author:** [@wil93](https://meta.discourse.org/u/wil93)\
**回覆:** 3\
**Last updated:** [2019年三月19日 02:39 UTC](https://meta.discourse.org/t/how-to-configure-static-ip-for-discourse-container/51616 "2019-03-19T02:39:06Z")

</div>

Since docker 1.10 it’s possible to set a static IP address for docker containers. This is useful when you have a nginx instance managing a lot of sites. I guess one should edit the .yml file, but I’m not sure how

---

## [我的 Debian 服务器上安装失败](https://meta.discourse.org/t/installation-fails-on-my-debian-server/111859)

<div class="topic-metadata">

**Author:** [@DustVoice](https://meta.discourse.org/u/DustVoice)\
**回覆:** 24\
**Last updated:** [2019年三月18日 22:15 UTC](https://meta.discourse.org/t/installation-fails-on-my-debian-server/111859 "2019-03-18T22:15:38Z")

</div>

不幸的是，我无法让基础的 Discourse 设置正常工作。它总是在完全相同的位置停止： I, \[2019-03-17T15:32:36.676696 #14\] INFO -- : \> cp /var/www/discourse/config/nginx.sample.conf /etc/nginx/conf.d/dis…

---

## [Spam Filter / Whitelist suggestions](https://meta.discourse.org/t/spam-filter-whitelist-suggestions/51467)

<div class="topic-metadata">

**Author:** [@VNVJeep](https://meta.discourse.org/u/VNVJeep)\
**回覆:** 3\
**Last updated:** [2016年十月15日 04:46 UTC](https://meta.discourse.org/t/spam-filter-whitelist-suggestions/51467 "2016-10-15T04:46:29Z")

</div>

We’re a cloud subscriber, and about to go live. I wanted to send some warning to all of our new, incoming users on suggestions for preventing discourse.org emails getting stuck in their spam filters. Does anyone have a…

---

## [站点徽标与带代理的 HTTPS](https://meta.discourse.org/t/site-logos-and-https-with-proxy/111752)

<div class="topic-metadata">

**Author:** [@zwetan](https://meta.discourse.org/u/zwetan)\
**回覆:** 2\
**Last updated:** [2019年三月16日 11:09 UTC](https://meta.discourse.org/t/site-logos-and-https-with-proxy/111752 "2019-03-16T11:09:08Z")

</div>

你好， 在两个不同的 Discourse 实例上， 均已升级至 v2.3.0.beta5 +43， 之前在“设置/必需”中上传的不同徽标 https://{FQDN}/admin/site\_settings/category/required 现在显示为……

---

## [Arch Linux - service-start-limit-hit](https://meta.discourse.org/t/arch-linux-service-start-limit-hit/111438)

<div class="topic-metadata">

**Author:** [@SealsRock12](https://meta.discourse.org/u/SealsRock12)\
**回覆:** 4\
**Last updated:** [2019年三月16日 01:49 UTC](https://meta.discourse.org/t/arch-linux-service-start-limit-hit/111438 "2019-03-16T01:49:20Z")

</div>

大家好， 我试图在我正在输入这条消息的电脑上安装 Discourse，该电脑目前运行的是 Arch Linux。我已按照说明操作，并刚刚运行了 ./discourse-setup。我已设置好所有必要的功能…

---

## [在 SmartOS lx 区域安装 Discourse](https://meta.discourse.org/t/install-discourse-on-smartos-zone-lx/111700)

<div class="topic-metadata">

**Author:** [@rmaiquez](https://meta.discourse.org/u/rmaiquez)\
**回覆:** 3\
**Last updated:** [2019年三月15日 17:14 UTC](https://meta.discourse.org/t/install-discourse-on-smartos-zone-lx/111700 "2019-03-15T17:14:54Z")

</div>

大家好，我有一台 SmartOS 服务器，希望在 Ubuntu 16.04 的 LX 区域中安装 Discourse。 我遇到的问题是，无法在 LX 区域中安装 Docker，因为这违背了 SmartOS 的理念…

---

## [全新安装卡在管理员访问权限处](https://meta.discourse.org/t/fresh-install-stalling-at-admin-access/111623)

<div class="topic-metadata">

**Author:** [@AlexHumva](https://meta.discourse.org/u/AlexHumva)\
**回覆:** 4\
**Last updated:** [2019年三月15日 00:39 UTC](https://meta.discourse.org/t/fresh-install-stalling-at-admin-access/111623 "2019-03-15T00:39:46Z")

</div>

所以我正在尝试设置一个基本的 Discourse 服务器，按照基础安装指南操作，一切启动正常。到了初始注册页面，输入了管理员信息，然后收到了确认邮件…

---

## [NodeChef Discourse 托管服务表现不佳](https://meta.discourse.org/t/nodechef-discourse-hosting-is-sub-par/111595)

<div class="topic-metadata">

**Author:** [@Paul\_Cormier1](https://meta.discourse.org/u/Paul_Cormier1)\
**回覆:** 0\
**Last updated:** [2019年三月14日 15:58 UTC](https://meta.discourse.org/t/nodechef-discourse-hosting-is-sub-par/111595 "2019-03-14T15:58:20Z")

</div>

我曾在 NodeChef 上托管一些 NodeJS 应用，尽管其界面存在一些 bug 和用户体验问题，但我对其性能和可用功能感到满意。我打算测试他们的 Discourse 托管服务……

---

## [论坛显示“Oops”消息](https://meta.discourse.org/t/forum-shows-oops-message/82202)

<div class="topic-metadata">

**Author:** [@ankur1857](https://meta.discourse.org/u/ankur1857)\
**回覆:** 26\
**Last updated:** [2019年三月14日 14:02 UTC](https://meta.discourse.org/t/forum-shows-oops-message/82202 "2019-03-14T14:02:00Z")

</div>

我的 Discourse 论坛显示了以下“Oops”消息。请帮助解决。 \[oops\]

---

## [Mailman 迁移至 Discourse](https://meta.discourse.org/t/mailman-to-discourse-migration/111485)

<div class="topic-metadata">

**Author:** [@zkhaial](https://meta.discourse.org/u/zkhaial)\
**回覆:** 2\
**Last updated:** [2019年三月13日 22:29 UTC](https://meta.discourse.org/t/mailman-to-discourse-migration/111485 "2019-03-13T22:29:09Z")

</div>

大家好， 希望一切顺利。 我在尝试从 GNU Mailman 迁移到 Discourse 时遇到了一些挑战。我已经配置了 POP，并且能够向 Discourse 发送邮件并创建新主题。我的问题是，Discourse…

---

## [无法登录、重置密码或创建新账户，原因是403 Forbidden错误](https://meta.discourse.org/t/cant-login-reset-password-or-create-new-account-due-to-403-forbidden-error/55322)

<div class="topic-metadata">

**Author:** [@poka](https://meta.discourse.org/u/poka)\
**回覆:** 10\
**Last updated:** [2019年三月13日 09:37 UTC](https://meta.discourse.org/t/cant-login-reset-password-or-create-new-account-due-to-403-forbidden-error/55322 "2019-03-13T09:37:04Z")

</div>

大家好！我在我的discourse上遇到了一个大问题。近几天，没有人再能登录，无论是电子邮件认证还是社交登录（Facebook、Google、Twitter等）。这非常奇怪，因为一切都……

---

## [Discourse on Azure Container Service?](https://meta.discourse.org/t/discourse-on-azure-container-service/63752)

<div class="topic-metadata">

**Author:** [@pmartin](https://meta.discourse.org/u/pmartin)\
**回覆:** 9\
**Last updated:** [2019年三月13日 08:17 UTC](https://meta.discourse.org/t/discourse-on-azure-container-service/63752 "2019-03-13T08:17:51Z")

</div>

Has anyone tried installing Discourse on Azure’s Docker on App Service? From what I have read, Azure is utilizing a specialized Linux distro to support the containers (see 4th heading on https://docs.docker.com/docker-…

---

## [Discourse 通过电子邮件使用的教程？](https://meta.discourse.org/t/tutorial-for-using-discourse-over-email/111308)

<div class="topic-metadata">

**Author:** [@ChristopherA](https://meta.discourse.org/u/ChristopherA)\
**回覆:** 3\
**Last updated:** [2019年三月12日 19:14 UTC](https://meta.discourse.org/t/tutorial-for-using-discourse-over-email/111308 "2019-03-12T19:14:11Z")

</div>

我们正在将一个现有的开源社区迁移到 Discourse。部分成员希望其继续保持邮件服务器的行为，即发送可由邮件客户端进行线程化处理的独立电子邮件，并支持回复……

---

## [S3 存储桶备份设置页面问题](https://meta.discourse.org/t/s3-bucket-backup-setting-page-problem/111382)

<div class="topic-metadata">

**Author:** [@Maximiliano\_Cipriano](https://meta.discourse.org/u/Maximiliano_Cipriano)\
**回覆:** 4\
**Last updated:** [2019年三月12日 13:55 UTC](https://meta.discourse.org/t/s3-bucket-backup-setting-page-problem/111382 "2019-03-12T13:55:31Z")

</div>

你好，我遇到了一个问题，我没有看到插入 AWS 访问密钥和秘密密钥的选项。 有什么建议吗？ Discourse 版本 已安装### \[v2.3.0.beta4 +1\]

---

## [Sidekiq 崩溃且无法恢复](https://meta.discourse.org/t/sidekiq-dying-and-not-coming-back-up/111267)

<div class="topic-metadata">

**Author:** [@LeoMcA](https://meta.discourse.org/u/LeoMcA)\
**回覆:** 4\
**Last updated:** [2019年三月11日 20:15 UTC](https://meta.discourse.org/t/sidekiq-dying-and-not-coming-back-up/111267 "2019-03-11T20:15:15Z")

</div>

我的 Sidekiq 进程出现了一个神秘的问题：它们不断崩溃且无法自动恢复。 关于 @sam 在此处讨论的 Sidekiq 进程监控：https://meta.discourse.org/t/running-s…

---

## [我只看到 Web 服务器的默认页面，而不是 Discourse（Jelastic 配合 Docker 镜像）](https://meta.discourse.org/t/i-only-get-the-default-page-from-the-webserver-and-not-discourse-jelastic-with-docker-image/111128)

<div class="topic-metadata">

**Author:** [@sm-a](https://meta.discourse.org/u/sm-a)\
**回覆:** 3\
**Last updated:** [2019年三月11日 11:25 UTC](https://meta.discourse.org/t/i-only-get-the-default-page-from-the-webserver-and-not-discourse-jelastic-with-docker-image/111128 "2019-03-11T11:25:01Z")

</div>

First Discourse 是一款出色的软件，我对此非常满意。不过，我在安装过程中遇到了一个问题。我想使用 Jelastic 配合 Docker 镜像。然而，当我加载 Jelastic 的 Docker 镜像时，仅……

---

## [您觉得Communiteq怎么样？](https://meta.discourse.org/t/how-do-you-like-communiteq/108962)

<div class="topic-metadata">

**Author:** [@Travis\_Hedrick](https://meta.discourse.org/u/Travis_Hedrick)\
**回覆:** 11\
**Last updated:** [2019年二月20日 15:25 UTC](https://meta.discourse.org/t/how-do-you-like-communiteq/108962 "2019-02-20T15:25:11Z")

</div>

大家好。我们想知道大家如何看待 Discourse Hosting Dot Com？我们有一个网站，目前每月约有 150 万用户（https://d.pr/i/SpzPnE），我们需要一个稳定且最好是托管的解决方案。 你们是否……

---

## [是否可以在本地托管 Discourse？](https://meta.discourse.org/t/is-it-possible-to-locally-host-discourse/107144)

<div class="topic-metadata">

**Author:** [@Teddy\_H](https://meta.discourse.org/u/Teddy_H)\
**回覆:** 4\
**Last updated:** [2019年三月9日 18:11 UTC](https://meta.discourse.org/t/is-it-possible-to-locally-host-discourse/107144 "2019-03-09T18:11:24Z")

</div>

我想在本地托管 Discourse 以测试论坛，但目前没有信用卡进行验证，因此无法使用 Discourse 的免费试用。请问这是否可行？如果可行，该如何实现？

---

## [Meta is moving to the Cloud 🌩](https://meta.discourse.org/t/meta-is-moving-to-the-cloud/72819)

<div class="topic-metadata">

**Author:** [@sam](https://meta.discourse.org/u/sam)\
**回覆:** 44\
**Last updated:** [2019年二月19日 04:57 UTC](https://meta.discourse.org/t/meta-is-moving-to-the-cloud/72819 "2019-02-19T04:57:10Z")

</div>

Read Only Mode Very Soon We are moving Meta to AWS today, this will involve about 30-45 minutes of “Read only” mode while we copy the DB over.

---

## [重建失败的“rubygems.org：连接重置过多”](https://meta.discourse.org/t/rebuild-failing-rubygems-org-too-many-connection-resets/111144)

<div class="topic-metadata">

**Author:** [@adorfer](https://meta.discourse.org/u/adorfer)\
**回覆:** 1\
**Last updated:** [2019年三月9日 06:31 UTC](https://meta.discourse.org/t/rebuild-failing-rubygems-org-too-many-connection-resets/111144 "2019-03-09T06:31:07Z")

</div>

在进行升级时（Ubuntu 16.04.06，较旧的安装版本，至少 2-3 个月未更新），通过 CLI 执行“rebuild app”命令后，我卡住了数小时。 执行命令：su discourse -c 'bundle install --deployment --verbo…

---

## [自定义 CSS 是否会在尝试升级时导致错误？](https://meta.discourse.org/t/can-custom-css-cause-an-error-when-trying-to-upgrade/110867)

<div class="topic-metadata">

**Author:** [@joshm](https://meta.discourse.org/u/joshm)\
**回覆:** 8\
**Last updated:** [2019年三月7日 15:07 UTC](https://meta.discourse.org/t/can-custom-css-cause-an-error-when-trying-to-upgrade/110867 "2019-03-07T15:07:32Z")

</div>

尝试升级时无法重建应用。错误消息如下： FAILED -------------------- Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake assets:precompile' 失败，返回 #

---

## [“convert”进程占用大量 CPU](https://meta.discourse.org/t/convert-process-eating-cpu/101309)

<div class="topic-metadata">

**Author:** [@soke](https://meta.discourse.org/u/soke)\
**回覆:** 14\
**Last updated:** [2019年三月7日 11:43 UTC](https://meta.discourse.org/t/convert-process-eating-cpu/101309 "2019-03-07T11:43:50Z")

</div>

您好。 我已升级到 Discourse 的最新版本。 我已更改了 CDN 地址并重新生成了帖子。 之后，我有很多进程依次运行，执行以下命令： convert jpeg:/var/www/discourse…

---

## [我不断收到确认邮件](https://meta.discourse.org/t/i-keep-getting-confirmation-mail/110267)

<div class="topic-metadata">

**Author:** [@Wurzelseppi](https://meta.discourse.org/u/Wurzelseppi)\
**回覆:** 3\
**Last updated:** [2019年三月6日 19:06 UTC](https://meta.discourse.org/t/i-keep-getting-confirmation-mail/110267 "2019-03-06T19:06:32Z")

</div>

大家好， 今天我安装了我的 Discourse 论坛，并尝试首次通过电子邮件确认登录，但由于邮件设置问题，该操作未能成功。 随后，我通过 \`rake admin:create\` 命令创建了管理员账户，并…

---

## [需要帮助搭建 Discourse 的自托管 VPS](https://meta.discourse.org/t/need-help-for-self-hosted-vps-for-discourse/110705)

<div class="topic-metadata">

**Author:** [@FirstLove](https://meta.discourse.org/u/FirstLove)\
**回覆:** 3\
**Last updated:** [2019年三月5日 08:47 UTC](https://meta.discourse.org/t/need-help-for-self-hosted-vps-for-discourse/110705 "2019-03-05T08:47:03Z")

</div>

这是我的 IP：http://120.79.54.248 我遵循了这个教程：discourse/docs/INSTALL-cloud.md at main · discourse/discourse · GitHub 每次我执行 /var/discourse# ./discourse-setup 时，它都能正常运行，没有任何错误…

---

## [启动失败 - 启动器重建应用](https://meta.discourse.org/t/failed-to-bootstrap-launcher-rebuild-app/110619)

<div class="topic-metadata">

**Author:** [@TestUser](https://meta.discourse.org/u/TestUser)\
**回覆:** 1\
**Last updated:** [2019年三月4日 17:22 UTC](https://meta.discourse.org/t/failed-to-bootstrap-launcher-rebuild-app/110619 "2019-03-04T17:22:03Z")

</div>

我已将 URL 从 http://example.com 更新为 http://example.com/forum。运行 ./launcher rebuild app 后，出现以下错误信息。如何解决此问题 :(。 FAILED -------------------- Errno::ENOENT: 没有这样的文件或目录

---

## [推荐数据库缓冲区和 Unicorn 工作进程](https://meta.discourse.org/t/recommended-db-buffers-and-unicorn-workers/110491)

<div class="topic-metadata">

**Author:** [@foros](https://meta.discourse.org/u/foros)\
**回覆:** 6\
**Last updated:** [2019年三月4日 00:14 UTC](https://meta.discourse.org/t/recommended-db-buffers-and-unicorn-workers/110491 "2019-03-04T00:14:28Z")

</div>

你好， 我想知道我为数据库缓冲区和 Unicorn 工作进程设置的配置是否适合我的机器。我的虚拟机有 4 个 vCPU 和 32GB 内存。我将数据库缓冲区设置为 8000MB，并启用了 10 个 Unicorn 工作进程。这样的设置是否合理？

[上一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=121)

[下一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=123)
