# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=125

[最新版本](https://meta.discourse.org/latest.md) · [分類](https://meta.discourse.org/categories.md) · [標簽](https://meta.discourse.org/tags.md)

**Page:** 126

---

## [Mini\_racer 0.2.0 导致打包工具失败](https://meta.discourse.org/t/mini-racer-0-2-0-causing-bundler-to-fail/106281)

<div class="topic-metadata">

**Author:** [@meyersh](https://meta.discourse.org/u/meyersh)\
**回覆:** 1\
**Last updated:** [2019年一月11日 16:21 UTC](https://meta.discourse.org/t/mini-racer-0-2-0-causing-bundler-to-fail/106281 "2019-01-11T16:21:38Z")

</div>

我正在将Discourse从1.9.6升级到2.1.6，但在运行bundle install时遇到问题。我使用的是Docker（Ubuntu 16.04）作为构建Discourse的基础镜像。Ruby版本为2.3.0。当我执行bundle install时，出现问题……

---

## [自托管 Discourse 是否需要商业许可证？](https://meta.discourse.org/t/do-we-need-a-commercial-license-for-self-hosted-discourse/106187)

<div class="topic-metadata">

**Author:** [@Subham\_Joshi](https://meta.discourse.org/u/Subham_Joshi)\
**回覆:** 1\
**Last updated:** [2019年一月10日 13:16 UTC](https://meta.discourse.org/t/do-we-need-a-commercial-license-for-self-hosted-discourse/106187 "2019-01-10T13:16:16Z")

</div>

我们希望在商业应用程序中使用 Discourse 作为社区门户。经调查，它是开源的，采用 GNU GPL 许可证。如果我们需要将自托管的 Discourse 包含在……中，是否需要商业许可证？

---

## [基本安装问题](https://meta.discourse.org/t/basic-installation-question/105992)

<div class="topic-metadata">

**Author:** [@hhlp](https://meta.discourse.org/u/hhlp)\
**回覆:** 4\
**Last updated:** [2019年一月8日 20:35 UTC](https://meta.discourse.org/t/basic-installation-question/105992 "2019-01-08T20:35:44Z")

</div>

一个简单而愚蠢的问题：如果我购买了贵方的基础托管计划，我是否可以访问服务器以安装插件，还是必须请求工作人员代为操作？另外，在基础计划中我可以安装多少个插件？

---

## [Front nginx https 反向代理到 discourse http](https://meta.discourse.org/t/front-nginx-https-reverse-proxy-to-discourse-http/106000)

<div class="topic-metadata">

**Author:** [@danchik](https://meta.discourse.org/u/danchik)\
**回覆:** 2\
**Last updated:** [2019年一月8日 22:00 UTC](https://meta.discourse.org/t/front-nginx-https-reverse-proxy-to-discourse-http/106000 "2019-01-08T22:00:02Z")

</div>

你好 我在 443 端口运行 Nginx，接收来自 https://discourse.example.com 的流量，并将其转发到运行在 8080 端口的 Discourse…… 当我访问 https://discourse.example.com 时，Discourse 显示欢迎…

---

## [邮件无法发送给用户](https://meta.discourse.org/t/mails-not-sending-to-users/105775)

<div class="topic-metadata">

**Author:** [@habeycole](https://meta.discourse.org/u/habeycole)\
**回覆:** 7\
**Last updated:** [2019年一月6日 13:15 UTC](https://meta.discourse.org/t/mails-not-sending-to-users/105775 "2019-01-06T13:15:30Z")

</div>

大家好， 我有一个由 Discourse 驱动的社区，自创建以来一直运行正常。但我发现，在同一社区注册的用户没有收到激活邮件，如果我手动激活他们……

---

## [收不到论坛邮件](https://meta.discourse.org/t/not-receiving-mails-from-forum/105802)

<div class="topic-metadata">

**Author:** [@defodanmark](https://meta.discourse.org/u/defodanmark)\
**回覆:** 1\
**Last updated:** [2019年一月6日 09:42 UTC](https://meta.discourse.org/t/not-receiving-mails-from-forum/105802 "2019-01-06T09:42:53Z")

</div>

大家好， 我一直在使用 Mailgun 设置 Discourse，并参考了 Paul Nicholson 的这段 YouTube 视频。YouTube 我的论坛一直运行正常，已经持续数周了。直到今天，当我尝试重新创建……

---

## [激活邮件中的链接已失效](https://meta.discourse.org/t/link-broken-in-activation-email/105726)

<div class="topic-metadata">

**Author:** [@talesky](https://meta.discourse.org/u/talesky)\
**回覆:** 3\
**Last updated:** [2019年一月5日 14:12 UTC](https://meta.discourse.org/t/link-broken-in-activation-email/105726 "2019-01-05T14:12:39Z")

</div>

我按照此链接中的设置文档操作：在 30 分钟内于云端设置 Discourse 我已在 Namecheap 注册了域名，并在 DigitalOcean 上创建了 A 记录，指向 d… 的 IP 地址。

---

## [为 Discourse 自建邮件服务器？](https://meta.discourse.org/t/hosting-my-own-mailserver-for-discourse/105316)

<div class="topic-metadata">

**Author:** [@Benjamin\_Johnston](https://meta.discourse.org/u/Benjamin_Johnston)\
**回覆:** 6\
**Last updated:** [2018年十二月30日 19:42 UTC](https://meta.discourse.org/t/hosting-my-own-mailserver-for-discourse/105316 "2018-12-30T19:42:01Z")

</div>

我四处查找过，但所有教程都建议使用像 Mailgun 这样的服务，而我更倾向于不使用。有人知道如何自行搭建邮件服务器以配合 Discourse 使用吗？

---

## [邮箱认证问题](https://meta.discourse.org/t/email-auth-problem/105223)

<div class="topic-metadata">

**Author:** [@xanita](https://meta.discourse.org/u/xanita)\
**回覆:** 2\
**Last updated:** [2018年十二月30日 13:34 UTC](https://meta.discourse.org/t/email-auth-problem/105223 "2018-12-30T13:34:35Z")

</div>

大家好！ 我在 Docker 上成功部署并运行了 Discourse，但无法使用某个特定邮箱正常工作。我用自己在小型服务器上运行的私人邮箱以及 Gmail 账户都能正常配置， 但我需要 ……

---

## [安装后仅显示“Index of /”](https://meta.discourse.org/t/only-seeing-index-of-after-install/105251)

<div class="topic-metadata">

**Author:** [@FAXES](https://meta.discourse.org/u/FAXES)\
**回覆:** 12\
**Last updated:** [2018年十二月29日 13:52 UTC](https://meta.discourse.org/t/only-seeing-index-of-after-install/105251 "2018-12-29T13:52:36Z")

</div>

嘿！ 基本系统信息 运行 Apache Ubuntu 问题 所以我已经安装了 Discourse 及所有相关组件，但访问域名链接时只看到： 我是否漏掉了某个步骤？ 请注意，这不是 Digital Ocean 系统…

---

## [升级自 1.9.0.beta11 时遇到问题](https://meta.discourse.org/t/trouble-upgrading-from-1-9-0-beta11/105219)

<div class="topic-metadata">

**Author:** [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**回覆:** 2\
**Last updated:** [2018年十二月29日 02:18 UTC](https://meta.discourse.org/t/trouble-upgrading-from-1-9-0-beta11/105219 "2018-12-29T02:18:40Z")

</div>

我试图从 Discourse 1.9.0.beta11 升级，该版本需要升级 PostgreSQL。PostgreSQL 升级似乎正常，但现在重建失败，错误如下：\\n由...引起：\\u0026hellip;

---

## [服务器重启后如何重启 Discourse？](https://meta.discourse.org/t/how-to-restart-discourse-after-server-reboot/105181)

<div class="topic-metadata">

**Author:** [@iraszl](https://meta.discourse.org/u/iraszl)\
**回覆:** 4\
**Last updated:** [2018年十二月28日 15:18 UTC](https://meta.discourse.org/t/how-to-restart-discourse-after-server-reboot/105181 "2018-12-28T15:18:30Z")

</div>

我有一台 DigitalOcean Droplet。我按照推荐使用 Docker 安装了 Discourse，运行正常。我还从备份恢复了 Discourse，也一切正常。然后，我想重启服务器以便新的备份能够完整...

---

## [新 Discourse 实例 + SMTP](https://meta.discourse.org/t/new-discourse-instance-smtp/95866)

<div class="topic-metadata">

**Author:** [@Iceman](https://meta.discourse.org/u/Iceman)\
**回覆:** 21\
**Last updated:** [2018年十二月26日 23:47 UTC](https://meta.discourse.org/t/new-discourse-instance-smtp/95866 "2018-12-26T23:47:50Z")

</div>

大家好， 是的，这是关于电子邮件的老问题（我们敬爱的 @codinghorror 最钟爱的“技术”）。我正尝试在完全不同的环境中部署另一个 Discourse 实例（毕竟我的主要实例已经……

---

## [Ubuntu updates intefere with Docker and AUFS?](https://meta.discourse.org/t/ubuntu-updates-intefere-with-docker-and-aufs/25039)

<div class="topic-metadata">

**Author:** [@downey](https://meta.discourse.org/u/downey)\
**回覆:** 17\
**Last updated:** [2016年三月2日 19:41 UTC](https://meta.discourse.org/t/ubuntu-updates-intefere-with-docker-and-aufs/25039 "2016-03-02T19:41:56Z")

</div>

This was going fine for me until the last moment, when I got the following super-useful error message: Error response from daemon: Cannot destroy container 1cd705ffc49f5ce0622614316e3a742b8e6c8a77362528338db30a6f352477d…

---

## [Postfix 的 SMTP 问题](https://meta.discourse.org/t/smtp-issue-with-postfix/104745)

<div class="topic-metadata">

**Author:** [@satish](https://meta.discourse.org/u/satish)\
**回覆:** 2\
**Last updated:** [2018年十二月21日 21:41 UTC](https://meta.discourse.org/t/smtp-issue-with-postfix/104745 "2018-12-21T21:41:00Z")

</div>

我在 Ubuntu 18.04 上安装了 Discourse，同时也安装了 Postfix 用于 SMTP 邮件，但 Discourse 无法发送任何邮件。我无法注册管理员账户。请问有人能帮忙解决一下吗？ 我按照以下说明操作……

---

## [无法上传备份，原因是磁盘空间不足](https://meta.discourse.org/t/unable-to-upload-backup-due-to-out-of-disk-space/104832)

<div class="topic-metadata">

**Author:** [@Amethi](https://meta.discourse.org/u/Amethi)\
**回覆:** 5\
**Last updated:** [2018年十二月21日 15:30 UTC](https://meta.discourse.org/t/unable-to-upload-backup-due-to-out-of-disk-space/104832 "2018-12-21T15:30:06Z")

</div>

您好，我正尝试紧急迁移到新服务器（旧服务器已彻底损坏，网站已离线！），在将旧服务器的备份上传到新服务器时，上传进度约 37% 后出现了这条令人“愉快”的提示： …

---

## [在新 Discourse 实例上启用 Let's Encrypt 时出现脚本错误](https://meta.discourse.org/t/script-error-enabling-lets-encrypt-on-new-discourse-instance/104791)

<div class="topic-metadata">

**Author:** [@L30110](https://meta.discourse.org/u/L30110)\
**回覆:** 2\
**Last updated:** [2018年十二月20日 22:07 UTC](https://meta.discourse.org/t/script-error-enabling-lets-encrypt-on-new-discourse-instance/104791 "2018-12-20T22:07:33Z")

</div>

今天处理了大量事务！正尝试通过 Discourse 的自动化系统启用 Let's Encrypt（我在 Apache 站点上已多次配置过 Let's Encrypt，此次希望尽可能保持论坛的原生状态）。配置过…

---

## [使用 DigitalOcean 和 SMTP 进行设置](https://meta.discourse.org/t/setup-with-digital-ocean-and-smtp/98356)

<div class="topic-metadata">

**Author:** [@UltraAviation1](https://meta.discourse.org/u/UltraAviation1)\
**回覆:** 13\
**Last updated:** [2018年十二月20日 22:31 UTC](https://meta.discourse.org/t/setup-with-digital-ocean-and-smtp/98356 "2018-12-20T22:31:07Z")

</div>

嘿！ 我需要一些关于设置的帮助，我可以进入 PUTTY 等工具。 我主要需要 SMTP 方面的帮助（获取服务或其他相关事项）。如果您有 Discord，请告诉我您是否能提供帮助。 谢谢。

---

## [在 Hostgator 站点上安装 Digital Ocean Discourse](https://meta.discourse.org/t/digital-ocean-discourse-install-with-hostgator-site/104603)

<div class="topic-metadata">

**Author:** [@David\_Ruehle](https://meta.discourse.org/u/David_Ruehle)\
**回覆:** 4\
**Last updated:** [2018年十二月19日 16:17 UTC](https://meta.discourse.org/t/digital-ocean-discourse-install-with-hostgator-site/104603 "2018-12-19T16:17:19Z")

</div>

您好，我正在尝试使用通过 Hover 购买并通过 HostGator 托管的域名来运行我的论坛。安装和以 HTTP 运行一切正常，我刚创建了 DNS A 记录并指向了 Droplet IP，但我需要 …

---

## [安全扫描发现 /login 存在 CSRF 安全警报](https://meta.discourse.org/t/csrf-on-login-security-alert-from-security-scans/104667)

<div class="topic-metadata">

**Author:** [@jlaura](https://meta.discourse.org/u/jlaura)\
**回覆:** 6\
**Last updated:** [2018年十二月19日 17:42 UTC](https://meta.discourse.org/t/csrf-on-login-security-alert-from-security-scans/104667 "2018-12-19T17:42:00Z")

</div>

我通过 Docker 容器在本地 Docker Swarm 中部署 Discourse。安装过程非常顺利，我们在极短的时间内就成功部署了一个可运行的原型。感谢提供出色的文档！…

---

## [删除已暂停的账户](https://meta.discourse.org/t/delete-a-suspended-account/104675)

<div class="topic-metadata">

**Author:** [@farribeiro](https://meta.discourse.org/u/farribeiro)\
**回覆:** 3\
**Last updated:** [2018年十二月19日 15:11 UTC](https://meta.discourse.org/t/delete-a-suspended-account/104675 "2018-12-19T15:11:28Z")

</div>

我参与了 Discourse 托管论坛，但我的账户已被暂停，我想删除它。我该如何操作？

---

## [特定搜索出现 502 错误网关](https://meta.discourse.org/t/502-bad-gateway-on-specific-searches/104616)

<div class="topic-metadata">

**Author:** [@CT075](https://meta.discourse.org/u/CT075)\
**回覆:** 3\
**Last updated:** [2018年十二月19日 12:47 UTC](https://meta.discourse.org/t/502-bad-gateway-on-specific-searches/104616 "2018-12-19T12:47:59Z")

</div>

（我已阅读此线程，但似乎没有帮助） 我们最近将站点更新到了更新版本的 Docker 和 Discourse，多位用户报告了整体站点速度变慢（我怀疑这与磁盘有关……

---

## [新安装的 Discourse 无法与 Rackspace 邮件配合使用的问题](https://meta.discourse.org/t/problems-getting-new-discourse-install-to-work-with-rackspace-email/104653)

<div class="topic-metadata">

**Author:** [@madeye](https://meta.discourse.org/u/madeye)\
**回覆:** 1\
**Last updated:** [2018年十二月19日 11:31 UTC](https://meta.discourse.org/t/problems-getting-new-discourse-install-to-work-with-rackspace-email/104653 "2018-12-19T11:31:44Z")

</div>

我刚在一台 CentOS 7 服务器上安装了 Docker Discourse，配置和启动过程非常顺利。然而，当我尝试注册管理员账户时，虽然收到了“我们已重新发送激活……”的提示，

---

## [未收到激活邮件，但日志显示已发送](https://meta.discourse.org/t/activation-mail-not-received-and-logs-says-it-sent/104546)

<div class="topic-metadata">

**Author:** [@randikam](https://meta.discourse.org/u/randikam)\
**回覆:** 1\
**Last updated:** [2018年十二月18日 15:41 UTC](https://meta.discourse.org/t/activation-mail-not-received-and-logs-says-it-sent/104546 "2018-12-18T15:41:17Z")

</div>

我没有收到激活邮件，但 production.log 显示邮件已成功发送。 请查看下方的 production.log 堆栈信息： Started GET "/finish-installation/confirm-email" for 220.247.229.50 at 2018-12-18 11:18:01 +…

---

## [Does the server need 2GB of RAM?](https://meta.discourse.org/t/does-the-server-need-2gb-of-ram/23630)

<div class="topic-metadata">

**Author:** [@Swathi](https://meta.discourse.org/u/Swathi)\
**回覆:** 19\
**Last updated:** [2017年七月27日 15:04 UTC](https://meta.discourse.org/t/does-the-server-need-2gb-of-ram/23630 "2017-07-27T15:04:29Z")

</div>

Hi, Is it mandatory that we should have 2GB of Ram for Discourse. I am planning to use discourse for one of my forum. Please help me. Thanks

---

## [全新安装后无法连接到 Redis](https://meta.discourse.org/t/failing-to-connect-to-redis-after-fresh-install/104007)

<div class="topic-metadata">

**Author:** [@majestic](https://meta.discourse.org/u/majestic)\
**回覆:** 4\
**Last updated:** [2018年十二月11日 18:01 UTC](https://meta.discourse.org/t/failing-to-connect-to-redis-after-fresh-install/104007 "2018-12-11T18:01:35Z")

</div>

你好。 我正在 AWS EC2 上基于 Ubuntu 16.04 LTS 全新安装 Discourse。不幸的是，我遇到了以下问题： \`连接到 localhost:6379 上的 Redis 时出错 (Errno::ECONNREFUSED) 订阅失败，rec…\`

---

## [Varnish config for discourse](https://meta.discourse.org/t/varnish-config-for-discourse/68575)

<div class="topic-metadata">

**Author:** [@Quintin\_Par](https://meta.discourse.org/u/Quintin_Par)\
**回覆:** 16\
**Last updated:** [2018年十二月11日 16:45 UTC](https://meta.discourse.org/t/varnish-config-for-discourse/68575 "2018-12-11T16:45:17Z")

</div>

Is there an official config for discourse that I can use?

---

## [运行启动器重建操作清除了我的数据库](https://meta.discourse.org/t/running-launcher-rebuild-wiped-my-db/103481)

<div class="topic-metadata">

**Author:** [@iegomez](https://meta.discourse.org/u/iegomez)\
**回覆:** 23\
**Last updated:** [2018年十二月10日 20:16 UTC](https://meta.discourse.org/t/running-launcher-rebuild-wiped-my-db/103481 "2018-12-10T20:16:05Z")

</div>

您好，我在尝试一键浏览器升级时遇到了相同的页面： 因此，我按照说明操作，结果导致 Discourse 数据库被清空（在唯一可用的容器中，因为命令清除了旧的容器…

---

## [托管 Discourse 最便宜的方式是什么？](https://meta.discourse.org/t/what-is-the-cheapest-way-to-host-discourse/103932)

<div class="topic-metadata">

**Author:** [@lolxgaming](https://meta.discourse.org/u/lolxgaming)\
**回覆:** 2\
**Last updated:** [2018年十二月10日 19:07 UTC](https://meta.discourse.org/t/what-is-the-cheapest-way-to-host-discourse/103932 "2018-12-10T19:07:17Z")

</div>

你好。 托管 Discourse 最便宜的方式是什么？ 感谢各位的回答，先谢过了。

---

## [是否可以在容器内部不运行 Nginx？](https://meta.discourse.org/t/is-it-possibe-to-run-a-container-without-nginx-internally/103718)

<div class="topic-metadata">

**Author:** [@Andrew\_Fritz](https://meta.discourse.org/u/Andrew_Fritz)\
**回覆:** 2\
**Last updated:** [2018年十二月7日 16:58 UTC](https://meta.discourse.org/t/is-it-possibe-to-run-a-container-without-nginx-internally/103718 "2018-12-07T16:58:00Z")

</div>

容器本身会在内部启动一个 nginx 服务器。它目前通过套接字模板运行在另一个 nginx 服务器之后（一切运行良好）。不过，我想移除中间那个仅仅在消耗资源的 nginx。

[上一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=124)

[下一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=126)
