# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=126

[最新版本](https://meta.discourse.org/latest.md) · [分類](https://meta.discourse.org/categories.md) · [標簽](https://meta.discourse.org/tags.md)

**Page:** 127

---

## [Digital Ocean 的 5 美元 Ubuntu Droplet 能否流畅运行 Discourse？](https://meta.discourse.org/t/can-digital-oceans-5-ubuntu-droplet-run-discourse-ok/103030)

<div class="topic-metadata">

**Author:** [@StevenBee](https://meta.discourse.org/u/StevenBee)\
**回覆:** 4\
**Last updated:** [2018年十一月29日 06:49 UTC](https://meta.discourse.org/t/can-digital-oceans-5-ubuntu-droplet-run-discourse-ok/103030 "2018-11-29T06:49:41Z")

</div>

你好！我注册了一个 Digital Ocean 账户，并通过“一键安装 Discourse”选项（使用 Ubuntu）启动了一个 Droplet。 我获取了凭据，并登录到了管理员账户，但……

---

## [使用 ProtonMail 帐户设置 Discourse](https://meta.discourse.org/t/setting-up-discourse-with-protonmail-account/71092)

<div class="topic-metadata">

**Author:** [@Becky](https://meta.discourse.org/u/Becky)\
**回覆:** 8\
**Last updated:** [2018年十一月29日 00:21 UTC](https://meta.discourse.org/t/setting-up-discourse-with-protonmail-account/71092 "2018-11-29T00:21:54Z")

</div>

Hello, I’m trying to setup Discourse with a ProtonMail admin email address. Apparently ProtonMail doesn’t support SMTP so I wondered if there’s a workaround. Has anyone had experience with this? It’s for this step: Ho…

---

## [Discourse 未向管理员用户发送激活邮件](https://meta.discourse.org/t/discourse-doesnt-send-activation-mail-to-admin-user/102764)

<div class="topic-metadata">

**Author:** [@ajibukunoluwa](https://meta.discourse.org/u/ajibukunoluwa)\
**回覆:** 5\
**Last updated:** [2018年十一月26日 13:47 UTC](https://meta.discourse.org/t/discourse-doesnt-send-activation-mail-to-admin-user/102764 "2018-11-26T13:47:07Z")

</div>

你好， Discourse 不会向管理员用户发送激活邮件，但在我运行 ./discourse-doctor 时会发送测试邮件，同时在尝试以普通用户注册时也能正常发送邮件。 我使用的是 Mailgun，并且也已……

---

## [手动完成安装？](https://meta.discourse.org/t/finishing-installation-manually/102678)

<div class="topic-metadata">

**Author:** [@ylluminate](https://meta.discourse.org/u/ylluminate)\
**回覆:** 2\
**Last updated:** [2018年十一月25日 05:05 UTC](https://meta.discourse.org/t/finishing-installation-manually/102678 "2018-11-25T05:05:13Z")

</div>

我在服务器上解决一些 SMTP 问题遇到了一些困难，希望在解决其他问题的同时，手动完成安装，因为另一位团队成员希望继续……

---

## [由 discourse.com 托管 .. 如何配置 / 重新烘焙 / SSH？](https://meta.discourse.org/t/hosted-by-discourse-com-how-to-configure-rebake-ssh/102366)

<div class="topic-metadata">

**Author:** [@bpaterson2000](https://meta.discourse.org/u/bpaterson2000)\
**回覆:** 3\
**Last updated:** [2018年十一月21日 01:40 UTC](https://meta.discourse.org/t/hosted-by-discourse-com-how-to-configure-rebake-ssh/102366 "2018-11-21T01:40:59Z")

</div>

所有关于配置/编辑 Discourse 的教程和指南似乎都是针对自托管方案的。 我没有看到如何按照“更改域名”或“重命名你的 Discourse”这样的教程来更改我的托管...

---

## [Docker 与 Engintron 问题](https://meta.discourse.org/t/docker-and-engintron-issue/102414)

<div class="topic-metadata">

**Author:** [@eesty](https://meta.discourse.org/u/eesty)\
**回覆:** 2\
**Last updated:** [2018年十一月20日 19:31 UTC](https://meta.discourse.org/t/docker-and-engintron-issue/102414 "2018-11-20T19:31:23Z")

</div>

大家好。 我已经为此努力了大约两个月，但一直没有成功，所以现在我决定硬着头皮向各位求助。 我有一台 CentOS 7 + WHM 的 VPS，除此之外运行正常。 上面我安装了多个 cPanel ……

---

## [Discourse docker canot setup](https://meta.discourse.org/t/discourse-docker-canot-setup/77218)

<div class="topic-metadata">

**Author:** [@James\_Tan](https://meta.discourse.org/u/James_Tan)\
**回覆:** 4\
**Last updated:** [2018年十月23日 08:32 UTC](https://meta.discourse.org/t/discourse-docker-canot-setup/77218 "2018-10-23T08:32:48Z")

</div>

after filling up all the information required by discourse-setup, gets this: Sorry, these containers/app.yml settings aren’t valid – can’t continue! If you have unusual requirements, edit containers/app.yml and then: …

---

## [Is there any way to access the public folder outside of Docker?](https://meta.discourse.org/t/is-there-any-way-to-access-the-public-folder-outside-of-docker/26051)

<div class="topic-metadata">

**Author:** [@kkershaw](https://meta.discourse.org/u/kkershaw)\
**回覆:** 7\
**Last updated:** [2015年十一月1日 22:17 UTC](https://meta.discourse.org/t/is-there-any-way-to-access-the-public-folder-outside-of-docker/26051 "2015-11-01T22:17:21Z")

</div>

The title is quite self explanatory, I was wondering if there’s any way to access the public folder in /var/www/discourse/public outside of Docker so I can easily copy files in and out to the host filesystem?

---

## [关于电子邮件配置的问题](https://meta.discourse.org/t/question-about-the-email-configuration/102074)

<div class="topic-metadata">

**Author:** [@StephaneFe](https://meta.discourse.org/u/StephaneFe)\
**回覆:** 1\
**Last updated:** [2018年十一月17日 08:57 UTC](https://meta.discourse.org/t/question-about-the-email-configuration/102074 "2018-11-17T08:57:00Z")

</div>

我正在按照此页面的说明操作，但我不理解这 6 个字段的含义： 管理员账户的电子邮件地址？\[me@example.com,you@example.com\]： 我可以在这里指定一个与...无关的电子邮件地址吗？

---

## [502 网关错误 - 新手求助](https://meta.discourse.org/t/502-bad-gateway-newbie-help-needed/102098)

<div class="topic-metadata">

**Author:** [@VerticalVeg](https://meta.discourse.org/u/VerticalVeg)\
**回覆:** 4\
**Last updated:** [2018年十一月15日 14:41 UTC](https://meta.discourse.org/t/502-bad-gateway-newbie-help-needed/102098 "2018-11-15T14:41:37Z")

</div>

我本周早些时候将论坛更新到了最新版本，当时运行正常——但今天早上却出现了 502 错误网关消息…… 我的技术知识非常有限，想知道可能的原因是什么，以及……

---

## [重建在“bundle exec rake db:migrate”处失败](https://meta.discourse.org/t/rebuild-failing-at-bundle-exec-rake-db-migrate/102025)

<div class="topic-metadata">

**Author:** [@Matteo\_Cuellar\_Vega](https://meta.discourse.org/u/Matteo_Cuellar_Vega)\
**回覆:** 0\
**Last updated:** [2018年十一月14日 12:38 UTC](https://meta.discourse.org/t/rebuild-failing-at-bundle-exec-rake-db-migrate/102025 "2018-11-14T12:38:35Z")

</div>

我在通过 Web 更新器更新 Discourse 后，Discourse 安装出现了问题。过去 6 小时我一直在阅读关于我所见错误的所有帖子，但似乎没有任何修复方案能……

---

## [管理界面与功能](https://meta.discourse.org/t/admin-interface-and-capabilities/101690)

<div class="topic-metadata">

**Author:** [@JasonGlazer](https://meta.discourse.org/u/JasonGlazer)\
**回覆:** 3\
**Last updated:** [2018年十一月13日 20:40 UTC](https://meta.discourse.org/t/admin-interface-and-capabilities/101690 "2018-11-13T20:40:29Z")

</div>

我正在考虑将一组 Mailman 邮件列表迁移到 Discourse，并希望了解 Discourse 管理端的功能。我没能找到太多相关文档。我是否弄错了……

---

## [更新我的分叉安装后出现错误](https://meta.discourse.org/t/i-got-an-error-after-updating-my-forked-install/101687)

<div class="topic-metadata">

**Author:** [@zyouchi](https://meta.discourse.org/u/zyouchi)\
**回覆:** 35\
**Last updated:** [2018年十一月13日 20:10 UTC](https://meta.discourse.org/t/i-got-an-error-after-updating-my-forked-install/101687 "2018-11-13T20:10:06Z")

</div>

我输入的命令如下： cd / var / discourse git pull ./launcher rebuild app 我收到了如下警告信息： 您所在的磁盘上 / var / lib / docker 的可用空间少于 5 GB……

---

## [无法通过命令行更新](https://meta.discourse.org/t/failing-to-update-through-command-line/101786)

<div class="topic-metadata">

**Author:** [@hosna](https://meta.discourse.org/u/hosna)\
**回覆:** 8\
**Last updated:** [2018年十一月12日 13:41 UTC](https://meta.discourse.org/t/failing-to-update-through-command-line/101786 "2018-11-12T13:41:03Z")

</div>

我这里有什么问题？:thinking: ./launcher rebuild app which: 在 (/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/root/bin) 中未找到 docker.io 警告：Docker 版本 17.05.0-ce 已弃用，建议升级到 17.06.2…

---

## [管理员未注册](https://meta.discourse.org/t/admin-is-not-registering/101718)

<div class="topic-metadata">

**Author:** [@mindaslab](https://meta.discourse.org/u/mindaslab)\
**回覆:** 8\
**Last updated:** [2018年十一月10日 15:37 UTC](https://meta.discourse.org/t/admin-is-not-registering/101718 "2018-11-10T15:37:51Z")

</div>

你好，我已在服务器上安装了 Discourse，但无法通过“注册管理员账户”这一步。我使用的是 Elastic Email，但其日志似乎并未显示有任何系统曾联系它来发送邮件。我已更新……

---

## [Rebuild 应用每次都会崩溃 :(](https://meta.discourse.org/t/rebuild-app-crashes-every-time/101520)

<div class="topic-metadata">

**Author:** [@filnik](https://meta.discourse.org/u/filnik)\
**回覆:** 6\
**Last updated:** [2018年十一月7日 16:54 UTC](https://meta.discourse.org/t/rebuild-app-crashes-every-time/101520 "2018-11-07T16:54:29Z")

</div>

你好， 我正在尝试重建一个 Discourse，需要更改其连接端口。每次运行 discourse\_setup 时都会出现以下错误。您知道可能的原因吗？ I, \[2018-11-07T10:52:46.331960 #14\] INF…

---

## [Meta 托管在什么规格的 EC2 实例上？](https://meta.discourse.org/t/what-size-ec2-instance-is-meta-hosted-on/101290)

<div class="topic-metadata">

**Author:** [@vegasloki](https://meta.discourse.org/u/vegasloki)\
**回覆:** 2\
**Last updated:** [2018年十一月5日 23:49 UTC](https://meta.discourse.org/t/what-size-ec2-instance-is-meta-hosted-on/101290 "2018-11-05T23:49:56Z")

</div>

您好。我是 Old Guy Dot Com 1.0 的难民。我正在为某个兴趣/用户社区考察 Discourse，该社区希望摆脱几年前收购其用户基础的企业利益。我已经搭建了一个……

---

## [电子邮件提供商的子域名](https://meta.discourse.org/t/subdomain-for-email-providers/101223)

<div class="topic-metadata">

**Author:** [@acinonyxjubatus](https://meta.discourse.org/u/acinonyxjubatus)\
**回覆:** 1\
**Last updated:** [2018年十一月3日 19:59 UTC](https://meta.discourse.org/t/subdomain-for-email-providers/101223 "2018-11-03T19:59:20Z")

</div>

在电子邮件提供商的 GitHub 页面上，我注意到： 请注意，在任何电子邮件提供商中，您都必须验证并使用子域名，例如 discourse.example.com。如果仅验证域名（例如 example.com），邮件将不会被……

---

## [DB 备份配置错误](https://meta.discourse.org/t/db-backup-config-error/100604)

<div class="topic-metadata">

**Author:** [@netpositive](https://meta.discourse.org/u/netpositive)\
**回覆:** 7\
**Last updated:** [2018年十月31日 05:41 UTC](https://meta.discourse.org/t/db-backup-config-error/100604 "2018-10-31T05:41:53Z")

</div>

我昨天将 Discourse 升级到最新稳定版并进行了完整重建。今天早上我遇到了这个奇怪的错误： \[2018-10-27 04:21:44\] 'netpositive' 已开始备份！ \[2018-10-27 04:21:44\] 正在标记备份 …

---

## [在现有 Nginx 下将 Discourse 安装为子目录](https://meta.discourse.org/t/install-discourse-as-a-subdirectory-with-existing-nginx/100710)

<div class="topic-metadata">

**Author:** [@Mayus](https://meta.discourse.org/u/Mayus)\
**回覆:** 8\
**Last updated:** [2018年十月29日 14:24 UTC](https://meta.discourse.org/t/install-discourse-as-a-subdirectory-with-existing-nginx/100710 "2018-10-29T14:24:27Z")

</div>

你好，我是 Discourse 的新手，非常希望能在自己的服务器上部署它。我还有一个 nginx 配置，可以连接到 WordPress 网站。我不想要子域名，只希望使用这个 URL：…

---

## [比较托管服务提供商](https://meta.discourse.org/t/comparing-hosting-providers/100034)

<div class="topic-metadata">

**Author:** [@Scoobie](https://meta.discourse.org/u/Scoobie)\
**回覆:** 13\
**Last updated:** [2018年十月26日 21:43 UTC](https://meta.discourse.org/t/comparing-hosting-providers/100034 "2018-10-26T21:43:56Z")

</div>

作为 Discourse 托管的新手，我正在努力了解各种托管选项及其提供的功能。 我是否遗漏了以下内容？ 作为一个新论坛，我只预期会有少量用户。 我至少需要……

---

## [日志显示邮件已发送！但实际未发送](https://meta.discourse.org/t/log-says-mail-is-sent-but-its-not/100512)

<div class="topic-metadata">

**Author:** [@alizeyn](https://meta.discourse.org/u/alizeyn)\
**回覆:** 5\
**Last updated:** [2018年十月26日 06:10 UTC](https://meta.discourse.org/t/log-says-mail-is-sent-but-its-not/100512 "2018-10-26T06:10:38Z")

</div>

首先，我阅读了几乎所有关于邮件故障排查的相关主题，包括 troubleshooting-email，但我仍然无法收到注册邮件。当我运行 discourse-doctor 时，它显示：邮件地址用于邮件…

---

## [Discobot 在 Communiteq 的欢迎消息中缺少表情符号](https://meta.discourse.org/t/missing-emojis-in-discobots-welcome-message-on-communiteq/100426)

<div class="topic-metadata">

**Author:** [@gnyma](https://meta.discourse.org/u/gnyma)\
**回覆:** 5\
**Last updated:** [2018年十月25日 13:01 UTC](https://meta.discourse.org/t/missing-emojis-in-discobots-welcome-message-on-communiteq/100426 "2018-10-25T13:01:19Z")

</div>

Discobot 的欢迎消息缺少了一些表情符号/图片（我附上了截图以说明情况）。我不确定出了什么问题。有人能指点一下我该如何修复吗？ 提前感谢！ Amy

---

## [数据库迁移遇到问题](https://meta.discourse.org/t/getting-issue-with-database-migrations/100381)

<div class="topic-metadata">

**Author:** [@Afx\_Afzaal](https://meta.discourse.org/u/Afx_Afzaal)\
**回覆:** 2\
**Last updated:** [2018年十月24日 19:48 UTC](https://meta.discourse.org/t/getting-issue-with-database-migrations/100381 "2018-10-24T19:48:24Z")

</div>

您好，我在运行以下命令时遇到了错误： \`bundle exec rake db:create db:migrate\` 错误信息：在“NOT”附近出现语法错误 第 1 行：CREATE SCHEMA IF NOT EXISTS discourse\_functions; PostgreSQL 版本：9.2.24 操作系统：CentOS

---

## [在 Docker 后端设置 Discourse 并通过 Nginx 反向代理时遇到问题。遇到 SPDY 协议错误](https://meta.discourse.org/t/problem-setting-up-discourse-with-docker-behind-nginx-reverse-proxy-encountering-spdy-protocol-error/100243)

<div class="topic-metadata">

**Author:** [@yookoala](https://meta.discourse.org/u/yookoala)\
**回覆:** 1\
**Last updated:** [2018年十月24日 04:19 UTC](https://meta.discourse.org/t/problem-setting-up-discourse-with-docker-behind-nginx-reverse-proxy-encountering-spdy-protocol-error/100243 "2018-10-24T04:19:35Z")

</div>

我尝试在已有运行 Nginx 的服务器上部署 Discourse。我使用了 Discourse 的 Docker 启动程序进行设置，该程序内部似乎还包含另一个中间 Nginx 代理。 设置完成后，我……

---

## [ScaleWay review?](https://meta.discourse.org/t/scaleway-review/40916)

<div class="topic-metadata">

**Author:** [@djcyry](https://meta.discourse.org/u/djcyry)\
**回覆:** 53\
**Last updated:** [2018年十月23日 14:17 UTC](https://meta.discourse.org/t/scaleway-review/40916 "2018-10-23T14:17:48Z")

</div>

Hello , Anyone is using scaleway vps·s ? i"ve got an invitation and i see good prices . PS. https://community.scaleway.com :wink: (DISCOURSE)

---

## [Setting up discourse for a small business: digital ocean? Communiteq? or discourse.org?](https://meta.discourse.org/t/setting-up-discourse-for-a-small-business-digital-ocean-communiteq-or-discourse-org/13434)

<div class="topic-metadata">

**Author:** [@mcwumbly](https://meta.discourse.org/u/mcwumbly)\
**回覆:** 10\
**Last updated:** [2018年十月22日 03:08 UTC](https://meta.discourse.org/t/setting-up-discourse-for-a-small-business-digital-ocean-communiteq-or-discourse-org/13434 "2018-10-22T03:08:41Z")

</div>

We are excited to try out discourse to communicate with our relatively small community of users, (usually employees of other businesses, professional freelancers) and partners. Think hundreds of users, not tens of thousa…

---

## [\[未解决\] GCloud：报告错误失败：无法连接到 localhost:6379 上的 Redis](https://meta.discourse.org/t/unsolved-gcloud-failed-to-report-error-error-connecting-to-redis-on-localhost-6379/100084)

<div class="topic-metadata">

**Author:** [@empireofryan](https://meta.discourse.org/u/empireofryan)\
**回覆:** 2\
**Last updated:** [2018年十月21日 02:37 UTC](https://meta.discourse.org/t/unsolved-gcloud-failed-to-report-error-error-connecting-to-redis-on-localhost-6379/100084 "2018-10-21T02:37:52Z")

</div>

想要将 Discourse 应用连接到 Google Cloud 上运行 Redis 和 PostgreSQL 的 Rails 应用吗？可以参考“如何在 Google Cloud Platform 上部署 Ruby Discourse 应用” | Google Cloud Platform 社区 | Google Cloud。…

---

## [安装后无图片、JS 文件、CSS 文件或字体](https://meta.discourse.org/t/no-images-js-files-css-files-or-fonts-after-install/99967)

<div class="topic-metadata">

**Author:** [@Bruce\_Bates](https://meta.discourse.org/u/Bruce_Bates)\
**回覆:** 3\
**Last updated:** [2018年十月19日 10:21 UTC](https://meta.discourse.org/t/no-images-js-files-css-files-or-fonts-after-install/99967 "2018-10-19T10:21:56Z")

</div>

我已经尝试重新安装大约 15 次了，但始终无法找出问题所在。我执行的是标准基础安装，未安装任何插件或其他额外内容。 sudo -s mkdir /var/discourse git clone https://github.com/disco…

---

## [来自 (localhost.localdomain) \[172.17.0.2\] 的连接出现 TLS 错误](https://meta.discourse.org/t/tls-error-on-connection-from-localhost-localdomain-172-17-0-2/99935)

<div class="topic-metadata">

**Author:** [@Bruce\_Bates](https://meta.discourse.org/u/Bruce_Bates)\
**回覆:** 9\
**Last updated:** [2018年十月19日 07:04 UTC](https://meta.discourse.org/t/tls-error-on-connection-from-localhost-localdomain-172-17-0-2/99935 "2018-10-19T07:04:56Z")

</div>

我完全不知道如何修复这个问题。当我尝试从 Discourse 发送邮件时，Exim 返回了这些错误。连接正常，但无法发送邮件。 Exim 错误： 2018-10-19 00:07:41 未找到 IP 地址 1… 对应的主机名

[上一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=125)

[下一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=127)
