# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=128

[最新版本](https://meta.discourse.org/latest.md) · [分類](https://meta.discourse.org/categories.md) · [標簽](https://meta.discourse.org/tags.md)

**Page:** 129

---

## [Destroying docker container does not destroy the database?](https://meta.discourse.org/t/destroying-docker-container-does-not-destroy-the-database/26411)

<div class="topic-metadata">

**Author:** [@jamesmarkcook](https://meta.discourse.org/u/jamesmarkcook)\
**回覆:** 7\
**Last updated:** [2015年三月16日 22:51 UTC](https://meta.discourse.org/t/destroying-docker-container-does-not-destroy-the-database/26411 "2015-03-16T22:51:27Z")

</div>

So…wait for it…I destroyed my postgres and web\_only containers, bootstrapped them again and hang on..what’s that? My forum is still there?! I’m quite confused and I’m not sure what’s going on. I used one of the import s…

---

## [欢迎使用 Nginx，而非默认首页](https://meta.discourse.org/t/welcome-to-nginx-instead-of-start-page/97362)

<div class="topic-metadata">

**Author:** [@Juan\_M\_Cresc](https://meta.discourse.org/u/Juan_M_Cresc)\
**回覆:** 2\
**Last updated:** [2018年九月17日 16:50 UTC](https://meta.discourse.org/t/welcome-to-nginx-instead-of-start-page/97362 "2018-09-17T16:50:02Z")

</div>

我已按照以下说明进行安装： /discourse/discourse/blob/master/docs/INSTALL-cloud.md 当我访问我的网站（foro.vuela.cc）时，收到来自 nginx 的欢迎消息。这是安装过程的最后输出…

---

## [在 5 美元的 Droplet 上托管的 Discourse 无法正常运行](https://meta.discourse.org/t/hosted-discourse-in-5-droplet-not-working-properly/97251)

<div class="topic-metadata">

**Author:** [@Varun\_Deva](https://meta.discourse.org/u/Varun_Deva)\
**回覆:** 6\
**Last updated:** [2018年九月15日 10:40 UTC](https://meta.discourse.org/t/hosted-discourse-in-5-droplet-not-working-properly/97251 "2018-09-15T10:40:38Z")

</div>

你好， 已在 DigitalOcean 的 5 美元 Droplet 上安装了 Droplet。 链接如下：forum.bustudymate.in 每次都会出现 502 错误（Bad Gateway）。 在 admin/upgrade 页面也显示错误。 现在邮件无法发送，并显示另一个警告…

---

## [无法升级到 2.1.0](https://meta.discourse.org/t/cannot-upgrade-to-2-1-0/97216)

<div class="topic-metadata">

**Author:** [@VojtechMyslivec](https://meta.discourse.org/u/VojtechMyslivec)\
**回覆:** 6\
**Last updated:** [2018年九月14日 21:42 UTC](https://meta.discourse.org/t/cannot-upgrade-to-2-1-0/97216 "2018-09-14T21:42:35Z")

</div>

你好， 我已在 VPS 上运行 Discourse 数月。它是通过 discourse\_docker 仓库安装的。过去我曾通过 Web 界面和命令行进行过多次升级。 现在，我在升级过程中遇到了一个问题……

---

## [更新 Web 和数据容器在 rake db:migrate 时失败，出现 PG::ConnectionBad 错误](https://meta.discourse.org/t/update-web-and-data-containers-fails-at-rake-db-migrate-with-pg-connectionbad/97118)

<div class="topic-metadata">

**Author:** [@ZackFea](https://meta.discourse.org/u/ZackFea)\
**回覆:** 2\
**Last updated:** [2018年九月13日 23:39 UTC](https://meta.discourse.org/t/update-web-and-data-containers-fails-at-rake-db-migrate-with-pg-connectionbad/97118 "2018-09-13T23:39:37Z")

</div>

我尝试使用 \`./launcher rebuild mywebcontainer\` 命令将我的 Discourse 更新到最新版本。此操作失败，请参见下方的日志。我尝试通过从 yml 配置中移除所有插件来解决此问题，但未成功。重新构建 t…

---

## [使用 Apache 或 NGINX 部署 WordPress 是否会影响 Discourse 集成？](https://meta.discourse.org/t/does-using-apache-or-nginx-for-a-wp-installation-make-a-difference-for-the-discourse-integration/96961)

<div class="topic-metadata">

**Author:** [@jord8on](https://meta.discourse.org/u/jord8on)\
**回覆:** 3\
**Last updated:** [2018年九月11日 16:17 UTC](https://meta.discourse.org/t/does-using-apache-or-nginx-for-a-wp-installation-make-a-difference-for-the-discourse-integration/96961 "2018-09-11T16:17:37Z")

</div>

我打算在 Digital Ocean 的 droplet 上安装 WordPress，并将其连接到位于另一个 droplet 上的 Discourse 实例。我想听听 Discourse 社区的意见，是否应该将 WordPress 设置在 LEMP（NGINX…

---

## [连接数据库时因每次查询延迟导致性能缓慢？](https://meta.discourse.org/t/slow-performance-due-to-per-query-latency-connecting-to-database/96907)

<div class="topic-metadata">

**Author:** [@Mark.Wahl](https://meta.discourse.org/u/Mark.Wahl)\
**回覆:** 8\
**Last updated:** [2018年九月11日 02:11 UTC](https://meta.discourse.org/t/slow-performance-due-to-per-query-latency-connecting-to-database/96907 "2018-09-11T02:11:11Z")

</div>

我已安装 Discourse，并注意到在某些情况下页面加载时间为 1 秒。我在 PostgreSQL 上启用了查询日志记录，发现所有查询的执行时间均少于 10 毫秒。然而，查看 /var/www/discour…

---

## [SparkPost 要求我验证域名所有权](https://meta.discourse.org/t/sparkpost-is-asking-me-to-verify-domain-ownership/96736)

<div class="topic-metadata">

**Author:** [@CharlesD](https://meta.discourse.org/u/CharlesD)\
**回覆:** 10\
**Last updated:** [2018年九月9日 07:01 UTC](https://meta.discourse.org/t/sparkpost-is-asking-me-to-verify-domain-ownership/96736 "2018-09-09T07:01:34Z")

</div>

SparkPost 要求我验证所有权，但我完全不知道如何在 Discourse 中上传 txt 文件以及如何创建子域名。我在哪里可以找到 www 文件夹来上传 txt 文件？我习惯使用 Apache、Nginx、vBulletin 等。

---

## [553 发件人邮箱地址不允许错误](https://meta.discourse.org/t/553-envelope-from-email-address-not-allowed-error/96740)

<div class="topic-metadata">

**Author:** [@Falenstarr](https://meta.discourse.org/u/Falenstarr)\
**回覆:** 2\
**Last updated:** [2018年九月8日 23:06 UTC](https://meta.discourse.org/t/553-envelope-from-email-address-not-allowed-error/96740 "2018-09-08T23:06:58Z")

</div>

大家好， 我第一次设置 Discourse 服务器，我觉得大部分都配置正确了，只是不得不使用命令 \`cd /var/discourse ./launcher enter app rake admin:create\` 才能……

---

## [Discourse 已集成：打开表情符号时的外部 Nginx 速率限制](https://meta.discourse.org/t/discourse-socketed-outer-nginx-rate-limiting-when-opening-emoticons/96417)

<div class="topic-metadata">

**Author:** [@TheBestPessimist](https://meta.discourse.org/u/TheBestPessimist)\
**回覆:** 2\
**Last updated:** [2018年九月7日 06:57 UTC](https://meta.discourse.org/t/discourse-socketed-outer-nginx-rate-limiting-when-opening-emoticons/96417 "2018-09-07T06:57:59Z")

</div>

我已在外部 Nginx 代理后通过套接字运行 Discourse。它运行正常：我可以查看帖子、创建新帖子、执行备份和恢复等操作。 我使用了 Discourse Docker 内部 Nginx 的设置（当时是…

---

## [Discourse 配置：Nginx 前置 Discourse：无 IP 地址](https://meta.discourse.org/t/discourse-socketed-nginx-in-front-of-discourse-no-ip-adresses/96382)

<div class="topic-metadata">

**Author:** [@TheBestPessimist](https://meta.discourse.org/u/TheBestPessimist)\
**回覆:** 5\
**Last updated:** [2018年九月5日 08:46 UTC](https://meta.discourse.org/t/discourse-socketed-nginx-in-front-of-discourse-no-ip-adresses/96382 "2018-09-05T08:46:12Z")

</div>

你好， 我的问题是，自从我在 Discourse 容器前部署了 nginx веб-сервер（按照此指南操作）后，我无法看到访问者的 IP 地址。 在 Discourse 前部署 nginx 之前： --------…

---

## [New install won't bootstrap; gem update socket error?](https://meta.discourse.org/t/new-install-wont-bootstrap-gem-update-socket-error/24681)

<div class="topic-metadata">

**Author:** [@lonewaffle](https://meta.discourse.org/u/lonewaffle)\
**回覆:** 8\
**Last updated:** [2015年二月2日 06:46 UTC](https://meta.discourse.org/t/new-install-wont-bootstrap-gem-update-socket-error/24681 "2015-02-02T06:46:31Z")

</div>

I’ve followed the instructions for installing Discourse using Docker and I can’t get it to bootstrap. I keep getting: FAILED -------------------- RuntimeError: cd /var/www/discourse && gem update bundler failed with ret…

---

## [使用 Cloudflare 时，名称服务器应使用 Cloudflare 设置，还是沿用主机服务器的设置？](https://meta.discourse.org/t/using-cloudflare-should-the-name-server-use-cloudflare-settings-or-stick-with-the-host-servers-settings/96154)

<div class="topic-metadata">

**Author:** [@Andy02](https://meta.discourse.org/u/Andy02)\
**回覆:** 12\
**Last updated:** [2018年九月1日 22:58 UTC](https://meta.discourse.org/t/using-cloudflare-should-the-name-server-use-cloudflare-settings-or-stick-with-the-host-servers-settings/96154 "2018-09-01T22:58:15Z")

</div>

你好，我们的网站分布在三台服务器上，其中 Discourse 独立部署在一台服务器上。目前，托管 Discourse 的服务器上的名称服务器设置为使用默认值（ns1.digitalocean.com、ns2 等）。 作为……

---

## [在 Nodechef 上安装](https://meta.discourse.org/t/installing-on-nodechef/96191)

<div class="topic-metadata">

**Author:** [@Sridhar\_Katakam](https://meta.discourse.org/u/Sridhar_Katakam)\
**回覆:** 5\
**Last updated:** [2018年九月2日 15:17 UTC](https://meta.discourse.org/t/installing-on-nodechef/96191 "2018-09-02T15:17:47Z")

</div>

你好， 我刚刚在 Nodechef 上安装了 Discourse，但无法正常运行。我已向他们的工单系统发送了以下信息，但觉得在这里可能能更快获得帮助。 安装网址为：http://forum-…

---

## [使用 Ubuntu 18.04 LTS 最小化镜像有什么理由不推荐吗？](https://meta.discourse.org/t/any-reason-not-to-use-ubuntu-18-04-lts-minimal-image/94544)

<div class="topic-metadata">

**Author:** [@Cheeser](https://meta.discourse.org/u/Cheeser)\
**回覆:** 14\
**Last updated:** [2018年九月2日 07:23 UTC](https://meta.discourse.org/t/any-reason-not-to-use-ubuntu-18-04-lts-minimal-image/94544 "2018-09-02T07:23:55Z")

</div>

我知道官方文档推荐 Ubuntu 16.04，但对于 Discourse 而言，Ubuntu 18.04 LTS Minimal（如 Google Cloud Compute 所提供的版本）是否存在任何阻碍性问题？ 已编辑，增加了一个问题：🙂 …

---

## [Discourse 仅在“www”A 记录上工作](https://meta.discourse.org/t/discourse-only-working-on-my-www-a-dns-record/96179)

<div class="topic-metadata">

**Author:** [@jord8on](https://meta.discourse.org/u/jord8on)\
**回覆:** 4\
**Last updated:** [2018年九月2日 07:04 UTC](https://meta.discourse.org/t/discourse-only-working-on-my-www-a-dns-record/96179 "2018-09-02T07:04:16Z")

</div>

我已在 DigitalOcean 的 Droplet 上成功部署并运行了 Discourse。 我已为 www.community.jewelbound.com 设置了如下“A”记录： 此重定向工作正常！ 我还已设置 community.jewelbound.com 为…

---

## [在子文件夹中安装 Discourse 后出现空白页面](https://meta.discourse.org/t/blank-page-after-installing-discourse-on-subfolder/96112)

<div class="topic-metadata">

**Author:** [@john3](https://meta.discourse.org/u/john3)\
**回覆:** 8\
**Last updated:** [2018年八月31日 21:57 UTC](https://meta.discourse.org/t/blank-page-after-installing-discourse-on-subfolder/96112 "2018-08-31T21:57:38Z")

</div>

嘿！ 我尝试在子文件夹中设置 Discourse。按照操作指南操作后，所有资源都显示空白页面并返回 404 错误。 我进入了容器应用并尝试执行以下命令，但出现了错误： root@discourse:/…

---

## [Performance, Scaling, and HA requirements](https://meta.discourse.org/t/performance-scaling-and-ha-requirements/60098)

<div class="topic-metadata">

**Author:** [@mdekkers](https://meta.discourse.org/u/mdekkers)\
**回覆:** 8\
**Last updated:** [2017年四月2日 05:29 UTC](https://meta.discourse.org/t/performance-scaling-and-ha-requirements/60098 "2017-04-02T05:29:17Z")

</div>

Hi all, I am working on upgrading a busy Drupal site with a very active forum. This forum sees about 2 million unique pageviews per month, with peaks to about 3 to 4 million per hour for a few weeks a year. We have abou…

---

## [How to create a new plugins?](https://meta.discourse.org/t/how-to-create-a-new-plugins/34829)

<div class="topic-metadata">

**Author:** [@arulbaskar](https://meta.discourse.org/u/arulbaskar)\
**回覆:** 2\
**Last updated:** [2018年八月29日 16:48 UTC](https://meta.discourse.org/t/how-to-create-a-new-plugins/34829 "2018-08-29T16:48:41Z")

</div>

hi how to install or create a new plugin. please help me

---

## [What do I need before signing up?](https://meta.discourse.org/t/what-do-i-need-before-signing-up/67914)

<div class="topic-metadata">

**Author:** [@gina\_riley](https://meta.discourse.org/u/gina_riley)\
**回覆:** 8\
**Last updated:** [2018年八月29日 11:47 UTC](https://meta.discourse.org/t/what-do-i-need-before-signing-up/67914 "2018-08-29T11:47:05Z")

</div>

A few questions, thank you in advance. (1) Before I sign up for discourse hosting, do I need to have a forum already for migration? (2) I have a great idea of the setup of a discourse so that being said, I am guessing …

---

## [在 DigitalOcean 和 Namecheap 上安装？](https://meta.discourse.org/t/installing-over-digitalocean-and-namecheap/95598)

<div class="topic-metadata">

**Author:** [@M\_A](https://meta.discourse.org/u/M_A)\
**回覆:** 11\
**Last updated:** [2018年八月29日 02:56 UTC](https://meta.discourse.org/t/installing-over-digitalocean-and-namecheap/95598 "2018-08-29T02:56:46Z")

</div>

嘿，这是我第一次接触这个，我尽量按照30分钟安装指南操作，但在DNS记录方面遇到了问题，因为网站无法加载，它们很可能没有…

---

## [从 nginx 后端重新生成 LetsEncrypt 密钥](https://meta.discourse.org/t/regenerating-letsencrypt-keys-from-behind-nginx/95884)

<div class="topic-metadata">

**Author:** [@mogu](https://meta.discourse.org/u/mogu)\
**回覆:** 2\
**Last updated:** [2018年八月29日 02:46 UTC](https://meta.discourse.org/t/regenerating-letsencrypt-keys-from-behind-nginx/95884 "2018-08-29T02:46:21Z")

</div>

我按照这份关于在 nginx 后端运行 Discourse 的优秀指南进行操作：在同一台机器上运行 Discourse 和其他网站。效果很好。不幸的是，SSL 证书（通过 LetsEncrypt 获取）在 90 天后过期，并且……

---

## [550 验证失败“无此用户”（回调验证）](https://meta.discourse.org/t/550-verification-failed-no-such-user-callback-verification/95560)

<div class="topic-metadata">

**Author:** [@dexpositoromero](https://meta.discourse.org/u/dexpositoromero)\
**回覆:** 4\
**Last updated:** [2018年八月24日 10:28 UTC](https://meta.discourse.org/t/550-verification-failed-no-such-user-callback-verification/95560 "2018-08-24T10:28:10Z")

</div>

大家好， 我在子域名上安装 Discourse 后遇到了一些邮件问题。我已经查阅了故障排除指南，但问题仍然存在。基本上，通过 MailGun 从 Discourse 发送的邮件无法到达收件人……

---

## [Failed to install due to not found /root/authorized\_keys file](https://meta.discourse.org/t/failed-to-install-due-to-not-found-root-authorized-keys-file/38873)

<div class="topic-metadata">

**Author:** [@javenfang](https://meta.discourse.org/u/javenfang)\
**回覆:** 11\
**Last updated:** [2018年八月23日 14:18 UTC](https://meta.discourse.org/t/failed-to-install-due-to-not-found-root-authorized-keys-file/38873 "2018-08-23T14:18:27Z")

</div>

I’ve tried many many times and different env, and try to search to resolve the problem. But I failed. With installation from official doc, I always fail into the error reported: I, \[2016-02-02T03:25:19.047866 #38\] INF…

---

## [恢复数据库备份时出错](https://meta.discourse.org/t/error-when-restore-db-backup/93145)

<div class="topic-metadata">

**Author:** [@StYas](https://meta.discourse.org/u/StYas)\
**回覆:** 25\
**Last updated:** [2018年八月23日 05:04 UTC](https://meta.discourse.org/t/error-when-restore-db-backup/93145 "2018-08-23T05:04:40Z")

</div>

你好。我刚安装了全新的 Discourse，创建了备份，现在正在尝试恢复： \[2018-07-25 23:04:18\] \[已启动\] \[2018-07-25 23:04:18\] 'systemsupport' 已启动恢复！ \[2018-07-25 23:04:18\] Markin…

---

## [安装求助……？](https://meta.discourse.org/t/installation-help/95364)

<div class="topic-metadata">

**Author:** [@mrcsvoon](https://meta.discourse.org/u/mrcsvoon)\
**回覆:** 5\
**Last updated:** [2018年八月22日 00:58 UTC](https://meta.discourse.org/t/installation-help/95364 "2018-08-22T00:58:10Z")

</div>

我不确定如何自己安装 Discourse，有人能在这里帮我吗？

---

## [主机名"smtp.tavoweb.lt"与服务器证书不匹配](https://meta.discourse.org/t/hostname-smtp-tavoweb-lt-does-not-match-the-server-certificate/95271)

<div class="topic-metadata">

**Author:** [@savas](https://meta.discourse.org/u/savas)\
**回覆:** 15\
**Last updated:** [2018年八月21日 22:18 UTC](https://meta.discourse.org/t/hostname-smtp-tavoweb-lt-does-not-match-the-server-certificate/95271 "2018-08-21T22:18:17Z")

</div>

已发送邮件至 mano@tavoweb.lt（耗时 77.2 毫秒） 作业异常：主机名"smtp.tavoweb.lt"与服务器证书不匹配 已发送邮件至 mano@tavoweb.lt（耗时 18.1 毫秒） 作业异常：主机名"smtp.tavoweb.lt"与服务器证书不匹配…

---

## [在 Windows Server 2016 上端到端安装 Discourse](https://meta.discourse.org/t/discourse-installation-end-to-end-on-windows-server-2016/95311)

<div class="topic-metadata">

**Author:** [@pkarun](https://meta.discourse.org/u/pkarun)\
**回覆:** 9\
**Last updated:** [2018年八月21日 19:05 UTC](https://meta.discourse.org/t/discourse-installation-end-to-end-on-windows-server-2016/95311 "2018-08-21T19:05:30Z")

</div>

您好， 我想了解在 Windows Server 2016 上完整安装 Discourse 的步骤。 谢谢， Arun

---

## [Discourse 邮件在 fresh installation 后无法工作（Zoho SMTP 服务器）](https://meta.discourse.org/t/discourse-email-does-not-work-after-fresh-installation-zoho-smtp-server/95068)

<div class="topic-metadata">

**Author:** [@permacultureProgram](https://meta.discourse.org/u/permacultureProgram)\
**回覆:** 10\
**Last updated:** [2018年八月20日 23:14 UTC](https://meta.discourse.org/t/discourse-email-does-not-work-after-fresh-installation-zoho-smtp-server/95068 "2018-08-20T23:14:27Z")

</div>

在按照这些说明于新的 Ramnode 服务器上全新安装 Discourse 后，我正尝试配置邮件功能，使其能与 Zoho 邮件客户端正常交互。到目前为止，我还无法发送任何邮件…

---

## [从 InvisionBoard v4.3 迁移到 Discourse v2.1 时的数据库模式问题](https://meta.discourse.org/t/database-schema-issues-when-migration-invisionboard-v4-3-to-discourse-v2-1/95019)

<div class="topic-metadata">

**Author:** [@oncletom](https://meta.discourse.org/u/oncletom)\
**回覆:** 1\
**Last updated:** [2018年八月17日 18:25 UTC](https://meta.discourse.org/t/database-schema-issues-when-migration-invisionboard-v4-3-to-discourse-v2-1/95019 "2018-08-17T18:25:19Z")

</div>

你好， 感谢 @pfaffman 为 InvisionBoard 转换器所做的工作。 我已经成功搭建并连接到我的远程数据库，但在浏览代码和遇到脚本错误后，我有几个问题。 什么 …

[上一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=127)

[下一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=129)
