# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=13

[Latest](https://meta.discourse.org/latest.md) · [Categories](https://meta.discourse.org/categories.md) · [Tags](https://meta.discourse.org/tags.md)

**Page:** 14

---

## [What if set db\_default\_text\_search\_config: "pg\_catalog.simple"](https://meta.discourse.org/t/what-if-set-db-default-text-search-config-pg-catalog-simple/57407)

<div class="topic-metadata">

**Author:** [@helperhaps](https://meta.discourse.org/u/helperhaps)\
**Replies:** 4\
**Last updated:** [April 21, 2025, 4:03pm UTC](https://meta.discourse.org/t/what-if-set-db-default-text-search-config-pg-catalog-simple/57407 "2025-04-21T16:03:11Z")

</div>

Recently, I notice that there is a params: db\_default\_text\_search\_config: "pg\_catalog.english" in the configuration file (standalone.yml/data.yml). I can guees what it means through its name. The issue is that my loc…

---

## [Update/rebuild error. How to diagnose and recover?](https://meta.discourse.org/t/update-rebuild-error-how-to-diagnose-and-recover/314958)

<div class="topic-metadata">

**Author:** [@Isambard](https://meta.discourse.org/u/Isambard)\
**Replies:** 5\
**Last updated:** [July 21, 2024, 10:20pm UTC](https://meta.discourse.org/t/update-rebuild-error-how-to-diagnose-and-recover/314958 "2024-07-21T22:20:30Z")

</div>

I just tried to update and there is a failure near the end: I, \[2024-07-04T07:17:18.714988 #807\] INFO -- : Writing /var/www/discourse/public/assets/scripts/discourse-test-listen-boot-9b14a0fc65c689577e6a428dcfd68020551…

---

## [Migration error on fresh startup running in k8s cluster](https://meta.discourse.org/t/migration-error-on-fresh-startup-running-in-k8s-cluster/184751)

<div class="topic-metadata">

**Author:** [@mobiusdickus](https://meta.discourse.org/u/mobiusdickus)\
**Replies:** 5\
**Last updated:** [April 14, 2025, 8:02pm UTC](https://meta.discourse.org/t/migration-error-on-fresh-startup-running-in-k8s-cluster/184751 "2025-04-14T20:02:09Z")

</div>

Hi! I am running the latest version of discourse on a k8s cluster and upon startup and I keep getting this error: ERROR: relation "translation\_overrides" does not exist at character 454 STATEMENT: SELECT a.attnam…

---

## [Discourse on Synology DSM 7.2?](https://meta.discourse.org/t/discourse-on-synology-dsm-7-2/361189)

<div class="topic-metadata">

**Author:** [@esm60pty](https://meta.discourse.org/u/esm60pty)\
**Replies:** 0\
**Last updated:** [April 10, 2025, 1:52am UTC](https://meta.discourse.org/t/discourse-on-synology-dsm-7-2/361189 "2025-04-10T01:52:41Z")

</div>

Hello, I’m new here and would like to know if anyone have successfully installed DISCOURSE on Synology NAS running DSM 7.2 and using Synology Container Manager. I have tried following the instructions from Mariushosting…

---

## [Have Discourse's requirements changed recently?](https://meta.discourse.org/t/have-discourses-requirements-changed-recently/358732)

<div class="topic-metadata">

**Author:** [@Canapin](https://meta.discourse.org/u/Canapin)\
**Replies:** 7\
**Last updated:** [April 4, 2025, 12:54pm UTC](https://meta.discourse.org/t/have-discourses-requirements-changed-recently/358732 "2025-04-04T12:54:58Z")

</div>

A lot of users have come across failed rebuilds recently (since September 2024) with the command was killed with SIGKILL error, even though the servers have more than 1 GB RAM (even 4 GB RAM). https://meta.discourse.org…

---

## [LC\_ALL/LANG/LANGUAGE = en\_US.UTF-8 correct for non-English sites?](https://meta.discourse.org/t/lc-all-lang-language-en-us-utf-8-correct-for-non-english-sites/358494)

<div class="topic-metadata">

**Author:** [@schneeland](https://meta.discourse.org/u/schneeland)\
**Replies:** 3\
**Last updated:** [April 3, 2025, 6:24pm UTC](https://meta.discourse.org/t/lc-all-lang-language-en-us-utf-8-correct-for-non-english-sites/358494 "2025-04-03T18:24:04Z")

</div>

Since I starting to set up a fresh instance of Discourse, I wondered: discourse-setup does not ask about the locale settings of the new site and generates an app.yml with LC\_ALL/LANG/LANGUAGE = en\_US.UTF-8. Is this c…

---

## [Upgrade failed: low disk space -- excess overlay files?](https://meta.discourse.org/t/upgrade-failed-low-disk-space-excess-overlay-files/287048)

<div class="topic-metadata">

**Author:** [@ToddZ](https://meta.discourse.org/u/ToddZ)\
**Replies:** 6\
**Last updated:** [April 3, 2025, 5:22pm UTC](https://meta.discourse.org/t/upgrade-failed-low-disk-space-excess-overlay-files/287048 "2025-04-03T17:22:46Z")

</div>

Well, sigh – I’m stuck on a failed upgrade. I’m on a 25G VPS, using the supported Docker installation. Upgrading docker\_manager via the admin panel went fine. Upgrading Discourse from v3.2.0.beta1 +125 to v3.2.0.beta3…

---

## [Did I overwrite my site settings with a cross-instance backup/restore?](https://meta.discourse.org/t/did-i-overwrite-my-site-settings-with-a-cross-instance-backup-restore/358786)

<div class="topic-metadata">

**Author:** [@johnr](https://meta.discourse.org/u/johnr)\
**Replies:** 3\
**Last updated:** [April 2, 2025, 12:35pm UTC](https://meta.discourse.org/t/did-i-overwrite-my-site-settings-with-a-cross-instance-backup-restore/358786 "2025-04-02T12:35:38Z")

</div>

My company is evaluating Discourse and I have created two instances, A and B. I wanted to check out the backup/restore functionality as it might apply to different instances and restored a backup from instance A to insta…

---

## [Docker problems](https://meta.discourse.org/t/docker-problems/359438)

<div class="topic-metadata">

**Author:** [@geoff777](https://meta.discourse.org/u/geoff777)\
**Replies:** 11\
**Last updated:** [April 1, 2025, 3:31pm UTC](https://meta.discourse.org/t/docker-problems/359438 "2025-04-01T15:31:32Z")

</div>

Having lots of problems installing discourse. Cant use two containers because of a weird ssh container problem. Single container.. app.yml leads to duplicate containers. Tried lots of ai assisted fixes but we’ve been…

---

## [Connect to database and redis on a docker host using sockets](https://meta.discourse.org/t/connect-to-database-and-redis-on-a-docker-host-using-sockets/359549)

<div class="topic-metadata">

**Author:** [@silverdr](https://meta.discourse.org/u/silverdr)\
**Replies:** 1\
**Last updated:** [March 31, 2025, 12:54am UTC](https://meta.discourse.org/t/connect-to-database-and-redis-on-a-docker-host-using-sockets/359549 "2025-03-31T00:54:40Z")

</div>

I have a multisite running in a container, connecting to remote “databases” server, with postgres and redis running over there. Now I want to move both of those to the host dockerised discourse runs on and connect to the…

---

## [I just installed Discourse, but the pages load very slowly due to slow external database](https://meta.discourse.org/t/i-just-installed-discourse-but-the-pages-load-very-slowly-due-to-slow-external-database/357617)

<div class="topic-metadata">

**Author:** [@佳闻\_刘](https://meta.discourse.org/u/%E4%BD%B3%E9%97%BB_%E5%88%98)\
**Replies:** 7\
**Last updated:** [March 29, 2025, 9:24pm UTC](https://meta.discourse.org/t/i-just-installed-discourse-but-the-pages-load-very-slowly-due-to-slow-external-database/357617 "2025-03-29T21:24:00Z")

</div>

Homepage take up 2-4 sec to respond Started GET "/" for 219.144.218.209 at 2025-03-17 18:22:55 +0000 Processing by ListController#latest as HTML Rendered layout layouts/application.html.erb (Duration: 1932.6ms | GC: 1…

---

## [Trouble with s3: Failed to open TCP connection to 169.254.169.254 due to missing secret access key](https://meta.discourse.org/t/trouble-with-s3-failed-to-open-tcp-connection-to-169-254-169-254-due-to-missing-secret-access-key/358402)

<div class="topic-metadata">

**Author:** [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**Replies:** 2\
**Last updated:** [March 23, 2025, 4:18pm UTC](https://meta.discourse.org/t/trouble-with-s3-failed-to-open-tcp-connection-to-169-254-169-254-due-to-missing-secret-access-key/358402 "2025-03-23T16:18:38Z")

</div>

This is a standard install. These credentials work on the old server and they work on the new server using s3cmd, but when I do a discourse restore to try to get a list of backups, I get Error retrieving instance profil…

---

## [Discourse Randomly Does Not run or Rebuild](https://meta.discourse.org/t/discourse-randomly-does-not-run-or-rebuild/358231)

<div class="topic-metadata">

**Author:** [@joshhabka](https://meta.discourse.org/u/joshhabka)\
**Replies:** 15\
**Last updated:** [March 22, 2025, 3:51am UTC](https://meta.discourse.org/t/discourse-randomly-does-not-run-or-rebuild/358231 "2025-03-22T03:51:15Z")

</div>

Out of nowhere, Discourse is no longer wanting to run and is not even rebuilding using ./launcher rebuild app. I commented out all plugins too. Here is the logs when I try to start it: https://codefile.io/f/8XUuOqyEDd H…

---

## [Difficulty installing on vm that includes CPanel and Apache](https://meta.discourse.org/t/difficulty-installing-on-vm-that-includes-cpanel-and-apache/358157)

<div class="topic-metadata">

**Author:** [@Gustavo\_Rip](https://meta.discourse.org/u/Gustavo_Rip)\
**Replies:** 7\
**Last updated:** [March 20, 2025, 4:25pm UTC](https://meta.discourse.org/t/difficulty-installing-on-vm-that-includes-cpanel-and-apache/358157 "2025-03-20T16:25:23Z")

</div>

Hi everyone! \*\*This is my first post. \*\* I’m a new Discourse user coming from phpBB. Two weeks ago, I installed Discourse in a Docker container using Nginx, since Apache uses ports 80 and 443 by default. I carefully f…

---

## [Confusion about LDAP setup](https://meta.discourse.org/t/confusion-about-ldap-setup/358146)

<div class="topic-metadata">

**Author:** [@marcoc](https://meta.discourse.org/u/marcoc)\
**Replies:** 1\
**Last updated:** [March 20, 2025, 2:34pm UTC](https://meta.discourse.org/t/confusion-about-ldap-setup/358146 "2025-03-20T14:34:22Z")

</div>

Hi everyone, I am trying to setup LDAP in our local discourse to use the LDAP server of our university. I got a working configuration of another app from a colleague and tried to adapt it to use it with the discourse LD…

---

## [What does DISCOURSE\_SMTP\_DOMAIN mean?](https://meta.discourse.org/t/what-does-discourse-smtp-domain-mean/229009)

<div class="topic-metadata">

**Author:** [@meglio](https://meta.discourse.org/u/meglio)\
**Replies:** 4\
**Last updated:** [March 20, 2025, 2:13pm UTC](https://meta.discourse.org/t/what-does-discourse-smtp-domain-mean/229009 "2025-03-20T14:13:07Z")

</div>

While already having DISCOURSE\_SMTP\_ADDRESS, what does the DISCOURSE\_SMTP\_DOMAIN setting in containers/app.yml do? It’s not that desktop clients usually ask for “address” and “domain” separately, so I got confused.

---

## [Failed new install](https://meta.discourse.org/t/failed-new-install/357790)

<div class="topic-metadata">

**Author:** [@Heliosurge](https://meta.discourse.org/u/Heliosurge)\
**Replies:** 7\
**Last updated:** [March 19, 2025, 2:58pm UTC](https://meta.discourse.org/t/failed-new-install/357790 "2025-03-19T14:58:42Z")

</div>

VPS 4 core 4g 200g. Ubuntu 24 lts Domain reg: IONOS \[2025-03-18T14:54:01.632117 #1\] INFO -- : \> cd /var/www/discourse && su discourse -c 'bundle exec rake assets:precompile:build' Node.js heap\_size\_limit (2005.75) is …

---

## [My install is 16,359 commits behind! Advice?](https://meta.discourse.org/t/my-install-is-16-359-commits-behind-advice/354327)

<div class="topic-metadata">

**Author:** [@trusktr](https://meta.discourse.org/u/trusktr)\
**Replies:** 14\
**Last updated:** [March 18, 2025, 11:39pm UTC](https://meta.discourse.org/t/my-install-is-16-359-commits-behind-advice/354327 "2025-03-18T23:39:36Z")

</div>

And the Upgrade button is grayed out: Any advice on how to “Upgrade”?

---

## [503 errors, can't post, edit, like, etc](https://meta.discourse.org/t/503-errors-cant-post-edit-like-etc/289979)

<div class="topic-metadata">

**Author:** [@dylanb](https://meta.discourse.org/u/dylanb)\
**Replies:** 4\
**Last updated:** [March 18, 2025, 7:33pm UTC](https://meta.discourse.org/t/503-errors-cant-post-edit-like-etc/289979 "2025-03-18T19:33:36Z")

</div>

I migrated my site to a new instance (Azure to Lightsail, 32gb ram) and am having a host of problems. The site is up and running but not seemingly working. It seems like I’m crashing my instance despite not having much…

---

## [Photoshop template for all Branding images here](https://meta.discourse.org/t/photoshop-template-for-all-branding-images-here/357755)

<div class="topic-metadata">

**Author:** [@alltiagocom](https://meta.discourse.org/u/alltiagocom)\
**Replies:** 2\
**Last updated:** [March 18, 2025, 1:49pm UTC](https://meta.discourse.org/t/photoshop-template-for-all-branding-images-here/357755 "2025-03-18T13:49:51Z")

</div>

I’m working on my own forum and since I had to create a Photoshop file for myself, why not sharing it with others who might need it? I’m using artboards to make it easier to work on all files at once and then easier to …

---

## [‘Port 443 of computer does not appear to be accessible’](https://meta.discourse.org/t/port-443-of-computer-does-not-appear-to-be-accessible/323307)

<div class="topic-metadata">

**Author:** [@Carlos\_Andres](https://meta.discourse.org/u/Carlos_Andres)\
**Replies:** 6\
**Last updated:** [March 17, 2025, 8:07am UTC](https://meta.discourse.org/t/port-443-of-computer-does-not-appear-to-be-accessible/323307 "2025-03-17T08:07:09Z")

</div>

Checking your domain name . . . WARNING: Port 443 of computer does not appear to be accessible using hostname: foro.caletawp.com. WARNING: Connection to http://foro.caletawp.com (port 80) also fails. This suggests that…

---

## [Rebuild taking ~3hours](https://meta.discourse.org/t/rebuild-taking-3hours/240859)

<div class="topic-metadata">

**Author:** [@smileBeda](https://meta.discourse.org/u/smileBeda)\
**Replies:** 35\
**Last updated:** [March 16, 2025, 11:27pm UTC](https://meta.discourse.org/t/rebuild-taking-3hours/240859 "2025-03-16T23:27:25Z")

</div>

I appreciate that, but rebuilding the app takes about 3 hours! And this is on a massive VPS. Wouldn’t it be a cool thing to be able to remove plugins just like we can add and remove themes? Perhaps something to consi…

---

## [Backups not running on Contabo Object Storage](https://meta.discourse.org/t/backups-not-running-on-contabo-object-storage/308688)

<div class="topic-metadata">

**Author:** [@tumbano](https://meta.discourse.org/u/tumbano)\
**Replies:** 7\
**Last updated:** [March 16, 2025, 12:53pm UTC](https://meta.discourse.org/t/backups-not-running-on-contabo-object-storage/308688 "2025-03-16T12:53:46Z")

</div>

I’m using Contabo Object Storage for backups and I need to leave “s3\_backup\_bucket” empty for it to work otherwise it adds the name at the beginnig of the bucket’s url and it doesn’t work. Now, if I run the backups manu…

---

## [Thinking of trying self-hosted and have some questions](https://meta.discourse.org/t/thinking-of-trying-self-hosted-and-have-some-questions/357265)

<div class="topic-metadata">

**Author:** [@alltiagocom](https://meta.discourse.org/u/alltiagocom)\
**Replies:** 9\
**Last updated:** [March 15, 2025, 10:52am UTC](https://meta.discourse.org/t/thinking-of-trying-self-hosted-and-have-some-questions/357265 "2025-03-15T10:52:45Z")

</div>

I’m looking at the official instructions to self-host and I have some questions: 1 - If I use DigitalOcean, what would I need for a new and small community, from this page? I believe that Droplets is required, but what …

---

## [Should I update my app.yml file?](https://meta.discourse.org/t/should-i-update-my-app-yml-file/357384)

<div class="topic-metadata">

**Author:** [@alltiagocom](https://meta.discourse.org/u/alltiagocom)\
**Replies:** 4\
**Last updated:** [March 15, 2025, 9:39am UTC](https://meta.discourse.org/t/should-i-update-my-app-yml-file/357384 "2025-03-15T09:39:57Z")

</div>

While checking the topic on how to install plugins, I noticed that this is being used: - sudo -E -u discourse git clone https://github.com/discourse/docker\_manager.git but on my app.yml file I only have: git clone htt…

---

## [Customising Discourse's web server behaviour using outlets](https://meta.discourse.org/t/customising-discourses-web-server-behaviour-using-outlets/356361)

<div class="topic-metadata">

**Author:** [@supermathie](https://meta.discourse.org/u/supermathie)\
**Replies:** 3\
**Last updated:** [March 12, 2025, 2:14am UTC](https://meta.discourse.org/t/customising-discourses-web-server-behaviour-using-outlets/356361 "2025-03-12T02:14:11Z")

</div>

Summary As of this commit the default nginx configuration for Discourse includes what are known as “outlets” - a supported way to inject additional statements into the nginx configuration in appropriate places. This cha…

---

## [How Can I Modify SMTP Details?](https://meta.discourse.org/t/how-can-i-modify-smtp-details/356638)

<div class="topic-metadata">

**Author:** [@Sharmila\_Saud](https://meta.discourse.org/u/Sharmila_Saud)\
**Replies:** 2\
**Last updated:** [March 12, 2025, 2:02am UTC](https://meta.discourse.org/t/how-can-i-modify-smtp-details/356638 "2025-03-12T02:02:26Z")

</div>

maybe i fill wrong SMTP Details But I want To Modify It How Can i do? i am not able to send email

---

## [Discourse is now installed. But This site can’t be reached](https://meta.discourse.org/t/discourse-is-now-installed-but-this-site-can-t-be-reached/356773)

<div class="topic-metadata">

**Author:** [@Sharmila\_Saud](https://meta.discourse.org/u/Sharmila_Saud)\
**Replies:** 2\
**Last updated:** [March 11, 2025, 10:49am UTC](https://meta.discourse.org/t/discourse-is-now-installed-but-this-site-can-t-be-reached/356773 "2025-03-11T10:49:04Z")

</div>

Discourse is now installed. Log into your admin account in a browser to continue configuring Discourse. But When i open my domain i face this issue This site can’t be reached domain.com refused to connect. Try: Ch…

---

## ["A new version (...) of configuration file /etc/ssh/sshd\_config is available, but the version installed currently has been locally modified"](https://meta.discourse.org/t/a-new-version-of-configuration-file-etc-ssh-sshd-config-is-available-but-the-version-installed-currently-has-been-locally-modified/356625)

<div class="topic-metadata">

**Author:** [@Jonathan5](https://meta.discourse.org/u/Jonathan5)\
**Replies:** 0\
**Last updated:** [March 10, 2025, 3:10pm UTC](https://meta.discourse.org/t/a-new-version-of-configuration-file-etc-ssh-sshd-config-is-available-but-the-version-installed-currently-has-been-locally-modified/356625 "2025-03-10T15:10:53Z")

</div>

Continuing the discussion from Updating I get a "Configuring openssh-server" message about the "sshd\_config" file: I got the same message. I too chose to keep the local version, and things seem to work. But could someo…

---

## [Operating System - Ubuntu, Linux or something else?](https://meta.discourse.org/t/operating-system-ubuntu-linux-or-something-else/356439)

<div class="topic-metadata">

**Author:** [@becl](https://meta.discourse.org/u/becl)\
**Replies:** 9\
**Last updated:** [March 9, 2025, 9:21pm UTC](https://meta.discourse.org/t/operating-system-ubuntu-linux-or-something-else/356439 "2025-03-09T21:21:10Z")

</div>

I am new to discourse and trying to setup for my own forum. I have a webserver running Linux and WHM/Cpanel which has worked out fine for my wordpress websites. I ran up a new server which I was going to host the new we…

[Previous page](https://meta.discourse.org/c/support/self-hosting/31.md?page=12)

[Next page](https://meta.discourse.org/c/support/self-hosting/31.md?page=14)
