# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=136

[最新版本](https://meta.discourse.org/latest.md) · [分類](https://meta.discourse.org/categories.md) · [標簽](https://meta.discourse.org/tags.md)

**Page:** 137

---

## [Can you install Discourse for Namecheap server hoster?](https://meta.discourse.org/t/can-you-install-discourse-for-namecheap-server-hoster/77065)

<div class="topic-metadata">

**Author:** [@fivem](https://meta.discourse.org/u/fivem)\
**回覆:** 2\
**Last updated:** [2018年一月1日 20:07 UTC](https://meta.discourse.org/t/can-you-install-discourse-for-namecheap-server-hoster/77065 "2018-01-01T20:07:50Z")

</div>

Can you install Discourse for Namecheap server hoster? And does it cost money or not?

---

## [Do I need a second aws S3 bucket for backup?](https://meta.discourse.org/t/do-i-need-a-second-aws-s3-bucket-for-backup/76969)

<div class="topic-metadata">

**Author:** [@Pravi](https://meta.discourse.org/u/Pravi)\
**回覆:** 9\
**Last updated:** [2017年十二月31日 16:51 UTC](https://meta.discourse.org/t/do-i-need-a-second-aws-s3-bucket-for-backup/76969 "2017-12-31T16:51:08Z")

</div>

Hi, I have setup image upload to aws S3. Its is working fine, but backup is not working with s3. I have created a new bucket for backup and added the bucket name in the admin panel. It gives me following error in logs, …

---

## [Is the official \`discourse-16.04\` Vagrant box compatible with VMware Workstation, or it is for VirtualBox only?](https://meta.discourse.org/t/is-the-official-discourse-16-04-vagrant-box-compatible-with-vmware-workstation-or-it-is-for-virtualbox-only/76692)

<div class="topic-metadata">

**Author:** [@dmitry\_fedyuk](https://meta.discourse.org/u/dmitry_fedyuk)\
**回覆:** 1\
**Last updated:** [2017年十二月27日 18:28 UTC](https://meta.discourse.org/t/is-the-official-discourse-16-04-vagrant-box-compatible-with-vmware-workstation-or-it-is-for-virtualbox-only/76692 "2017-12-27T18:28:51Z")

</div>

---

## [Docker using a lot of CPU](https://meta.discourse.org/t/docker-using-a-lot-of-cpu/76788)

<div class="topic-metadata">

**Author:** [@tophee](https://meta.discourse.org/u/tophee)\
**回覆:** 7\
**Last updated:** [2017年十二月26日 23:27 UTC](https://meta.discourse.org/t/docker-using-a-lot-of-cpu/76788 "2017-12-26T23:27:32Z")

</div>

For no apparent reason, my server (Hetzner VPS) became virtually unreachable today, i.e. it was so busy that it took multiple attempts to login via ssh and even when it didn’t fail, it literally took minutes until I got …

---

## [由于插件问题在重建/升级discourse时出现错误](https://meta.discourse.org/t/error-when-rebuilding-upgrading-discourse-due-to-bad-plugin/76787)

<div class="topic-metadata">

**Author:** [@swfsql](https://meta.discourse.org/u/swfsql)\
**回覆:** 1\
**Last updated:** [2017年十二月26日 21:40 UTC](https://meta.discourse.org/t/error-when-rebuilding-upgrading-discourse-due-to-bad-plugin/76787 "2017-12-26T21:40:43Z")

</div>

嗨，在我名为“multi”（多站点）的discourse实例中，我注意到有很多util.rb:23进程占用内存/交换空间，导致我无法运行./launcher stop multi（硬盘空间耗尽），因此我试图杀死ruby，但未成功…

---

## [Error while trying to install Discourse](https://meta.discourse.org/t/error-while-trying-to-install-discourse/76767)

<div class="topic-metadata">

**Author:** [@Temmyhlee](https://meta.discourse.org/u/Temmyhlee)\
**回覆:** 7\
**Last updated:** [2017年十二月26日 21:11 UTC](https://meta.discourse.org/t/error-while-trying-to-install-discourse/76767 "2017-12-26T21:11:15Z")

</div>

Hello, I have been trying to install discourse on my development server but it isn’t working and I have increased the Ram to 4gb. Can anyone please help me with it? The error is attached… 156:M 26 Dec 10:09:29.206 # WA…

---

## [Locks up while running Sidekiq after migration](https://meta.discourse.org/t/locks-up-while-running-sidekiq-after-migration/76640)

<div class="topic-metadata">

**Author:** [@fwielstra](https://meta.discourse.org/u/fwielstra)\
**回覆:** 6\
**Last updated:** [2017年十二月24日 14:46 UTC](https://meta.discourse.org/t/locks-up-while-running-sidekiq-after-migration/76640 "2017-12-24T14:46:25Z")

</div>

I’ve been trying to import my vBulletin forum into Discourse for a while now. I’ve been following this guide: Migrate a vBulletin 4 forum to Discourse. I’m running the product on my Macbook using the Vagrant image as de…

---

## [NGINX Proxy Mixed Content Error](https://meta.discourse.org/t/nginx-proxy-mixed-content-error/76641)

<div class="topic-metadata">

**Author:** [@Zelakto](https://meta.discourse.org/u/Zelakto)\
**回覆:** 1\
**Last updated:** [2017年十二月23日 20:59 UTC](https://meta.discourse.org/t/nginx-proxy-mixed-content-error/76641 "2017-12-23T20:59:23Z")

</div>

Hi there, Recently, a user complained to me about not being able to create an account due to there being too many accounts registered for that IP address. Turns out, this was because I was running my Discourse forum on …

---

## [Failed to bootstrap due to plugins using deprecated constants](https://meta.discourse.org/t/failed-to-bootstrap-due-to-plugins-using-deprecated-constants/76581)

<div class="topic-metadata">

**Author:** [@LordAres](https://meta.discourse.org/u/LordAres)\
**回覆:** 8\
**Last updated:** [2017年十二月21日 23:20 UTC](https://meta.discourse.org/t/failed-to-bootstrap-due-to-plugins-using-deprecated-constants/76581 "2017-12-21T23:20:10Z")

</div>

I guess you could say this is my first issue with Discourse. I tried to update to 1.9.0.beta17, When I try to run the ./launcher rebuild app it starts out fine and then after a few short moments I get hit with this erro…

---

## [Can I self-host this for free?](https://meta.discourse.org/t/can-i-self-host-this-for-free/76592)

<div class="topic-metadata">

**Author:** [@lilcub](https://meta.discourse.org/u/lilcub)\
**回覆:** 3\
**Last updated:** [2017年十二月21日 23:03 UTC](https://meta.discourse.org/t/can-i-self-host-this-for-free/76592 "2017-12-21T23:03:50Z")

</div>

Am I able to Self-Host this by myself for free?

---

## [继承话语安装——需要一些帮助](https://meta.discourse.org/t/inheriting-discourse-install-need-some-assistance/76505)

<div class="topic-metadata">

**Author:** [@jerdog](https://meta.discourse.org/u/jerdog)\
**回覆:** 18\
**Last updated:** [2017年十二月21日 19:45 UTC](https://meta.discourse.org/t/inheriting-discourse-install-need-some-assistance/76505 "2017-12-21T19:45:09Z")

</div>

所以我接手了一个新职位，我们一直在使用Discourse——然后转到了AnswerHub (:man\_shrugging:)，我可能会让我们重新回到Discourse。我以前用过discourse——但这个瞬间……

---

## [Disable memory warning](https://meta.discourse.org/t/disable-memory-warning/76240)

<div class="topic-metadata">

**Author:** [@thatawesomeguy](https://meta.discourse.org/u/thatawesomeguy)\
**回覆:** 3\
**Last updated:** [2017年十二月20日 11:46 UTC](https://meta.discourse.org/t/disable-memory-warning/76240 "2017-12-20T11:46:05Z")

</div>

Hi, I am hosting Discourse on a VPS with 1GB memory. I had some issues installing it initially because although it has 1GB installed the environment reports just under 1GB (991448 kB available). I modified the install …

---

## [为什么我需要块存储？](https://meta.discourse.org/t/why-do-i-need-a-block-storage/76247)

<div class="topic-metadata">

**Author:** [@XPMai](https://meta.discourse.org/u/XPMai)\
**回覆:** 8\
**Last updated:** [2017年十二月18日 07:37 UTC](https://meta.discourse.org/t/why-do-i-need-a-block-storage/76247 "2017-12-18T07:37:44Z")

</div>

我还没有安装Discourse，也通过谷歌搜索未能找到答案。 我还没有安装Discourse，因为它需要一个VPS/昂贵的云托管，我只是在做一些研究…… 我可以……

---

## [My forum disappeared because Apache got installed](https://meta.discourse.org/t/my-forum-disappeared-because-apache-got-installed/76291)

<div class="topic-metadata">

**Author:** [@hashOK](https://meta.discourse.org/u/hashOK)\
**回覆:** 4\
**Last updated:** [2017年十二月18日 07:04 UTC](https://meta.discourse.org/t/my-forum-disappeared-because-apache-got-installed/76291 "2017-12-18T07:04:56Z")

</div>

My forum was good till today morning I noticed that the home page has somehow been replaced my apache default page.It has disappeared or at least got hidden. My server is amazon web server and I can confirm that the …

---

## [How to install on OpenVZ](https://meta.discourse.org/t/how-to-install-on-openvz/76270)

<div class="topic-metadata">

**Author:** [@Wojtek\_Konowrocki](https://meta.discourse.org/u/Wojtek_Konowrocki)\
**回覆:** 1\
**Last updated:** [2017年十二月17日 20:18 UTC](https://meta.discourse.org/t/how-to-install-on-openvz/76270 "2017-12-17T20:18:05Z")

</div>

I want to install discourse on OpenVZ, but i can’t use mandrillapp. I can’t switch to kvm or other

---

## [Build docker base image fail](https://meta.discourse.org/t/build-docker-base-image-fail/76119)

<div class="topic-metadata">

**Author:** [@ray\_chen](https://meta.discourse.org/u/ray_chen)\
**回覆:** 4\
**Last updated:** [2017年十二月15日 13:05 UTC](https://meta.discourse.org/t/build-docker-base-image-fail/76119 "2017-12-15T13:05:23Z")

</div>

I tried to build image using Dockerfile from discourse\_docker/image/base at master · discourse/discourse\_docker · GitHub but ends up with below error. Step 46/59 : ADD phantomjs /usr/local/bin/phantomjs ADD failed: stat…

---

## [Digital Ocean hosting: Do I need a system admin?](https://meta.discourse.org/t/digital-ocean-hosting-do-i-need-a-system-admin/59525)

<div class="topic-metadata">

**Author:** [@immalex](https://meta.discourse.org/u/immalex)\
**回覆:** 28\
**Last updated:** [2017年十二月14日 07:10 UTC](https://meta.discourse.org/t/digital-ocean-hosting-do-i-need-a-system-admin/59525 "2017-12-14T07:10:08Z")

</div>

I have been running my discourse forum on Digital Ocean for a few months. Works beautifully at $10 a month. I know DO is an unmanaged VPS, so I am wondering what maintenance task is required? If maintenance tasks are re…

---

## [Discourse+Docker+AWS - "bootstrap" talks to DB fine, "run" doesn't](https://meta.discourse.org/t/discourse-docker-aws-bootstrap-talks-to-db-fine-run-doesnt/27464)

<div class="topic-metadata">

**Author:** [@j00bar](https://meta.discourse.org/u/j00bar)\
**回覆:** 7\
**Last updated:** [2017年十二月13日 22:43 UTC](https://meta.discourse.org/t/discourse-docker-aws-bootstrap-talks-to-db-fine-run-doesnt/27464 "2017-12-13T22:43:15Z")

</div>

Howdy! I’m running Discourse using discourse docker on EC2 using RDS as my database. My app.yml contains all of the proper DISCOURSE\_DB\_\* settings, and sure enough, when I ran launcher bootstrap app, everything worked j…

---

## [Sending email failed with Net::SMTPServerBusy: 440 mail from account doesn't conform with authentication](https://meta.discourse.org/t/sending-email-failed-with-net-smtpserverbusy-440-mail-from-account-doesnt-conform-with-authentication/75790)

<div class="topic-metadata">

**Author:** [@FrankFang](https://meta.discourse.org/u/FrankFang)\
**回覆:** 3\
**Last updated:** [2017年十二月10日 20:32 UTC](https://meta.discourse.org/t/sending-email-failed-with-net-smtpserverbusy-440-mail-from-account-doesnt-conform-with-authentication/75790 "2017-12-10T20:32:25Z")

</div>

Here is my smtp settings in app.yml 1 DISCOURSE\_SMTP\_ADDRESS: 'smtp.xxx.com' 2 DISCOURSE\_SMTP\_PORT: 25 3 DISCOURSE\_SMTP\_USER\_NAME: 'no-reply@yyy.com' 4 DISCOURSE\_SMTP\_PASSWORD: '\*\*\*' 5 DISCOURSE\_SMTP…

---

## [Can't send mail -- unprocessable entity](https://meta.discourse.org/t/cant-send-mail-unprocessable-entity/75195)

<div class="topic-metadata">

**Author:** [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**回覆:** 4\
**Last updated:** [2017年十二月9日 14:46 UTC](https://meta.discourse.org/t/cant-send-mail-unprocessable-entity/75195 "2017-12-09T14:46:45Z")

</div>

I’ve set up a new site, using my script that calls discourse-setup like a normal person would. Email is not going out. It never shows up in the mailgun logs. I’ve double-checked the password/username and switched from p…

---

## [Instance broken cannot load such file simple-rss](https://meta.discourse.org/t/instance-broken-cannot-load-such-file-simple-rss/75725)

<div class="topic-metadata">

**Author:** [@ZackFea](https://meta.discourse.org/u/ZackFea)\
**回覆:** 2\
**Last updated:** [2017年十二月9日 10:30 UTC](https://meta.discourse.org/t/instance-broken-cannot-load-such-file-simple-rss/75725 "2017-12-09T10:30:00Z")

</div>

I did add a new plugin and got automatic the last version. ./launcher cleanup ./launcher rebuild app end in this error: LoadError: cannot load such file -- simple-rss Here is the full log: I, \[2017-12-09T10:07:24.95…

---

## [SMTP Email Doesn't Work on Synology DSM 6](https://meta.discourse.org/t/smtp-email-doesnt-work-on-synology-dsm-6/75531)

<div class="topic-metadata">

**Author:** [@Tyson](https://meta.discourse.org/u/Tyson)\
**回覆:** 6\
**Last updated:** [2017年十二月7日 20:34 UTC](https://meta.discourse.org/t/smtp-email-doesnt-work-on-synology-dsm-6/75531 "2017-12-07T20:34:11Z")

</div>

I installed Discourse on a Synology RackStation using the Discourse Docker package from the Synology Package Center. It shows the package is published by Civilized Discourse Construction Kit so I assume it’s an officiall…

---

## [How to setup automatic updates for Ubuntu running Discourse?](https://meta.discourse.org/t/how-to-setup-automatic-updates-for-ubuntu-running-discourse/63501)

<div class="topic-metadata">

**Author:** [@mhwebee](https://meta.discourse.org/u/mhwebee)\
**回覆:** 8\
**Last updated:** [2017年十二月6日 01:19 UTC](https://meta.discourse.org/t/how-to-setup-automatic-updates-for-ubuntu-running-discourse/63501 "2017-12-06T01:19:49Z")

</div>

DigitalOcean VM - In Ubuntu (16.04.2) I used the “dpkg-reconfigure -plow unattended-upgrades” command, but I get this return “update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults…

---

## [DISCOURSE\_SMTP\_PASSWORD change failed](https://meta.discourse.org/t/discourse-smtp-password-change-failed/75441)

<div class="topic-metadata">

**Author:** [@Pravi7434](https://meta.discourse.org/u/Pravi7434)\
**回覆:** 5\
**Last updated:** [2017年十二月5日 21:51 UTC](https://meta.discourse.org/t/discourse-smtp-password-change-failed/75441 "2017-12-05T21:51:46Z")

</div>

Hello, I got above mentioned error while installing discourse on aws ec2. The problem was with my SES smtp password ( AmQ/22sNDN2Bg5vS+zH3IDfy+lfmF3OgGg/CnsAZMg90 ). Later I changed the password to one without any speci…

---

## [Digital Ocean $15 vs $20, what is a better option for Discourse?](https://meta.discourse.org/t/digital-ocean-15-vs-20-what-is-a-better-option-for-discourse/75308)

<div class="topic-metadata">

**Author:** [@meglio](https://meta.discourse.org/u/meglio)\
**回覆:** 7\
**Last updated:** [2017年十二月5日 07:56 UTC](https://meta.discourse.org/t/digital-ocean-15-vs-20-what-is-a-better-option-for-discourse/75308 "2017-12-05T07:56:56Z")

</div>

Digital Ocean is a recommended provider for Discourse self-hosting. It recently introduced a $15 / mo plan. Compare it to $10 and $20 plans that were there and are still an option: It is interesting that the $15 opt…

---

## [Latest update requires cache purge in CloudFlare](https://meta.discourse.org/t/latest-update-requires-cache-purge-in-cloudflare/73166)

<div class="topic-metadata">

**Author:** [@barreeeiroo](https://meta.discourse.org/u/barreeeiroo)\
**回覆:** 70\
**Last updated:** [2017年十二月5日 04:28 UTC](https://meta.discourse.org/t/latest-update-requires-cache-purge-in-cloudflare/73166 "2017-12-05T04:28:28Z")

</div>

I think if you access to my community is enough to see the problem :confused: EVEN ON SAFE MODE IS BROKEN

---

## [Configuring email SMTP settings just isn't working](https://meta.discourse.org/t/configuring-email-smtp-settings-just-isnt-working/75341)

<div class="topic-metadata">

**Author:** [@Frank\_Bailey](https://meta.discourse.org/u/Frank_Bailey)\
**回覆:** 2\
**Last updated:** [2017年十二月4日 17:11 UTC](https://meta.discourse.org/t/configuring-email-smtp-settings-just-isnt-working/75341 "2017-12-04T17:11:17Z")

</div>

Hi folks. I try not to post unless I’m really, truly stuck. I’ve installed Discourse as a Docker container in Ubuntu 16.04 which is a guest VM in VirtualBox with a Windows 10 host. The installation was successful, howeve…

---

## [Does it make any sense to colocate your own hardware for running a single Discourse instance?](https://meta.discourse.org/t/does-it-make-any-sense-to-colocate-your-own-hardware-for-running-a-single-discourse-instance/75310)

<div class="topic-metadata">

**Author:** [@meglio](https://meta.discourse.org/u/meglio)\
**回覆:** 2\
**Last updated:** [2017年十二月4日 06:51 UTC](https://meta.discourse.org/t/does-it-make-any-sense-to-colocate-your-own-hardware-for-running-a-single-discourse-instance/75310 "2017-12-04T06:51:43Z")

</div>

Are there any preconditions for running a single Discourse instance on your own hardware (colocation), rather than renting a VPS (e.g. Digital Ocean) or a dedicated server (e.g. Softlayer or Hetzner)? I’ve never had an …

---

## [Installing a plugin on a hosted plan?](https://meta.discourse.org/t/installing-a-plugin-on-a-hosted-plan/75059)

<div class="topic-metadata">

**Author:** [@guaiasilk](https://meta.discourse.org/u/guaiasilk)\
**回覆:** 5\
**Last updated:** [2017年十一月30日 04:47 UTC](https://meta.discourse.org/t/installing-a-plugin-on-a-hosted-plan/75059 "2017-11-30T04:47:56Z")

</div>

I’m not very techy (at all) and want to use Discourse to build my online community on. I’ve got it set up with my domain and started to get the hang of using it and customizing the basics. I wanted to install a plugin, …

---

## [NOQUEUE: reject using Direct Email Delivery](https://meta.discourse.org/t/noqueue-reject-using-direct-email-delivery/75054)

<div class="topic-metadata">

**Author:** [@dfriestedt](https://meta.discourse.org/u/dfriestedt)\
**回覆:** 3\
**Last updated:** [2017年十一月30日 01:15 UTC](https://meta.discourse.org/t/noqueue-reject-using-direct-email-delivery/75054 "2017-11-30T01:15:41Z")

</div>

I have a new discourse installation and am setting up Direct Email Delivery according to these instructions: \[Configure direct-delivery incoming email for self-hosted sites with Mail-Receiver\] I have this working on a …

[上一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=135)

[下一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=137)
