# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=140

[最新版本](https://meta.discourse.org/latest.md) · [分類](https://meta.discourse.org/categories.md) · [標簽](https://meta.discourse.org/tags.md)

**Page:** 141

---

## [安装失败：插件](https://meta.discourse.org/t/installation-failed-plugins/67884)

<div class="topic-metadata">

**Author:** [@barreeeiroo](https://meta.discourse.org/u/barreeeiroo)\
**回覆:** 7\
**Last updated:** [2017年八月12日 13:38 UTC](https://meta.discourse.org/t/installation-failed-plugins/67884 "2017-08-12T13:38:28Z")

</div>

我正在尝试用 ./launcher rebuild app 重建 Discourse，但出现以下错误： FAILED -------------------- Pups::ExecError: cd /var/www/discourse/plugins && git clone https://github.com/discourse/docker\_mana……

---

## [Update failed due to primary key sequence error](https://meta.discourse.org/t/update-failed-due-to-primary-key-sequence-error/67852)

<div class="topic-metadata">

**Author:** [@mdxdave](https://meta.discourse.org/u/mdxdave)\
**回覆:** 6\
**Last updated:** [2017年八月12日 01:11 UTC](https://meta.discourse.org/t/update-failed-due-to-primary-key-sequence-error/67852 "2017-08-12T01:11:17Z")

</div>

I’ve tried to update from Version v1.9.0.beta4 +300 to 1.9.0.beta5 by pulling the latest changes (git pull) and try to rebuild the app (./launcher rebuild app), but the migration failed with the following message: Any f…

---

## [Discourse Hosting and Space](https://meta.discourse.org/t/discourse-hosting-and-space/67620)

<div class="topic-metadata">

**Author:** [@gina\_riley](https://meta.discourse.org/u/gina_riley)\
**回覆:** 5\
**Last updated:** [2017年八月8日 01:15 UTC](https://meta.discourse.org/t/discourse-hosting-and-space/67620 "2017-08-08T01:15:29Z")

</div>

I am fairly certain I read this here but I can not seem to find it using the search function. If this has already been answered, please direct me to the link. In the meantime, I am in the process of trying to set up my …

---

## [Discourse on 512MB Droplet](https://meta.discourse.org/t/discourse-on-512mb-droplet/67575)

<div class="topic-metadata">

**Author:** [@rhukee](https://meta.discourse.org/u/rhukee)\
**回覆:** 1\
**Last updated:** [2017年八月7日 04:11 UTC](https://meta.discourse.org/t/discourse-on-512mb-droplet/67575 "2017-08-07T04:11:47Z")

</div>

Would Discourse work on a DO 512MB droplet? does this depend on how big or small my community is? if so, how many users would this handle?

---

## [How to keep track of trial?](https://meta.discourse.org/t/how-to-keep-track-of-trial/67552)

<div class="topic-metadata">

**Author:** [@Jimble](https://meta.discourse.org/u/Jimble)\
**回覆:** 1\
**Last updated:** [2017年八月6日 14:04 UTC](https://meta.discourse.org/t/how-to-keep-track-of-trial/67552 "2017-08-06T14:04:24Z")

</div>

I have no idea what day I’m on in my 14-day trial. I’m nervous about getting billed 100 dollars for the next month. We just wanted to try it out so that we can host it ourselves. I can’t find any information about thi…

---

## [每次打开Putty时设置话语吗？](https://meta.discourse.org/t/setting-discourse-evrytime-you-open-putty/67542)

<div class="topic-metadata">

**Author:** [@smota](https://meta.discourse.org/u/smota)\
**回覆:** 5\
**Last updated:** [2017年八月6日 01:17 UTC](https://meta.discourse.org/t/setting-discourse-evrytime-you-open-putty/67542 "2017-08-06T01:17:48Z")

</div>

您好，专家，每次我打开Putty时，discourse都会要求配置初始数据。比如电子邮件管理员、SMTP邮件等，怎样才能关闭这个功能？\[图片\]

---

## [Kcptun on server and No Space for Discourse now](https://meta.discourse.org/t/kcptun-on-server-and-no-space-for-discourse-now/67481)

<div class="topic-metadata">

**Author:** [@xiasummer](https://meta.discourse.org/u/xiasummer)\
**回覆:** 4\
**Last updated:** [2017年八月5日 11:15 UTC](https://meta.discourse.org/t/kcptun-on-server-and-no-space-for-discourse-now/67481 "2017-08-05T11:15:37Z")

</div>

Hi, I’m from China, and as the VPN was stoped by the government. So I build up the shadowsocks and Kcptun service on my server to help me surf the blocked websited. But a few months passed I found my server space all o…

---

## [Forum shows "This page isn’t working"](https://meta.discourse.org/t/forum-shows-this-page-isn-t-working/67097)

<div class="topic-metadata">

**Author:** [@ankur1857](https://meta.discourse.org/u/ankur1857)\
**回覆:** 10\
**Last updated:** [2017年八月2日 11:42 UTC](https://meta.discourse.org/t/forum-shows-this-page-isn-t-working/67097 "2017-08-02T11:42:14Z")

</div>

My discourse forum is showing the message “This page isn’t working”. Please help to resolve the issue.

---

## [Rebuild app has stuck](https://meta.discourse.org/t/rebuild-app-has-stuck/67300)

<div class="topic-metadata">

**Author:** [@Alexander\_Wright](https://meta.discourse.org/u/Alexander_Wright)\
**回覆:** 1\
**Last updated:** [2017年八月2日 09:22 UTC](https://meta.discourse.org/t/rebuild-app-has-stuck/67300 "2017-08-02T09:22:24Z")

</div>

Hi, I was prompted to refresh the launcher and run ./launcher rebuild app for the latest version upgrade. It’s now got stuck here: 155:M 02 Aug 08:34:46.052 \* 10 changes in 300 seconds. Saving... 155:M 02 Aug 08:34:46…

---

## [Why does the docker image take so much space?](https://meta.discourse.org/t/why-does-the-docker-image-take-so-much-space/67190)

<div class="topic-metadata">

**Author:** [@Chopper](https://meta.discourse.org/u/Chopper)\
**回覆:** 4\
**Last updated:** [2017年八月2日 00:43 UTC](https://meta.discourse.org/t/why-does-the-docker-image-take-so-much-space/67190 "2017-08-02T00:43:45Z")

</div>

This is the question about the 10GO min, what in the docker container take so much place ? A default install of Discourse is ~5-6go, so what takes so much space with an empty forum ? Thanks

---

## [Starting a second Discourse forum on the same VPS](https://meta.discourse.org/t/starting-a-second-discourse-forum-on-the-same-vps/67160)

<div class="topic-metadata">

**Author:** [@\_vincent](https://meta.discourse.org/u/_vincent)\
**回覆:** 4\
**Last updated:** [2017年八月1日 17:29 UTC](https://meta.discourse.org/t/starting-a-second-discourse-forum-on-the-same-vps/67160 "2017-08-01T17:29:59Z")

</div>

Hi, I would like to host a second forum on an OVH VPS. Main standalone discourse instance runs on the domain root (https://zbeul.org) and I want the new one to be ran on https://mao.zbeul.org. I figured the best soluti…

---

## [Rebuild app complains about diskspace (AWS)](https://meta.discourse.org/t/rebuild-app-complains-about-diskspace-aws/67181)

<div class="topic-metadata">

**Author:** [@donlucas](https://meta.discourse.org/u/donlucas)\
**回覆:** 7\
**Last updated:** [2017年八月1日 00:08 UTC](https://meta.discourse.org/t/rebuild-app-complains-about-diskspace-aws/67181 "2017-08-01T00:08:01Z")

</div>

Been trying to walk through the INSTALL-cloud.md documentation on an AWS ec2 instance. I’ve virtual linked /var/discourse to a drive with 33GB available but when I execute the ./launcher rebuild app command, I get the f…

---

## [DigitalOcean vs AWS Lightsail](https://meta.discourse.org/t/digitalocean-vs-aws-lightsail/59637)

<div class="topic-metadata">

**Author:** [@liberaltech](https://meta.discourse.org/u/liberaltech)\
**回覆:** 6\
**Last updated:** [2017年七月30日 21:06 UTC](https://meta.discourse.org/t/digitalocean-vs-aws-lightsail/59637 "2017-07-30T21:06:19Z")

</div>

I tried both and it looks like Discourse is deployable to both in the exact same way. Just follow the Docker instructions for both. I ended up deploying Discourse on AWS Lightsail (Ubuntu VPS) for $10/month.

---

## [Your Docker installation is not working correctly](https://meta.discourse.org/t/your-docker-installation-is-not-working-correctly/67051)

<div class="topic-metadata">

**Author:** [@SMT](https://meta.discourse.org/u/SMT)\
**回覆:** 6\
**Last updated:** [2017年七月29日 12:37 UTC](https://meta.discourse.org/t/your-docker-installation-is-not-working-correctly/67051 "2017-07-29T12:37:52Z")

</div>

I was getting bad gateway error. So I tried to rebuilt discourse. But it stucks at downloading image. How to solve this? Pulling repository docker.io/discourse/base Tag 2.0.20170728 not found in repository docker.io/dis…

---

## [Port 80 appears to already be in use](https://meta.discourse.org/t/port-80-appears-to-already-be-in-use/57618)

<div class="topic-metadata">

**Author:** [@m1raz](https://meta.discourse.org/u/m1raz)\
**回覆:** 5\
**Last updated:** [2017年七月29日 04:19 UTC](https://meta.discourse.org/t/port-80-appears-to-already-be-in-use/57618 "2017-07-29T04:19:42Z")

</div>

Hello, when i run discourse\_setup, it says Port 80 is used. Maybe there is something hosting installed by default, so I want to clear port 80 successfull instalation. Port 80 appears to already be in use. If you are tr…

---

## [Installation issues on Scaleway](https://meta.discourse.org/t/installation-issues-on-scaleway/66867)

<div class="topic-metadata">

**Author:** [@CFi](https://meta.discourse.org/u/CFi)\
**回覆:** 3\
**Last updated:** [2017年七月28日 16:02 UTC](https://meta.discourse.org/t/installation-issues-on-scaleway/66867 "2017-07-28T16:02:02Z")

</div>

Hello, I tried to install discourse on x64 Scaleway server. I changed settings to allow smtp according to this post ScaleWay review? - #44 by ljpp I followed instructions from this page discourse/docs/INSTALL-cloud.md…

---

## [Email not showing on admin account registration -- email protected](https://meta.discourse.org/t/email-not-showing-on-admin-account-registration-email-protected/66985)

<div class="topic-metadata">

**Author:** [@rhukee](https://meta.discourse.org/u/rhukee)\
**回覆:** 1\
**Last updated:** [2017年七月28日 05:01 UTC](https://meta.discourse.org/t/email-not-showing-on-admin-account-registration-email-protected/66985 "2017-07-28T05:01:26Z")

</div>

I’m trying to install Discourse on DigitalOcean following this tutorial and I don’t have any problems until I get to the Register Admin Account, then i get this: any ideas on how i can fix this?

---

## [Discourse-saml as sole login method](https://meta.discourse.org/t/discourse-saml-as-sole-login-method/66916)

<div class="topic-metadata">

**Author:** [@alexweej](https://meta.discourse.org/u/alexweej)\
**回覆:** 5\
**Last updated:** [2017年七月27日 14:56 UTC](https://meta.discourse.org/t/discourse-saml-as-sole-login-method/66916 "2017-07-27T14:56:09Z")

</div>

I can see from the admin settings that the built-in (non-SAML) SSO support can do things like: sso overrides bio - Overrides user bio in user profile and prevents user from changing it sso overrides email - Overrid…

---

## [Why does Docker say "WARNING: No swap limit support!"](https://meta.discourse.org/t/why-does-docker-say-warning-no-swap-limit-support/29945)

<div class="topic-metadata">

**Author:** [@nahtnam](https://meta.discourse.org/u/nahtnam)\
**回覆:** 7\
**Last updated:** [2017年七月27日 09:30 UTC](https://meta.discourse.org/t/why-does-docker-say-warning-no-swap-limit-support/29945 "2017-07-27T09:30:19Z")

</div>

Is it weird that even after completing the tutorial, Docker says that there is no swap file detected?

---

## [Rebuild failing after adding discourse-saml plugin](https://meta.discourse.org/t/rebuild-failing-after-adding-discourse-saml-plugin/66879)

<div class="topic-metadata">

**Author:** [@alexweej](https://meta.discourse.org/u/alexweej)\
**回覆:** 1\
**Last updated:** [2017年七月26日 20:46 UTC](https://meta.discourse.org/t/rebuild-failing-after-adding-discourse-saml-plugin/66879 "2017-07-26T20:46:48Z")

</div>

After adding the discourse-saml plugin, when running ./launcher rebuild app we’re seeing the following fatal error: ERROR: While executing gem ... (TypeError) no implicit conversion of nil into String I, \[2017-07-2…

---

## [Login with SSO option does not exchange SSL certificates](https://meta.discourse.org/t/login-with-sso-option-does-not-exchange-ssl-certificates/66664)

<div class="topic-metadata">

**Author:** [@vishal\_vr](https://meta.discourse.org/u/vishal_vr)\
**回覆:** 10\
**Last updated:** [2017年七月26日 15:57 UTC](https://meta.discourse.org/t/login-with-sso-option-does-not-exchange-ssl-certificates/66664 "2017-07-26T15:57:28Z")

</div>

I have a main domain hosted on Firebase, which runs the actual website of our business. Then installed Discourse platform hosted in another sub domain but on a different hosting platform. Discourse forum was edited and w…

---

## [Hosted Discourse Version?](https://meta.discourse.org/t/hosted-discourse-version/66739)

<div class="topic-metadata">

**Author:** [@Martin\_Cash](https://meta.discourse.org/u/Martin_Cash)\
**回覆:** 2\
**Last updated:** [2017年七月25日 01:42 UTC](https://meta.discourse.org/t/hosted-discourse-version/66739 "2017-07-25T01:42:16Z")

</div>

I could have sworn there was an area in Account Management hat displayed the current version/build. Was that removed or am I looking in the wrong place? What prompted this was the new emoji picker that I need in my life. …

---

## [Device "docker0" does not exist. ubuntu 16.04](https://meta.discourse.org/t/device-docker0-does-not-exist-ubuntu-16-04/66656)

<div class="topic-metadata">

**Author:** [@11145](https://meta.discourse.org/u/11145)\
**回覆:** 5\
**Last updated:** [2017年七月23日 03:55 UTC](https://meta.discourse.org/t/device-docker0-does-not-exist-ubuntu-16-04/66656 "2017-07-23T03:55:26Z")

</div>

I can not install the discourse. When I try to start I see this: root@s9ffd138e:/var/discourse# ./launcher start app Device "docker0" does not exist. Cannot connect to the docker daemon - verify it is running and you h…

---

## [SparkPost experience (superb support)](https://meta.discourse.org/t/sparkpost-experience-superb-support/65302)

<div class="topic-metadata">

**Author:** [@tophee](https://meta.discourse.org/u/tophee)\
**回覆:** 2\
**Last updated:** [2017年七月22日 23:35 UTC](https://meta.discourse.org/t/sparkpost-experience-superb-support/65302 "2017-07-22T23:35:55Z")

</div>

I just want to share my experience with SparkPost support here because O am simply blown away by their service (I’m still on their free plan). I contacted them because I had a couple of bounces where the reason was that…

---

## [Problems with Sparkpost email on install](https://meta.discourse.org/t/problems-with-sparkpost-email-on-install/66580)

<div class="topic-metadata">

**Author:** [@jestyr27](https://meta.discourse.org/u/jestyr27)\
**回覆:** 7\
**Last updated:** [2017年七月22日 03:20 UTC](https://meta.discourse.org/t/problems-with-sparkpost-email-on-install/66580 "2017-07-22T03:20:50Z")

</div>

Hey guys, I’ve been working on getting Discourse setup on my website and cannot get the email confirmation to go through, or to pass through sparkpost Here’s my error log: Started GET "/about.json" for 64.71.168.196 a…

---

## [Install discourse with internet access only via proxy](https://meta.discourse.org/t/install-discourse-with-internet-access-only-via-proxy/66396)

<div class="topic-metadata">

**Author:** [@jimbob](https://meta.discourse.org/u/jimbob)\
**回覆:** 17\
**Last updated:** [2017年七月20日 10:11 UTC](https://meta.discourse.org/t/install-discourse-with-internet-access-only-via-proxy/66396 "2017-07-20T10:11:58Z")

</div>

Hi All, (Note that I have deliberately broken all domain names by inserting whitespace because they are getting detected as links, and as a noob I cannot post \>2 links in a post) I am trying to install discourse on a r…

---

## [Installing/Running Discourse with Nanobox](https://meta.discourse.org/t/installing-running-discourse-with-nanobox/66214)

<div class="topic-metadata">

**Author:** [@sdomino](https://meta.discourse.org/u/sdomino)\
**回覆:** 3\
**Last updated:** [2017年七月14日 22:41 UTC](https://meta.discourse.org/t/installing-running-discourse-with-nanobox/66214 "2017-07-14T22:41:22Z")

</div>

DISCLAIMER: Unsupported installs of Discourse are highly discouraged. If you feel like you must proceed please understand that the Discourse team cannot, and should not, provide support for this installation. If you hav…

---

## [Runit is running as a process on the host, why?](https://meta.discourse.org/t/runit-is-running-as-a-process-on-the-host-why/66205)

<div class="topic-metadata">

**Author:** [@c3iq](https://meta.discourse.org/u/c3iq)\
**回覆:** 2\
**Last updated:** [2017年七月14日 15:46 UTC](https://meta.discourse.org/t/runit-is-running-as-a-process-on-the-host-why/66205 "2017-07-14T15:46:34Z")

</div>

Hello, I’ve just run through the set up for Discourse on a VM that runs another service (MediaWiki) via Apache (a standards thing) on CentOS (another standards thing). After the successful run I end up with Nginx insta…

---

## [Discourse installation on Redhat](https://meta.discourse.org/t/discourse-installation-on-redhat/66134)

<div class="topic-metadata">

**Author:** [@gashmicky](https://meta.discourse.org/u/gashmicky)\
**回覆:** 5\
**Last updated:** [2017年七月14日 09:52 UTC](https://meta.discourse.org/t/discourse-installation-on-redhat/66134 "2017-07-14T09:52:04Z")

</div>

Is there any document or steps that i have follow to install discourse in redhat?

---

## [Let's Encrypt 未续订](https://meta.discourse.org/t/letsencrypt-not-renewing/65561)

<div class="topic-metadata">

**Author:** [@RogerBW](https://meta.discourse.org/u/RogerBW)\
**回覆:** 5\
**Last updated:** [2017年七月14日 08:06 UTC](https://meta.discourse.org/t/letsencrypt-not-renewing/65561 "2017-07-14T08:06:18Z")

</div>

它正在尝试更新证书，但验证似乎超时了。这已经持续好几天了。这里是 /shared/letsencrypt/acme.sh.log；我用“IBO\*”和“mz2\*”替换了加密材料字符串……

[上一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=139)

[下一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=141)
