# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=151

[Latest](https://meta.discourse.org/latest.md) · [Categories](https://meta.discourse.org/categories.md) · [Tags](https://meta.discourse.org/tags.md)

**Page:** 152

---

## [\[Noob\] Need help installing Discourse on WAMP as a subdomain to a WordPress localhost](https://meta.discourse.org/t/noob-need-help-installing-discourse-on-wamp-as-a-subdomain-to-a-wordpress-localhost/41952)

<div class="topic-metadata">

**Author:** [@Virilux](https://meta.discourse.org/u/Virilux)\
**Replies:** 1\
**Last updated:** [April 3, 2016, 3:13pm UTC](https://meta.discourse.org/t/noob-need-help-installing-discourse-on-wamp-as-a-subdomain-to-a-wordpress-localhost/41952 "2016-04-03T15:13:28Z")

</div>

Hi! Sorry I’ve been looking around trying to figure this out but I’m new to web development. So I installed WAMP and got WordPress running smoothly on the local server. I wanted a forum for the site, but bbPress wasn’t …

---

## [Discourse 1.5 upgrade problems](https://meta.discourse.org/t/discourse-1-5-upgrade-problems/41879)

<div class="topic-metadata">

**Author:** [@DanteZii](https://meta.discourse.org/u/DanteZii)\
**Replies:** 2\
**Last updated:** [April 1, 2016, 2:48pm UTC](https://meta.discourse.org/t/discourse-1-5-upgrade-problems/41879 "2016-04-01T14:48:13Z")

</div>

more than one hour…what should I do?:sweat\_smile:

---

## [Seeking a current guide for DigitalOcean droplet using the 1-click "Discourse 14.04" button](https://meta.discourse.org/t/seeking-a-current-guide-for-digitalocean-droplet-using-the-1-click-discourse-14-04-button/41835)

<div class="topic-metadata">

**Author:** [@dylanh724](https://meta.discourse.org/u/dylanh724)\
**Replies:** 2\
**Last updated:** [March 31, 2016, 5:25pm UTC](https://meta.discourse.org/t/seeking-a-current-guide-for-digitalocean-droplet-using-the-1-click-discourse-14-04-button/41835 "2016-03-31T17:25:56Z")

</div>

Everything wants me to access some “yml” file that doesn’t seem to exist with the latest and greatest way to install Discourse, now that it’s an official 1-click app on DigitalOcean droplets. Anyone have a non-dated gui…

---

## [Can't install Docker on Linode, aufs-tools not found](https://meta.discourse.org/t/cant-install-docker-on-linode-aufs-tools-not-found/18416)

<div class="topic-metadata">

**Author:** [@liwei\_swjtu](https://meta.discourse.org/u/liwei_swjtu)\
**Replies:** 16\
**Last updated:** [March 31, 2016, 9:36pm UTC](https://meta.discourse.org/t/cant-install-docker-on-linode-aufs-tools-not-found/18416 "2016-03-31T21:36:48Z")

</div>

I’m using linode box with Ubuntu13.04,when I tried to install docker, appears the following erros: root@bbs:/home/dushu# sudo apt-get install lxc-docker --fix-missing Reading package lists... Done Building dependency tr…

---

## [Run bootstrap behind SSL-intercepting proxy, all SSL connections fail](https://meta.discourse.org/t/run-bootstrap-behind-ssl-intercepting-proxy-all-ssl-connections-fail/31289)

<div class="topic-metadata">

**Author:** [@Sirius](https://meta.discourse.org/u/Sirius)\
**Replies:** 10\
**Last updated:** [March 28, 2016, 9:08am UTC](https://meta.discourse.org/t/run-bootstrap-behind-ssl-intercepting-proxy-all-ssl-connections-fail/31289 "2016-03-28T09:08:37Z")

</div>

I want to install discourse on a VM that is behind a proxy. But I got the certificate error when the script updates gem. The log info is as following: FAILED RuntimeError: cd /var/www/discourse && gem update bundler fa…

---

## [Bitnami install on AWS EC2 - email won't work](https://meta.discourse.org/t/bitnami-install-on-aws-ec2-email-wont-work/41393)

<div class="topic-metadata">

**Author:** [@sidonaldson](https://meta.discourse.org/u/sidonaldson)\
**Replies:** 5\
**Last updated:** [March 24, 2016, 12:19pm UTC](https://meta.discourse.org/t/bitnami-install-on-aws-ec2-email-wont-work/41393 "2016-03-24T12:19:10Z")

</div>

I know this install technique isn’t supported but if anyone can help me debug the issue I would be very grateful! I launch the image, runs correctly, I add my mailgun settings and all test emails send fine. I can change…

---

## [New installation on Fedora 23 - FAILED RuntimeError: cd /var/www/discourse && su discourse -c](https://meta.discourse.org/t/new-installation-on-fedora-23-failed-runtimeerror-cd-var-www-discourse-su-discourse-c/41220)

<div class="topic-metadata">

**Author:** [@philip\_rhoades](https://meta.discourse.org/u/philip_rhoades)\
**Replies:** 17\
**Last updated:** [March 21, 2016, 6:34pm UTC](https://meta.discourse.org/t/new-installation-on-fedora-23-failed-runtimeerror-cd-var-www-discourse-su-discourse-c/41220 "2016-03-21T18:34:16Z")

</div>

People, I am trying to do an installation on a new DO server with Fedora 23 x86\_64 but get a long way into: ./launcher bootstrap app before it finally stops with: FAILED -------------------- RuntimeError: cd /var/www…

---

## [Docker install, endless "downloading base image"](https://meta.discourse.org/t/docker-install-endless-downloading-base-image/41350)

<div class="topic-metadata">

**Author:** [@JimmyX](https://meta.discourse.org/u/JimmyX)\
**Replies:** 5\
**Last updated:** [March 21, 2016, 11:08am UTC](https://meta.discourse.org/t/docker-install-endless-downloading-base-image/41350 "2016-03-21T11:08:13Z")

</div>

I installed docker on my laptop. I get as far as logging into the docker with “vagrant ssh” and then I execute vagrant@vagrant-ubuntu-trusty-64:/vagrant$ ./launcher start WARNING: We are about to start downloading t…

---

## [\[SOLVED\] NFS mount hangs - need Vagrant file for Fedora 23](https://meta.discourse.org/t/solved-nfs-mount-hangs-need-vagrant-file-for-fedora-23/41314)

<div class="topic-metadata">

**Author:** [@JimmyX](https://meta.discourse.org/u/JimmyX)\
**Replies:** 2\
**Last updated:** [March 20, 2016, 5:47am UTC](https://meta.discourse.org/t/solved-nfs-mount-hangs-need-vagrant-file-for-fedora-23/41314 "2016-03-20T05:47:03Z")

</div>

Vagrant downloads the virtual box file OK but “vagrant up” hangs on NFS mount. Through Virtual Box I can log into the discourse box (user/password vagrant/vagrant) and I can mount /vagrant from my laptop OK. That means N…

---

## [Why the forums takes full of total 20Gb of disk?](https://meta.discourse.org/t/why-the-forums-takes-full-of-total-20gb-of-disk/41294)

<div class="topic-metadata">

**Author:** [@M\_c\_Tau](https://meta.discourse.org/u/M_c_Tau)\
**Replies:** 6\
**Last updated:** [March 19, 2016, 9:21am UTC](https://meta.discourse.org/t/why-the-forums-takes-full-of-total-20gb-of-disk/41294 "2016-03-19T09:21:33Z")

</div>

Hello I am running just a very small with some threads. It suddenly stops working due to no free space on the Vultr VPS. I just wonder, why the disk is full. Probably someone uploaded some big files on purpose, where is…

---

## [Suggestion: look at openshift free tier](https://meta.discourse.org/t/suggestion-look-at-openshift-free-tier/41242)

<div class="topic-metadata">

**Author:** [@Fabio\_Machado\_de\_Oli](https://meta.discourse.org/u/Fabio_Machado_de_Oli)\
**Replies:** 0\
**Last updated:** [March 17, 2016, 11:59pm UTC](https://meta.discourse.org/t/suggestion-look-at-openshift-free-tier/41242 "2016-03-17T23:59:12Z")

</div>

I know it’s been mentioned before, but I think it was not discussed on enough detail. While openshift free tier doesn’t offer Docker, they give 3 “gears” in their free plan, and each one of them has 512MB of memory. It…

---

## [Alternatives to Mandrill](https://meta.discourse.org/t/alternatives-to-mandrill/41142)

<div class="topic-metadata">

**Author:** [@alwayslookright](https://meta.discourse.org/u/alwayslookright)\
**Replies:** 2\
**Last updated:** [March 16, 2016, 3:54pm UTC](https://meta.discourse.org/t/alternatives-to-mandrill/41142 "2016-03-16T15:54:46Z")

</div>

What are the alternatives to using Mandrill? I work on a lot of sites that are about gambling and for those that don’t know, mailchimp has a strict policy that is anti-gambling. After just mentioning the word gambling, …

---

## [Hosting migration from LAMP, SMF, Wordpress advice/recs](https://meta.discourse.org/t/hosting-migration-from-lamp-smf-wordpress-advice-recs/41029)

<div class="topic-metadata">

**Author:** [@tjb1013](https://meta.discourse.org/u/tjb1013)\
**Replies:** 0\
**Last updated:** [March 14, 2016, 5:32pm UTC](https://meta.discourse.org/t/hosting-migration-from-lamp-smf-wordpress-advice-recs/41029 "2016-03-14T17:32:35Z")

</div>

I’ve been running a sports website for years that for the past six or so has run Wordpress, SMF and a couple of simple database apps that list rosters and prospects - simple lookups with an admin interface. I’m the defi…

---

## [WordPress, Discourse and Local SMTP Server](https://meta.discourse.org/t/wordpress-discourse-and-local-smtp-server/40929)

<div class="topic-metadata">

**Author:** [@DelphiKnight](https://meta.discourse.org/u/DelphiKnight)\
**Replies:** 2\
**Last updated:** [March 14, 2016, 11:19am UTC](https://meta.discourse.org/t/wordpress-discourse-and-local-smtp-server/40929 "2016-03-14T11:19:18Z")

</div>

Hello, Is it possible to install WordPress, Discourse and local SMTP server together? I need to use in this way: WP site address: www.example.com Discourse: www.example.com/community SMTP server for Doscourse and WP…

---

## [Server in China can't reach rubygems.org so install fails](https://meta.discourse.org/t/server-in-china-cant-reach-rubygems-org-so-install-fails/39329)

<div class="topic-metadata">

**Author:** [@saluzi](https://meta.discourse.org/u/saluzi)\
**Replies:** 17\
**Last updated:** [February 10, 2016, 5:55pm UTC](https://meta.discourse.org/t/server-in-china-cant-reach-rubygems-org-so-install-fails/39329 "2016-02-10T17:55:19Z")

</div>

Install being given today FAILED -------------------- RuntimeError: cd /var/www/discourse && su discourse -c ‘bundle install --deployment --verbose --without test --without development’ failed with return #\<Process::S…

---

## [Start failed, address already in use](https://meta.discourse.org/t/start-failed-address-already-in-use/40741)

<div class="topic-metadata">

**Author:** [@armando](https://meta.discourse.org/u/armando)\
**Replies:** 5\
**Last updated:** [March 8, 2016, 1:19pm UTC](https://meta.discourse.org/t/start-failed-address-already-in-use/40741 "2016-03-08T13:19:29Z")

</div>

Hello, I can’t see my discourse page at the usual page (ceprovamos.tk), I can see only the default Apache2 Ubuntu Default Page. I had forgotten to pay the cloud service and they stopped my server. Then I payed and rest…

---

## [Traditional Permissions Setup vs Trust Levels?](https://meta.discourse.org/t/traditional-permissions-setup-vs-trust-levels/40739)

<div class="topic-metadata">

**Author:** [@BigSlacker](https://meta.discourse.org/u/BigSlacker)\
**Replies:** 4\
**Last updated:** [March 8, 2016, 12:40pm UTC](https://meta.discourse.org/t/traditional-permissions-setup-vs-trust-levels/40739 "2016-03-08T12:40:18Z")

</div>

Simply put I want to be able to manage the trust levels myself. Especially who can edit wiki articles. Is this even feasible in the “open” system? I need something like: new users - can post in application forum only …

---

## [Discourse and Vultr? Where to start on new instance for multi?](https://meta.discourse.org/t/discourse-and-vultr-where-to-start-on-new-instance-for-multi/23134)

<div class="topic-metadata">

**Author:** [@purldator](https://meta.discourse.org/u/purldator)\
**Replies:** 9\
**Last updated:** [March 4, 2016, 10:37pm UTC](https://meta.discourse.org/t/discourse-and-vultr-where-to-start-on-new-instance-for-multi/23134 "2016-03-04T22:37:36Z")

</div>

Hey there! I have been ‘shopping’ for different forum solutions that have nothing to do with PHP and really innovate the entire ‘thing’ of forums. I’ve checked out NodeBB but it is lacking in community-related aspects …

---

## [One-click install or Docker install?](https://meta.discourse.org/t/one-click-install-or-docker-install/40144)

<div class="topic-metadata">

**Author:** [@mansoorix](https://meta.discourse.org/u/mansoorix)\
**Replies:** 1\
**Last updated:** [February 25, 2016, 8:29am UTC](https://meta.discourse.org/t/one-click-install-or-docker-install/40144 "2016-02-25T08:29:35Z")

</div>

Hi Folks, I am going to install Discourse on Digital Ocean. Just figured out that they have a One-click install through their own panel. I also noticed this tutorial by Docker. Which one do you recommend? First one see…

---

## [Discourse installation on CentOS 6.5](https://meta.discourse.org/t/discourse-installation-on-centos-6-5/40149)

<div class="topic-metadata">

**Author:** [@Niki](https://meta.discourse.org/u/Niki)\
**Replies:** 2\
**Last updated:** [February 25, 2016, 11:59am UTC](https://meta.discourse.org/t/discourse-installation-on-centos-6-5/40149 "2016-02-25T11:59:12Z")

</div>

Dear Discourse community, I would like to install Discourse software on my dedicated server that uses CentOS 6.7, but I have received the following reply from my support team: \*\* In order to install discourse, it will …

---

## [Reset Discourse DB, possible?](https://meta.discourse.org/t/reset-discourse-db-possible/39995)

<div class="topic-metadata">

**Author:** [@patron](https://meta.discourse.org/u/patron)\
**Replies:** 2\
**Last updated:** [February 23, 2016, 12:24am UTC](https://meta.discourse.org/t/reset-discourse-db-possible/39995 "2016-02-23T00:24:22Z")

</div>

Hello, I installed Discourse into a DO droplet and started using it for a project. Now I realize I need to make a copy of it but without content. Is there anyway I can do this without starting from scratch? Thanks a lo…

---

## [Failed to connect to github.com port 443](https://meta.discourse.org/t/failed-to-connect-to-github-com-port-443/39967)

<div class="topic-metadata">

**Author:** [@JashtsSerie](https://meta.discourse.org/u/JashtsSerie)\
**Replies:** 4\
**Last updated:** [February 22, 2016, 5:14pm UTC](https://meta.discourse.org/t/failed-to-connect-to-github-com-port-443/39967 "2016-02-22T17:14:54Z")

</div>

Hello, I Want to install Discourse on my VPS OS : Ubuntu 14.04 LTS 64BIT Ram: 15 CPU: 8, I Have try 2-3 times but still the same problem! Docker version 1.10.1, build 9e83765 I’m not using any proxy! Can you he…

---

## [Using Discourse in traditional server](https://meta.discourse.org/t/using-discourse-in-traditional-server/39929)

<div class="topic-metadata">

**Author:** [@sivag](https://meta.discourse.org/u/sivag)\
**Replies:** 3\
**Last updated:** [February 21, 2016, 3:42pm UTC](https://meta.discourse.org/t/using-discourse-in-traditional-server/39929 "2016-02-21T15:42:32Z")

</div>

Hi, Currently i’m using vbulletin 4.2 in WiredTree VPS. Can I migrate to discourse ? Is it feasible or should I run it in DO ?

---

## [Are lowendbox servers any good?](https://meta.discourse.org/t/are-lowendbox-servers-any-good/14603)

<div class="topic-metadata">

**Author:** [@KrisAlcordo](https://meta.discourse.org/u/KrisAlcordo)\
**Replies:** 11\
**Last updated:** [February 20, 2016, 2:38pm UTC](https://meta.discourse.org/t/are-lowendbox-servers-any-good/14603 "2016-02-20T14:38:58Z")

</div>

Hi, is anyone here hosting a live discourse installation on a server from lowendbox.com? I am thinking of getting one from them but would like to know if anyone here has any experience/feedback with servers on that site…

---

## [Deploying discourse on server already running another rails app](https://meta.discourse.org/t/deploying-discourse-on-server-already-running-another-rails-app/38467)

<div class="topic-metadata">

**Author:** [@adass](https://meta.discourse.org/u/adass)\
**Replies:** 8\
**Last updated:** [February 17, 2016, 7:38pm UTC](https://meta.discourse.org/t/deploying-discourse-on-server-already-running-another-rails-app/38467 "2016-02-17T19:38:13Z")

</div>

Hi, I am trying to deploy a docker discourse on a linux server already running an apache + passenger + rails application. First I thought it would be easy – just setup docker to use another port (8080), but then I found…

---

## [DigitalOcean cloud installation - going inside the docker](https://meta.discourse.org/t/digitalocean-cloud-installation-going-inside-the-docker/39565)

<div class="topic-metadata">

**Author:** [@Steve\_Ng](https://meta.discourse.org/u/Steve_Ng)\
**Replies:** 4\
**Last updated:** [February 15, 2016, 7:19am UTC](https://meta.discourse.org/t/digitalocean-cloud-installation-going-inside-the-docker/39565 "2016-02-15T07:19:55Z")

</div>

Hi, I follow the installation instruction at discourse/docs/INSTALL-cloud.md at main · discourse/discourse · GitHub How do i go inside the code to perform things like bin/rake admin:create Is there anyway I can se…

---

## [SMTP usernames with backslash?](https://meta.discourse.org/t/smtp-usernames-with-backslash/38337)

<div class="topic-metadata">

**Author:** [@Knud](https://meta.discourse.org/u/Knud)\
**Replies:** 4\
**Last updated:** [February 10, 2016, 10:44pm UTC](https://meta.discourse.org/t/smtp-usernames-with-backslash/38337 "2016-02-10T22:44:10Z")

</div>

Dear all, I’m trying to set up Discourse on a virtual server. I can use the organisation’s SMTP-server for mail, so that is fine and I got everything set-up, except for one proplem: no emails are being sent. I then crea…

---

## [What are "page views" in Discourse.org hosting?](https://meta.discourse.org/t/what-are-page-views-in-discourse-org-hosting/39338)

<div class="topic-metadata">

**Author:** [@downey](https://meta.discourse.org/u/downey)\
**Replies:** 2\
**Last updated:** [February 10, 2016, 6:57pm UTC](https://meta.discourse.org/t/what-are-page-views-in-discourse-org-hosting/39338 "2016-02-10T18:57:39Z")

</div>

The hosting tiers each have a target number of pages views. If someone is already hosting their own instance and considering migrating, where would they look to find the current value of this number as interpreted by th…

---

## [Can I use cPanel to install Discourse forum software?](https://meta.discourse.org/t/can-i-use-cpanel-to-install-discourse-forum-software/39302)

<div class="topic-metadata">

**Author:** [@RIM](https://meta.discourse.org/u/RIM)\
**Replies:** 2\
**Last updated:** [February 9, 2016, 5:18pm UTC](https://meta.discourse.org/t/can-i-use-cpanel-to-install-discourse-forum-software/39302 "2016-02-09T17:18:42Z")

</div>

Question is above. If not that’s quite silly… cPanel is one of the most popular web hosts people use. If your looking to reach a bigger audience its essential.

---

## [Nobody warned about this gotcha. Now is there any way to recover app.yml? From built container?](https://meta.discourse.org/t/nobody-warned-about-this-gotcha-now-is-there-any-way-to-recover-app-yml-from-built-container/39289)

<div class="topic-metadata">

**Author:** [@Romanr](https://meta.discourse.org/u/Romanr)\
**Replies:** 1\
**Last updated:** [February 9, 2016, 4:03pm UTC](https://meta.discourse.org/t/nobody-warned-about-this-gotcha-now-is-there-any-way-to-recover-app-yml-from-built-container/39289 "2016-02-09T16:03:45Z")

</div>

Every time you change configuration and perform “launcher rebuild app” the docker creates the new image that takes 1.5 GB. I was editing configuration and tuning the installation, and during one of rebuilds it just hang…

[Previous page](https://meta.discourse.org/c/support/self-hosting/31.md?page=150)

[Next page](https://meta.discourse.org/c/support/self-hosting/31.md?page=152)
