# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=155

[最新版本](https://meta.discourse.org/latest.md) · [分類](https://meta.discourse.org/categories.md) · [標簽](https://meta.discourse.org/tags.md)

**Page:** 156

---

## [Migrate from Invision Power Board](https://meta.discourse.org/t/migrate-from-invision-power-board/30755)

<div class="topic-metadata">

**Author:** [@cacklewack](https://meta.discourse.org/u/cacklewack)\
**回覆:** 3\
**Last updated:** [2015年七月4日 22:13 UTC](https://meta.discourse.org/t/migrate-from-invision-power-board/30755 "2015-07-04T22:13:53Z")

</div>

Hello, I’m investigating migrating our Invision Power Board forum to Discourse, either hosted or one-time install. Is there a converter in place, or how would I go about this?

---

## [Installation on Ubuntu 14.04 LTS + Apache 2 + Plesk 12](https://meta.discourse.org/t/installation-on-ubuntu-14-04-lts-apache-2-plesk-12/30716)

<div class="topic-metadata">

**Author:** [@Maxunit](https://meta.discourse.org/u/Maxunit)\
**回覆:** 3\
**Last updated:** [2015年七月3日 15:27 UTC](https://meta.discourse.org/t/installation-on-ubuntu-14-04-lts-apache-2-plesk-12/30716 "2015-07-03T15:27:46Z")

</div>

Dear Discourse Community, I came across this fine looking Community Software while looking for a Forum…etc pp. Anyway :smile: I have a Root Server from the Server Provider called Hetzner. It runs Ubuntu 14.04 LTS and…

---

## [What is Communiteq.org? (.org not .com)](https://meta.discourse.org/t/what-is-communiteq-org-org-not-com/30554)

<div class="topic-metadata">

**Author:** [@KajMagnus](https://meta.discourse.org/u/KajMagnus)\
**回覆:** 5\
**Last updated:** [2015年六月28日 20:43 UTC](https://meta.discourse.org/t/what-is-communiteq-org-org-not-com/30554 "2015-06-28T20:43:38Z")

</div>

Edit: The owner of the .org site writes below that it was a demo project and he’s taking it offline. See https://meta.discourse.org/t/what-is-\[Communiteq\](https://www.communiteq.com) (formerly DiscourseHosting)-org-org-n…

---

## [You should post your affiliate URL for DigitalOcean](https://meta.discourse.org/t/you-should-post-your-affiliate-url-for-digitalocean/30430)

<div class="topic-metadata">

**Author:** [@tenzan](https://meta.discourse.org/u/tenzan)\
**回覆:** 5\
**Last updated:** [2015年六月25日 00:06 UTC](https://meta.discourse.org/t/you-should-post-your-affiliate-url-for-digitalocean/30430 "2015-06-25T00:06:51Z")

</div>

I believe some people start using DigitalOcean for the first time just because you mentioned it in your Discourse install guide. I think you should also post your affiliate URL for DigitalOcean so you’ll get a referral f…

---

## [How does Discourse host Discourse?](https://meta.discourse.org/t/how-does-discourse-host-discourse/30292)

<div class="topic-metadata">

**Author:** [@chuchuva](https://meta.discourse.org/u/chuchuva)\
**回覆:** 4\
**Last updated:** [2015年六月22日 20:47 UTC](https://meta.discourse.org/t/how-does-discourse-host-discourse/30292 "2015-06-22T20:47:12Z")

</div>

Discourse team, can you please share how you host Discourse installations for your clients? Do you provision a separate VM for each client? Do you use Docker at all? (If you don’t want to share your secret sauce that’…

---

## [Installing: Available on 127.0.0.1 (locally) but not on the public addressout](https://meta.discourse.org/t/installing-available-on-127-0-0-1-locally-but-not-on-the-public-addressout/30226)

<div class="topic-metadata">

**Author:** [@damio](https://meta.discourse.org/u/damio)\
**回覆:** 2\
**Last updated:** [2015年六月19日 19:58 UTC](https://meta.discourse.org/t/installing-available-on-127-0-0-1-locally-but-not-on-the-public-addressout/30226 "2015-06-19T19:58:55Z")

</div>

I followed this tutorial: https://www.digitalocean.com/community/tutorials/how-to-install-discourse-on-ubuntu-14-04 When I try to access the public address ( 178.62.20.234 ), I doesn’t respond (I have a timeout after a …

---

## [Server specs for multisite](https://meta.discourse.org/t/server-specs-for-multisite/29920)

<div class="topic-metadata">

**Author:** [@tenzan](https://meta.discourse.org/u/tenzan)\
**回覆:** 7\
**Last updated:** [2015年六月18日 12:29 UTC](https://meta.discourse.org/t/server-specs-for-multisite/29920 "2015-06-18T12:29:06Z")

</div>

Recommended environment: Dual core CPU recommended 1 GB RAM minimum (with swap) 64 bit Linux compatible with Docker The above is for 1 domain, I assume. What are the minimum specs requirements for multisite…

---

## [multisite.yml 看起来怎么样？](https://meta.discourse.org/t/how-does-multisite-yml-look/30110)

<div class="topic-metadata">

**Author:** [@tenzan](https://meta.discourse.org/u/tenzan)\
**回覆:** 1\
**Last updated:** [2015年六月17日 03:29 UTC](https://meta.discourse.org/t/how-does-multisite-yml-look/30110 "2015-06-17T03:29:20Z")

</div>

Where can I see a template? I wonder why this how-to didn’t mention about multisite.yml structure

---

## [Will I need to start over with multisite configuration from standalone version?](https://meta.discourse.org/t/will-i-need-to-start-over-with-multisite-configuration-from-standalone-version/30040)

<div class="topic-metadata">

**Author:** [@tenzan](https://meta.discourse.org/u/tenzan)\
**回覆:** 4\
**Last updated:** [2015年六月17日 03:25 UTC](https://meta.discourse.org/t/will-i-need-to-start-over-with-multisite-configuration-from-standalone-version/30040 "2015-06-17T03:25:59Z")

</div>

At the moment, I have installed my Discourse, for example, at example.com as standalone on DigitalOcean. Now I want to have 2 sites, with subdomains: lang1.example.com (current example.com) lang2.example.com Do I hav…

---

## [How do I use the Docker install from within a corporate proxy/firewall?](https://meta.discourse.org/t/how-do-i-use-the-docker-install-from-within-a-corporate-proxy-firewall/29780)

<div class="topic-metadata">

**Author:** [@andrenit](https://meta.discourse.org/u/andrenit)\
**回覆:** 1\
**Last updated:** [2015年六月8日 20:37 UTC](https://meta.discourse.org/t/how-do-i-use-the-docker-install-from-within-a-corporate-proxy-firewall/29780 "2015-06-08T20:37:10Z")

</div>

I understand the current Docker image has been conceived as a portable installation tool, so every setup is up-to-date, but this choice makes the image kinda useless for those who live behind corporate proxies/firewalls. …

---

## [I made some changes to settings and then my site wont be up](https://meta.discourse.org/t/i-made-some-changes-to-settings-and-then-my-site-wont-be-up/29730)

<div class="topic-metadata">

**Author:** [@Senthil](https://meta.discourse.org/u/Senthil)\
**回覆:** 3\
**Last updated:** [2015年六月7日 02:47 UTC](https://meta.discourse.org/t/i-made-some-changes-to-settings-and-then-my-site-wont-be-up/29730 "2015-06-07T02:47:04Z")

</div>

Started GET "/" for 8.25.197.27 at 2015-06-06 19:05:51 +0000 PG::ConnectionBad (FATAL: the database system is shutting down ): config/initializers/quiet\_logger.rb:10:in \`call\_with\_quiet\_assets' config/initializers/…

---

## [Discourse on cloud while wordpress on shared hosting?](https://meta.discourse.org/t/discourse-on-cloud-while-wordpress-on-shared-hosting/29347)

<div class="topic-metadata">

**Author:** [@substance\_D](https://meta.discourse.org/u/substance_D)\
**回覆:** 3\
**Last updated:** [2015年六月1日 12:45 UTC](https://meta.discourse.org/t/discourse-on-cloud-while-wordpress-on-shared-hosting/29347 "2015-06-01T12:45:13Z")

</div>

I have a wordpress Site with woocommerce hosted on simple cPanel Based host. I am looking to host discourse on Amazon. Is this possible; mysite.com points to wordpress and forums.mysite.com should point to discourse? I…

---

## [Restoring from backup failed with ERROR: must be superuser to create an operator family](https://meta.discourse.org/t/restoring-from-backup-failed-with-error-must-be-superuser-to-create-an-operator-family/29385)

<div class="topic-metadata">

**Author:** [@mugli](https://meta.discourse.org/u/mugli)\
**回覆:** 9\
**Last updated:** [2015年五月29日 20:02 UTC](https://meta.discourse.org/t/restoring-from-backup-failed-with-error-must-be-superuser-to-create-an-operator-family/29385 "2015-05-29T20:02:59Z")

</div>

I’m trying to restore a backup from non-docker discourse installation to a docker based one. The backup process completed properly. But I cannot restore it after several tries of backup and restoring. Here’s the restore…

---

## [How to configure ipv4 / ipv6 settings](https://meta.discourse.org/t/how-to-configure-ipv4-ipv6-settings/29263)

<div class="topic-metadata">

**Author:** [@fredrik](https://meta.discourse.org/u/fredrik)\
**回覆:** 6\
**Last updated:** [2015年五月28日 20:23 UTC](https://meta.discourse.org/t/how-to-configure-ipv4-ipv6-settings/29263 "2015-05-28T20:23:55Z")

</div>

Hi! My site suddenly “disappeared” after my web host updated and restarted my server. After some poking around, I did a ‘netstat’ and only ‘tcp6’ entries were listed for the ports that discourse were supposed to serve …

---

## [Blank page after install on CentOS 6.6](https://meta.discourse.org/t/blank-page-after-install-on-centos-6-6/29284)

<div class="topic-metadata">

**Author:** [@dleung](https://meta.discourse.org/u/dleung)\
**回覆:** 3\
**Last updated:** [2015年五月27日 00:09 UTC](https://meta.discourse.org/t/blank-page-after-install-on-centos-6-6/29284 "2015-05-27T00:09:03Z")

</div>

I’m trying to install Discourse on CentOS 6.6 running on my VM on my local box. I’ve followed instruction on http://www.howtoinstalldiscourse.com/how-to-install-discourse-on-centos/. I got it running, but all i got is a …

---

## [Typo in app.yml, possible to salvage my install](https://meta.discourse.org/t/typo-in-app-yml-possible-to-salvage-my-install/29058)

<div class="topic-metadata">

**Author:** [@ajoy39](https://meta.discourse.org/u/ajoy39)\
**回覆:** 2\
**Last updated:** [2015年五月21日 04:24 UTC](https://meta.discourse.org/t/typo-in-app-yml-possible-to-salvage-my-install/29058 "2015-05-21T04:24:47Z")

</div>

I made a typo in my DISCOURSE\_HOSTNAME, unfortunately I’m just now realizing this after about 2 hours of general configuration and design work. Didn’t show up until I started uploading images and they were all broken in …

---

## [Question about configuring email on shared hosting](https://meta.discourse.org/t/question-about-configuring-email-on-shared-hosting/28868)

<div class="topic-metadata">

**Author:** [@dbo](https://meta.discourse.org/u/dbo)\
**回覆:** 6\
**Last updated:** [2015年五月20日 18:33 UTC](https://meta.discourse.org/t/question-about-configuring-email-on-shared-hosting/28868 "2015-05-20T18:33:49Z")

</div>

I just setup Discourse using the guide on the GitHub repo for setting up on Digital Ocean, and it seems that everything is working well after having some trouble with the email config and not knowing that I had to rebuil…

---

## [Need proper documentation for multisite discourse with docker](https://meta.discourse.org/t/need-proper-documentation-for-multisite-discourse-with-docker/28297)

<div class="topic-metadata">

**Author:** [@Pon\_Athithan](https://meta.discourse.org/u/Pon_Athithan)\
**回覆:** 9\
**Last updated:** [2015年五月20日 07:39 UTC](https://meta.discourse.org/t/need-proper-documentation-for-multisite-discourse-with-docker/28297 "2015-05-20T07:39:45Z")

</div>

Hi, I am searching a proper documentation to create multi site in single server but still I couldn’t find well defined documentation for intermediate level developer. I have tried some multisite discourse with d…

---

## [Bootstrap Failed, out of memory error](https://meta.discourse.org/t/bootstrap-failed-out-of-memory-error/28800)

<div class="topic-metadata">

**Author:** [@littleviolette](https://meta.discourse.org/u/littleviolette)\
**回覆:** 16\
**Last updated:** [2015年五月14日 19:50 UTC](https://meta.discourse.org/t/bootstrap-failed-out-of-memory-error/28800 "2015-05-14T19:50:25Z")

</div>

I tried searching through the forum for troubleshooting but couldn’t find a similar error code that other people have encountered. Would someone shed light on what I have done wrong? FAILED -------------------- Runtime…

---

## [Downloading uploaded zip files: net::ERR\_INVALID\_RESPONSE](https://meta.discourse.org/t/downloading-uploaded-zip-files-net-err-invalid-response/28758)

<div class="topic-metadata">

**Author:** [@masda70](https://meta.discourse.org/u/masda70)\
**回覆:** 2\
**Last updated:** [2015年五月14日 08:21 UTC](https://meta.discourse.org/t/downloading-uploaded-zip-files-net-err-invalid-response/28758 "2015-05-14T08:21:36Z")

</div>

Setup: Unicorn behind Nginx installation with SSL. Latest Discourse (master). .zip uploads are allowed. Operation: download an uploaded .zip file. Attempting GET request from authenticated user in Chrome at https://exa…

---

## [Redundant Discourse Hosting on AWS](https://meta.discourse.org/t/redundant-discourse-hosting-on-aws/28358)

<div class="topic-metadata">

**Author:** [@bboyle1234](https://meta.discourse.org/u/bboyle1234)\
**回覆:** 14\
**Last updated:** [2015年五月13日 11:56 UTC](https://meta.discourse.org/t/redundant-discourse-hosting-on-aws/28358 "2015-05-13T11:56:59Z")

</div>

I initially intended to host my forum in a way that is protected against server hardware failure by having it hosted in AWS in the following way: RDS for PostGres, Elasticache for Redis, S3 for user uploads 2 docker …

---

## [Migration failure PG::UndefinedObject: ERROR: type "json" does not exist](https://meta.discourse.org/t/migration-failure-pg-error-type-json-does-not-exist/28751)

<div class="topic-metadata">

**Author:** [@mugli](https://meta.discourse.org/u/mugli)\
**回覆:** 5\
**Last updated:** [2015年五月13日 09:37 UTC](https://meta.discourse.org/t/migration-failure-pg-error-type-json-does-not-exist/28751 "2015-05-13T09:37:09Z")

</div>

Hi, I’m still on a non-docker discourse. I was trying to upgrade to v1.3.0.beta9 from v1.3.0.beta3 (following this guide: https://github.com/discourse/discourse/blob/master/docs/INSTALL-ubuntu.md) and facing this error …

---

## [Don't claim support for Ruby 2.0](https://meta.discourse.org/t/dont-claim-support-for-ruby-2-0/28595)

<div class="topic-metadata">

**Author:** [@palant](https://meta.discourse.org/u/palant)\
**回覆:** 5\
**Last updated:** [2015年五月11日 11:21 UTC](https://meta.discourse.org/t/dont-claim-support-for-ruby-2-0/28595 "2015-05-11T11:21:26Z")

</div>

Install document currently says: Ruby 2.0+ (we recommend 2.0.0-p353 or higher) Actually, Ruby 2.0.0 won’t work. When I tried I got an error from the Sidekiq gem: uninitialized constant Sidekiq::Sinatra This was c…

---

## [Average 'payload' size per pageview (to calculate bandwidth needs)](https://meta.discourse.org/t/average-payload-size-per-pageview-to-calculate-bandwidth-needs/28600)

<div class="topic-metadata">

**Author:** [@purldator](https://meta.discourse.org/u/purldator)\
**回覆:** 3\
**Last updated:** [2015年五月11日 01:26 UTC](https://meta.discourse.org/t/average-payload-size-per-pageview-to-calculate-bandwidth-needs/28600 "2015-05-11T01:26:09Z")

</div>

I, in my constant yak shaving, have mentally conjured a hypothetical formula to ballpark a possible bandwidth figure. This is so I can anticipate bandwidth costs. For me, it’s better to get some idea of what I may be u…

---

## [Which IP should I point in \`containers/app.yml\` for installing on a local host?](https://meta.discourse.org/t/which-ip-should-i-point-in-containers-app-yml-for-installing-on-a-local-host/28534)

<div class="topic-metadata">

**Author:** [@diff](https://meta.discourse.org/u/diff)\
**回覆:** 6\
**Last updated:** [2015年五月9日 22:19 UTC](https://meta.discourse.org/t/which-ip-should-i-point-in-containers-app-yml-for-installing-on-a-local-host/28534 "2015-05-09T22:19:44Z")

</div>

I’m going to install Discourse on my machine to test and customize it. I want it to be installed on my machine and run from it. I don’t need it be on the internet somewhere. Now, I’m confused in this step: When it…

---

## [Bulk file uploads (for migration)](https://meta.discourse.org/t/bulk-file-uploads-for-migration/28402)

<div class="topic-metadata">

**Author:** [@4ZM](https://meta.discourse.org/u/4ZM)\
**回覆:** 2\
**Last updated:** [2015年五月8日 06:17 UTC](https://meta.discourse.org/t/bulk-file-uploads-for-migration/28402 "2015-05-08T06:17:12Z")

</div>

We almost managed to migrate from Vanilla to discourse. Unfortunately the migration script didn’t handle attachments. Manually uploading all files and creating a “here is a list of all old attachments”-post with links t…

---

## [Cheapest Hosting Option?](https://meta.discourse.org/t/cheapest-hosting-option/28484)

<div class="topic-metadata">

**Author:** [@nahtnam](https://meta.discourse.org/u/nahtnam)\
**回覆:** 3\
**Last updated:** [2015年五月8日 07:49 UTC](https://meta.discourse.org/t/cheapest-hosting-option/28484 "2015-05-08T07:49:58Z")

</div>

Hey! I was wondering what the cheapest option is to host Discourse. I have seen a lot of sites that say 6gb of ram for $5-10 per month (http://vpsdime.com/) but they never end up having the correct version of kernel. T…

---

## [Setting up sub-domain in cPanel](https://meta.discourse.org/t/setting-up-sub-domain-in-cpanel/28354)

<div class="topic-metadata">

**Author:** [@Erik\_Manger](https://meta.discourse.org/u/Erik_Manger)\
**回覆:** 3\
**Last updated:** [2015年五月5日 20:11 UTC](https://meta.discourse.org/t/setting-up-sub-domain-in-cpanel/28354 "2015-05-05T20:11:32Z")

</div>

Hi, I have a dedicated server from Namecheap and am trying to pair the forum.domain.com within cPanel. How would I do this through DNS editor? I have a Digital Hosting plan hosting the forum itself.

---

## [Error in installing](https://meta.discourse.org/t/error-in-installing/28299)

<div class="topic-metadata">

**Author:** [@Erik\_Manger](https://meta.discourse.org/u/Erik_Manger)\
**回覆:** 2\
**Last updated:** [2015年五月4日 21:55 UTC](https://meta.discourse.org/t/error-in-installing/28299 "2015-05-04T21:55:45Z")

</div>

Hi, Error response from daemon: Cannot start container app: Error starting userland proxy: listen tcp 0.0.0.0:80: bind: address already in use What does this mean? I got it after trying to run the application.

---

## [SQL Error during import](https://meta.discourse.org/t/sql-error-during-import/27793)

<div class="topic-metadata">

**Author:** [@cocojoe](https://meta.discourse.org/u/cocojoe)\
**回覆:** 18\
**Last updated:** [2015年五月3日 16:53 UTC](https://meta.discourse.org/t/sql-error-during-import/27793 "2015-05-03T16:53:06Z")

</div>

Trying to import a discourse backup ~ 3GB from version v1.3.0.beta5 +97 to latest-release +87. During the import the following sql issue \[2015-04-21 08:34:05\] psql:/var/www/discourse/tmp/restores/default/2015-04-21-083…

[上一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=154)

[下一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=156)
