# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=18

[Latest](https://meta.discourse.org/latest.md) · [Categories](https://meta.discourse.org/categories.md) · [Tags](https://meta.discourse.org/tags.md)

**Page:** 19

---

## [I can't start Discourse](https://meta.discourse.org/t/i-cant-start-discourse/327505)

<div class="topic-metadata">

**Author:** [@NogayHan](https://meta.discourse.org/u/NogayHan)\
**Replies:** 11\
**Last updated:** [September 23, 2024, 5:47pm UTC](https://meta.discourse.org/t/i-cant-start-discourse/327505 "2024-09-23T17:47:13Z")

</div>

Hello, I am using Ubuntu. After the classic server update I had to restart the server. After restarting, Discourse started giving error 502 then 503. My resources are sufficient, if they were not sufficient, it would n…

---

## [Why won't my remote backups restore?](https://meta.discourse.org/t/why-wont-my-remote-backups-restore/327660)

<div class="topic-metadata">

**Author:** [@Brandon007](https://meta.discourse.org/u/Brandon007)\
**Replies:** 4\
**Last updated:** [September 23, 2024, 12:19pm UTC](https://meta.discourse.org/t/why-wont-my-remote-backups-restore/327660 "2024-09-23T12:19:14Z")

</div>

I migrated servers last night and just could not get the remote backup to restore. Instead, I was presented with this error in the backup log. Remote Backups EXCEPTION: Failed to download archive to tmp directory. I…

---

## [Tips for setting up a multi-subdomain Discourse instance with shared SSO?](https://meta.discourse.org/t/tips-for-setting-up-a-multi-subdomain-discourse-instance-with-shared-sso/326971)

<div class="topic-metadata">

**Author:** [@featherless](https://meta.discourse.org/u/featherless)\
**Replies:** 1\
**Last updated:** [September 18, 2024, 4:11pm UTC](https://meta.discourse.org/t/tips-for-setting-up-a-multi-subdomain-discourse-instance-with-shared-sso/326971 "2024-09-18T16:11:17Z")

</div>

Hello everyone! I’ve read through a bunch of threads here on multi-site Discourses, but noticed that most of them are from 3+ years ago so I wanted to check in on whether there might be any recent advice, changes, tips, …

---

## [HTTPS works perfectly, but HTTP URL displays NGINX welcome page and doesn't redirect](https://meta.discourse.org/t/https-works-perfectly-but-http-url-displays-nginx-welcome-page-and-doesnt-redirect/177195)

<div class="topic-metadata">

**Author:** [@ajmuir](https://meta.discourse.org/u/ajmuir)\
**Replies:** 12\
**Last updated:** [September 18, 2024, 3:40am UTC](https://meta.discourse.org/t/https-works-perfectly-but-http-url-displays-nginx-welcome-page-and-doesnt-redirect/177195 "2024-09-18T03:40:36Z")

</div>

I’ve recently installed Discourse to a Ubuntu Focal Fossa VPS and it works great, however I’m struggling to overcome some URL peculiarities. The following is the behaviour I am seeing (in Safari). I have A NAME records …

---

## [Is Scaleway a good option for object storage?](https://meta.discourse.org/t/is-scaleway-a-good-option-for-object-storage/237046)

<div class="topic-metadata">

**Author:** [@Fabrice](https://meta.discourse.org/u/Fabrice)\
**Replies:** 8\
**Last updated:** [September 16, 2024, 12:02pm UTC](https://meta.discourse.org/t/is-scaleway-a-good-option-for-object-storage/237046 "2024-09-16T12:02:43Z")

</div>

Hello everyone, I’ve been looking at moving my Discourse install to a VPS, I’ve found one at a nice price, but it doesn’t have all the storage I’d like, so I’ve been looking at a few object storage options, and a fairly …

---

## [Forwarding from https:// to https://www](https://meta.discourse.org/t/forwarding-from-https-to-https-www/326416)

<div class="topic-metadata">

**Author:** [@Taxick](https://meta.discourse.org/u/Taxick)\
**Replies:** 15\
**Last updated:** [September 14, 2024, 11:00am UTC](https://meta.discourse.org/t/forwarding-from-https-to-https-www/326416 "2024-09-14T11:00:03Z")

</div>

Hi. I’m new to discourse! I’m hosting discourse on my Ubuntu 24.04 server :slight\_smile: But I need help with domain forwarding.. If I go to this site: https:// mysite - It doesn’t work.. If I go to this site: https:…

---

## [Installation time and effort](https://meta.discourse.org/t/installation-time-and-effort/325653)

<div class="topic-metadata">

**Author:** [@Claire\_C](https://meta.discourse.org/u/Claire_C)\
**Replies:** 2\
**Last updated:** [September 12, 2024, 3:51pm UTC](https://meta.discourse.org/t/installation-time-and-effort/325653 "2024-09-12T15:51:32Z")

</div>

Hi all, We’re looking at moving from an established Salesforce forum to Discourse, by the looks of things we will have to migrate and integrate ourselves. Has anyone else done this? How much time/effort did it take? I’m…

---

## [Error 500 after Update](https://meta.discourse.org/t/error-500-after-update/326196)

<div class="topic-metadata">

**Author:** [@D.VE](https://meta.discourse.org/u/D.VE)\
**Replies:** 2\
**Last updated:** [September 12, 2024, 2:24pm UTC](https://meta.discourse.org/t/error-500-after-update/326196 "2024-09-12T14:24:59Z")

</div>

I was on 3.2.xx and was trying to update via Admin Panel. But it somehow it failed. Nothing works and now I only get a 500 Error. I’m running Discourse on a plesk server. How can I access the logs via console? Any ide…

---

## [Discourse /tmp/avatar\_proxy folder](https://meta.discourse.org/t/discourse-tmp-avatar-proxy-folder/325846)

<div class="topic-metadata">

**Author:** [@LeBlanc](https://meta.discourse.org/u/LeBlanc)\
**Replies:** 0\
**Last updated:** [September 10, 2024, 1:29pm UTC](https://meta.discourse.org/t/discourse-tmp-avatar-proxy-folder/325846 "2024-09-10T13:29:56Z")

</div>

I found that each time discourse was rebuilt, the user’s default avatar was re-requested after startup. After doing some learning about it, I discovered that there is a default avatar whose data is stored in a temporary …

---

## [No web\_only.yml](https://meta.discourse.org/t/no-web-only-yml/325750)

<div class="topic-metadata">

**Author:** [@WesPenre](https://meta.discourse.org/u/WesPenre)\
**Replies:** 3\
**Last updated:** [September 10, 2024, 3:46am UTC](https://meta.discourse.org/t/no-web-only-yml/325750 "2024-09-10T03:46:26Z")

</div>

Our Discourse crashed when we updated the Ubuntu server on Digital Ocean and rebooted it. So, Discourse had to be set up from scratch. That was successful, but it went down again this morning when I tried to learn to ins…

---

## [Migration failed: relation "user\_required\_fields\_versions" already exists](https://meta.discourse.org/t/migration-failed-relation-user-required-fields-versions-already-exists/325378)

<div class="topic-metadata">

**Author:** [@Clo](https://meta.discourse.org/u/Clo)\
**Replies:** 18\
**Last updated:** [September 9, 2024, 6:47pm UTC](https://meta.discourse.org/t/migration-failed-relation-user-required-fields-versions-already-exists/325378 "2024-09-09T18:47:55Z")

</div>

Hi, please can someone assist? I updated my website from admin dashboard then it gave an error 500. I then manually updated and rebuilt the app from console as suggested by this topic: Manually update Discourse and Doc…

---

## [Launcher pulls an update on ‘enter app’](https://meta.discourse.org/t/launcher-pulls-an-update-on-enter-app/313051)

<div class="topic-metadata">

**Author:** [@Isambard](https://meta.discourse.org/u/Isambard)\
**Replies:** 2\
**Last updated:** [September 8, 2024, 6:13pm UTC](https://meta.discourse.org/t/launcher-pulls-an-update-on-enter-app/313051 "2024-09-08T18:13:10Z")

</div>

I’m seeing strange behaviour which I’m assuming is a bug: On ARM systems, when you do ./launcher enter app it does a pull\_image. I’m guessing it is due to this: # 4. discourse docker image is downloaded 3 test=\`$do…

---

## [YML Validation prior to rebuild?](https://meta.discourse.org/t/yml-validation-prior-to-rebuild/325226)

<div class="topic-metadata">

**Author:** [@TonyG](https://meta.discourse.org/u/TonyG)\
**Replies:** 3\
**Last updated:** [September 7, 2024, 6:28am UTC](https://meta.discourse.org/t/yml-validation-prior-to-rebuild/325226 "2024-09-07T06:28:47Z")

</div>

This is on a self-hosted Discourse installation in a private VPS with a typical Docker installation. I did it again: I waited through a two hour “flawless” update rebuild to v3.4.0.beta2-dev. Then added a couple lines…

---

## [Adding idrive as S3 service](https://meta.discourse.org/t/adding-idrive-as-s3-service/322230)

<div class="topic-metadata">

**Author:** [@Bathinda](https://meta.discourse.org/u/Bathinda)\
**Replies:** 7\
**Last updated:** [September 7, 2024, 6:06am UTC](https://meta.discourse.org/t/adding-idrive-as-s3-service/322230 "2024-09-07T06:06:18Z")

</div>

Do you mean I just need to fill the values demanded by Aws\_S3 fields in Disco Admin Settings with the values provided by iDrive S3? (because there are no other fields in the disco admin settings for any other S3 service…

---

## [502 Bad Gateway Error for around 4 hours now](https://meta.discourse.org/t/502-bad-gateway-error-for-around-4-hours-now/325277)

<div class="topic-metadata">

**Author:** [@cl0ver\_chomik](https://meta.discourse.org/u/cl0ver_chomik)\
**Replies:** 1\
**Last updated:** [September 6, 2024, 8:48am UTC](https://meta.discourse.org/t/502-bad-gateway-error-for-around-4-hours-now/325277 "2024-09-06T08:48:00Z")

</div>

Hello! :wave: So, the forum I visit (https://forum.creative.gimkit.com) has had a 502 bad gateway error for around 4 hours now. Any ways to fix it? It’s a forum with ~6000 users.

---

## [Rescaling the server, which configs need to be changed? - unicorn workers, memory, etc](https://meta.discourse.org/t/rescaling-the-server-which-configs-need-to-be-changed-unicorn-workers-memory-etc/252788)

<div class="topic-metadata">

**Author:** [@Alon1](https://meta.discourse.org/u/Alon1)\
**Replies:** 5\
**Last updated:** [September 4, 2024, 12:32pm UTC](https://meta.discourse.org/t/rescaling-the-server-which-configs-need-to-be-changed-unicorn-workers-memory-etc/252788 "2024-09-04T12:32:52Z")

</div>

TLDR: Is there a guide or a list of recommended configurations to consider when rescaling a server? When installing Discourse for the first time on a server, there are some settings that are auto-set. One convenience t…

---

## [After configuring Brevo's SMTP, I cannot receive emails](https://meta.discourse.org/t/after-configuring-brevos-smtp-i-cannot-receive-emails/324842)

<div class="topic-metadata">

**Author:** [@nwnuyhs](https://meta.discourse.org/u/nwnuyhs)\
**Replies:** 2\
**Last updated:** [September 4, 2024, 9:56am UTC](https://meta.discourse.org/t/after-configuring-brevos-smtp-i-cannot-receive-emails/324842 "2024-09-04T09:56:36Z")

</div>

Here is the smtp infor，can anyone tell what’s wrong of the cofing? ## TODO: List of comma delimited emails that will be made admin and developer ## on initial signup example 'user1@example.com,user2@example.com' DIS…

---

## [PostgreSQL Stuck During Rebuilding](https://meta.discourse.org/t/postgresql-stuck-during-rebuilding/323434)

<div class="topic-metadata">

**Author:** [@haroldfy](https://meta.discourse.org/u/haroldfy)\
**Replies:** 51\
**Last updated:** [September 4, 2024, 8:48am UTC](https://meta.discourse.org/t/postgresql-stuck-during-rebuilding/323434 "2024-09-04T08:48:16Z")

</div>

Hello everyone, I’m running into an issue with PostgreSQL startup issue when I tried to rebuild my app, and I’m hoping to get some help. Here’s the log, it has been stuck on this status for more than 30 mins. Status: …

---

## [Stuck on update](https://meta.discourse.org/t/stuck-on-update/324342)

<div class="topic-metadata">

**Author:** [@Wildweasel](https://meta.discourse.org/u/Wildweasel)\
**Replies:** 2\
**Last updated:** [September 4, 2024, 2:52am UTC](https://meta.discourse.org/t/stuck-on-update/324342 "2024-09-04T02:52:47Z")

</div>

Hello, I didn’t find the information so I open that topic. I’m currently stuck on update after launching . ./launcher rebuild app The process stopped at “database system is ready to accept connections” without exiti…

---

## [Forum Full Crash (Test Pressing)](https://meta.discourse.org/t/forum-full-crash-test-pressing/323663)

<div class="topic-metadata">

**Author:** [@Apiento](https://meta.discourse.org/u/Apiento)\
**Replies:** 8\
**Last updated:** [September 4, 2024, 2:52am UTC](https://meta.discourse.org/t/forum-full-crash-test-pressing/323663 "2024-09-04T02:52:37Z")

</div>

My forum crashed when I was updating the software and has now totally disapeared. I get the following error messages… " Oops The software powering this discussion forum encountered an unexpected problem. We apologize f…

---

## [Change SMTP settings in a working forum](https://meta.discourse.org/t/change-smtp-settings-in-a-working-forum/131817)

<div class="topic-metadata">

**Author:** [@Yankxcool](https://meta.discourse.org/u/Yankxcool)\
**Replies:** 9\
**Last updated:** [September 3, 2024, 9:27pm UTC](https://meta.discourse.org/t/change-smtp-settings-in-a-working-forum/131817 "2024-09-03T21:27:59Z")

</div>

Hello, just a quick question. It’s possible to edit SMTP email options on a working forum? Rebuild command will wipe all forum content (threads, posts, users, design)? in the case that I edit app.yml Thanks.

---

## [Directory /var/discourse space is 70G?](https://meta.discourse.org/t/directory-var-discourse-space-is-70g/324737)

<div class="topic-metadata">

**Author:** [@nwnuyhs](https://meta.discourse.org/u/nwnuyhs)\
**Replies:** 3\
**Last updated:** [September 3, 2024, 6:32pm UTC](https://meta.discourse.org/t/directory-var-discourse-space-is-70g/324737 "2024-09-03T18:32:23Z")

</div>

My website is a new website ,and users less than 200, and the VPS ROM is 90G,but today ,my websiete502 Bad Gateway nginx afternoon I received an email： The download\_remote\_images\_to\_local setting is disabled because t…

---

## [Error while updating discourse installation](https://meta.discourse.org/t/error-while-updating-discourse-installation/278862)

<div class="topic-metadata">

**Author:** [@Habib](https://meta.discourse.org/u/Habib)\
**Replies:** 9\
**Last updated:** [September 13, 2023, 2:04pm UTC](https://meta.discourse.org/t/error-while-updating-discourse-installation/278862 "2023-09-13T14:04:34Z")

</div>

Hello there, this Habib, I have been trying to update my discourse installation through the link provided in the dashboard, but unfortunately, an error and now I cant go back to site as it says that Oops The software p…

---

## [WARNING: Port 443 of computer does not appear to be accessible using hostname: \<mydomain\>.com](https://meta.discourse.org/t/warning-port-443-of-computer-does-not-appear-to-be-accessible-using-hostname-mydomain-com/272567)

<div class="topic-metadata">

**Author:** [@shibi](https://meta.discourse.org/u/shibi)\
**Replies:** 11\
**Last updated:** [September 3, 2024, 7:23am UTC](https://meta.discourse.org/t/warning-port-443-of-computer-does-not-appear-to-be-accessible-using-hostname-mydomain-com/272567 "2024-09-03T07:23:15Z")

</div>

app was not started ! ./discourse-doctor may help diagnose the problem. ./discourse-setup: line 260: \*0: syntax error: operand expected (error token is “\*0”) Hostname for your Discourse? \[discourse.example.com\]: .com …

---

## ['Restore' Failing: Can ignore discrepancies](https://meta.discourse.org/t/restore-failing-can-ignore-discrepancies/322057)

<div class="topic-metadata">

**Author:** [@Bathinda](https://meta.discourse.org/u/Bathinda)\
**Replies:** 12\
**Last updated:** [September 2, 2024, 10:40am UTC](https://meta.discourse.org/t/restore-failing-can-ignore-discrepancies/322057 "2024-09-02T10:40:26Z")

</div>

This topic later evolved into ‘Restore Failing’ from 4th post onwards, which is main issue now. You can ignore 1st 4 posts. I’ve set my upoads to Aws S3 years ago/in the beginning only. Even when I (as far as I can say)…

---

## [Connection error to external Redis](https://meta.discourse.org/t/connection-error-to-external-redis/318330)

<div class="topic-metadata">

**Author:** [@Joan\_Tomàs\_i\_Buliart](https://meta.discourse.org/u/Joan_Tom%C3%A0s_i_Buliart)\
**Replies:** 1\
**Last updated:** [September 2, 2024, 7:51am UTC](https://meta.discourse.org/t/connection-error-to-external-redis/318330 "2024-09-02T07:51:51Z")

</div>

Hello Community, We have a Discourse setup in Kubernetes. We are running a deployment with the Discourse container image, using external Redis and external PostgreSQL. To manage Redis HA, we deployed 3 nodes within a S…

---

## [Postgresql locks with high concurrency API key usage](https://meta.discourse.org/t/postgresql-locks-with-high-concurrency-api-key-usage/318383)

<div class="topic-metadata">

**Author:** [@Joan\_Tomàs\_i\_Buliart](https://meta.discourse.org/u/Joan_Tom%C3%A0s_i_Buliart)\
**Replies:** 1\
**Last updated:** [September 2, 2024, 7:50am UTC](https://meta.discourse.org/t/postgresql-locks-with-high-concurrency-api-key-usage/318383 "2024-09-02T07:50:07Z")

</div>

Hello Community, We are using the Discourse API on a self-hosted installation. Our use case is quite intensive in terms of concurrency, with around 100 API requests per second on average. We are also using PostgreSQL+Pa…

---

## [Not getting an Activation Email](https://meta.discourse.org/t/not-getting-an-activation-email/324050)

<div class="topic-metadata">

**Author:** [@yang1981](https://meta.discourse.org/u/yang1981)\
**Replies:** 6\
**Last updated:** [August 31, 2024, 8:42pm UTC](https://meta.discourse.org/t/not-getting-an-activation-email/324050 "2024-08-31T20:42:17Z")

</div>

I followed the standard installation progress, but still can not get an activation mail I’m very sure my email configuration in app.yml is correct, I wrote a test program in the same docker, with the same config files,…

---

## [Can I run Discourse in "rootless" Docker on VPS?](https://meta.discourse.org/t/can-i-run-discourse-in-rootless-docker-on-vps/265335)

<div class="topic-metadata">

**Author:** [@JBull](https://meta.discourse.org/u/JBull)\
**Replies:** 3\
**Last updated:** [August 30, 2024, 10:03pm UTC](https://meta.discourse.org/t/can-i-run-discourse-in-rootless-docker-on-vps/265335 "2024-08-30T22:03:13Z")

</div>

A post by Jay Pfaffman says You need root privileges and to be able to install docker. I have an Ubuntu VPS hosted by Pair.com, which offers a Docker installation, so I don’t need root privileges to install Docker. H…

---

## [Issue with new update: debugging options](https://meta.discourse.org/t/issue-with-new-update-debugging-options/323972)

<div class="topic-metadata">

**Author:** [@Isambard](https://meta.discourse.org/u/Isambard)\
**Replies:** 16\
**Last updated:** [August 30, 2024, 6:56pm UTC](https://meta.discourse.org/t/issue-with-new-update-debugging-options/323972 "2024-08-30T18:56:20Z")

</div>

I noticed some issues with the recent update. I just updated from 3.4.0 beta1 to the latest (3.4.0.beta2-dev) and the site seems to work and then after a while (within 2 hours) the site stops responding (I get a host err…

[Previous page](https://meta.discourse.org/c/support/self-hosting/31.md?page=17)

[Next page](https://meta.discourse.org/c/support/self-hosting/31.md?page=19)
