# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=19

[Latest](https://meta.discourse.org/latest.md) · [Categories](https://meta.discourse.org/categories.md) · [Tags](https://meta.discourse.org/tags.md)

**Page:** 20

---

## [Can I run Discourse in "rootless" Docker on VPS?](https://meta.discourse.org/t/can-i-run-discourse-in-rootless-docker-on-vps/265335)

<div class="topic-metadata">

**Author:** [@JBull](https://meta.discourse.org/u/JBull)\
**Replies:** 3\
**Last updated:** [August 30, 2024, 10:03pm UTC](https://meta.discourse.org/t/can-i-run-discourse-in-rootless-docker-on-vps/265335 "2024-08-30T22:03:13Z")

</div>

A post by Jay Pfaffman says You need root privileges and to be able to install docker. I have an Ubuntu VPS hosted by Pair.com, which offers a Docker installation, so I don’t need root privileges to install Docker. H…

---

## [Issue with new update: debugging options](https://meta.discourse.org/t/issue-with-new-update-debugging-options/323972)

<div class="topic-metadata">

**Author:** [@Isambard](https://meta.discourse.org/u/Isambard)\
**Replies:** 16\
**Last updated:** [August 30, 2024, 6:56pm UTC](https://meta.discourse.org/t/issue-with-new-update-debugging-options/323972 "2024-08-30T18:56:20Z")

</div>

I noticed some issues with the recent update. I just updated from 3.4.0 beta1 to the latest (3.4.0.beta2-dev) and the site seems to work and then after a while (within 2 hours) the site stops responding (I get a host err…

---

## [Update fails with error postgres already running stop container](https://meta.discourse.org/t/update-fails-with-error-postgres-already-running-stop-container/324149)

<div class="topic-metadata">

**Author:** [@sallypf](https://meta.discourse.org/u/sallypf)\
**Replies:** 2\
**Last updated:** [August 30, 2024, 12:14pm UTC](https://meta.discourse.org/t/update-fails-with-error-postgres-already-running-stop-container/324149 "2024-08-30T12:14:36Z")

</div>

I tried to update discourse from web admin first, which failed then I’m trying to do it from the command line and it is getting stuck at postgres already running… I’ve digital ocean droplet with ubuntu. I’ve read other…

---

## [Laucher rebuild app fails](https://meta.discourse.org/t/laucher-rebuild-app-fails/324107)

<div class="topic-metadata">

**Author:** [@flob](https://meta.discourse.org/u/flob)\
**Replies:** 2\
**Last updated:** [August 30, 2024, 7:55am UTC](https://meta.discourse.org/t/laucher-rebuild-app-fails/324107 "2024-08-30T07:55:56Z")

</div>

Hello, I spent some time searching for a solution to my problem, so I decided to post a request for help here. Any help would be greatly appreciated. thank you. My Discourse update failed when trying to rebuild using t…

---

## [Update Error](https://meta.discourse.org/t/update-error/323924)

<div class="topic-metadata">

**Author:** [@fidelio](https://meta.discourse.org/u/fidelio)\
**Replies:** 6\
**Last updated:** [August 30, 2024, 12:16pm UTC](https://meta.discourse.org/t/update-error/323924 "2024-08-30T12:16:52Z")

</div>

I tried to update to 3.4.0 last night and the update keeps failing. Can’t find an obvious plug-in error and there appears to be enough memory also… ==================== SERIOUS PROBLEM!!!! ==================== app no…

---

## [Discourse notification e-mail sending with Brevo(Sendinblue)](https://meta.discourse.org/t/discourse-notification-e-mail-sending-with-brevo-sendinblue/308342)

<div class="topic-metadata">

**Author:** [@Architect](https://meta.discourse.org/u/Architect)\
**Replies:** 5\
**Last updated:** [August 29, 2024, 6:20pm UTC](https://meta.discourse.org/t/discourse-notification-e-mail-sending-with-brevo-sendinblue/308342 "2024-08-29T18:20:07Z")

</div>

Good day, fellow discoursians!! Have setup discourse site to send e-mail with brevo which is working perfectly, except that e-mails are being flagged with this alert: ("We could not prove that the content or sender …

---

## [An error occurred while restoring from a backup: discourse\_functions.raise\_discourse\_voting\_category\_settings\_readonly() does not exist](https://meta.discourse.org/t/an-error-occurred-while-restoring-from-a-backup-discourse-functions-raise-discourse-voting-category-settings-readonly-does-not-exist/319988)

<div class="topic-metadata">

**Author:** [@exlabs](https://meta.discourse.org/u/exlabs)\
**Replies:** 5\
**Last updated:** [August 28, 2024, 3:37pm UTC](https://meta.discourse.org/t/an-error-occurred-while-restoring-from-a-backup-discourse-functions-raise-discourse-voting-category-settings-readonly-does-not-exist/319988 "2024-08-28T15:37:55Z")

</div>

Hello, I have a back-up made using our main instance Discourse 3.4.0.beta1-dev version 633a19fcc09a41a31eadd176519483217b2ec241 I want to upload this back-up to a local instance, it’s a fresh install running Discourse …

---

## [Virtual Drive Issue](https://meta.discourse.org/t/virtual-drive-issue/323658)

<div class="topic-metadata">

**Author:** [@Darin\_Schmidt](https://meta.discourse.org/u/Darin_Schmidt)\
**Replies:** 2\
**Last updated:** [August 27, 2024, 9:54pm UTC](https://meta.discourse.org/t/virtual-drive-issue/323658 "2024-08-27T21:54:55Z")

</div>

Building a new server and coming across an interesting issue. If I create a new attached drive to my VM in Ubuntu, mount it at /var/discourse the build fails. I assume it has something to do with links or so I need some …

---

## [Can I run wordpress in the same VPS with a second IP?](https://meta.discourse.org/t/can-i-run-wordpress-in-the-same-vps-with-a-second-ip/125693)

<div class="topic-metadata">

**Author:** [@chi\_noti\_info](https://meta.discourse.org/u/chi_noti_info)\
**Replies:** 14\
**Last updated:** [August 27, 2024, 1:48pm UTC](https://meta.discourse.org/t/can-i-run-wordpress-in-the-same-vps-with-a-second-ip/125693 "2024-08-27T13:48:53Z")

</div>

Hi. I know it is recommended to run discourse on it’s own server but I am running this project out of my own pocket, and it is basically a hobby with little prospects or intention of monetization in the short term at l…

---

## [Install emailing using Namecheap email hosting](https://meta.discourse.org/t/install-emailing-using-namecheap-email-hosting/32963)

<div class="topic-metadata">

**Author:** [@mootzoo](https://meta.discourse.org/u/mootzoo)\
**Replies:** 6\
**Last updated:** [August 26, 2024, 5:33pm UTC](https://meta.discourse.org/t/install-emailing-using-namecheap-email-hosting/32963 "2024-08-26T17:33:57Z")

</div>

Trying to install discourse. Domain is hosted my Namecheap. Using Namecheap email hosting. address is set to admin@mydomain.com Using Digital Ocean for VPS Hosting. Email between me@gmail.com - admin@mydomain.com wo…

---

## [Choice of hosting solution (Vultr)](https://meta.discourse.org/t/choice-of-hosting-solution-vultr/172482)

<div class="topic-metadata">

**Author:** [@Almightybean](https://meta.discourse.org/u/Almightybean)\
**Replies:** 5\
**Last updated:** [August 26, 2024, 3:51pm UTC](https://meta.discourse.org/t/choice-of-hosting-solution-vultr/172482 "2024-08-26T15:51:17Z")

</div>

I think Discorse works mostly in single core, right? So you have to prefer single core over multi-core, no? Because for example on vultr I have the possibility to choose, for example, between these two options (it change…

---

## [Can I run Discourse on the same DigitalOcean Droplet as my current NodeBB instance?](https://meta.discourse.org/t/can-i-run-discourse-on-the-same-digitalocean-droplet-as-my-current-nodebb-instance/323313)

<div class="topic-metadata">

**Author:** [@nino1904](https://meta.discourse.org/u/nino1904)\
**Replies:** 3\
**Last updated:** [August 26, 2024, 9:41am UTC](https://meta.discourse.org/t/can-i-run-discourse-on-the-same-digitalocean-droplet-as-my-current-nodebb-instance/323313 "2024-08-26T09:41:46Z")

</div>

Hi all, I’m currenty thinking about switching from NodeBB with MongoDB to Discourse. As I can see there are even migration scripts, that’s awesome. Before doing so I would like to install Discourse on my DigitalOcean D…

---

## [Remove the installation step Resend Activation Email discourse](https://meta.discourse.org/t/remove-the-installation-step-resend-activation-email-discourse/322758)

<div class="topic-metadata">

**Author:** [@Carlos\_Andres](https://meta.discourse.org/u/Carlos_Andres)\
**Replies:** 3\
**Last updated:** [August 26, 2024, 9:33am UTC](https://meta.discourse.org/t/remove-the-installation-step-resend-activation-email-discourse/322758 "2024-08-26T09:33:56Z")

</div>

remove the installation step Resend Activation Email discourse, the truth is I have not yet configured the email ports so I want to skip that step I want to enter I stay here helps

---

## [New install on ionos ubuntu 22.04 vps keeps failing](https://meta.discourse.org/t/new-install-on-ionos-ubuntu-22-04-vps-keeps-failing/322203)

<div class="topic-metadata">

**Author:** [@gbsky](https://meta.discourse.org/u/gbsky)\
**Replies:** 20\
**Last updated:** [August 25, 2024, 3:30pm UTC](https://meta.discourse.org/t/new-install-on-ionos-ubuntu-22-04-vps-keeps-failing/322203 "2024-08-25T15:30:54Z")

</div>

new install on ionos ubuntu 22.04 vps keeps failing first domain was loading up and smtp failed then even domain not even loading like browser saying error page taking too long to respond already installed in digitalo…

---

## [Running out of memory for assets:precompile with bitnami](https://meta.discourse.org/t/running-out-of-memory-for-assets-precompile-with-bitnami/323091)

<div class="topic-metadata">

**Author:** [@davispuh](https://meta.discourse.org/u/davispuh)\
**Replies:** 2\
**Last updated:** [August 23, 2024, 3:51pm UTC](https://meta.discourse.org/t/running-out-of-memory-for-assets-precompile-with-bitnami/323091 "2024-08-23T15:51:12Z")

</div>

Hi, I’m trying to install Discourse but assets:precompile step is getting OOM killed. I have 4 cores and 6 GB of RAM but it’s still not enough. 26604 ? Ss 0:00 \\\_ sh -c RAILS\_ENV=production bundle exec rak…

---

## [Update failed (v3.2.4 +1	=\> v3.3.0 +12)](https://meta.discourse.org/t/update-failed-v3-2-4-1-v3-3-0-12/322954)

<div class="topic-metadata">

**Author:** [@CamilleRoux](https://meta.discourse.org/u/CamilleRoux)\
**Replies:** 0\
**Last updated:** [August 22, 2024, 6:40pm UTC](https://meta.discourse.org/t/update-failed-v3-2-4-1-v3-3-0-12/322954 "2024-08-22T18:40:13Z")

</div>

Hi, I’ve an error during the latest update: $ yarn install yarn install v1.22.19 \[1/5\] Validating package.json... \[2/5\] Resolving packages... warning Resolution field "unset-value@2.0.1" is incompatible with requested v…

---

## [Looks like DO is disabling Smtp in their Discourse hosting plans](https://meta.discourse.org/t/looks-like-do-is-disabling-smtp-in-their-discourse-hosting-plans/321531)

<div class="topic-metadata">

**Author:** [@oga](https://meta.discourse.org/u/oga)\
**Replies:** 25\
**Last updated:** [August 20, 2024, 2:32am UTC](https://meta.discourse.org/t/looks-like-do-is-disabling-smtp-in-their-discourse-hosting-plans/321531 "2024-08-20T02:32:13Z")

</div>

Heads up folks. We got through setting up everything and it has worked. But since two days, the sign up email has not been functioning. Turned out it was disabled by Digital Ocean. Per email they sent us, Smtp for Discou…

---

## [Nginx as reverse proxy and Content Security Policy issue](https://meta.discourse.org/t/nginx-as-reverse-proxy-and-content-security-policy-issue/322288)

<div class="topic-metadata">

**Author:** [@sandra.mccollum](https://meta.discourse.org/u/sandra.mccollum)\
**Replies:** 7\
**Last updated:** [August 19, 2024, 11:49pm UTC](https://meta.discourse.org/t/nginx-as-reverse-proxy-and-content-security-policy-issue/322288 "2024-08-19T23:49:49Z")

</div>

Anyone using nginx as a reverse proxy figured out the correct syntax to configure style-src? I would love to see a working CSP add header for CSP Credit goes to moderator for the pic.

---

## [Proxmox setup](https://meta.discourse.org/t/proxmox-setup/322311)

<div class="topic-metadata">

**Author:** [@IsThisHorizon](https://meta.discourse.org/u/IsThisHorizon)\
**Replies:** 1\
**Last updated:** [August 19, 2024, 6:00pm UTC](https://meta.discourse.org/t/proxmox-setup/322311 "2024-08-19T18:00:49Z")

</div>

So I have proxmox setup with a Nginx container already running port 80:443. I have made a container for discourse. I have made a reverse proxy for the port 80:443 to go to the containers IP address. I have tested this us…

---

## [Yet other SMTP 587 port email various errors](https://meta.discourse.org/t/yet-other-smtp-587-port-email-various-errors/264267)

<div class="topic-metadata">

**Author:** [@Hyan](https://meta.discourse.org/u/Hyan)\
**Replies:** 2\
**Last updated:** [August 19, 2024, 2:17am UTC](https://meta.discourse.org/t/yet-other-smtp-587-port-email-various-errors/264267 "2024-08-19T02:17:15Z")

</div>

Different SMTP servers may occur different errors even with 587 port if testing with ./discourse-doctor TLS and STARTTLS are mutually exclusive This error has never mentioned in meta so far, you should set explicitly…

---

## [Should I be concerned about these warnings when rebuilding Discourse?](https://meta.discourse.org/t/should-i-be-concerned-about-these-warnings-when-rebuilding-discourse/322118)

<div class="topic-metadata">

**Author:** [@augustinecicc](https://meta.discourse.org/u/augustinecicc)\
**Replies:** 2\
**Last updated:** [August 18, 2024, 9:37pm UTC](https://meta.discourse.org/t/should-i-be-concerned-about-these-warnings-when-rebuilding-discourse/322118 "2024-08-18T21:37:17Z")

</div>

I get these warnings when rebuilding Discourse after a git pull and ./launcher rebuild app warning Resolution field "unset-value@2.0.1" is incompatible with requested version "unset-value@^1.0.0" warning " \> @discourse/…

---

## [NGinx.conf File location](https://meta.discourse.org/t/nginx-conf-file-location/322162)

<div class="topic-metadata">

**Author:** [@gekketovie](https://meta.discourse.org/u/gekketovie)\
**Replies:** 2\
**Last updated:** [August 18, 2024, 3:45pm UTC](https://meta.discourse.org/t/nginx-conf-file-location/322162 "2024-08-18T15:45:20Z")

</div>

I’ve been up and down on this forum to look for this bur for some reason no one is specifiying where they have their nginx.conf file stored on a docker based install. If someone could point it out to me where i could fi…

---

## [Got stuck on a yarn warning when trying to install](https://meta.discourse.org/t/got-stuck-on-a-yarn-warning-when-trying-to-install/322054)

<div class="topic-metadata">

**Author:** [@CycleBai](https://meta.discourse.org/u/CycleBai)\
**Replies:** 4\
**Last updated:** [August 18, 2024, 2:47am UTC](https://meta.discourse.org/t/got-stuck-on-a-yarn-warning-when-trying-to-install/322054 "2024-08-18T02:47:38Z")

</div>

English is not my native language, if there are grammatical errors in this post, please edit it, thank you! When I tried to install Discourse on Ubuntu 22.04 LTS, it got stuck at one operation for more than 15 minutes…

---

## [How to set S3 only save user upload files](https://meta.discourse.org/t/how-to-set-s3-only-save-user-upload-files/321926)

<div class="topic-metadata">

**Author:** [@Yt.w](https://meta.discourse.org/u/Yt.w)\
**Replies:** 5\
**Last updated:** [August 16, 2024, 10:36am UTC](https://meta.discourse.org/t/how-to-set-s3-only-save-user-upload-files/321926 "2024-08-16T10:36:02Z")

</div>

Hello, I would like to use S3 to only save my uploaded file and I don’t want to save my assets(like js) to S3. Is there anyway to do it?

---

## [Can Discourse migrate existing local content when connected to S3 storage?](https://meta.discourse.org/t/can-discourse-migrate-what-is-already-in-in-locally-when-it-is-connected-to-s3-storage/321747)

<div class="topic-metadata">

**Author:** [@CAKE\_NICE](https://meta.discourse.org/u/CAKE_NICE)\
**Replies:** 3\
**Last updated:** [August 15, 2024, 8:17am UTC](https://meta.discourse.org/t/can-discourse-migrate-what-is-already-in-in-locally-when-it-is-connected-to-s3-storage/321747 "2024-08-15T08:17:39Z")

</div>

Discourse’s backup is a zip archive After unzipping one is the database and the other is the upload files (uploads) When using S3 storage, this Uploads will not appear in the backup file, but will be stored in the obje…

---

## [Installation ended, what do I do now?](https://meta.discourse.org/t/installation-ended-what-do-i-do-now/321463)

<div class="topic-metadata">

**Author:** [@NateDhaliwal](https://meta.discourse.org/u/NateDhaliwal)\
**Replies:** 4\
**Last updated:** [August 14, 2024, 5:58pm UTC](https://meta.discourse.org/t/installation-ended-what-do-i-do-now/321463 "2024-08-14T17:58:45Z")

</div>

After setting up Discourse on a standard install on my Pi, it ended with: + /usr/bin/docker run --shm-size=512m -d --restart=always -e LANG=en\_US.UTF-8 -e RAILS\_ENV=production -e UNICORN\_WORKERS=8 -e UNICORN\_SIDEKIQS=1 …

---

## [Lots of HTTP 502 and 429 after updating to 3.4.0.beta1-dev](https://meta.discourse.org/t/lots-of-http-502-and-429-after-updating-to-3-4-0-beta1-dev/320896)

<div class="topic-metadata">

**Author:** [@Crius](https://meta.discourse.org/u/Crius)\
**Replies:** 23\
**Last updated:** [August 13, 2024, 1:28pm UTC](https://meta.discourse.org/t/lots-of-http-502-and-429-after-updating-to-3-4-0-beta1-dev/320896 "2024-08-13T13:28:42Z")

</div>

Discourse version: 3.4.0.beta1-dev (bf3d8a0a94) Updated yesterday and had to disable minify from Cloudflare as suggested here: However, since then, lots of users (me included) experimented several instances of 502 (B…

---

## [LoadError: cannot load such file -- topic\_list\_item\_serializer](https://meta.discourse.org/t/loaderror-cannot-load-such-file-topic-list-item-serializer/321407)

<div class="topic-metadata">

**Author:** [@Jagster](https://meta.discourse.org/u/Jagster)\
**Replies:** 11\
**Last updated:** [August 13, 2024, 10:28am UTC](https://meta.discourse.org/t/loaderror-cannot-load-such-file-topic-list-item-serializer/321407 "2024-08-13T10:28:32Z")

</div>

I just tried do upgraiding and it failed. Only errorlike I found was this: I, \[2024-08-13T05:52:05.670992 #1\] INFO -- : \> cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' Plugin name is 'discourse…

---

## [Formatting issues when adding plugins to app.yml](https://meta.discourse.org/t/formatting-issues-adding-plugins-to-app-yml/307381)

<div class="topic-metadata">

**Author:** [@Master](https://meta.discourse.org/u/Master)\
**Replies:** 8\
**Last updated:** [August 13, 2024, 4:18am UTC](https://meta.discourse.org/t/formatting-issues-adding-plugins-to-app-yml/307381 "2024-08-13T04:18:37Z")

</div>

Hello, I have been a discourse user since yesterday, using the given code I have not been able to install the plugin since it always says the following error: (): did not find expected key while parsing a block mapping …

---

## [Suddenly I'm not able to bootstrap 'Data' container](https://meta.discourse.org/t/suddenly-im-not-able-to-bootstrap-data-container/321168)

<div class="topic-metadata">

**Author:** [@Bathinda](https://meta.discourse.org/u/Bathinda)\
**Replies:** 1\
**Last updated:** [August 12, 2024, 9:31pm UTC](https://meta.discourse.org/t/suddenly-im-not-able-to-bootstrap-data-container/321168 "2024-08-12T21:31:19Z")

</div>

Answer to the above problem: I just came to know (mostly be chance/experiment) that you cannot bootstrap the data container. You HAVE TO rebuild the ‘data’ container. And also, you first need to stop ‘web\_only’ contain…

[Previous page](https://meta.discourse.org/c/support/self-hosting/31.md?page=18)

[Next page](https://meta.discourse.org/c/support/self-hosting/31.md?page=20)
