# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=3

[Latest](https://meta.discourse.org/latest.md) · [Categories](https://meta.discourse.org/categories.md) · [Tags](https://meta.discourse.org/tags.md)

**Page:** 4

---

## [How to regain Admin access when Discourse ID is disabled and before ticking Enable Local Login option?](https://meta.discourse.org/t/how-to-regain-admin-access-when-discourse-id-is-disabled-and-before-ticking-enable-local-login-option/403202)

<div class="topic-metadata">

**Author:** [@smokiebacon](https://meta.discourse.org/u/smokiebacon)\
**Replies:** 2\
**Last updated:** [May 18, 2026, 6:46pm UTC](https://meta.discourse.org/t/how-to-regain-admin-access-when-discourse-id-is-disabled-and-before-ticking-enable-local-login-option/403202 "2026-05-18T18:46:58Z")

</div>

So I may have completely messed up and unable to forever gain access to my community. I wanted to turn off Discourse ID and let users sign up locally, with their own username and password, and not route through Discourse…

---

## [Failed to restore data after migrating Discourse](https://meta.discourse.org/t/discourse/402623)

<div class="topic-metadata">

**Author:** [@iouvps](https://meta.discourse.org/u/iouvps)\
**Replies:** 10\
**Last updated:** [May 18, 2026, 2:00am UTC](https://meta.discourse.org/t/discourse/402623 "2026-05-18T02:00:56Z")

</div>

\[2026-05-11 02:05:14\] Reconnecting to the database... \[2026-05-11 02:05:14\] Reloading site settings... \[2026-05-11 02:05:14\] Disabling outgoing emails for non-staff users... \[2026-05-11 02:05:14\] Running seed fu... \[2026…

---

## [How to make a redirect from non-existent pages](https://meta.discourse.org/t/how-to-make-a-redirect-from-non-existent-pages/402807)

<div class="topic-metadata">

**Author:** [@Vsekraski](https://meta.discourse.org/u/Vsekraski)\
**Replies:** 3\
**Last updated:** [May 13, 2026, 8:55am UTC](https://meta.discourse.org/t/how-to-make-a-redirect-from-non-existent-pages/402807 "2026-05-13T08:55:44Z")

</div>

When a user visits a non-existent page, it displays the error “Error. This page does not exist or is hidden from public view.” Is it possible to redirect users from such pages to the desired page?

---

## [Self Hosted, AWS Lightsail and Ubuntu](https://meta.discourse.org/t/self-hosted-aws-lightsail-and-ubuntu/402512)

<div class="topic-metadata">

**Author:** [@fuse](https://meta.discourse.org/u/fuse)\
**Replies:** 3\
**Last updated:** [May 9, 2026, 9:41pm UTC](https://meta.discourse.org/t/self-hosted-aws-lightsail-and-ubuntu/402512 "2026-05-09T21:41:57Z")

</div>

Long topic title… whew! :flushed\_face::roll\_eyes::grin: Anyone else running self hosted on AWS Lightsail? Out of curiosity I went and looked at the self install instructions today, noted Ubuntu LTS was the recommendati…

---

## [Installing Discourse Behind Reverse Proxy using recommended (supported) installation](https://meta.discourse.org/t/installing-discourse-behind-reverse-proxy-using-recommended-supported-installation/300191)

<div class="topic-metadata">

**Author:** [@NullUsername](https://meta.discourse.org/u/NullUsername)\
**Replies:** 7\
**Last updated:** [May 6, 2026, 9:32pm UTC](https://meta.discourse.org/t/installing-discourse-behind-reverse-proxy-using-recommended-supported-installation/300191 "2026-05-06T21:32:12Z")

</div>

In this post, I will show you exactly how to run discourse behind a nginx reverse proxy. While still using the supported installation methods. Requirements: Valid domain name. Valid ssl certificate. Valid DNS entries …

---

## [Self-hosted installation behind a non-publicly routeable IP address](https://meta.discourse.org/t/installation-auto-hebergee-derriere-une-ip-non-routee-publiquement/402198)

<div class="topic-metadata">

**Author:** [@manu-p](https://meta.discourse.org/u/manu-p)\
**Replies:** 13\
**Last updated:** [May 6, 2026, 4:43pm UTC](https://meta.discourse.org/t/installation-auto-hebergee-derriere-une-ip-non-routee-publiquement/402198 "2026-05-06T16:43:54Z")

</div>

Hello, For testing/validation purposes, I'm installing Discourse on a local Ubuntu machine with a fixed local IP, let's say 192.168.1.200. It's behind a router with a public IP, let's say A.B.C.D, …

---

## [This file is too large](https://meta.discourse.org/t/topic/402101)

<div class="topic-metadata">

**Author:** [@Vsekraski](https://meta.discourse.org/u/Vsekraski)\
**Replies:** 29\
**Last updated:** [May 4, 2026, 7:26am UTC](https://meta.discourse.org/t/topic/402101 "2026-05-04T07:26:20Z")

</div>

Hello. I'm unable to upload videos, even ones as small as 2MB. It says "This file is too large." How can I resolve this issue?

---

## [OIDC users not associating with existing Discourse users](https://meta.discourse.org/t/oidc-users-not-associating-with-existing-discourse-users/383894)

<div class="topic-metadata">

**Author:** [@WurstLander](https://meta.discourse.org/u/WurstLander)\
**Replies:** 4\
**Last updated:** [May 4, 2026, 5:06am UTC](https://meta.discourse.org/t/oidc-users-not-associating-with-existing-discourse-users/383894 "2026-05-04T05:06:35Z")

</div>

Hi! I’m trying to set up Discourse with the Discourse OpenID Connect plugin and Keycloak. I’ve managed to make it work, and was able to not only login to my Discourse instance using my Keycloak credentials, but also ass…

---

## [Bypass the 6 badge fav limit](https://meta.discourse.org/t/bypass-the-6-badge-fav-limit/402015)

<div class="topic-metadata">

**Author:** [@codixer](https://meta.discourse.org/u/codixer)\
**Replies:** 19\
**Last updated:** [May 2, 2026, 4:39pm UTC](https://meta.discourse.org/t/bypass-the-6-badge-fav-limit/402015 "2026-05-02T16:39:11Z")

</div>

So out communities have a very specific use for… badges. Some have 4 badges and they’ll do fine. However, we also have users with 24 badges! I want to know if there is a way to make the max\_favorite\_badges to be s…

---

## [Composer image resize threshold](https://meta.discourse.org/t/composer-image-resize-threshold/402018)

<div class="topic-metadata">

**Author:** [@gallery3540](https://meta.discourse.org/u/gallery3540)\
**Replies:** 14\
**Last updated:** [May 1, 2026, 8:19pm UTC](https://meta.discourse.org/t/composer-image-resize-threshold/402018 "2026-05-01T20:19:07Z")

</div>

Continuing the discussion from Client side image optimization enabled by default: I’m the admin on a self-hosted Discourse instance for local photographers where we mostly upload high quality media. I’d like to change t…

---

## [Fresh install without lets-encrypt on docker](https://meta.discourse.org/t/fresh-install-without-lets-encrypt-on-docker/401632)

<div class="topic-metadata">

**Author:** [@josir](https://meta.discourse.org/u/josir)\
**Replies:** 2\
**Last updated:** [April 29, 2026, 10:43pm UTC](https://meta.discourse.org/t/fresh-install-without-lets-encrypt-on-docker/401632 "2026-04-29T22:43:19Z")

</div>

Hi folks, I am trying a fresh install but I have an external nginx that manage all my certificates. How can I disable the ssl/letsencrypt option on docker?

---

## [Can the /var/discourse and /var/lib/docker folders be on different volumes?](https://meta.discourse.org/t/can-the-var-discourse-and-var-lib-docker-folders-be-on-different-volumes/401332)

<div class="topic-metadata">

**Author:** [@Dannii](https://meta.discourse.org/u/Dannii)\
**Replies:** 5\
**Last updated:** [April 28, 2026, 6:17pm UTC](https://meta.discourse.org/t/can-the-var-discourse-and-var-lib-docker-folders-be-on-different-volumes/401332 "2026-04-28T18:17:17Z")

</div>

I’m self hosting on Linode and am planning to add a block storage volume because there’s no longer enough space for Discourse to compress its backups. (I’ve done a docker image prune etc which is giving us a bit of time,…

---

## [IPBv4 migration script issues](https://meta.discourse.org/t/ipbv4-migration-script-issues/401561)

<div class="topic-metadata">

**Author:** [@Anonymous\_Moose](https://meta.discourse.org/u/Anonymous_Moose)\
**Replies:** 3\
**Last updated:** [April 27, 2026, 8:05pm UTC](https://meta.discourse.org/t/ipbv4-migration-script-issues/401561 "2026-04-27T20:05:47Z")

</div>

It failed to import all the avatars (only imported admins) and it saw that an admin already existed on our forum so it didn’t make a new one or replace it, I thought it had merged it but it didn’t migrate any of their po…

---

## [Trying to install this for a client on HestiaCP, hitting GitHub error even though it can access the internet fine?](https://meta.discourse.org/t/trying-to-install-this-for-a-client-on-hestiacp-hitting-github-error-even-though-it-can-access-the-internet-fine/401528)

<div class="topic-metadata">

**Author:** [@Anonymous\_Moose](https://meta.discourse.org/u/Anonymous_Moose)\
**Replies:** 1\
**Last updated:** [April 25, 2026, 10:18pm UTC](https://meta.discourse.org/t/trying-to-install-this-for-a-client-on-hestiacp-hitting-github-error-even-though-it-can-access-the-internet-fine/401528 "2026-04-25T22:18:54Z")

</div>

Not entirely sure what’s going on. I know I don’t particular like Docker though. I’m running Ubuntu Server, and trying to get this working for a domain on HestiaCP and the auto-install script said it couldn’t see the dom…

---

## [Getting notified that out of date but not able to update](https://meta.discourse.org/t/getting-notified-that-out-of-date-but-not-able-to-update/401160)

<div class="topic-metadata">

**Author:** [@smilitello](https://meta.discourse.org/u/smilitello)\
**Replies:** 16\
**Last updated:** [April 22, 2026, 9:05pm UTC](https://meta.discourse.org/t/getting-notified-that-out-of-date-but-not-able-to-update/401160 "2026-04-22T21:05:37Z")

</div>

---

## [Can't enable DiscourseID on a site with force-https disabled](https://meta.discourse.org/t/cant-enable-discourseid-on-a-site-with-force-https-disabled/399376)

<div class="topic-metadata">

**Author:** [@darkpixlz](https://meta.discourse.org/u/darkpixlz)\
**Replies:** 6\
**Last updated:** [April 20, 2026, 7:18pm UTC](https://meta.discourse.org/t/cant-enable-discourseid-on-a-site-with-force-https-disabled/399376 "2026-04-20T19:18:26Z")

</div>

For context, I have my Discourse test site running in a Proxmox container behind Nginx (npmplus) on a different server on the same network (but not subnet). Not really anything special. I tried enabling force-https but I…

---

## [When OpenID Connect overrides email](https://meta.discourse.org/t/when-openid-connect-overrides-email/401037)

<div class="topic-metadata">

**Author:** [@Ethsim2](https://meta.discourse.org/u/Ethsim2)\
**Replies:** 0\
**Last updated:** [April 20, 2026, 10:25am UTC](https://meta.discourse.org/t/when-openid-connect-overrides-email/401037 "2026-04-20T10:25:29Z")

</div>

On a self-hosted site using OpenID Connect, is there a supported Rails console method to mark an existing alternate email in user\_emails as confirmed without changing the account’s primary email? Goal: avoid duplicate a…

---

## [/upcoming-events intermittent drop on 2GB vRAM server](https://meta.discourse.org/t/upcoming-events-intermittent-drop-on-2gb-vram-server/399931)

<div class="topic-metadata">

**Author:** [@Ethsim2](https://meta.discourse.org/u/Ethsim2)\
**Replies:** 3\
**Last updated:** [April 15, 2026, 8:29pm UTC](https://meta.discourse.org/t/upcoming-events-intermittent-drop-on-2gb-vram-server/399931 "2026-04-15T20:29:17Z")

</div>

Hello, I’m experiencing user-facing rate limiting on the Safari Progressive Web Application for Discourse in Production. I have caught a screen recording of this occurrence, followed by my exact Discourse versions’. …

---

## [2 emails rejected by 2026.4.0-latest ( 5f0d95e1f1 )](https://meta.discourse.org/t/2-emails-rejected-by-2026-4-0-latest-5f0d95e1f1/400152)

<div class="topic-metadata">

**Author:** [@Ethsim2](https://meta.discourse.org/u/Ethsim2)\
**Replies:** 4\
**Last updated:** [April 15, 2026, 8:26pm UTC](https://meta.discourse.org/t/2-emails-rejected-by-2026-4-0-latest-5f0d95e1f1/400152 "2026-04-15T20:26:53Z")

</div>

Hi, I’m seeing an intermittent inbound email processing failure on a self-hosted site using mail-receiver. What happened Two separate inbound emails: were delivered to the correct Discourse address appear in /admin/em…

---

## [Exception: Failed to initialize site default after upgrade](https://meta.discourse.org/t/exception-failed-to-initialize-site-default-after-upgrade/400558)

<div class="topic-metadata">

**Author:** [@jlc](https://meta.discourse.org/u/jlc)\
**Replies:** 3\
**Last updated:** [April 13, 2026, 6:58pm UTC](https://meta.discourse.org/t/exception-failed-to-initialize-site-default-after-upgrade/400558 "2026-04-13T18:58:53Z")

</div>

I recently upgraded a self-hosted instance of Discourse using the ./launcher rebuild app strategy. The rebuild seemed to work, but Discourse itself failed to respond. Using docker logs app gives the following output: ru…

---

## [How to configure c panel email server to work with incoming emails](https://meta.discourse.org/t/how-to-configure-c-panel-email-server-to-work-with-incoming-emails/388143)

<div class="topic-metadata">

**Author:** [@adopilot](https://meta.discourse.org/u/adopilot)\
**Replies:** 6\
**Last updated:** [April 11, 2026, 12:28pm UTC](https://meta.discourse.org/t/how-to-configure-c-panel-email-server-to-work-with-incoming-emails/388143 "2026-04-11T12:28:25Z")

</div>

My email server are hosted on C panel. Now I want to setup my discource to fetch email from c panel mail accounts, so users can replay using email option. Since I am unable to route all unknown emails to discouce inbox…

---

## [Trying to setup discourse and cannot use it due to sso?](https://meta.discourse.org/t/trying-to-setup-discourse-and-cannot-use-it-due-to-sso/399956)

<div class="topic-metadata">

**Author:** [@Dirtkick0](https://meta.discourse.org/u/Dirtkick0)\
**Replies:** 2\
**Last updated:** [April 10, 2026, 5:49pm UTC](https://meta.discourse.org/t/trying-to-setup-discourse-and-cannot-use-it-due-to-sso/399956 "2026-04-10T17:49:46Z")

</div>

Trying to setup a discourse site, Its being routed through NGINX. enable\_discourse\_id: Failed to automatically register with Discourse ID. This could be due to network connectivity issues, firewall restrictions, or the …

---

## [All plugins not functioning due to CORS error after recent upgrade](https://meta.discourse.org/t/all-plugins-not-functioning-due-to-cors-error-after-recent-upgrade/399466)

<div class="topic-metadata">

**Author:** [@TomoftheFog](https://meta.discourse.org/u/TomoftheFog)\
**Replies:** 22\
**Last updated:** [April 10, 2026, 7:20am UTC](https://meta.discourse.org/t/all-plugins-not-functioning-due-to-cors-error-after-recent-upgrade/399466 "2026-04-10T07:20:18Z")

</div>

Since last week, all plugins both core and installed have stopped functioning even when enabled on our forum. Initially I thought this was something to do with the previously mentioned bug FIX: Compile missing rollup plu…

---

## [ERR\_CONNECTION\_TIMED\_OUT when trying to connect to a discourse instance hosted on Cloudflare Tunnels](https://meta.discourse.org/t/err-connection-timed-out-when-trying-to-connect-to-a-discourse-instance-hosted-on-cloudflare-tunnels/400126)

<div class="topic-metadata">

**Author:** [@raadtotheraad](https://meta.discourse.org/u/raadtotheraad)\
**Replies:** 0\
**Last updated:** [April 7, 2026, 2:47pm UTC](https://meta.discourse.org/t/err-connection-timed-out-when-trying-to-connect-to-a-discourse-instance-hosted-on-cloudflare-tunnels/400126 "2026-04-07T14:47:18Z")

</div>

Hey there, I used the guide here, but when I try to connect, I receive the ERR\_CONNECTION\_TIMED\_OUT Error. Anyone know what I should do now? Thanks!

---

## [Question about port forwarding](https://meta.discourse.org/t/question-about-port-forwarding/400059)

<div class="topic-metadata">

**Author:** [@raadtotheraad](https://meta.discourse.org/u/raadtotheraad)\
**Replies:** 2\
**Last updated:** [April 7, 2026, 9:49am UTC](https://meta.discourse.org/t/question-about-port-forwarding/400059 "2026-04-07T09:49:21Z")

</div>

When port forwarding my domain to my device (as my router doesnt allow port forwarding) using something like cloudflare tunnels, should it be something like localhost:80, or the IP address of the machine, or something el…

---

## [Production upgrades - correct procedure to follow](https://meta.discourse.org/t/production-upgrades-correct-procedure-to-follow/399550)

<div class="topic-metadata">

**Author:** [@stevejr](https://meta.discourse.org/u/stevejr)\
**Replies:** 9\
**Last updated:** [April 6, 2026, 4:16pm UTC](https://meta.discourse.org/t/production-upgrades-correct-procedure-to-follow/399550 "2026-04-06T16:16:03Z")

</div>

Hi, I am about to upgrade our production discourse server (we self-host on EC2 as per the official installation instructions) and wanted to confirm the recommended approach. We do not have the upgrade button enabled in…

---

## [Auto updates via cronjob - is this safe?](https://meta.discourse.org/t/auto-updates-via-cronjob-is-this-safe/241232)

<div class="topic-metadata">

**Author:** [@OrkoGrayskull](https://meta.discourse.org/u/OrkoGrayskull)\
**Replies:** 8\
**Last updated:** [April 6, 2026, 2:35pm UTC](https://meta.discourse.org/t/auto-updates-via-cronjob-is-this-safe/241232 "2026-04-06T14:35:14Z")

</div>

I’m thinking of auto-updating Discourse via cronjob. For example every two weeks in the night a cronjob with the following: cd /var/discourse ./launcher rebuild app Do you think this is safe to do? Or should I do this …

---

## [Bootstrap error: relation "ai\_agent\_mcp\_servers" does not exist -- due to migration id collision](https://meta.discourse.org/t/bootstrap-error-relation-ai-agent-mcp-servers-does-not-exist-due-to-migration-id-collision/399572)

<div class="topic-metadata">

**Author:** [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**Replies:** 10\
**Last updated:** [April 2, 2026, 3:48pm UTC](https://meta.discourse.org/t/bootstrap-error-relation-ai-agent-mcp-servers-does-not-exist-due-to-migration-id-collision/399572 "2026-04-02T15:48:44Z")

</div>

Bootstrap is failing with this error: PG::UndefinedTable: ERROR: relation "ai\_agent\_mcp\_servers" does not exist more stuff: in /etc/nginx/conf.d/discourse.conf I, \[2026-03-30T15:32:25.835970 #1\] INFO -- : \> cd /var/…

---

## [Transfering inbox group messages to another instance?](https://meta.discourse.org/t/transfering-inbox-group-messages-to-another-instance/398971)

<div class="topic-metadata">

**Author:** [@Wall-E](https://meta.discourse.org/u/Wall-E)\
**Replies:** 6\
**Last updated:** [March 31, 2026, 3:08am UTC](https://meta.discourse.org/t/transfering-inbox-group-messages-to-another-instance/398971 "2026-03-31T03:08:57Z")

</div>

My discourse site has a group that needs to migrate to a different self-hosted Discourse instance, under a different domain. Only the users of that group will go to the new instance. Is it possible to transfer only the …

---

## [Help deploying older versions of Discourse](https://meta.discourse.org/t/help-deploying-older-versions-of-discourse/399409)

<div class="topic-metadata">

**Author:** [@singi2016cn](https://meta.discourse.org/u/singi2016cn)\
**Replies:** 22\
**Last updated:** [March 30, 2026, 6:36pm UTC](https://meta.discourse.org/t/help-deploying-older-versions-of-discourse/399409 "2026-03-30T18:36:21Z")

</div>

这里应该有一个错误，我尝试通过标签拉取v3.6.0.beta2，结果遇到下面的错误： FAILED -------------------- Pups::ExecError: cd /var/www/discourse && sudo -H -E -u discourse bash -c ' set -o errexit git fetch --tags --prune-tags --prune --force origin …

[Previous page](https://meta.discourse.org/c/support/self-hosting/31.md?page=2)

[Next page](https://meta.discourse.org/c/support/self-hosting/31.md?page=4)
