# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=31

[Latest](https://meta.discourse.org/latest.md) · [Categories](https://meta.discourse.org/categories.md) · [Tags](https://meta.discourse.org/tags.md)

**Page:** 32

---

## [Uninitialized constant](https://meta.discourse.org/t/uninitialized-constant/296269)

<div class="topic-metadata">

**Author:** [@Justman10000](https://meta.discourse.org/u/Justman10000)\
**Replies:** 4\
**Last updated:** [February 22, 2024, 3:12pm UTC](https://meta.discourse.org/t/uninitialized-constant/296269 "2024-02-22T15:12:31Z")

</div>

Hello, have this: lib/discourse.rb:545:in \`current\_hostname’: uninitialized constant Discourse::SiteSetting (NameError) Here the commands

---

## [Discourse offline after failed upgrade "bootstrap failed with exit code 5"](https://meta.discourse.org/t/discourse-offline-after-failed-upgrade-bootstrap-failed-with-exit-code-5/288193)

<div class="topic-metadata">

**Author:** [@Richie](https://meta.discourse.org/u/Richie)\
**Replies:** 24\
**Last updated:** [February 22, 2024, 1:16pm UTC](https://meta.discourse.org/t/discourse-offline-after-failed-upgrade-bootstrap-failed-with-exit-code-5/288193 "2024-02-22T13:16:05Z")

</div>

Hi everyone, My Discourse is currently offline :cry: :pensive: It failed after trying to upgrade this morning from/to v3.2.0.beta3 +468: On the command line, the error message is: And the full console log: root@g…

---

## [Default Volume Directory For Each Container](https://meta.discourse.org/t/default-volume-directory-for-each-container/70169)

<div class="topic-metadata">

**Author:** [@Isabel\_Jason](https://meta.discourse.org/u/Isabel_Jason)\
**Replies:** 3\
**Last updated:** [September 16, 2017, 9:54am UTC](https://meta.discourse.org/t/default-volume-directory-for-each-container/70169 "2017-09-16T09:54:48Z")

</div>

I am an entire new to docker and I comprehend the way default container volumes are made. container volumes are within/var/lib/docker/volumes. would i be able to change the default volume catalog for every holder, to an …

---

## [Rebuild failure: "extconf failed, exit code 1" -- due to old Docker?](https://meta.discourse.org/t/rebuild-failure-extconf-failed-exit-code-1-due-to-old-docker/287756)

<div class="topic-metadata">

**Author:** [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**Replies:** 10\
**Last updated:** [February 21, 2024, 11:42pm UTC](https://meta.discourse.org/t/rebuild-failure-extconf-failed-exit-code-1-due-to-old-docker/287756 "2024-02-21T23:42:18Z")

</div>

I’ve got a rebuild that’s failing, I think due to this. It’s running Ubuntu 16.04 with Docker version 17.05.0-ce, build 89658be, which I know is suspect, but I wanted to give this person one more rebuild if at all possib…

---

## [New Install Bootstrap Fail in 'bundle exec rake themes:update assets:precompile'](https://meta.discourse.org/t/new-install-bootstrap-fail-in-bundle-exec-rake-themes-update-assets-precompile/296136)

<div class="topic-metadata">

**Author:** [@gren](https://meta.discourse.org/u/gren)\
**Replies:** 7\
**Last updated:** [February 21, 2024, 6:33pm UTC](https://meta.discourse.org/t/new-install-bootstrap-fail-in-bundle-exec-rake-themes-update-assets-precompile/296136 "2024-02-21T18:33:05Z")

</div>

I have been trying to install discourse for 10 hours straight with little luck. I initially had a 1Gb Digital Ocean droplet but setup was taking 30-40 minutes and sometimes disconnecting. I upgraded to a 2Gb droplet and …

---

## [installation in directadmin](https://meta.discourse.org/t/installation-in-directadmin/296101)

<div class="topic-metadata">

**Author:** [@crashlepton](https://meta.discourse.org/u/crashlepton)\
**Replies:** 5\
**Last updated:** [February 21, 2024, 10:01am UTC](https://meta.discourse.org/t/installation-in-directadmin/296101 "2024-02-21T10:01:29Z")

</div>

I am currently exploring options for installing Discourse on my DirectAdmin hosting environment. However, due to limited permissions and the absence of Docker support, I am facing challenges in the installation process. …

---

## [Problem after installing plugin](https://meta.discourse.org/t/problem-after-installing-plugin/295812)

<div class="topic-metadata">

**Author:** [@Ahmed26](https://meta.discourse.org/u/Ahmed26)\
**Replies:** 9\
**Last updated:** [February 19, 2024, 8:45pm UTC](https://meta.discourse.org/t/problem-after-installing-plugin/295812 "2024-02-19T20:45:04Z")

</div>

After installing the plugin, I cannot access my site. My transactions are correct. There are errors in the picture. What is the problem? tarihforum.com

---

## [How to Unblock port 80 and 443 which is closed on NMAP](https://meta.discourse.org/t/how-to-unblock-port-80-and-443-which-is-closed-on-nmap/295701)

<div class="topic-metadata">

**Author:** [@Dorcas\_Kagoya](https://meta.discourse.org/u/Dorcas_Kagoya)\
**Replies:** 1\
**Last updated:** [February 18, 2024, 8:56pm UTC](https://meta.discourse.org/t/how-to-unblock-port-80-and-443-which-is-closed-on-nmap/295701 "2024-02-18T20:56:27Z")

</div>

When I check my UFW status port 80 and 443 are are open but then when check on NMAP port 80 and 443 are a closed how do open them.

---

## [How to setup subdomain](https://meta.discourse.org/t/how-to-setup-subdomain/295763)

<div class="topic-metadata">

**Author:** [@xha1e](https://meta.discourse.org/u/xha1e)\
**Replies:** 1\
**Last updated:** [February 18, 2024, 12:34am UTC](https://meta.discourse.org/t/how-to-setup-subdomain/295763 "2024-02-18T00:34:46Z")

</div>

How do I go about setting up forum.mywebsite.com ? I have added an A record, with name of forum However, I am not sure where to find the IP address of my discourse server? The discourse server is hosted by discourse, …

---

## [Hetzner experiences](https://meta.discourse.org/t/hetzner-experiences/54430)

<div class="topic-metadata">

**Author:** [@ljpp](https://meta.discourse.org/u/ljpp)\
**Replies:** 27\
**Last updated:** [June 19, 2023, 11:20am UTC](https://meta.discourse.org/t/hetzner-experiences/54430 "2023-06-19T11:20:19Z")

</div>

Time to test a new hosting company :slight\_smile: .This time I opted for German Hetzner, and their 4.80€ VPS CX1. Note that this price is VAT inclusive, so it is one of the very cheapest on the market (many providers pre…

---

## [WSL WARNING: Port 443 of computer does not appear to be accessible using hostname](https://meta.discourse.org/t/wsl-warning-port-443-of-computer-does-not-appear-to-be-accessible-using-hostname/295290)

<div class="topic-metadata">

**Author:** [@ecomter](https://meta.discourse.org/u/ecomter)\
**Replies:** 4\
**Last updated:** [February 17, 2024, 9:24am UTC](https://meta.discourse.org/t/wsl-warning-port-443-of-computer-does-not-appear-to-be-accessible-using-hostname/295290 "2024-02-17T09:24:13Z")

</div>

While installing Discourse on WSL2 Ubuntu 18.04, I stopped other web services on Windows. However, the installation displayed an error message. I am certain that I have set the correct D NS record for this device’…

---

## [Failed to bootstrap on first install](https://meta.discourse.org/t/failed-to-bootstrap-on-first-install/295475)

<div class="topic-metadata">

**Author:** [@tumbleweed](https://meta.discourse.org/u/tumbleweed)\
**Replies:** 17\
**Last updated:** [February 16, 2024, 6:57pm UTC](https://meta.discourse.org/t/failed-to-bootstrap-on-first-install/295475 "2024-02-16T18:57:07Z")

</div>

I followed the tutorial at 🇨🇳 Detailed installation guide + control panel | 超级详细教学安装discourse+控制面板 to deploy Discourse on a cloud server. I installed Docker and started the container as instructed. However, after complet…

---

## [Inaccessible behind Traefik Proxy](https://meta.discourse.org/t/inaccessible-behind-traefik-proxy/295508)

<div class="topic-metadata">

**Author:** [@tgrosinger](https://meta.discourse.org/u/tgrosinger)\
**Replies:** 1\
**Last updated:** [February 15, 2024, 7:10pm UTC](https://meta.discourse.org/t/inaccessible-behind-traefik-proxy/295508 "2024-02-15T19:10:18Z")

</div>

I’ve read through a bunch of posts about running Discourse behind a Traefik proxy, but unfortunately I seem to still be missing something. From the host if I curl the internal IP of the container I can see the Discourse…

---

## [Unexpected errors from attempted upgrade with the main branch](https://meta.discourse.org/t/unexpected-errors-from-attempted-upgrade-with-the-main-branch/295280)

<div class="topic-metadata">

**Author:** [@anon36555649](https://meta.discourse.org/u/anon36555649)\
**Replies:** 6\
**Last updated:** [February 15, 2024, 4:31pm UTC](https://meta.discourse.org/t/unexpected-errors-from-attempted-upgrade-with-the-main-branch/295280 "2024-02-15T16:31:44Z")

</div>

Have some unexpected errors from attempted upgrade with the main branch: warning Resolution field "unset-value@2.0.1" is incompatible with requested version "unset-value@^1.0.0" \[2/4\] Fetching packages... warning Patter…

---

## [First installation - Error on rebuild app](https://meta.discourse.org/t/first-installation-error-on-rebuild-app/295230)

<div class="topic-metadata">

**Author:** [@peyrusse](https://meta.discourse.org/u/peyrusse)\
**Replies:** 8\
**Last updated:** [February 15, 2024, 3:31pm UTC](https://meta.discourse.org/t/first-installation-error-on-rebuild-app/295230 "2024-02-15T15:31:35Z")

</div>

Unable to rebuild app on a VM Machine, i got this error message when i launch ./launcher rebuild app. This is my first installation on this machine of Discourse. Any idea how to solve this problem ? Thanks. FAILED ----…

---

## [Migration from SAS to self-hosted kubernetes](https://meta.discourse.org/t/migration-from-sas-to-self-hosted-kubernetes/295466)

<div class="topic-metadata">

**Author:** [@Andrés\_Tarrío](https://meta.discourse.org/u/Andr%C3%A9s_Tarr%C3%ADo)\
**Replies:** 2\
**Last updated:** [February 15, 2024, 2:24pm UTC](https://meta.discourse.org/t/migration-from-sas-to-self-hosted-kubernetes/295466 "2024-02-15T14:24:11Z")

</div>

Hello everyone: I’m in the process of migrating my Discourse installation from the SAS version to a Kubernetes environment using the charts provided by Bitnami. I’ve encountered difficulties when trying to restore expo…

---

## [Upgrading very old Discourse Get Ruby error](https://meta.discourse.org/t/upgrading-very-old-discourse-get-ruby-error/295387)

<div class="topic-metadata">

**Author:** [@Oogiem](https://meta.discourse.org/u/Oogiem)\
**Replies:** 9\
**Last updated:** [February 14, 2024, 10:59pm UTC](https://meta.discourse.org/t/upgrading-very-old-discourse-get-ruby-error/295387 "2024-02-14T22:59:51Z")

</div>

I’m trying to update a very old installation. I started with this: cd /var/discourse sudo git pull sudo ./launcher rebuild app Then I get a failed and scrolling up the log file the only error is this ERROR: Error …

---

## [Unable to connect to discourse after installtion](https://meta.discourse.org/t/unable-to-connect-to-discourse-after-installtion/295390)

<div class="topic-metadata">

**Author:** [@Dorcas\_Kagoya](https://meta.discourse.org/u/Dorcas_Kagoya)\
**Replies:** 3\
**Last updated:** [February 14, 2024, 10:45pm UTC](https://meta.discourse.org/t/unable-to-connect-to-discourse-after-installtion/295390 "2024-02-14T22:45:11Z")

</div>

I installed discourse successfully but when try to launch the domain I get an error of unable to connect What i need to check to fix this issue?

---

## [Best configurations for speeding up standalone discourse](https://meta.discourse.org/t/best-configurations-for-speeding-up-standalone-discourse/162456)

<div class="topic-metadata">

**Author:** [@nildarar](https://meta.discourse.org/u/nildarar)\
**Replies:** 25\
**Last updated:** [February 14, 2024, 7:27pm UTC](https://meta.discourse.org/t/best-configurations-for-speeding-up-standalone-discourse/162456 "2024-02-14T19:27:19Z")

</div>

Our Discourse site has more than 10k users and about 700 daily engaged users. users sending an average of 10k posts per day. our community has more than 160k pageviews/day including crawlers and anonymous users. Almost a…

---

## [502 bad gateway with clean rebuild and no plugins except discourse docker](https://meta.discourse.org/t/502-bad-gateway-with-clean-rebuild-and-no-plugins-except-discourse-docker/295143)

<div class="topic-metadata">

**Author:** [@jimkleiber](https://meta.discourse.org/u/jimkleiber)\
**Replies:** 5\
**Last updated:** [February 14, 2024, 9:06am UTC](https://meta.discourse.org/t/502-bad-gateway-with-clean-rebuild-and-no-plugins-except-discourse-docker/295143 "2024-02-14T09:06:42Z")

</div>

Continuing the discussion from Can't rebuild, clang-11 is missing: I was getting a failed rebuild when I had the lines for chatbot embeddings in the app.yml. So I removed these lines in the hooks for building pgembeddi…

---

## [Nginx upstream timed out (110: Connection timed out)](https://meta.discourse.org/t/nginx-upstream-timed-out-110-connection-timed-out/196403)

<div class="topic-metadata">

**Author:** [@X\_Code](https://meta.discourse.org/u/X_Code)\
**Replies:** 20\
**Last updated:** [February 13, 2024, 2:58am UTC](https://meta.discourse.org/t/nginx-upstream-timed-out-110-connection-timed-out/196403 "2024-02-13T02:58:51Z")

</div>

Hi my site is https://1o24bbs.com/ No upgrade no operation, out of nowhere nginx shows it fails to connect to upstream: http://127.0.0.1:3000 How do I trouble shoot it? Appreciate the help

---

## [How do I edit my "/containers/app.yml file" from the root@digitialoceandropletname ssh workspace?](https://meta.discourse.org/t/how-do-i-edit-my-containers-app-yml-file-from-the-root-digitialoceandropletname-ssh-workspace/56628)

<div class="topic-metadata">

**Author:** [@railsnoob](https://meta.discourse.org/u/railsnoob)\
**Replies:** 6\
**Last updated:** [February 12, 2024, 10:46pm UTC](https://meta.discourse.org/t/how-do-i-edit-my-containers-app-yml-file-from-the-root-digitialoceandropletname-ssh-workspace/56628 "2024-02-12T22:46:15Z")

</div>

I installed discourse through DigitalOcean with the instructions here The instructions read: If you need to change or fix these settings after bootstrapping, edit your /containers/app.yml file I am at the command pr…

---

## [Steps involved to downgrade from 2GB to 1GB on DO?](https://meta.discourse.org/t/steps-involved-to-downgrade-from-2gb-to-1gb-on-do/265056)

<div class="topic-metadata">

**Author:** [@Brandon007](https://meta.discourse.org/u/Brandon007)\
**Replies:** 5\
**Last updated:** [February 12, 2024, 10:39pm UTC](https://meta.discourse.org/t/steps-involved-to-downgrade-from-2gb-to-1gb-on-do/265056 "2024-02-12T22:39:26Z")

</div>

When I initially setup my install, I was under the impression that I needed a 2GB server. Apparently, that’s not the case from additional reading since then. What steps are involved in downgrading on Digital Ocean? I’m …

---

## [Clean install on freshly spawned VPN with Ubuntu 22.04 fails](https://meta.discourse.org/t/clean-install-on-freshly-spawned-vpn-with-ubuntu-22-04-fails/295039)

<div class="topic-metadata">

**Author:** [@Ale\_D](https://meta.discourse.org/u/Ale_D)\
**Replies:** 1\
**Last updated:** [February 12, 2024, 7:35am UTC](https://meta.discourse.org/t/clean-install-on-freshly-spawned-vpn-with-ubuntu-22-04-fails/295039 "2024-02-12T07:35:33Z")

</div>

The clean install on Ubuntu 22.04 by standard install keep failing. I see these errors and I don’t know what I need to check to resolve it (I am new to Discourse) I, \[2024-02-12T06:24:53.611992 #1\] INFO -- : \> cd /var…

---

## [Problem with Upgrade \[error 137\]](https://meta.discourse.org/t/problem-with-upgrade-error-137/293652)

<div class="topic-metadata">

**Author:** [@anon36555649](https://meta.discourse.org/u/anon36555649)\
**Replies:** 31\
**Last updated:** [February 11, 2024, 10:22pm UTC](https://meta.discourse.org/t/problem-with-upgrade-error-137/293652 "2024-02-11T22:22:41Z")

</div>

For standard install site have this error log for most recent upgrade: \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\* \*\*\* Please be patient, next steps might take a while \*\*\* \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*…

---

## [Free Hosting Plan and AWS](https://meta.discourse.org/t/free-hosting-plan-and-aws/294394)

<div class="topic-metadata">

**Author:** [@Monk](https://meta.discourse.org/u/Monk)\
**Replies:** 4\
**Last updated:** [February 10, 2024, 7:01pm UTC](https://meta.discourse.org/t/free-hosting-plan-and-aws/294394 "2024-02-10T19:01:05Z")

</div>

Hello all, would it be possible to combine a free Creators plan according to https://free.discourse.group/ with a AWS S3 for extended storage? I have checked in a friend’s site and it was not immediately obvious if the …

---

## [Can't rebuild, clang-11 is missing](https://meta.discourse.org/t/cant-rebuild-clang-11-is-missing/294950)

<div class="topic-metadata">

**Author:** [@Firepup650](https://meta.discourse.org/u/Firepup650)\
**Replies:** 6\
**Last updated:** [February 10, 2024, 6:49pm UTC](https://meta.discourse.org/t/cant-rebuild-clang-11-is-missing/294950 "2024-02-10T18:49:35Z")

</div>

We can’t rebuild our forum right now, clang-11 is missing when we try to rebuild, even though I explicitly installed it before the second rebuild, and it looks like it’s getting installed anyways no wait, that’s clang-13…

---

## [Can't restore my backup on Bitnami helm charts. You should migrate first!](https://meta.discourse.org/t/cant-restore-my-backup-on-bitnami-helm-charts-you-should-migrate-first/294853)

<div class="topic-metadata">

**Author:** [@oleksii](https://meta.discourse.org/u/oleksii)\
**Replies:** 1\
**Last updated:** [February 9, 2024, 5:09pm UTC](https://meta.discourse.org/t/cant-restore-my-backup-on-bitnami-helm-charts-you-should-migrate-first/294853 "2024-02-09T17:09:05Z")

</div>

I have stock instance and I am going to migrate to Kubernetes. I can’t restore backup from 3.3.0.beta1-dev instance to kubernetes 3.1.3 version. I guess the easiest way would be to wait until bitnami update docker imag…

---

## [Should we increase the default swap space to 3GB or 4GB?](https://meta.discourse.org/t/should-we-increase-the-default-swap-space-to-3gb-or-4gb/294222)

<div class="topic-metadata">

**Author:** [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**Replies:** 12\
**Last updated:** [February 8, 2024, 12:18pm UTC](https://meta.discourse.org/t/should-we-increase-the-default-swap-space-to-3gb-or-4gb/294222 "2024-02-08T12:18:51Z")

</div>

I’ve just done a bunch of upgrades and decided the easiest way to solve the memory errors was just to double the swap to 4GB. The down-side is that on a 1GB droplet there is only 25GB of SSD, so losing 4 of it to swap is…

---

## [SMTP gives error ERROR - execution expired](https://meta.discourse.org/t/smtp-gives-error-error-execution-expired/294612)

<div class="topic-metadata">

**Author:** [@Luc\_Sun](https://meta.discourse.org/u/Luc_Sun)\
**Replies:** 0\
**Last updated:** [February 7, 2024, 11:16pm UTC](https://meta.discourse.org/t/smtp-gives-error-error-execution-expired/294612 "2024-02-07T23:16:46Z")

</div>

Can’t use google workspace but found it works with the support app i made with a app password but won’t work with the error execution expired

[Previous page](https://meta.discourse.org/c/support/self-hosting/31.md?page=30)

[Next page](https://meta.discourse.org/c/support/self-hosting/31.md?page=32)
