# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=45

[最新版本](https://meta.discourse.org/latest.md) · [分類](https://meta.discourse.org/categories.md) · [標簽](https://meta.discourse.org/tags.md)

**Page:** 46

---

## [哪个 Ruby 版本？](https://meta.discourse.org/t/which-ruby-version/269501)

<div class="topic-metadata">

**Author:** [@steinhh](https://meta.discourse.org/u/steinhh)\
**回覆:** 2\
**Last updated:** [2023年六月24日 12:02 UTC](https://meta.discourse.org/t/which-ruby-version/269501 "2023-06-24T12:02:00Z")

</div>

您好，我被迫在 RHEL8 系统上使用不受支持的“从头开始”安装（情况很复杂），我想知道当前 Discourse 版本应该使用哪个 Ruby 版本？

---

## [部署失败 - exec\_command.rb:117:in \`spawn](https://meta.discourse.org/t/deployment-fails-exec-command-rbin-spawn/269039)

<div class="topic-metadata">

**Author:** [@lejeczek](https://meta.discourse.org/u/lejeczek)\
**回覆:** 6\
**Last updated:** [2023年六月24日 10:02 UTC](https://meta.discourse.org/t/deployment-fails-exec-command-rbin-spawn/269039 "2023-06-24T10:02:27Z")

</div>

大家好。 在我在这里用长日志弄得一团糟之前，我把它们粘贴在下面。 部署每次都以这种方式失败。任何人都可以分享关于问题是什么以及如何修复的任何建议，我将非常感激。 … 我，\[2023-06…

---

## [升级到 3.0.2：NameError：未定义方法 \`call' 用于类 \`Redis::Client'（附带“修复”）](https://meta.discourse.org/t/upgrade-to-3-0-2-nameerror-undefined-method-call-for-class-redis-client-with-a-fix/258602)

<div class="topic-metadata">

**Author:** [@steinhh](https://meta.discourse.org/u/steinhh)\
**回覆:** 11\
**Last updated:** [2023年六月23日 18:10 UTC](https://meta.discourse.org/t/upgrade-to-3-0-2-nameerror-undefined-method-call-for-class-redis-client-with-a-fix/258602 "2023-06-23T18:10:23Z")

</div>

刚尝试从 3.0.1 升级到 3.0.2，在 rake db:migrate 阶段遇到了这个错误： rake aborted! NameError: undefined method \`call' for class \`Redis::Client' Did you mean? caller /var/discourse/vendor/bundle/ru…

---

## [从 3.0.3 更新到 3.0.4 时出现问题：错误 523](https://meta.discourse.org/t/problems-while-updating-from-3-0-3-to-3-0-4-error-523/268815)

<div class="topic-metadata">

**Author:** [@gmoirod](https://meta.discourse.org/u/gmoirod)\
**回覆:** 17\
**Last updated:** [2023年六月23日 15:11 UTC](https://meta.discourse.org/t/problems-while-updating-from-3-0-3-to-3-0-4-error-523/268815 "2023-06-23T15:11:59Z")

</div>

你好！ 我在尝试使用启动器实用程序升级我的安装时遇到一个问题。 当构建容器尝试更改上传文件的所有权时，我收到一个错误 523… 有什么想法吗？ 这是日志： $ sud…

---

## [关于 Replit 的讨论？](https://meta.discourse.org/t/discourse-on-replit/208611)

<div class="topic-metadata">

**Author:** [@joecooldoo](https://meta.discourse.org/u/joecooldoo)\
**回覆:** 16\
**Last updated:** [2023年六月20日 13:44 UTC](https://meta.discourse.org/t/discourse-on-replit/208611 "2023-06-20T13:44:05Z")

</div>

有什么办法可以在 Replit 上运行 discourse 吗？

---

## [Backblaze S3 问题：删除后重复上传](https://meta.discourse.org/t/backblaze-s3-issue-duplicated-uploads-after-delete/183313)

<div class="topic-metadata">

**Author:** [@c00bt00p](https://meta.discourse.org/u/c00bt00p)\
**回覆:** 14\
**Last updated:** [2023年六月20日 12:53 UTC](https://meta.discourse.org/t/backblaze-s3-issue-duplicated-uploads-after-delete/183313 "2023-06-20T12:53:40Z")

</div>

我正在使用 Backblaze 作为 S3 存储，并且启用了清理孤立上传的设置。问题是，它没有删除孤立的上传，而是创建了一个 0 字节的重复文件。 例如，请参见下文。(…

---

## [如何配置托管服务的电子邮件域名](https://meta.discourse.org/t/how-to-configure-email-domain-with-hosted-service/141657)

<div class="topic-metadata">

**Author:** [@Young](https://meta.discourse.org/u/Young)\
**回覆:** 2\
**Last updated:** [2023年六月19日 16:16 UTC](https://meta.discourse.org/t/how-to-configure-email-domain-with-hosted-service/141657 "2023-06-19T16:16:32Z")

</div>

我已使用 Discourse 设置了标准包。但是，当我授予用户管理员权限时，我仍然收到来自 xxx@discoursemail.com 的电子邮件。我该如何配置，使邮件从我的电子邮件服务发出？谢谢

---

## [\[网站宕机 :(\] 升级\\重建失败 - 数据库迁移问题？](https://meta.discourse.org/t/site-down-upgrade-rebuild-failure-db-migration-issue/268359)

<div class="topic-metadata">

**Author:** [@SouperC](https://meta.discourse.org/u/SouperC)\
**回覆:** 8\
**Last updated:** [2023年六月19日 12:57 UTC](https://meta.discourse.org/t/site-down-upgrade-rebuild-failure-db-migration-issue/268359 "2023-06-19T12:57:51Z")

</div>

今天升级到 Discourse 的当前版本，重建失败了，而且我不太确定是什么原因造成的。安装的版本比当前版本落后了好几个迭代（我认为是 2.8x）。当我...时，docker 镜像更新进行得很顺利

---

## [Docker 备份和恢复问题](https://meta.discourse.org/t/docker-backup-and-restore-question/268740)

<div class="topic-metadata">

**Author:** [@Taste-OF-IT](https://meta.discourse.org/u/Taste-OF-IT)\
**回覆:** 9\
**Last updated:** [2023年六月19日 09:46 UTC](https://meta.discourse.org/t/docker-backup-and-restore-question/268740 "2023-06-19T09:46:38Z")

</div>

您好，我在 Docker 中运行 Discourse CE。我拥有 root 权限，并使用 docker id stop 和 docker image save -o file.tar 来备份容器。之后，我成功升级了 discourse。现在我测试使用 docke…进行恢复

---

## [无法发送电子邮件](https://meta.discourse.org/t/impossible-to-send-emails/268476)

<div class="topic-metadata">

**Author:** [@tmc1](https://meta.discourse.org/u/tmc1)\
**回覆:** 2\
**Last updated:** [2023年六月17日 18:48 UTC](https://meta.discourse.org/t/impossible-to-send-emails/268476 "2023-06-17T18:48:36Z")

</div>

大家好， 我的域名在namecheap，也有一个邮箱账户。 我尝试在Vultr上安装Discourse，后来又在DO服务器上安装，但都无法发送邮件，从管理员的第一封邮件开始……

---

## [二次/后续容器实例化失败？](https://meta.discourse.org/t/secondary-subsequent-container-instantiation-fails/268642)

<div class="topic-metadata">

**Author:** [@lejeczek](https://meta.discourse.org/u/lejeczek)\
**回覆:** 1\
**Last updated:** [2023年六月16日 16:13 UTC](https://meta.discourse.org/t/secondary-subsequent-container-instantiation-fails/268642 "2023-06-16T16:13:06Z")

</div>

大家好。 我刚开始使用 Discourse，请对我温柔点。 我已成功部署了第一个容器 - 它是 Bitnami 的，用于 Discourse，在 RHEL/Centos 上不起作用 - 然后销毁/移除了容器……

---

## [收不到管理员登录激活邮件](https://meta.discourse.org/t/i-dont-receive-the-activation-email-to-log-in-as-an-admin/268600)

<div class="topic-metadata">

**Author:** [@sogdaze](https://meta.discourse.org/u/sogdaze)\
**回覆:** 2\
**Last updated:** [2023年六月16日 10:10 UTC](https://meta.discourse.org/t/i-dont-receive-the-activation-email-to-log-in-as-an-admin/268600 "2023-06-16T10:10:36Z")

</div>

您还无法登录。我们之前已向您发送了一封激活邮件至 我收到了这样的消息，但没有收到邮件？我该如何以管理员身份登录我的网站？

---

## [Let's Encrypt 1周限制的解决方法](https://meta.discourse.org/t/workaround-for-the-1-week-lets-encrypt-limit/268586)

<div class="topic-metadata">

**Author:** [@tmc1](https://meta.discourse.org/u/tmc1)\
**回覆:** 2\
**Last updated:** [2023年六月16日 08:50 UTC](https://meta.discourse.org/t/workaround-for-the-1-week-lets-encrypt-limit/268586 "2023-06-16T08:50:55Z")

</div>

大家好！ 我正在尝试安装 Discourse，但在几次重建后网站无法加载，原因是： 是否有任何方法可以请求一组不同的域作为变通方法来绕过限制……

---

## [论坛离线，更新出现问题](https://meta.discourse.org/t/forum-offline-trouble-updating/257851)

<div class="topic-metadata">

**Author:** [@jidetheblogger](https://meta.discourse.org/u/jidetheblogger)\
**回覆:** 6\
**Last updated:** [2023年六月14日 22:11 UTC](https://meta.discourse.org/t/forum-offline-trouble-updating/257851 "2023-06-14T22:11:08Z")

</div>

我的论坛离线了 我尝试更新它 但下面是我收到的错误 102:signal-handler (1678624734) 收到 SIGTERM 调度关闭... 2023-03-12 12:38:54.291 UTC \[41\] LOG: 中止任何活动事务 ……

---

## [从3.0.0更新到3.0.1时出现问题](https://meta.discourse.org/t/problems-while-updating-from-3-0-0-to-3-0-1/253066)

<div class="topic-metadata">

**Author:** [@Massi](https://meta.discourse.org/u/Massi)\
**回覆:** 16\
**Last updated:** [2023年六月14日 14:53 UTC](https://meta.discourse.org/t/problems-while-updating-from-3-0-0-to-3-0-1/253066 "2023-06-14T14:53:53Z")

</div>

您好， 今天我已将我们的 Discourse 应用更新至 3.0.1。更新在尝试处理 postgres 迁移时失败。 具体在此处： 2023-01-27 04:50:48.628 UTC \[483\] discourse@discourse ERROR: duplicate key value violates…

---

## [Sidekiq 在一段时间后停止](https://meta.discourse.org/t/sidekiq-stops-after-some-time/267777)

<div class="topic-metadata">

**Author:** [@bizotto](https://meta.discourse.org/u/bizotto)\
**回覆:** 7\
**Last updated:** [2023年六月14日 13:29 UTC](https://meta.discourse.org/t/sidekiq-stops-after-some-time/267777 "2023-06-14T13:29:53Z")

</div>

大家好， 我有一个安装，包含 3 个 Openshift 部署，一个用于 Redis (7.0.10)，一个用于 Postgress (13.10)，另一个用于 discourse (stable 3.0.3)，所有部署后都能正常工作，然而，在几天后…

---

## [在 hosts 文件中添加条目](https://meta.discourse.org/t/adding-an-entry-in-hosts-file/255835)

<div class="topic-metadata">

**Author:** [@Netboy3](https://meta.discourse.org/u/Netboy3)\
**回覆:** 2\
**Last updated:** [2023年六月13日 09:03 UTC](https://meta.discourse.org/t/adding-an-entry-in-hosts-file/255835 "2023-06-13T09:03:17Z")

</div>

我需要在 mail-receiver 容器的 hosts 文件中添加一个条目。有没有办法在安装时使用 YAML 配置中的条目来做到这一点？我尝试过 run: 和 exec: 但都没有成功。

---

## [关于一个 sub-subdomain 的讨论](https://meta.discourse.org/t/discourse-on-a-sub-subdomain/268056)

<div class="topic-metadata">

**Author:** [@FrancescoM](https://meta.discourse.org/u/FrancescoM)\
**回覆:** 2\
**Last updated:** [2023年六月12日 15:37 UTC](https://meta.discourse.org/t/discourse-on-a-sub-subdomain/268056 "2023-06-12T15:37:07Z")

</div>

大家好，是否可以在子子域名上安装 Discourse？ 例如： https://forum.subdomain.domain.com/ 非常感谢您的帮助

---

## [低成本CDN服务资产（半免费）的想法！](https://meta.discourse.org/t/idea-for-low-cost-cdn-service-for-assets-semi-free/267969)

<div class="topic-metadata">

**Author:** [@ARHAEEM](https://meta.discourse.org/u/ARHAEEM)\
**回覆:** 0\
**Last updated:** [2023年六月12日 00:43 UTC](https://meta.discourse.org/t/idea-for-low-cost-cdn-service-for-assets-semi-free/267969 "2023-06-12T00:43:10Z")

</div>

我知道互联网上有很多bbcode论坛要求用户将自己的文件上传到imgur之类的网址，然后在帖子中嵌入网址…… 但在一些独特的论坛上，我发现它们要求用户使用网址上传，但它们使用了缓存……

---

## [如何减少邮件回复频率](https://meta.discourse.org/t/how-to-reduce-the-mail-frequency-of-reply/267916)

<div class="topic-metadata">

**Author:** [@whitewaterdeu](https://meta.discourse.org/u/whitewaterdeu)\
**回覆:** 2\
**Last updated:** [2023年六月11日 03:48 UTC](https://meta.discourse.org/t/how-to-reduce-the-mail-frequency-of-reply/267916 "2023-06-11T03:48:21Z")

</div>

我论坛上的一个用户提到我，论坛发出的邮件太多很烦人。 我查看了管理员设置，并更改了摘要邮件的频率，但我不知道如何更改回复的频率……

---

## [在同一云服务器上使用 Caddy 安装 Discourse 和 N8N (Hetzner Cloud)](https://meta.discourse.org/t/installing-discourse-with-n8n-using-caddy-in-same-cloud-server-hetzner-cloud/267709)

<div class="topic-metadata">

**Author:** [@ARHAEEM](https://meta.discourse.org/u/ARHAEEM)\
**回覆:** 1\
**Last updated:** [2023年六月10日 22:49 UTC](https://meta.discourse.org/t/installing-discourse-with-n8n-using-caddy-in-same-cloud-server-hetzner-cloud/267709 "2023-06-10T22:49:44Z")

</div>

大家好， 可能这是一种不寻常的方式，但我运行了一个Hetzner服务器，发现了Discourse，我计划在将我的服务器从cax11升级到cax21 64x（4核，8GB）之后使用它。我使用了官方

---

## [发送聊天消息时出错\[从 3.1.0beta4 降级到 Stable\]](https://meta.discourse.org/t/error-when-i-send-a-message-in-chat-downgraded-to-stable-from-3-1-0beta4/267780)

<div class="topic-metadata">

**Author:** [@FrancescoM](https://meta.discourse.org/u/FrancescoM)\
**回覆:** 16\
**Last updated:** [2023年六月9日 18:42 UTC](https://meta.discourse.org/t/error-when-i-send-a-message-in-chat-downgraded-to-stable-from-3-1-0beta4/267780 "2023-06-09T18:42:35Z")

</div>

您好，几天前，我将我的 Discourse 版本从 3.1.0.beta4 更改为 3.0.3，因为存在主题安装问题。 现在，当我发送聊天消息时，我会收到此错误： 错误：关系“chat\_uploads”不存在 行 1……

---

## [手动更新 discourse 时需要内核版本升级](https://meta.discourse.org/t/kernel-version-upgrade-required-when-manually-updating-discourse/253756)

<div class="topic-metadata">

**Author:** [@AMK](https://meta.discourse.org/u/AMK)\
**回覆:** 35\
**Last updated:** [2023年六月8日 21:37 UTC](https://meta.discourse.org/t/kernel-version-upgrade-required-when-manually-updating-discourse/253756 "2023-06-08T21:37:40Z")

</div>

在按照此处说明运行更新时：将 Discourse 和 Docker 映像手动更新到最新版本，我会收到以下错误： “不支持内核版本 4.4.0-210-generic，请升级到至少 4.14.0” 我需要做什么……

---

## [新安装的站点显示错误：“Ember CLI 在开发模式下是必需的”](https://meta.discourse.org/t/freshly-installed-site-is-showing-the-error-ember-cli-is-required-in-development-mode/266475)

<div class="topic-metadata">

**Author:** [@ratnamraj\_raj](https://meta.discourse.org/u/ratnamraj_raj)\
**回覆:** 17\
**Last updated:** [2023年六月8日 11:07 UTC](https://meta.discourse.org/t/freshly-installed-site-is-showing-the-error-ember-cli-is-required-in-development-mode/266475 "2023-06-08T11:07:31Z")

</div>

我正在使用 Ruby on Rails 应用程序、nginx 和 passenger ruby - 3.2.2 和 rails 7 但当我尝试从 nginx 配置文件以开发模式运行时 它显示： 要以开发模式运行 Ember CLI，请……

---

## [如何将 Discourse 论坛数据（话题、聊天和配置）迁移到另一台服务器](https://meta.discourse.org/t/how-to-migrate-discourse-forum-data-topics-chat-and-configuration-to-another-server/267203)

<div class="topic-metadata">

**Author:** [@rupesh](https://meta.discourse.org/u/rupesh)\
**回覆:** 5\
**Last updated:** [2023年六月7日 22:06 UTC](https://meta.discourse.org/t/how-to-migrate-discourse-forum-data-topics-chat-and-configuration-to-another-server/267203 "2023-06-07T22:06:58Z")

</div>

我们有一个部署了 Discourse 的公共网站，我们需要将数据恢复到隔离服务器，或/和将数据复制到另一台服务器。我无法简单地进行备份并修改 .sql 来更改域名。是否有可供我使用的迁移工具或指南？

---

## [Let's Encrypt 在防火墙后的 IP 出现问题](https://meta.discourse.org/t/lets-encrypt-failing-for-ip-behind-firewall/267396)

<div class="topic-metadata">

**Author:** [@Qcloud1223](https://meta.discourse.org/u/Qcloud1223)\
**回覆:** 7\
**Last updated:** [2023年六月7日 14:33 UTC](https://meta.discourse.org/t/lets-encrypt-failing-for-ip-behind-firewall/267396 "2023-06-07T14:33:14Z")

</div>

大家好， 安装 Discourse 后，我收到一个 HTTP 502 错误，日志显示： $ sudo ./launcher logs app 检测到 x86\_64 架构。 run-parts: 正在执行 /etc/runit/1.d/00-ensure-links run-parts: 正在执行 /etc/runit/1.d/00…

---

## [我的服务器可以访问github，但是docker不能](https://meta.discourse.org/t/my-server-can-access-github-but-docker-cant/267470)

<div class="topic-metadata">

**Author:** [@whitewaterdeu](https://meta.discourse.org/u/whitewaterdeu)\
**回覆:** 1\
**Last updated:** [2023年六月7日 05:33 UTC](https://meta.discourse.org/t/my-server-can-access-github-but-docker-cant/267470 "2023-06-07T05:33:27Z")

</div>

大家好，我正在使用一台位于香港的服务器，我已经测试过我的服务器可以访问GitHub root@cvm-3k8ngdw25i225:/var/discourse# wget https://github.com/discourse/discourse.git/ --2023-06-07 02:30:54-- https:000...

---

## [无法通过smtp服务器(mailjet)发送邮件](https://meta.discourse.org/t/cant-send-mail-by-smtp-server-mailjet/267201)

<div class="topic-metadata">

**Author:** [@whitewaterdeu](https://meta.discourse.org/u/whitewaterdeu)\
**回覆:** 5\
**Last updated:** [2023年六月6日 12:01 UTC](https://meta.discourse.org/t/cant-send-mail-by-smtp-server-mailjet/267201 "2023-06-06T12:01:25Z")

</div>

你好！我遇到了一个关于发送邮件的问题，任何帮助都将不胜感激 :smiling\_face\_with\_three\_hearts: 我正在使用mailjet作为smtp服务器，我已经设置了app.yml，参考了主题（如何使用Mailjet作为免费SMTP服务…）

---

## [还原失败。请检查日志。](https://meta.discourse.org/t/the-restore-failed-please-check-the-logs/267181)

<div class="topic-metadata">

**Author:** [@inj3ct0r](https://meta.discourse.org/u/inj3ct0r)\
**回覆:** 12\
**Last updated:** [2023年六月5日 20:23 UTC](https://meta.discourse.org/t/the-restore-failed-please-check-the-logs/267181 "2023-06-05T20:23:16Z")

</div>

你好 我刚刚删除了我的旧VPS并购买了新的（所有都在hetzner中），我正在尝试备份上次的编辑。 我得到了这个日志 \[2023-06-04 13:01:35\] 确保 /var/www/discourse/tmp/restores/default/2023-06-04-130135 …

---

## [command的标准安装中的长时间暂停：cd /var/www/discourse && su discourse -c 'bundle install --retry 3 --jobs 4'](https://meta.discourse.org/t/long-pause-in-standard-installation-of-command-cd-var-www-discourse-su-discourse-c-bundle-install-retry-3-jobs-4/267142)

<div class="topic-metadata">

**Author:** [@whitewaterdeu](https://meta.discourse.org/u/whitewaterdeu)\
**回覆:** 5\
**Last updated:** [2023年六月4日 10:55 UTC](https://meta.discourse.org/t/long-pause-in-standard-installation-of-command-cd-var-www-discourse-su-discourse-c-bundle-install-retry-3-jobs-4/267142 "2023-06-04T10:55:11Z")

</div>

大家好！我是来自中国的 Discourse 新用户，在标准安装中遇到了一个奇怪的问题。执行 ./discourse-setup 命令后，我的终端卡在了该命令上很长时间（超过 20 分钟……

[上一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=44)

[下一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=46)
