# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=6

[最新版本](https://meta.discourse.org/latest.md) · [分類](https://meta.discourse.org/categories.md) · [標簽](https://meta.discourse.org/tags.md)

**Page:** 7

---

## [Discourse Docker 服务无法正常启动](https://meta.discourse.org/t/discourse-docker/393857)

<div class="topic-metadata">

**Author:** [@AkarinLiu](https://meta.discourse.org/u/AkarinLiu)\
**回覆:** 2\
**Last updated:** [2026年一月20日 13:20 UTC](https://meta.discourse.org/t/discourse-docker/393857 "2026-01-20T13:20:31Z")

</div>

我想在本地试用 Discourse，于是使用了 Docker Compose 尝试搭建： version: '3.8' services: postgres: image: pgvector/pgvector:pg17 container\_name: discourse-postgres restart: always environment: POSTGRES\_USER: disco…

---

## [体验报告：IDN 域名](https://meta.discourse.org/t/experience-report-idn-domain-name/393882)

<div class="topic-metadata">

**Author:** [@John\_Platte](https://meta.discourse.org/u/John_Platte)\
**回覆:** 0\
**Last updated:** [2026年一月20日 13:09 UTC](https://meta.discourse.org/t/experience-report-idn-domain-name/393882 "2026-01-20T13:09:44Z")

</div>

我正在自托管一个 Discourse 实例，刚刚切换到了一个国际化域名（非拉丁字符）。想分享几点让这次切换比预期更曲折的因素： 首先：ask.discourse.com 错误地……

---

## [哪些版本的 AWS Aurora Postgres 受支持？](https://meta.discourse.org/t/which-versions-of-aws-aurora-postgres-are-supported/393871)

<div class="topic-metadata">

**Author:** [@stevejr](https://meta.discourse.org/u/stevejr)\
**回覆:** 1\
**Last updated:** [2026年一月20日 11:42 UTC](https://meta.discourse.org/t/which-versions-of-aws-aurora-postgres-are-supported/393871 "2026-01-20T11:42:30Z")

</div>

您好， 根据官方的独立 Postgres 安装文档，Postgres v13 是受支持的，但更高版本可能工作也可能不工作。这份文档相当旧了，所以不确定这个说法是否仍然正确。 鉴于 AWS 的 V13……

---

## [各种多站点安装问题](https://meta.discourse.org/t/various-multisite-installation-questions/398693)

<div class="topic-metadata">

**Author:** [@Isambard](https://meta.discourse.org/u/Isambard)\
**回覆:** 9\
**Last updated:** [2026年一月19日 21:15 UTC](https://meta.discourse.org/t/various-multisite-installation-questions/398693 "2026-01-19T21:15:09Z")

</div>

我想知道上面建议配置中的 \`db\_id: 2\` 值是做什么用的？ 另外，向现有多站点设置中添加新站点的过程是什么？是只需： 更新 yaml \`./launcher bootstrap multisite \[1\]\` ……

---

## [卡在“注册管理员账户”界面，即使管理员用户已激活](https://meta.discourse.org/t/stuck-at-register-admin-account-even-with-an-activated-admin-user/393828)

<div class="topic-metadata">

**Author:** [@Florent](https://meta.discourse.org/u/Florent)\
**回覆:** 1\
**Last updated:** [2026年一月19日 20:34 UTC](https://meta.discourse.org/t/stuck-at-register-admin-account-even-with-an-activated-admin-user/393828 "2026-01-19T20:34:12Z")

</div>

您好， 我已在 VPS 上安装了 Discourse。当我访问用户界面时，我看到 我点击“注册”按钮，但出现 尽管我有一个活跃的管理员用户： 我还需要做些什么？ 编辑：我尝试过使用隐身模式……

---

## [\[多站点安装\] pnpm 在重建过程中出现权限错误](https://meta.discourse.org/t/mutlisite-installation-pnpm-permission-error-during-rebuild/393702)

<div class="topic-metadata">

**Author:** [@Padoup-Padoup](https://meta.discourse.org/u/Padoup-Padoup)\
**回覆:** 4\
**Last updated:** [2026年一月16日 20:21 UTC](https://meta.discourse.org/t/mutlisite-installation-pnpm-permission-error-during-rebuild/393702 "2026-01-16T20:21:51Z")

</div>

您好， 我无法升级/重建我的 \`web\_only\` 容器。调用 \`multisite migrate\` 时，重建似乎失败了。全新安装（没有数据，只有我的 \`data.yml\` 和 \`web\_only.yml\` 文件）会产生相同的错误（重建……

---

## [配置QQ邮箱发件，邮件正常到达，但是Discourse报错，会重复发送](https://meta.discourse.org/t/qq-discourse/392616)

<div class="topic-metadata">

**Author:** [@qi\_lu](https://meta.discourse.org/u/qi_lu)\
**回覆:** 8\
**Last updated:** [2026年一月14日 12:59 UTC](https://meta.discourse.org/t/qq-discourse/392616 "2026-01-14T12:59:45Z")

</div>

我最初遵守的安装教程： 我的设置： DISCOURSE\_DEVELOPER\_EMAILS: 'xxx@gmail.com' ## TODO: Configure the mail server ## (used for validation of new accounts, notifications, digests, etc.) ## required: hostname of the SMTP m…

---

## [最佳的 Discourse 托管网站？](https://meta.discourse.org/t/best-hosting-sites-for-discourse/393411)

<div class="topic-metadata">

**Author:** [@westes](https://meta.discourse.org/u/westes)\
**回覆:** 1\
**Last updated:** [2026年一月14日 07:27 UTC](https://meta.discourse.org/t/best-hosting-sites-for-discourse/393411 "2026-01-14T07:27:14Z")

</div>

我正在研究运行自己的云服务器以学习 Discourse 的基础知识。鉴于我的 UNIX 管理技能仅够我自己“上吊”，我想对我的选择有一个宏观的了解。首先，最好的托管……

---

## [Windows 服务器发布方法](https://meta.discourse.org/t/windows-server-publish-method/393215)

<div class="topic-metadata">

**Author:** [@vijayan\_mmm](https://meta.discourse.org/u/vijayan_mmm)\
**回覆:** 1\
**Last updated:** [2026年一月12日 10:49 UTC](https://meta.discourse.org/t/windows-server-publish-method/393215 "2026-01-12T10:49:39Z")

</div>

希望我们可以在 Windows/Mac 系统上安装它。当前的启动器脚本查找 Linux 系统，我在 Mac 和 Windows 上运行它总是失败。

---

## [“rename\_discourse\_rewind\_disabled\_to\_enabled”中的迁移错误](https://meta.discourse.org/t/migration-error-in-rename-discourse-rewind-disabled-to-enabled/393049)

<div class="topic-metadata">

**Author:** [@sniper756](https://meta.discourse.org/u/sniper756)\
**回覆:** 25\
**Last updated:** [2026年一月11日 18:49 UTC](https://meta.discourse.org/t/migration-error-in-rename-discourse-rewind-disabled-to-enabled/393049 "2026-01-11T18:49:01Z")

</div>

重新rebuild 失败了~日志如下： discourse -c 'bundle exec rake db:migrate' rake aborted! StandardError: An error has occurred, this and all later migrations canceled: (StandardError) You must drop a column's default value before m…

---

## [安装插件后报错，\*\* failed to bootstrap \*\*](https://meta.discourse.org/t/failed-to-bootstrap/393174)

<div class="topic-metadata">

**Author:** [@xu2](https://meta.discourse.org/u/xu2)\
**回覆:** 4\
**Last updated:** [2026年一月11日 11:08 UTC](https://meta.discourse.org/t/failed-to-bootstrap/393174 "2026-01-11T11:08:30Z")

</div>

下午试着安装几个插件，但是重建时就出现了这个错误： 2026-01-11 09:16:55.588 UTC \\\[45\\\] LOG: received fast shutdown request I, \\\[2026-01-11T09:16:55.588399 #1\\\] INFO – : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/re…

---

## [关于安装后镜像的处理](https://meta.discourse.org/t/topic/393129)

<div class="topic-metadata">

**Author:** [@sniper756](https://meta.discourse.org/u/sniper756)\
**回覆:** 2\
**Last updated:** [2026年一月10日 06:48 UTC](https://meta.discourse.org/t/topic/393129 "2026-01-10T06:48:11Z")

</div>

家人们，我是用docker 部署安装的discourse. 每次rebuild后，docker中就会生成一个本机镜像。请问以下镜像是干什么用的？能删除么？ discourse/base:2.0.20251003-1437 discourse/base:2.0.20260109-0020 谢谢。

---

## [在 Discourse 中使用 Azure Communication Service 配置 SMTP 时遇到困难](https://meta.discourse.org/t/struggling-to-configure-smtp-in-discourse-with-azure-communication-service/290511)

<div class="topic-metadata">

**Author:** [@gichamba](https://meta.discourse.org/u/gichamba)\
**回覆:** 9\
**Last updated:** [2026年一月9日 17:49 UTC](https://meta.discourse.org/t/struggling-to-configure-smtp-in-discourse-with-azure-communication-service/290511 "2026-01-09T17:49:07Z")

</div>

大家好， 我一直在努力在我的 Discourse 安装中设置 SMTP，这确实是一个挑战。我查阅了许多帖子，例如这一个，但都没有成功。 情况是这样的：我怀疑我的问题与我必须使用的用户名和密码的格式及长度有关。我正在使用 Azure Communication Service 作为我的 SMTP 服务器，这需要一种特定的配置，其中涉及 Azure Entra 应用程序（以前称为 Azure Active Directory）。 直奔…

---

## [升级 Ubuntu 25.10 后无法更新 Discourse](https://meta.discourse.org/t/cannot-update-discourse-after-ubuntu-25-10-upgrade/393079)

<div class="topic-metadata">

**Author:** [@Andro](https://meta.discourse.org/u/Andro)\
**回覆:** 6\
**Last updated:** [2026年一月9日 16:47 UTC](https://meta.discourse.org/t/cannot-update-discourse-after-ubuntu-25-10-upgrade/393079 "2026-01-09T16:47:20Z")

</div>

救命！ 由于 25.04 即将停止支持 (EOL)，我已将服务器升级到 Ubuntu 25.10。现在当我尝试更新 Discourse 时，总是出现以下错误： 是什么导致了这个问题？

---

## [关于discourse部署后更新升级问题](https://meta.discourse.org/t/discourse/392972)

<div class="topic-metadata">

**Author:** [@sniper756](https://meta.discourse.org/u/sniper756)\
**回覆:** 5\
**Last updated:** [2026年一月9日 02:04 UTC](https://meta.discourse.org/t/discourse/392972 "2026-01-09T02:04:01Z")

</div>

大家好，我是discourse新手，我想请教一下，discourse部署成功后，查看管理有台有可更新的版本。我发现有两种升级方法： 1、通过ssh，进入discourse目录后，运行./launcher rebuild app 进行升级更新 2、通过discourse-管理员-更新discourse-更新 请问这两种方法有什么区别？优先采取那种升级方法？ 谢谢

---

## [Sidekiq redis 数据库索引超出范围](https://meta.discourse.org/t/sidekiq-redis-db-index-out-of-range/393012)

<div class="topic-metadata">

**Author:** [@kyfrankie](https://meta.discourse.org/u/kyfrankie)\
**回覆:** 0\
**Last updated:** [2026年一月8日 21:45 UTC](https://meta.discourse.org/t/sidekiq-redis-db-index-out-of-range/393012 "2026-01-08T21:45:58Z")

</div>

使用外部 Redis 数据库（Azure 托管的 Redis）进行安装，该数据库仅提供一个数据库实例。Sidekiq 尝试连接到不允许的 DB 1。是否有办法强制所有 Sidekiq 实例连接到……

---

## [升级中止 - Unicorn 工作进程运行不足](https://meta.discourse.org/t/upgrade-abort-not-enough-unicorn-workers-running/393003)

<div class="topic-metadata">

**Author:** [@m\_terenui](https://meta.discourse.org/u/m_terenui)\
**回覆:** 4\
**Last updated:** [2026年一月8日 20:33 UTC](https://meta.discourse.org/t/upgrade-abort-not-enough-unicorn-workers-running/393003 "2026-01-08T20:33:57Z")

</div>

亲爱的，晚上好， 希望您一切都好！！ 我正尝试升级我的自托管实例上的 Discourse，但收到了以下错误消息： \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\* \*\*\* 请保持 p……

---

## [访问 /admin/upgrade 可能导致服务器错误](https://meta.discourse.org/t/visiting-admin-upgrade-may-lead-to-a-server-error/274411)

<div class="topic-metadata">

**Author:** [@david](https://meta.discourse.org/u/david)\
**回覆:** 1\
**Last updated:** [2023年十二月15日 21:16 UTC](https://meta.discourse.org/t/visiting-admin-upgrade-may-lead-to-a-server-error/274411 "2023-12-15T21:16:20Z")

</div>

如果您当前运行的 Discourse 标准安装版本早于 v3.1.0.beta7（或稳定版早于 v3.0.6），则在尝试通过管理界面升级时可能会遇到此错误： ……

---

## [重建时内存不足，即使有 4GB 交换空间？](https://meta.discourse.org/t/out-of-memory-on-rebuild-with-4gb-swap/392831)

<div class="topic-metadata">

**Author:** [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**回覆:** 12\
**Last updated:** [2026年一月8日 07:44 UTC](https://meta.discourse.org/t/out-of-memory-on-rebuild-with-4gb-swap/392831 "2026-01-08T07:44:37Z")

</div>

我今天遇到了几次双容器引导失败，错误信息类似 ERR\_PNPM\_RECURSIVE\_EXEC\_FIRST\_FAIL 命令被 SIGKILL 终止（强制终止）：ember build -prod"\] 我认为一旦我添加了交换空间，并且它...

---

## [管理界面中不再有更新？](https://meta.discourse.org/t/updates-no-longer-in-the-admin-ui/392726)

<div class="topic-metadata">

**Author:** [@DavidO](https://meta.discourse.org/u/DavidO)\
**回覆:** 11\
**Last updated:** [2026年一月7日 15:31 UTC](https://meta.discourse.org/t/updates-no-longer-in-the-admin-ui/392726 "2026-01-07T15:31:02Z")

</div>

根据我读到的信息，我猜这个功能被移除了？现在管理界面中没有点击更新的选项了吗？ 我不确定我落后了多少，这个改动有多新，或者是否可以以某种方式重新启用它。它曾是……

---

## [用 Podman 部署](https://meta.discourse.org/t/deploy-with-podman/348930)

<div class="topic-metadata">

**Author:** [@max.hammer](https://meta.discourse.org/u/max.hammer)\
**回覆:** 2\
**Last updated:** [2026年一月6日 09:14 UTC](https://meta.discourse.org/t/deploy-with-podman/348930 "2026-01-06T09:14:21Z")

</div>

大家好 你们有人成功用 Podman 运行 Discourse 了吗？ 此致

---

## [这意味着所有内容都在自动更新吗？](https://meta.discourse.org/t/does-this-mean-everything-is-auto-updating/392617)

<div class="topic-metadata">

**Author:** [@stephtara](https://meta.discourse.org/u/stephtara)\
**回覆:** 2\
**Last updated:** [2026年一月4日 02:37 UTC](https://meta.discourse.org/t/does-this-mean-everything-is-auto-updating/392617 "2026-01-04T02:37:26Z")

</div>

您好！我是一名新的 Discourse 管理员。我的一个懂技术的朋友帮我安装的，所以我可能缺少一些如果我自己安装就会有的先验知识。 我在我的管理空间里看到了这个： 这是否意味着事情……

---

## [Pros and cons of multiple standalone containers vs one for multiple Discourse installs?](https://meta.discourse.org/t/pros-and-cons-of-multiple-standalone-containers-vs-one-for-multiple-discourse-installs/32978)

<div class="topic-metadata">

**Author:** [@AstonJ](https://meta.discourse.org/u/AstonJ)\
**回覆:** 5\
**Last updated:** [2026年一月3日 07:47 UTC](https://meta.discourse.org/t/pros-and-cons-of-multiple-standalone-containers-vs-one-for-multiple-discourse-installs/32978 "2026-01-03T07:47:13Z")

</div>

There seems to be two options for multiple Discoure installs, multiple containers or one - what are the pros and cons of each, and perhaps, which do you think makes more sense for my needs (see below)? My server is set …

---

## [AWS CDN 和 S3 的问题](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132)

<div class="topic-metadata">

**Author:** [@philh](https://meta.discourse.org/u/philh)\
**回覆:** 22\
**Last updated:** [2025年十二月30日 04:20 UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132 "2025-12-30T04:20:27Z")

</div>

@Falco 这种情况仍然存在吗？我记得读到过一些关于使用 AWS 的近期问题的文章，但我找不到那个主题了。 我在使用各种相关主题作为指南时，在使用 AWS S3 时遇到了许多问题。 备份正在起作用……

---

## [是否应该将我的交换文件从 2GB 增加？](https://meta.discourse.org/t/should-i-increase-the-swap-file-from-2gb/391808)

<div class="topic-metadata">

**Author:** [@alltiagocom](https://meta.discourse.org/u/alltiagocom)\
**回覆:** 14\
**Last updated:** [2025年十二月27日 20:30 UTC](https://meta.discourse.org/t/should-i-increase-the-swap-file-from-2gb/391808 "2025-12-27T20:30:38Z")

</div>

我最近在 Hetzner 服务器上重新安装了 Discourse。现在我有 4GB 内存和 40GB 空间。默认情况下，它创建了 2GB 的交换文件。 这足够吗？

---

## [为个人使用（笔记本电脑 \<-\> VPS）安装 tailscale magicdns](https://meta.discourse.org/t/install-with-tailscale-magicdns-for-personal-use-laptop-vps/392079)

<div class="topic-metadata">

**Author:** [@dontdieych](https://meta.discourse.org/u/dontdieych)\
**回覆:** 5\
**Last updated:** [2025年十二月25日 10:39 UTC](https://meta.discourse.org/t/install-with-tailscale-magicdns-for-personal-use-laptop-vps/392079 "2025-12-25T10:39:01Z")

</div>

您好，我想在通过 Tailscale 连接到我笔记本电脑的 VPS 上安装 Discourse。用于个人笔记/维基/日记/随便什么。我可以使用 Tailscale 的 magicdns 来 ping/ssh/https 到 VPS（例如 abc.a-b.ts.net）。只有我这一个用户……

---

## [Discourse/Discourse Docker 镜像中内置主题预览图片丢失 (404)](https://meta.discourse.org/t/built-in-theme-preview-images-missing-404-in-discourse-discourse-docker-image/391859)

<div class="topic-metadata">

**Author:** [@YuriEarth](https://meta.discourse.org/u/YuriEarth)\
**回覆:** 1\
**Last updated:** [2025年十二月21日 21:33 UTC](https://meta.discourse.org/t/built-in-theme-preview-images-missing-404-in-discourse-discourse-docker-image/391859 "2025-12-21T21:33:25Z")

</div>

我正在使用实验性的 \`discourse/discourse:3.5.1\` Docker 镜像（通过 Docker Compose，而不是启动器）运行 Discourse，并注意到管理员主题页面中内置的主题预览图片返回 404 错误……

---

## [使用rsync迁移discourse时遇到的Postgresql问题](https://meta.discourse.org/t/postgresql-problem-on-moving-discourse-with-rsync/318771)

<div class="topic-metadata">

**Author:** [@Saiano](https://meta.discourse.org/u/Saiano)\
**回覆:** 15\
**Last updated:** [2025年十二月19日 20:57 UTC](https://meta.discourse.org/t/postgresql-problem-on-moving-discourse-with-rsync/318771 "2025-12-19T20:57:01Z")

</div>

我正在将我的 discourse 迁移到新的 vps，使用了 使用 rsync 将 Discourse 站点迁移到另一台 VPS - 文档 / 自托管 - Discourse Meta 复制完所有文件后，运行 /discourse-setup 时出现此错误： 570:M 27 Jul 2024 14:26:52.569 # 警告：无法创建服务器 TCP 监听套接字 \*:6379：bind：地址已在使用中 570:M 27 Jul …

---

## [使用 S3 CDN 上传时的异地备份](https://meta.discourse.org/t/off-site-backup-when-using-s3-cdn-for-uploads/391736)

<div class="topic-metadata">

**Author:** [@Overgrow](https://meta.discourse.org/u/Overgrow)\
**回覆:** 5\
**Last updated:** [2025年十二月19日 14:52 UTC](https://meta.discourse.org/t/off-site-backup-when-using-s3-cdn-for-uploads/391736 "2025-12-19T14:52:51Z")

</div>

对于那些使用 S3 CDN 进行上传的用户，除了仅依赖 CDN 之外，你们采用哪些方法来维护文件的异地备份？我对大家的备份策略和任何替代方案很感兴趣……

---

## [新安装的discourse无法使用网易邮箱发送验证邮件？](https://meta.discourse.org/t/discourse/391621)

<div class="topic-metadata">

**Author:** [@wenviwu](https://meta.discourse.org/u/wenviwu)\
**回覆:** 5\
**Last updated:** [2025年十二月19日 00:40 UTC](https://meta.discourse.org/t/discourse/391621 "2025-12-19T00:40:39Z")

</div>

docker环境 discourse 3.5.1版本下，新安装的discourse无法使用网易邮箱发送验证邮件？

[上一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=5)

[下一頁](https://meta.discourse.org/c/support/self-hosting/31.md?page=7)
