# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=66

[Latest](https://meta.discourse.org/latest.md) · [Categories](https://meta.discourse.org/categories.md) · [Tags](https://meta.discourse.org/tags.md)

**Page:** 67

---

## [Need help! Rebuild app, no space left on device](https://meta.discourse.org/t/need-help-rebuild-app-no-space-left-on-device/52794)

<div class="topic-metadata">

**Author:** [@Nam\_Nguyen](https://meta.discourse.org/u/Nam_Nguyen)\
**Replies:** 3\
**Last updated:** [November 11, 2016, 8:39am UTC](https://meta.discourse.org/t/need-help-rebuild-app-no-space-left-on-device/52794 "2016-11-11T08:39:39Z")

</div>

Hello, I try to add plugin to app.yml file , but when I run Rebuild app, I have Error in bellow, can anyone help me please, Thank you so much :slight\_smile: 155:M 11 Nov 08:14:09.904 # Error trying to save the DB, can'…

---

## [Just Created My First Instance But Need Help](https://meta.discourse.org/t/just-created-my-first-instance-but-need-help/224381)

<div class="topic-metadata">

**Author:** [@SamGreenwood](https://meta.discourse.org/u/SamGreenwood)\
**Replies:** 35\
**Last updated:** [April 28, 2022, 4:31am UTC](https://meta.discourse.org/t/just-created-my-first-instance-but-need-help/224381 "2022-04-28T04:31:26Z")

</div>

I got the instance I created up and running a few hours ago but am having the following issues: not staying logged in randomly 404ing (Is it possible that my IP root domain (sometimes) leads configuration wizard even t…

---

## [Thread:0x000055c972f94c78](https://meta.discourse.org/t/thread-0x000055c972f94c78/225448)

<div class="topic-metadata">

**Author:** [@Justman10000](https://meta.discourse.org/u/Justman10000)\
**Replies:** 1\
**Last updated:** [April 27, 2022, 4:15pm UTC](https://meta.discourse.org/t/thread-0x000055c972f94c78/225448 "2022-04-27T16:15:40Z")

</div>

After the previous problem, now a new one appears! #\<Thread:0x000055c972f94c78 /home/discourse/lib/scheduler/defer.rb:79 run\> terminated with exception (report\_on\_exception is true): /usr/local/rvm/gems/ruby-3.0.2/gem…

---

## [Installing for production via Docker on existing server with Litespeed?](https://meta.discourse.org/t/installing-for-production-via-docker-on-existing-server-with-litespeed/225420)

<div class="topic-metadata">

**Author:** [@Serb](https://meta.discourse.org/u/Serb)\
**Replies:** 3\
**Last updated:** [April 27, 2022, 3:10pm UTC](https://meta.discourse.org/t/installing-for-production-via-docker-on-existing-server-with-litespeed/225420 "2022-04-27T15:10:04Z")

</div>

If I follow the installation steps here: how would that work out with my existing CentOS cPanel server running Litespeed instead of Apache as a webserver, with a dozen other websites on the server already? What tweak…

---

## [Ports blocked (Hetzner cloud server)](https://meta.discourse.org/t/ports-blocked-hetzner-cloud-server/225146)

<div class="topic-metadata">

**Author:** [@Paketbote](https://meta.discourse.org/u/Paketbote)\
**Replies:** 16\
**Last updated:** [April 26, 2022, 7:36pm UTC](https://meta.discourse.org/t/ports-blocked-hetzner-cloud-server/225146 "2022-04-26T19:36:57Z")

</div>

Hi, I’m trying to install Discourse on a cloud server from Hetzner but when running ./discourse-setup I get the message that ports are blocked (domain.de is obviously not the real domain): WARNING: Port 443 of computer…

---

## [Free Hosting - Any Ideas?](https://meta.discourse.org/t/free-hosting-any-ideas/225352)

<div class="topic-metadata">

**Author:** [@firozkhanuk1214](https://meta.discourse.org/u/firozkhanuk1214)\
**Replies:** 8\
**Last updated:** [April 26, 2022, 6:38pm UTC](https://meta.discourse.org/t/free-hosting-any-ideas/225352 "2022-04-26T18:38:53Z")

</div>

I’ve been looking for free forever hosting for Discourse but I find nothing. Any ideas?

---

## [Uploads missing after restore](https://meta.discourse.org/t/uploads-missing-after-restore/225121)

<div class="topic-metadata">

**Author:** [@ABC\_123](https://meta.discourse.org/u/ABC_123)\
**Replies:** 3\
**Last updated:** [April 24, 2022, 12:33pm UTC](https://meta.discourse.org/t/uploads-missing-after-restore/225121 "2022-04-24T12:33:08Z")

</div>

I’m trying to move my Discourse instance to a different server. I tried using the restore option in the admin dashboard on the destination server but it kept failing with this error: \[2022-04-23 21:59:00\] Remapping upl…

---

## [Discourse run error in k8s](https://meta.discourse.org/t/discourse-run-error-in-k8s/224732)

<div class="topic-metadata">

**Author:** [@Yaoqi\_Yan](https://meta.discourse.org/u/Yaoqi_Yan)\
**Replies:** 5\
**Last updated:** [April 24, 2022, 6:17am UTC](https://meta.discourse.org/t/discourse-run-error-in-k8s/224732 "2022-04-24T06:17:47Z")

</div>

I would like to install discourse in K8s. The Docker works well in local environment but report bellow error after upload to k8s. Looks like related to postures and redis. Can anybody help? run-parts: executing /etc/ru…

---

## [Mail system not working even thought I tested it with telnet and other platforms](https://meta.discourse.org/t/mail-system-not-working-even-thought-i-tested-it-with-telnet-and-other-platforms/163089)

<div class="topic-metadata">

**Author:** [@AshuGuptaGamer](https://meta.discourse.org/u/AshuGuptaGamer)\
**Replies:** 8\
**Last updated:** [April 23, 2022, 7:33pm UTC](https://meta.discourse.org/t/mail-system-not-working-even-thought-i-tested-it-with-telnet-and-other-platforms/163089 "2022-04-23T19:33:28Z")

</div>

For some reason, I am not getting a mail from my discourse setup. I already tested my SMTP settings and they are working for other platforms Also tested it with Telnet.

---

## [PostgreSQL 13+ required for production?](https://meta.discourse.org/t/postgresql-13-required-for-production/225095)

<div class="topic-metadata">

**Author:** [@silverdr](https://meta.discourse.org/u/silverdr)\
**Replies:** 2\
**Last updated:** [April 23, 2022, 5:02pm UTC](https://meta.discourse.org/t/postgresql-13-required-for-production/225095 "2022-04-23T17:02:30Z")

</div>

Reading The Fine README I found the “minimum versions: Ruby 2.7+, PostgreSQL 13+, \[…\]” Since the servers I’d like to run Discourse on, all have already PostgreSQL 12.x installed and serving other applications, I find it …

---

## [Discourse Rebuild not working](https://meta.discourse.org/t/discourse-rebuild-not-working/225073)

<div class="topic-metadata">

**Author:** [@vmsman](https://meta.discourse.org/u/vmsman)\
**Replies:** 4\
**Last updated:** [April 23, 2022, 4:22am UTC](https://meta.discourse.org/t/discourse-rebuild-not-working/225073 "2022-04-23T04:22:46Z")

</div>

I had an error message when trying to add a post with an embedded graphic. It appeared that there was a file protection issue and it was suggested that I perform: ./launcher rebuild app I did that and got these errors…

---

## [Failed to upgrade to v2.9.0beta3](https://meta.discourse.org/t/failed-to-upgrade-to-v2-9-0beta3/221953)

<div class="topic-metadata">

**Author:** [@hellekin](https://meta.discourse.org/u/hellekin)\
**Replies:** 8\
**Last updated:** [March 25, 2022, 10:54pm UTC](https://meta.discourse.org/t/failed-to-upgrade-to-v2-9-0beta3/221953 "2022-03-25T22:54:15Z")

</div>

From v2.9.0beta2 on a multisite, multicontainer setup: == 20220304162250 EnableUnaccentExtension: migrating ========================== -- enable\_extension("unaccent") Docker Manager: FAILED TO UPGRADE #\<RuntimeError: Ru…

---

## [Docker plugin update broke site during latest update](https://meta.discourse.org/t/docker-plugin-update-broke-site-during-latest-update/225031)

<div class="topic-metadata">

**Author:** [@Drew-ART](https://meta.discourse.org/u/Drew-ART)\
**Replies:** 5\
**Last updated:** [April 22, 2022, 4:39pm UTC](https://meta.discourse.org/t/docker-plugin-update-broke-site-during-latest-update/225031 "2022-04-22T16:39:04Z")

</div>

I ran the latest update. The update page 1st prompted me to update the Docker plugin. After doing so i got the message saying i’d need to rebuild the apps in the server as there was an issue with the site image, which se…

---

## [Can't Reach Site (Take 2)](https://meta.discourse.org/t/cant-reach-site-take-2/225037)

<div class="topic-metadata">

**Author:** [@TheEngineer](https://meta.discourse.org/u/TheEngineer)\
**Replies:** 1\
**Last updated:** [April 22, 2022, 2:21pm UTC](https://meta.discourse.org/t/cant-reach-site-take-2/225037 "2022-04-22T14:21:35Z")

</div>

Well, I find myself in a similar predicament as I did earlier in the week. I had a typo in app.yml before that was preventing my site from being reached. I’m going through the Change the Domain thread and the rake compl…

---

## [My website is always down](https://meta.discourse.org/t/my-website-is-always-down/225006)

<div class="topic-metadata">

**Author:** [@danielabc](https://meta.discourse.org/u/danielabc)\
**Replies:** 46\
**Last updated:** [April 22, 2022, 12:13pm UTC](https://meta.discourse.org/t/my-website-is-always-down/225006 "2022-04-22T12:13:18Z")

</div>

server error when trying to load /latest.json?ascending=false Error code: 500 error This page is not working www.dexforum.com.br is currently unable to fulfill this request. HTTP 500 ERROR Why is this happening? How…

---

## [Cloudflare Tunnel Pi Help](https://meta.discourse.org/t/cloudflare-tunnel-pi-help/224938)

<div class="topic-metadata">

**Author:** [@bloodshot\_pico](https://meta.discourse.org/u/bloodshot_pico)\
**Replies:** 6\
**Last updated:** [April 21, 2022, 5:56pm UTC](https://meta.discourse.org/t/cloudflare-tunnel-pi-help/224938 "2022-04-21T17:56:14Z")

</div>

So I had the Discourse software up and running fine yesterday, and I woke up today ready to handle the task of setting up my tunnel with Cloudflare. I’m pretty sure I followed all the steps correctly etc. However I must…

---

## [Unable to update Discourse...help?](https://meta.discourse.org/t/unable-to-update-discourse-help/224303)

<div class="topic-metadata">

**Author:** [@mallorycs](https://meta.discourse.org/u/mallorycs)\
**Replies:** 5\
**Last updated:** [April 21, 2022, 6:00pm UTC](https://meta.discourse.org/t/unable-to-update-discourse-help/224303 "2022-04-21T18:00:11Z")

</div>

When I try to update Discourse, I get this: You are running an old version of the Discourse image. Upgrades via the web UI are disabled until you run the latest image. To do so log in to your server using SSH and run: …

---

## [Activation emails go to spam](https://meta.discourse.org/t/activation-emails-go-to-spam/121863)

<div class="topic-metadata">

**Author:** [@calebs](https://meta.discourse.org/u/calebs)\
**Replies:** 6\
**Last updated:** [July 3, 2019, 2:10am UTC](https://meta.discourse.org/t/activation-emails-go-to-spam/121863 "2019-07-03T02:10:28Z")

</div>

This is my 3rd time installing Discourse and I’m experiencing this issue for the first time. Whenever you make an account, the activation email goes to spam’s folder. Already tested with Gmail and Hotmail. Mail-tester sh…

---

## [Redis version error when I run bundle exec db:create](https://meta.discourse.org/t/redis-version-error-when-i-run-bundle-exec-db-create/224896)

<div class="topic-metadata">

**Author:** [@Zeshan\_Raja](https://meta.discourse.org/u/Zeshan_Raja)\
**Replies:** 0\
**Last updated:** [April 21, 2022, 2:26am UTC](https://meta.discourse.org/t/redis-version-error-when-i-run-bundle-exec-db-create/224896 "2022-04-21T02:26:25Z")

</div>

Hi! I trying to following the directions seen here: However, when I try to run bundle exec rake db:create, I get the following error: nil versions are discouraged and will be deprecated in Rubygems 4 Discourse requir…

---

## [Update from 2.9.0beta1 to beta4 failed](https://meta.discourse.org/t/update-from-2-9-0beta1-to-beta4-failed/224766)

<div class="topic-metadata">

**Author:** [@sunjam](https://meta.discourse.org/u/sunjam)\
**Replies:** 17\
**Last updated:** [April 20, 2022, 7:29pm UTC](https://meta.discourse.org/t/update-from-2-9-0beta1-to-beta4-failed/224766 "2022-04-20T19:29:45Z")

</div>

I, \[2022-04-19T19:46:59.893019 #1\] INFO -- : Terminating async processes I, \[2022-04-19T19:46:59.893129 #1\] INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U po…

---

## [Activation Email Help](https://meta.discourse.org/t/activation-email-help/224760)

<div class="topic-metadata">

**Author:** [@bloodshot\_pico](https://meta.discourse.org/u/bloodshot_pico)\
**Replies:** 10\
**Last updated:** [April 20, 2022, 4:01pm UTC](https://meta.discourse.org/t/activation-email-help/224760 "2022-04-20T16:01:12Z")

</div>

So I’ve got Discourse up and running on my Pi, however I’m trying to run my emails through Zoho and I’ve got my Cloudflare rules applied to allow Zoho use the domain for the custom emails. I do get an email to my Zoho in…

---

## [Restoring Backup, 'Email Protected' and can't receive emails](https://meta.discourse.org/t/restoring-backup-email-protected-and-cant-receive-emails/224663)

<div class="topic-metadata">

**Author:** [@ethhaqn](https://meta.discourse.org/u/ethhaqn)\
**Replies:** 6\
**Last updated:** [April 20, 2022, 2:02pm UTC](https://meta.discourse.org/t/restoring-backup-email-protected-and-cant-receive-emails/224663 "2022-04-20T14:02:29Z")

</div>

So I created a backup of Discourse on my old VPS (I’ve now done a fresh reinstall). I tried running discourse enable\_restore and discourse restore \[file\] as recommended here, however I keep receiving back discourse: comm…

---

## [502 Bad Gateway after trying to rebuild test-passed branch](https://meta.discourse.org/t/502-bad-gateway-after-trying-to-rebuild-test-passed-branch/224560)

<div class="topic-metadata">

**Author:** [@waerfa](https://meta.discourse.org/u/waerfa)\
**Replies:** 5\
**Last updated:** [April 17, 2022, 10:15pm UTC](https://meta.discourse.org/t/502-bad-gateway-after-trying-to-rebuild-test-passed-branch/224560 "2022-04-17T22:15:37Z")

</div>

I tried to rebuild app after I followed the instruction about this: Change tracking branch for your Discourse instance, but when I update the app.yml and rebuild the container: git pull ./launcher rebuild app I got th…

---

## [Resizing images after upload settings](https://meta.discourse.org/t/resizing-images-after-upload-settings/72889)

<div class="topic-metadata">

**Author:** [@TerminalAddict](https://meta.discourse.org/u/TerminalAddict)\
**Replies:** 25\
**Last updated:** [April 17, 2022, 8:16pm UTC](https://meta.discourse.org/t/resizing-images-after-upload-settings/72889 "2022-04-17T20:16:57Z")

</div>

Hi All, totally confused after reading threads here about image resizing etc. I’ve set “client\_max\_body\_size” to 102400 in admin-\>settings-files to allow uploading from cellphones. But I cannot for the life of me figu…

---

## [SSL Certificate](https://meta.discourse.org/t/ssl-certificate/224489)

<div class="topic-metadata">

**Author:** [@ethhaqn](https://meta.discourse.org/u/ethhaqn)\
**Replies:** 1\
**Last updated:** [April 16, 2022, 7:42pm UTC](https://meta.discourse.org/t/ssl-certificate/224489 "2022-04-16T19:42:34Z")

</div>

Please can someone help me setup an SSL certificate so I can use https? It may be worth noting that I’m using nginx and I’ve already issued an SSL certificate with certbot.

---

## [Discourse\_docker not forcing command line upgrade?](https://meta.discourse.org/t/discourse-docker-not-forcing-command-line-upgrade/224426)

<div class="topic-metadata">

**Author:** [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**Replies:** 4\
**Last updated:** [April 15, 2022, 4:38pm UTC](https://meta.discourse.org/t/discourse-docker-not-forcing-command-line-upgrade/224426 "2022-04-15T16:38:11Z")

</div>

It seems that this is a security issue that requires a command-line upgrade, but I’m seeing a forced rebuild on only a couple of the sites that I’ve checked, and those seem really old. Continuing the discussion from 2.…

---

## [Down after upgrade: yarn: not found](https://meta.discourse.org/t/down-after-upgrade-yarn-not-found/224418)

<div class="topic-metadata">

**Author:** [@ygramoel](https://meta.discourse.org/u/ygramoel)\
**Replies:** 2\
**Last updated:** [April 15, 2022, 3:24pm UTC](https://meta.discourse.org/t/down-after-upgrade-yarn-not-found/224418 "2022-04-15T15:24:29Z")

</div>

While trying to upgrade my self-hosted Discourse instance forum.embeetle.com: git pull ./launcher rebuild app I got this error: sh: 1: yarn: not found and the forum is down. This issue looks similar (also mentions y…

---

## [Redirect from one server to another server and keep everything after the URL](https://meta.discourse.org/t/redirect-from-one-server-to-another-server-and-keep-everything-after-the-url/110713)

<div class="topic-metadata">

**Author:** [@rajpriya](https://meta.discourse.org/u/rajpriya)\
**Replies:** 2\
**Last updated:** [March 5, 2019, 11:16am UTC](https://meta.discourse.org/t/redirect-from-one-server-to-another-server-and-keep-everything-after-the-url/110713 "2019-03-05T11:16:38Z")

</div>

I have successfully installed discourse in my new server(For ex: http://shop.com) but i installed my forum related shop in another server (Forex: http://example.com). Implementation: I need to show the content from exam…

---

## [Service-worker redirection 403](https://meta.discourse.org/t/service-worker-redirection-403/224096)

<div class="topic-metadata">

**Author:** [@satonotdead](https://meta.discourse.org/u/satonotdead)\
**Replies:** 3\
**Last updated:** [April 13, 2022, 1:59am UTC](https://meta.discourse.org/t/service-worker-redirection-403/224096 "2022-04-13T01:59:03Z")

</div>

Hi, we are using Bunny CDN and see that error after last update (own hosted instance): service-worker.js:1 Uncaught DOMException: Failed to execute 'importScripts' on 'WorkerGlobalScope': The script at 'https://CDN/java…

---

## [How do I restore Discourse under a different domain?](https://meta.discourse.org/t/how-do-i-restore-discourse-under-a-different-domain/224028)

<div class="topic-metadata">

**Author:** [@hexworks](https://meta.discourse.org/u/hexworks)\
**Replies:** 2\
**Last updated:** [April 12, 2022, 12:20pm UTC](https://meta.discourse.org/t/how-do-i-restore-discourse-under-a-different-domain/224028 "2022-04-12T12:20:58Z")

</div>

I’m trying to migrate my Discourse installation to another server but I’d like to try it out first. I managed to install the new server, backup the old one and restore it to the new one and it seems to be working, but wh…

[Previous page](https://meta.discourse.org/c/support/self-hosting/31.md?page=65)

[Next page](https://meta.discourse.org/c/support/self-hosting/31.md?page=67)
