# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=68

[Latest](https://meta.discourse.org/latest.md) · [Categories](https://meta.discourse.org/categories.md) · [Tags](https://meta.discourse.org/tags.md)

**Page:** 69

---

## [Install discourse error help me?](https://meta.discourse.org/t/install-discourse-error-help-me/221469)

<div class="topic-metadata">

**Author:** [@Dennis19872020](https://meta.discourse.org/u/Dennis19872020)\
**Replies:** 5\
**Last updated:** [March 20, 2022, 10:52am UTC](https://meta.discourse.org/t/install-discourse-error-help-me/221469 "2022-03-20T10:52:58Z")

</div>

In ./discourse-setup after： FAILED -------------------- Pups::ExecError: cd /var/www/discourse && git fetch --depth 1 origin tests-passed failed with return #\<Process::Status: pid 157 exit 128\> Location of failure: /us…

---

## [Changing SMTP password](https://meta.discourse.org/t/changing-smtp-password/221450)

<div class="topic-metadata">

**Author:** [@kejsaren](https://meta.discourse.org/u/kejsaren)\
**Replies:** 2\
**Last updated:** [March 19, 2022, 11:48pm UTC](https://meta.discourse.org/t/changing-smtp-password/221450 "2022-03-19T23:48:38Z")

</div>

I need to change the Mailgun SMTP password (of security reasons). I am not a coder. So, does this mean I can´t do it myself but need help from a programmer?

---

## [Infinite 301 redirect with reverse proxy setup](https://meta.discourse.org/t/infinite-301-redirect-with-reverse-proxy-setup/221268)

<div class="topic-metadata">

**Author:** [@powi](https://meta.discourse.org/u/powi)\
**Replies:** 5\
**Last updated:** [March 18, 2022, 12:22pm UTC](https://meta.discourse.org/t/infinite-301-redirect-with-reverse-proxy-setup/221268 "2022-03-18T12:22:16Z")

</div>

So hi, I’m having an issue with installing Discourse, everytime I try to connect to my website, I have an infinite 301 redirect Here is my HOST nginx configuration of the discourse instance server { server\_name…

---

## [Discourse HA setup in network isolated env](https://meta.discourse.org/t/discourse-ha-setup-in-network-isolated-env/220938)

<div class="topic-metadata">

**Author:** [@Veeru\_Badavath](https://meta.discourse.org/u/Veeru_Badavath)\
**Replies:** 18\
**Last updated:** [March 17, 2022, 8:55pm UTC](https://meta.discourse.org/t/discourse-ha-setup-in-network-isolated-env/220938 "2022-03-17T20:55:09Z")

</div>

Thanks in advance. I’m planning setup discourse with high availability in production environment. The below are my design plan and some environment condition. Setup with 3 application servers and 2 Postgres DB server…

---

## [Javascript resources are being blocked by Content Security Policy (Cloudflare Rocket loader)](https://meta.discourse.org/t/javascript-resources-are-being-blocked-by-content-security-policy-cloudflare-rocket-loader/220900)

<div class="topic-metadata">

**Author:** [@sanityz\_eclipse](https://meta.discourse.org/u/sanityz_eclipse)\
**Replies:** 2\
**Last updated:** [March 17, 2022, 10:29am UTC](https://meta.discourse.org/t/javascript-resources-are-being-blocked-by-content-security-policy-cloudflare-rocket-loader/220900 "2022-03-17T10:29:32Z")

</div>

After installing Discourse using Bitnami docker image, some javascript resources are being blocked by Content Security Policy https://mysite/cdn-cgi/apps/head/Ec\_4R3r\_qp6Wu8DwcCflp-OGvgg.js https://mysite/cdn-cgi/scrip…

---

## [S3 media saves gazillions of "AccessDenied" xmls](https://meta.discourse.org/t/s3-media-saves-gazillions-of-accessdenied-xmls/220948)

<div class="topic-metadata">

**Author:** [@Alon1](https://meta.discourse.org/u/Alon1)\
**Replies:** 5\
**Last updated:** [March 16, 2022, 5:24pm UTC](https://meta.discourse.org/t/s3-media-saves-gazillions-of-accessdenied-xmls/220948 "2022-03-16T17:24:28Z")

</div>

The Discourse works very well, media on S3 works very well. However I just noticed that the S3 bucket has thousands of small files saved every day like this: The content of each file looks like this: \<Error\> \<Code\>A…

---

## [How to fix error No: 'noindex' detected in 'X-Robots-Tag'](https://meta.discourse.org/t/how-to-fix-error-no-noindex-detected-in-x-robots-tag/221064)

<div class="topic-metadata">

**Author:** [@johnmurphy](https://meta.discourse.org/u/johnmurphy)\
**Replies:** 3\
**Last updated:** [March 16, 2022, 1:40pm UTC](https://meta.discourse.org/t/how-to-fix-error-no-noindex-detected-in-x-robots-tag/221064 "2022-03-16T13:40:56Z")

</div>

Hi all I have indexed my site to google and get error “No: ‘noindex’ detected in ‘X-Robots-Tag’”. How to remove this header tag ?

---

## [/var/lib/docker/overlay2 disk usage Very High](https://meta.discourse.org/t/var-lib-docker-overlay2-disk-usage-very-high/109599)

<div class="topic-metadata">

**Author:** [@adambirds](https://meta.discourse.org/u/adambirds)\
**Replies:** 6\
**Last updated:** [February 19, 2019, 11:27pm UTC](https://meta.discourse.org/t/var-lib-docker-overlay2-disk-usage-very-high/109599 "2019-02-19T23:27:46Z")

</div>

I have a new forum, which currently has around 60 users, and currently only about 3 topics. (I only invited users today). We hope to have around 3000 users. I have a 40GB VPS currently, which can be expanded, but /var/l…

---

## [Rewrite username with SAML/OpenIDC Logins](https://meta.discourse.org/t/rewrite-username-with-saml-openidc-logins/220999)

<div class="topic-metadata">

**Author:** [@holtgrewe](https://meta.discourse.org/u/holtgrewe)\
**Replies:** 2\
**Last updated:** [March 15, 2022, 4:16pm UTC](https://meta.discourse.org/t/rewrite-username-with-saml-openidc-logins/220999 "2022-03-15T16:16:16Z")

</div>

First of all, thank you for providing such great software as open source. I have successfully setup discourse on our server with OpenIDC integration to our local keycloak server. However, keycloak delivers user names as…

---

## [How can I update nginx.conf without resetting it on rebuild?](https://meta.discourse.org/t/how-can-i-update-nginx-conf-without-resetting-it-on-rebuild/48102)

<div class="topic-metadata">

**Author:** [@markm1](https://meta.discourse.org/u/markm1)\
**Replies:** 2\
**Last updated:** [August 4, 2016, 6:08am UTC](https://meta.discourse.org/t/how-can-i-update-nginx-conf-without-resetting-it-on-rebuild/48102 "2016-08-04T06:08:58Z")

</div>

Hi, I have a question - How can I update nginx.conf or discourse.conf without having it reset when the container is rebuilt? I edit the file using nano, save it. But when I rebuild the app, the original file is there i…

---

## [Site's down - app won't start, port 443 conflict?](https://meta.discourse.org/t/sites-down-app-wont-start-port-443-conflict/220950)

<div class="topic-metadata">

**Author:** [@danb35](https://meta.discourse.org/u/danb35)\
**Replies:** 4\
**Last updated:** [March 15, 2022, 12:04am UTC](https://meta.discourse.org/t/sites-down-app-wont-start-port-443-conflict/220950 "2022-03-15T00:04:47Z")

</div>

I have Discourse installed in a Ubuntu 18.04 VPS following the standard install instructions. It’s been running well for a couple of years now, but when I went to my site this afternoon, the TLS cert was expired–and sin…

---

## [Port - Not reachable](https://meta.discourse.org/t/port-not-reachable/220854)

<div class="topic-metadata">

**Author:** [@Justman10000](https://meta.discourse.org/u/Justman10000)\
**Replies:** 2\
**Last updated:** [March 13, 2022, 8:49pm UTC](https://meta.discourse.org/t/port-not-reachable/220854 "2022-03-13T20:49:47Z")

</div>

Hi, I have Discourse configured on port 90 and 453. The container also runs on these ports, but although these are also open, Discourse is still not reachable!

---

## [Discourse behind reverse proxy and https](https://meta.discourse.org/t/discourse-behind-reverse-proxy-and-https/148705)

<div class="topic-metadata">

**Author:** [@Grunskin](https://meta.discourse.org/u/Grunskin)\
**Replies:** 18\
**Last updated:** [March 13, 2022, 6:31pm UTC](https://meta.discourse.org/t/discourse-behind-reverse-proxy-and-https/148705 "2022-03-13T18:31:59Z")

</div>

I’m trying to setup Discourse behind my Apache reverse proxy but I can’t get it working properly with https. I’ve had a lot of problems getting this far. Right now I have Discourse on a server and an Apache server infro…

---

## [Can anyone install discourse for me?](https://meta.discourse.org/t/can-anyone-install-discourse-for-me/80156)

<div class="topic-metadata">

**Author:** [@ckhawand](https://meta.discourse.org/u/ckhawand)\
**Replies:** 26\
**Last updated:** [March 13, 2022, 2:36pm UTC](https://meta.discourse.org/t/can-anyone-install-discourse-for-me/80156 "2022-03-13T14:36:55Z")

</div>

So… I recently got a VPS (hostinger VPS plan 6), well, a powerful one let’s say, here are its specs: |CPU Cores|8| |Total CPU Speed|19.2Ghz| |Memory|8Gb| |Disk Space|160Gb| |Bandwidth|8000Gb| Alright, so I have no expe…

---

## [Error on restore: could not create unique index](https://meta.discourse.org/t/error-on-restore-could-not-create-unique-index/220816)

<div class="topic-metadata">

**Author:** [@slackmoehrle](https://meta.discourse.org/u/slackmoehrle)\
**Replies:** 1\
**Last updated:** [March 12, 2022, 10:01pm UTC](https://meta.discourse.org/t/error-on-restore-could-not-create-unique-index/220816 "2022-03-12T22:01:07Z")

</div>

I am moving our community to a new provider. CREATE INDEX CREATE INDEX ERROR: could not create unique index "index\_incoming\_referers\_on\_path\_and\_incoming\_domain\_id" DETAIL: Key (path, incoming\_domain\_id)=(/m/search, 9…

---

## [Looking for a recent Cloudflare how-to guide](https://meta.discourse.org/t/looking-for-a-recent-cloudflare-how-to-guide/220813)

<div class="topic-metadata">

**Author:** [@Richie](https://meta.discourse.org/u/Richie)\
**Replies:** 0\
**Last updated:** [March 12, 2022, 8:59pm UTC](https://meta.discourse.org/t/looking-for-a-recent-cloudflare-how-to-guide/220813 "2022-03-12T20:59:31Z")

</div>

I’ve been reading various cloudflare topics here but can’t seem to find an up to date / complete “how to” guide. For example, this topic is over four years old: Is there a more recent guide somewhere? My Discourse…

---

## [Rebake aborts with error message](https://meta.discourse.org/t/rebake-aborts-with-error-message/220803)

<div class="topic-metadata">

**Author:** [@Canapin](https://meta.discourse.org/u/Canapin)\
**Replies:** 4\
**Last updated:** [March 12, 2022, 5:50pm UTC](https://meta.discourse.org/t/rebake-aborts-with-error-message/220803 "2022-03-12T17:50:29Z")

</div>

Hi! When I try to rebake posts with a rake task, It sometimes stops with this message: 168858 / 329447 ( 51.3%)WARNING: terminating connection because of crash of another server process DETAIL: The postmaster has com…

---

## [Build Fails on New Host](https://meta.discourse.org/t/build-fails-on-new-host/220755)

<div class="topic-metadata">

**Author:** [@Samir\_Faci](https://meta.discourse.org/u/Samir_Faci)\
**Replies:** 3\
**Last updated:** [March 12, 2022, 3:09am UTC](https://meta.discourse.org/t/build-fails-on-new-host/220755 "2022-03-12T03:09:18Z")

</div>

I copied and the entire /var/discourse to a new host. Updated the CNAME and SSL all working fine. When I try to do a rebuild, I get an issue with that I can’t figure out. sudo ./launcher rebuild app I, \[2022-03-11T16…

---

## [Docker Argument '--skip-mac-address' causes rebuild error](https://meta.discourse.org/t/docker-argument-skip-mac-address-causes-rebuild-error/220783)

<div class="topic-metadata">

**Author:** [@Wolfereign](https://meta.discourse.org/u/Wolfereign)\
**Replies:** 0\
**Last updated:** [March 11, 2022, 10:42pm UTC](https://meta.discourse.org/t/docker-argument-skip-mac-address-causes-rebuild-error/220783 "2022-03-11T22:42:21Z")

</div>

Hi All, I’m trying to install discourse using docker host networking and am running into a weird error with the rebuild command. If I run ./launcher rebuild app --docker-args --net=host --skip-mac-address then discours…

---

## [Problem with rebuild Discourse at Docker](https://meta.discourse.org/t/problem-with-rebuild-discourse-at-docker/220442)

<div class="topic-metadata">

**Author:** [@Robert\_Work](https://meta.discourse.org/u/Robert_Work)\
**Replies:** 3\
**Last updated:** [March 10, 2022, 11:07pm UTC](https://meta.discourse.org/t/problem-with-rebuild-discourse-at-docker/220442 "2022-03-10T23:07:22Z")

</div>

Hello, I’m forced with an update problem. When I try to update Discourse via admin/upgrade page I receive information about the old Docker image. So I try to connect to the Discourse server and update by typing the com…

---

## [How to access the discourse database?](https://meta.discourse.org/t/how-to-access-the-discourse-database/41845)

<div class="topic-metadata">

**Author:** [@Newuser](https://meta.discourse.org/u/Newuser)\
**Replies:** 13\
**Last updated:** [March 10, 2022, 8:26pm UTC](https://meta.discourse.org/t/how-to-access-the-discourse-database/41845 "2022-03-10T20:26:03Z")

</div>

Hi all, This is probably a stupid question but how can I access the database? Is there something equivalent to phpadmin (or another GUI) that I can use to view and edit the database of discourse? If not, then what is t…

---

## [Your Docker installation is not working correctly after running launcher rebuild app](https://meta.discourse.org/t/your-docker-installation-is-not-working-correctly-after-running-launcher-rebuild-app/109145)

<div class="topic-metadata">

**Author:** [@jidetheblogger](https://meta.discourse.org/u/jidetheblogger)\
**Replies:** 6\
**Last updated:** [February 16, 2019, 7:50am UTC](https://meta.discourse.org/t/your-docker-installation-is-not-working-correctly-after-running-launcher-rebuild-app/109145 "2019-02-16T07:50:45Z")

</div>

After running ./launcher rebuild app, I got this… which: no docker.io in (/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/root/bin) which: no docker.io in (/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/root/ …

---

## [Discourse Running With Nginx Issue](https://meta.discourse.org/t/discourse-running-with-nginx-issue/220627)

<div class="topic-metadata">

**Author:** [@bloodshot\_pico](https://meta.discourse.org/u/bloodshot_pico)\
**Replies:** 2\
**Last updated:** [March 10, 2022, 2:57pm UTC](https://meta.discourse.org/t/discourse-running-with-nginx-issue/220627 "2022-03-10T14:57:08Z")

</div>

So I’ve messed with both Nginx and Discourse a little bit recently, and I was having trouble yesterday. I wiped the machine due to me making mistakes and following X amount of guides. Today I booted up the machine with …

---

## [When trying to upgrade: Error running ember build](https://meta.discourse.org/t/when-trying-to-upgrade-error-running-ember-build/220532)

<div class="topic-metadata">

**Author:** [@dpb](https://meta.discourse.org/u/dpb)\
**Replies:** 19\
**Last updated:** [March 10, 2022, 1:46am UTC](https://meta.discourse.org/t/when-trying-to-upgrade-error-running-ember-build/220532 "2022-03-10T01:46:34Z")

</div>

When running the update with ./launcher rebuild our\_app\_config.yml, the following error shows up in the log: Error running ember build This is the most of the log (whole log was too large, so i cutted some repetitive s…

---

## [Discourse developement environment setup](https://meta.discourse.org/t/discourse-developement-environment-setup/220492)

<div class="topic-metadata">

**Author:** [@Hemant\_Raju1](https://meta.discourse.org/u/Hemant_Raju1)\
**Replies:** 3\
**Last updated:** [March 9, 2022, 7:07pm UTC](https://meta.discourse.org/t/discourse-developement-environment-setup/220492 "2022-03-09T19:07:09Z")

</div>

Hii I have installed discourse for development using docker . Followed this: Install Discourse for development using Docker So now i want to start making some changes in functionality/code. Here what i exactly looki…

---

## [Website shows if I type IP, but not if I type site name](https://meta.discourse.org/t/website-shows-if-i-type-ip-but-not-if-i-type-site-name/109255)

<div class="topic-metadata">

**Author:** [@DanielLav](https://meta.discourse.org/u/DanielLav)\
**Replies:** 2\
**Last updated:** [February 15, 2019, 4:54pm UTC](https://meta.discourse.org/t/website-shows-if-i-type-ip-but-not-if-i-type-site-name/109255 "2019-02-15T16:54:16Z")

</div>

Hello, i’d firstly like to apologise for the the lack of detail in the title and the lack of detail that’ll be in the post. I’m new to all of this and I have no idea what I’m doing. Basically yesterday I made a digitalo…

---

## [Unable to migrate to S3, therefore unable to restore from backup](https://meta.discourse.org/t/unable-to-migrate-to-s3-therefore-unable-to-restore-from-backup/220484)

<div class="topic-metadata">

**Author:** [@teward](https://meta.discourse.org/u/teward)\
**Replies:** 2\
**Last updated:** [March 9, 2022, 5:43am UTC](https://meta.discourse.org/t/unable-to-migrate-to-s3-therefore-unable-to-restore-from-backup/220484 "2022-03-09T05:43:27Z")

</div>

So, I have a Discourse backup from our initial server and we’re trying to move the system to a new system. Unfortunately, there are two problems: During restore, it says that 71 of 1073 uploads are not migrated to S3…

---

## [Failed Upgrade from 2.3.0 to 2.8.1](https://meta.discourse.org/t/failed-upgrade-from-2-3-0-to-2-8-1/220132)

<div class="topic-metadata">

**Author:** [@will\_io](https://meta.discourse.org/u/will_io)\
**Replies:** 11\
**Last updated:** [March 8, 2022, 8:25pm UTC](https://meta.discourse.org/t/failed-upgrade-from-2-3-0-to-2-8-1/220132 "2022-03-08T20:25:12Z")

</div>

I need to be sure what I am experiencing is normal. SSL certificate expired, forcing a rebuild of app which failed. What I had to do after failed upgrade: reconstruct database from data\_dir files - :white\_check\_mark: …

---

## ['launcher' fails - limited storage - launcher destroy app](https://meta.discourse.org/t/launcher-fails-limited-storage-launcher-destroy-app/220430)

<div class="topic-metadata">

**Author:** [@lejeczek](https://meta.discourse.org/u/lejeczek)\
**Replies:** 2\
**Last updated:** [March 8, 2022, 7:25pm UTC](https://meta.discourse.org/t/launcher-fails-limited-storage-launcher-destroy-app/220430 "2022-03-08T19:25:09Z")

</div>

Hi guys. I wonder if it’s a bug? -\> $ ./launcher destroy app x86\_64 arch detected. WARNING: We are about to start downloading the Discourse base image This process may take anywhere between a few minutes to an hour, d…

---

## [Rebuilding gives db:migrate error due to broken plugin](https://meta.discourse.org/t/rebuilding-gives-db-migrate-error-due-to-broken-plugin/220264)

<div class="topic-metadata">

**Author:** [@Kumar\_Karuppaiah](https://meta.discourse.org/u/Kumar_Karuppaiah)\
**Replies:** 4\
**Last updated:** [March 8, 2022, 6:02am UTC](https://meta.discourse.org/t/rebuilding-gives-db-migrate-error-due-to-broken-plugin/220264 "2022-03-08T06:02:17Z")

</div>

Hi, I want to connect the discourse with a separate a postgre SQL server. I have created a database server in Azure and I have followed the same steps that are mentioned in the below link. I am getting the below erro…

[Previous page](https://meta.discourse.org/c/support/self-hosting/31.md?page=67)

[Next page](https://meta.discourse.org/c/support/self-hosting/31.md?page=69)
