# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=72

[Latest](https://meta.discourse.org/latest.md) · [Categories](https://meta.discourse.org/categories.md) · [Tags](https://meta.discourse.org/tags.md)

**Page:** 73

---

## [Noob install problem: WARNING: Port 443 of computer](https://meta.discourse.org/t/noob-install-problem-warning-port-443-of-computer/214261)

<div class="topic-metadata">

**Author:** [@GetReadyMan](https://meta.discourse.org/u/GetReadyMan)\
**Replies:** 9\
**Last updated:** [January 16, 2022, 1:54am UTC](https://meta.discourse.org/t/noob-install-problem-warning-port-443-of-computer/214261 "2022-01-16T01:54:15Z")

</div>

A Noob here trying to install Discourse on a Digital Ocean droplet and getting the Port 443 warning. Hostname for your Discourse? \[discourse.example.com\]: discourse.chaffeespeaks.com Checking your domain name . . . WAR…

---

## [Skipping the configuration wizard after installation](https://meta.discourse.org/t/skipping-the-configuration-wizard-after-installation/59214)

<div class="topic-metadata">

**Author:** [@squidboylan](https://meta.discourse.org/u/squidboylan)\
**Replies:** 6\
**Last updated:** [January 21, 2019, 7:49am UTC](https://meta.discourse.org/t/skipping-the-configuration-wizard-after-installation/59214 "2019-01-21T07:49:04Z")

</div>

I’m writing an Ansible playbook to deploy discourse automatically. The problem is that I would like to automate the configuration that is done in the web browser after the installation. This would make it so that things …

---

## [Postfix setup for remote discourse configuration?](https://meta.discourse.org/t/postfix-setup-for-remote-discourse-configuration/214957)

<div class="topic-metadata">

**Author:** [@f1r4s](https://meta.discourse.org/u/f1r4s)\
**Replies:** 0\
**Last updated:** [January 15, 2022, 3:00pm UTC](https://meta.discourse.org/t/postfix-setup-for-remote-discourse-configuration/214957 "2022-01-15T15:00:45Z")

</div>

Hello, I have setup Postfix with mailgun on seperated VPS for sending mails using this topic; after finish i still cannot find how or what information i should update the app.yml file for the setting to connect there…

---

## [Discourse stopped working with 404 errors](https://meta.discourse.org/t/discourse-stopped-working-with-404-errors/106997)

<div class="topic-metadata">

**Author:** [@Bruce\_Bates](https://meta.discourse.org/u/Bruce_Bates)\
**Replies:** 5\
**Last updated:** [January 21, 2019, 4:11am UTC](https://meta.discourse.org/t/discourse-stopped-working-with-404-errors/106997 "2019-01-21T04:11:10Z")

</div>

Discourse was working great for a few months, then I wake up to find the page won’t load. Not sure if something changed in my system’s config or what. I tried sudo ./launcher rebuild app that didn’t seem to help. Then I …

---

## [After upgrade, docker: local\_discourse/app is not a valid mac address](https://meta.discourse.org/t/after-upgrade-docker-local-discourse-app-is-not-a-valid-mac-address/214905)

<div class="topic-metadata">

**Author:** [@Féréol](https://meta.discourse.org/u/F%C3%A9r%C3%A9ol)\
**Replies:** 8\
**Last updated:** [January 14, 2022, 9:39pm UTC](https://meta.discourse.org/t/after-upgrade-docker-local-discourse-app-is-not-a-valid-mac-address/214905 "2022-01-14T21:39:55Z")

</div>

After an upgrade by: git pull ./launcher rebuild app The service is not starting even by a ./launcher start app I am getting an error related to mac-address and there is no mac address on the command line: # ./launc…

---

## [Can I use some of the help content from the meta site](https://meta.discourse.org/t/can-i-use-some-of-the-help-content-from-the-meta-site/211998)

<div class="topic-metadata">

**Author:** [@RichWilkie](https://meta.discourse.org/u/RichWilkie)\
**Replies:** 5\
**Last updated:** [January 14, 2022, 9:49pm UTC](https://meta.discourse.org/t/can-i-use-some-of-the-help-content-from-the-meta-site/211998 "2022-01-14T21:49:07Z")

</div>

Hi all, I’m starting a new community and want to use some of the “how to” docs and help content that is available on the discourse site to pre-populate some of the things that people will definitely ask about. I’m think…

---

## [What is the size of your Discourse instance?](https://meta.discourse.org/t/what-is-the-size-of-your-discourse-instance/49538)

<div class="topic-metadata">

**Author:** [@ljpp](https://meta.discourse.org/u/ljpp)\
**Replies:** 8\
**Last updated:** [January 13, 2022, 7:55pm UTC](https://meta.discourse.org/t/what-is-the-size-of-your-discourse-instance/49538 "2022-01-13T19:55:18Z")

</div>

Our community (Tappara.co, in Finnish) is less than one year old. We have about 58k posts by 1000+ users. Images and backups are pushed to Amazon S3. Our backup size today is about 217MB and growing at a rate of 0.5MB …

---

## [How to renew ssl without using: ./launcher rebuild app](https://meta.discourse.org/t/how-to-renew-ssl-without-using-launcher-rebuild-app/214717)

<div class="topic-metadata">

**Author:** [@hokod](https://meta.discourse.org/u/hokod)\
**Replies:** 3\
**Last updated:** [January 13, 2022, 7:54pm UTC](https://meta.discourse.org/t/how-to-renew-ssl-without-using-launcher-rebuild-app/214717 "2022-01-13T19:54:28Z")

</div>

renew ssl (in some cases I encountered, SSL’s free of Let’s Encrypt did not automatically renew). What command can be used to renew ssl without using: ./launcher rebuild app ? Because rebuild will affect the database, …

---

## [After Rebuild got error: postgres:10/main, Causes CPU to go high](https://meta.discourse.org/t/after-rebuild-got-error-postgres-10-main-causes-cpu-to-go-high/214307)

<div class="topic-metadata">

**Author:** [@hokod](https://meta.discourse.org/u/hokod)\
**Replies:** 3\
**Last updated:** [January 11, 2022, 10:02pm UTC](https://meta.discourse.org/t/after-rebuild-got-error-postgres-10-main-causes-cpu-to-go-high/214307 "2022-01-11T22:02:58Z")

</div>

I use htop command, I noticed the CPU goes too high. I get the error: postgres: 10/main How to handle this error?

---

## [Forum stuck on loading wheel when trying to load posts](https://meta.discourse.org/t/forum-stuck-on-loading-wheel-when-trying-to-load-posts/214388)

<div class="topic-metadata">

**Author:** [@Hammad1412](https://meta.discourse.org/u/Hammad1412)\
**Replies:** 4\
**Last updated:** [January 10, 2022, 9:46pm UTC](https://meta.discourse.org/t/forum-stuck-on-loading-wheel-when-trying-to-load-posts/214388 "2022-01-10T21:46:25Z")

</div>

Hi, Our forum seems to get stuck trying to load a post when you click on it, or try and open up a category. Just want to know what’s going wrong? Here is a link to the forum - https://gov.indexcoop.com/. Here is the v…

---

## [How to config error index\_topics\_on\_lower\_title](https://meta.discourse.org/t/how-to-config-error-index-topics-on-lower-title/214213)

<div class="topic-metadata">

**Author:** [@Bank\_Live](https://meta.discourse.org/u/Bank_Live)\
**Replies:** 0\
**Last updated:** [January 8, 2022, 2:35am UTC](https://meta.discourse.org/t/how-to-config-error-index-topics-on-lower-title/214213 "2022-01-08T02:35:41Z")

</div>

I use command ./launcher rebuild app and see this error. But rebuild app pass.

---

## [Shutting down forum (NOT deleting it)](https://meta.discourse.org/t/shutting-down-forum-not-deleting-it/213722)

<div class="topic-metadata">

**Author:** [@Mads](https://meta.discourse.org/u/Mads)\
**Replies:** 25\
**Last updated:** [January 7, 2022, 10:50am UTC](https://meta.discourse.org/t/shutting-down-forum-not-deleting-it/213722 "2022-01-07T10:50:53Z")

</div>

Hello guys, I’m currently not able to administer my forum and want to shut it down for a while as it needs a new SSL link which I haven’t figured out how to do yet. I don’t want any of our users to risk getting hacked. …

---

## [Configure cerbot with app.yml?](https://meta.discourse.org/t/configure-cerbot-with-app-yml/213994)

<div class="topic-metadata">

**Author:** [@f1r4s](https://meta.discourse.org/u/f1r4s)\
**Replies:** 4\
**Last updated:** [January 6, 2022, 4:09pm UTC](https://meta.discourse.org/t/configure-cerbot-with-app-yml/213994 "2022-01-06T16:09:36Z")

</div>

Hello, My site is using Cloudflare, and everything is good, but i see in checking https checker there is https 443: Error: A call to SSPI failed, see inner exception. I’m looking to disable Cloudflare SSL and use cert…

---

## [How to put discourse on a web host](https://meta.discourse.org/t/how-to-put-discourse-on-a-web-host/83590)

<div class="topic-metadata">

**Author:** [@NADMIN](https://meta.discourse.org/u/NADMIN)\
**Replies:** 7\
**Last updated:** [March 24, 2018, 5:26pm UTC](https://meta.discourse.org/t/how-to-put-discourse-on-a-web-host/83590 "2018-03-24T17:26:19Z")

</div>

How to put discourse on a web host Hosting : https://obambu.com/ GB : 5G If there is a way - could you please give me a step by step way to do it? I am new to all this stuff (so if you could use simple terms that wou…

---

## [Persistent configuration of restart-policy](https://meta.discourse.org/t/persistent-configuration-of-restart-policy/213715)

<div class="topic-metadata">

**Author:** [@svogt](https://meta.discourse.org/u/svogt)\
**Replies:** 4\
**Last updated:** [January 3, 2022, 8:53pm UTC](https://meta.discourse.org/t/persistent-configuration-of-restart-policy/213715 "2022-01-03T20:53:31Z")

</div>

Hi, I’m using the discourse\_docker repo with the launcher script to run an internal Discourse instance. I’d like to persistently change the restart policy from always to unless-stopped to be able to keep the docker cont…

---

## [Cloning and making our own Discourse community](https://meta.discourse.org/t/cloning-and-making-our-own-discourse-community/213702)

<div class="topic-metadata">

**Author:** [@Horizon](https://meta.discourse.org/u/Horizon)\
**Replies:** 3\
**Last updated:** [January 3, 2022, 10:48am UTC](https://meta.discourse.org/t/cloning-and-making-our-own-discourse-community/213702 "2022-01-03T10:48:44Z")

</div>

Hello team, This is Horizon from India I am planning to make my own Discourse community for my business but I need some information from you What will be the size for cloning discourse Can I clone it on Windows 7 …

---

## [How to debug S3 uploads](https://meta.discourse.org/t/how-to-debug-s3-uploads/213616)

<div class="topic-metadata">

**Author:** [@Andro](https://meta.discourse.org/u/Andro)\
**Replies:** 6\
**Last updated:** [January 3, 2022, 6:23am UTC](https://meta.discourse.org/t/how-to-debug-s3-uploads/213616 "2022-01-03T06:23:26Z")

</div>

For a brief moment I had S3 uploads to a bucket working. Then I followed the several posts here to make sure it is all correct and now all uploads go local. I cant see any clues in the error log. How does one go about d…

---

## [Configure the new install discourse SMTP Email with Mailgun on AWS Lightsail server](https://meta.discourse.org/t/configure-the-new-install-discourse-smtp-email-with-mailgun-on-aws-lightsail-server/213282)

<div class="topic-metadata">

**Author:** [@quangmai911](https://meta.discourse.org/u/quangmai911)\
**Replies:** 5\
**Last updated:** [December 30, 2021, 12:48pm UTC](https://meta.discourse.org/t/configure-the-new-install-discourse-smtp-email-with-mailgun-on-aws-lightsail-server/213282 "2021-12-30T12:48:34Z")

</div>

Dear all, I got an issue with my new install discourse server at the email invitation for admin account setup. I follow the troubleshooting as this guide here but still not figuring what I am missing https://meta.disco…

---

## [Discourse update doesn't wait for Postgress DB to shut down](https://meta.discourse.org/t/discourse-update-doesnt-wait-for-postgress-db-to-shut-down/212961)

<div class="topic-metadata">

**Author:** [@kinetiksoft](https://meta.discourse.org/u/kinetiksoft)\
**Replies:** 4\
**Last updated:** [December 29, 2021, 7:20pm UTC](https://meta.discourse.org/t/discourse-update-doesnt-wait-for-postgress-db-to-shut-down/212961 "2021-12-29T19:20:15Z")

</div>

Yesterday we tried rebuilding the forum several times with the same result - it failed, and log shows it is related to how Discourse shuts the database down. It looks like it doesn’t match the speed expectations set by r…

---

## [Policy and permission issues with s3 buckets?](https://meta.discourse.org/t/policy-and-permission-issues-with-s3-buckets/104956)

<div class="topic-metadata">

**Author:** [@Shane\_Liebling](https://meta.discourse.org/u/Shane_Liebling)\
**Replies:** 20\
**Last updated:** [January 14, 2019, 11:29pm UTC](https://meta.discourse.org/t/policy-and-permission-issues-with-s3-buckets/104956 "2019-01-14T23:29:22Z")

</div>

I have two S3 buckets, one for backups one for uploads. I have one user/policy for both with full s3 access. I have both uploads and backups set to go to s3. Strangely, I can make a backup and it will end up on s3, but a…

---

## [Let's Encrypt cert renewals (suddenly) failing](https://meta.discourse.org/t/lets-encrypt-cert-renewals-suddenly-failing/213071)

<div class="topic-metadata">

**Author:** [@L30110](https://meta.discourse.org/u/L30110)\
**Replies:** 26\
**Last updated:** [December 28, 2021, 1:14am UTC](https://meta.discourse.org/t/lets-encrypt-cert-renewals-suddenly-failing/213071 "2021-12-28T01:14:16Z")

</div>

Sometime back – it’s not clear how long but at least several months – Let’s Encrypt renewals started failing on my Discourse forum, after running fine for years. When I initially noted this some days ago, the cert had ex…

---

## [Set custom docker network in container/app.yml](https://meta.discourse.org/t/set-custom-docker-network-in-container-app-yml/200701)

<div class="topic-metadata">

**Author:** [@BHamidpour](https://meta.discourse.org/u/BHamidpour)\
**Replies:** 2\
**Last updated:** [December 27, 2021, 3:54am UTC](https://meta.discourse.org/t/set-custom-docker-network-in-container-app-yml/200701 "2021-12-27T03:54:05Z")

</div>

Hello There, How I can add a custom docker network block like the below sample to my discourse conf file (container/app.yml)? I want the discourse container to connect to “my-network” after ./launch rebuild and running…

---

## [AWS S3 Object Ownership](https://meta.discourse.org/t/aws-s3-object-ownership/213112)

<div class="topic-metadata">

**Author:** [@shawnngtq](https://meta.discourse.org/u/shawnngtq)\
**Replies:** 2\
**Last updated:** [December 26, 2021, 2:01pm UTC](https://meta.discourse.org/t/aws-s3-object-ownership/213112 "2021-12-26T14:01:23Z")

</div>

Hi, I followed these guides My backup works fine but not for others. To make it work, I have to enabled ACLs, which is not recommended by AWS. Was wondering how can we make S3 work using ACLs disabled (recom…

---

## [My discourse forum github login broken by setting ENV proxy in app.yml](https://meta.discourse.org/t/my-discourse-forum-github-login-broken-by-setting-env-proxy-in-app-yml/212508)

<div class="topic-metadata">

**Author:** [@zilongshanren](https://meta.discourse.org/u/zilongshanren)\
**Replies:** 8\
**Last updated:** [December 26, 2021, 6:31am UTC](https://meta.discourse.org/t/my-discourse-forum-github-login-broken-by-setting-env-proxy-in-app-yml/212508 "2021-12-26T06:31:25Z")

</div>

Hi, everyone In order to run ./launcher rebuild app, I use a proxy to help me pull code from Github smoothly. env: LANG: en\_US.UTF-8 DISCOURSE\_DEFAULT\_LOCALE: zh\_CN HTTP\_PROXY: http://10.27.xxx.xxx:7890 HTTPS\_P…

---

## [Redis Problems? (Forum broken after upgrade)](https://meta.discourse.org/t/redis-problems-forum-broken-after-upgrade/212938)

<div class="topic-metadata">

**Author:** [@L30110](https://meta.discourse.org/u/L30110)\
**Replies:** 33\
**Last updated:** [December 24, 2021, 6:13pm UTC](https://meta.discourse.org/t/redis-problems-forum-broken-after-upgrade/212938 "2021-12-24T18:13:05Z")

</div>

I was prompted to upgrade today, and then required to do the build through launcher. Since then Discourse has been basically broken. Already logged in users can see the home page and select messages from there to display…

---

## [Unable to rebuild app: not supported docker storage driver (btrfs)](https://meta.discourse.org/t/unable-to-rebuild-app-not-supported-docker-storage-driver-btrfs/209200)

<div class="topic-metadata">

**Author:** [@ariznaf](https://meta.discourse.org/u/ariznaf)\
**Replies:** 15\
**Last updated:** [December 22, 2021, 8:52pm UTC](https://meta.discourse.org/t/unable-to-rebuild-app-not-supported-docker-storage-driver-btrfs/209200 "2021-12-22T20:52:49Z")

</div>

We are going to migrate our server and the discourse installation. We are using a new server with btrfs file system. I am making some tests in a test machine, I have copied all the files and installed all neccesary par…

---

## [App rebuild aborts due to custom wizard plugin](https://meta.discourse.org/t/app-rebuild-aborts-due-to-custom-wizard-plugin/210645)

<div class="topic-metadata">

**Author:** [@GuidoD](https://meta.discourse.org/u/GuidoD)\
**Replies:** 9\
**Last updated:** [December 22, 2021, 2:24pm UTC](https://meta.discourse.org/t/app-rebuild-aborts-due-to-custom-wizard-plugin/210645 "2021-12-22T14:24:50Z")

</div>

a rebuild with the latest version does abort with a FileNotFound error: ... I, \[2021-12-01T07:30:27.434946 #670\] INFO -- : Writing /var/www/discourse/public/assets/locales/es-ae86f17b3afa4050566e8f73dc225848cb65e80cad4…

---

## [Discourse Setup Error](https://meta.discourse.org/t/discourse-setup-error/212752)

<div class="topic-metadata">

**Author:** [@TwoBrake](https://meta.discourse.org/u/TwoBrake)\
**Replies:** 3\
**Last updated:** [December 22, 2021, 6:18am UTC](https://meta.discourse.org/t/discourse-setup-error/212752 "2021-12-22T06:18:26Z")

</div>

Hello there! I was just setting up Discourse on my virtual private server and the configuration setup was a success. Then I got the error ERR\_CONNECTION\_REFUSED when opening the web page in my browser. I was wondering wh…

---

## [Running public Discourse server w/o Elastic IP assigned](https://meta.discourse.org/t/running-public-discourse-server-w-o-elastic-ip-assigned/212843)

<div class="topic-metadata">

**Author:** [@lee7](https://meta.discourse.org/u/lee7)\
**Replies:** 1\
**Last updated:** [December 21, 2021, 11:01pm UTC](https://meta.discourse.org/t/running-public-discourse-server-w-o-elastic-ip-assigned/212843 "2021-12-21T23:01:06Z")

</div>

Hi, when deploying Discourse on AWS, is it necessary to assign an Elastic IP address or is a CNAME pointed at the EC2 instance’s public DNS entry enough? e.g. ec2-x-xx-x-xxx.us-east-2.compute.amazonaws.com

---

## [Staging or Sandbox environments for Business Discourse hosted forums](https://meta.discourse.org/t/staging-or-sandbox-environments-for-business-discourse-hosted-forums/212715)

<div class="topic-metadata">

**Author:** [@hequaye](https://meta.discourse.org/u/hequaye)\
**Replies:** 2\
**Last updated:** [December 21, 2021, 8:12pm UTC](https://meta.discourse.org/t/staging-or-sandbox-environments-for-business-discourse-hosted-forums/212715 "2021-12-21T20:12:00Z")

</div>

Continuing the discussion from Exclusive Sandbox or Staging Environs for Orgs?: A challenge we’ve found with Discourse is the lack of a staging or sandbox environment that is exclusive to our org. We’d like a place wher…

[Previous page](https://meta.discourse.org/c/support/self-hosting/31.md?page=71)

[Next page](https://meta.discourse.org/c/support/self-hosting/31.md?page=73)
