# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=77

[Latest](https://meta.discourse.org/latest.md) · [Categories](https://meta.discourse.org/categories.md) · [Tags](https://meta.discourse.org/tags.md)

**Page:** 78

---

## [Installation Errors](https://meta.discourse.org/t/installation-errors/202614)

<div class="topic-metadata">

**Author:** [@northeastprince](https://meta.discourse.org/u/northeastprince)\
**Replies:** 7\
**Last updated:** [September 7, 2021, 11:34pm UTC](https://meta.discourse.org/t/installation-errors/202614 "2021-09-07T23:34:46Z")

</div>

Everything was fine until this happened… Then it said failed to bootstrap. I’m running Ubuntu 18. Any help would be appreciated!

---

## [Self-installation VS DigitalOcean 1-click installation](https://meta.discourse.org/t/self-installation-vs-digitalocean-1-click-installation/202682)

<div class="topic-metadata">

**Author:** [@tenzan](https://meta.discourse.org/u/tenzan)\
**Replies:** 7\
**Last updated:** [September 6, 2021, 8:43am UTC](https://meta.discourse.org/t/self-installation-vs-digitalocean-1-click-installation/202682 "2021-09-06T08:43:51Z")

</div>

Hi, What’s the difference between self-installation (official install) VS DigitalOcean 1-click installation. I’ve tried both and didn’t notice any issues. Thanks.

---

## [Port 80 fails when setting up](https://meta.discourse.org/t/port-80-fails-when-setting-up/202753)

<div class="topic-metadata">

**Author:** [@nnamso\_](https://meta.discourse.org/u/nnamso_)\
**Replies:** 9\
**Last updated:** [September 7, 2021, 11:47am UTC](https://meta.discourse.org/t/port-80-fails-when-setting-up/202753 "2021-09-07T11:47:39Z")

</div>

Any help with this?

---

## [Mail sending problem](https://meta.discourse.org/t/mail-sending-problem/202406)

<div class="topic-metadata">

**Author:** [@GiorgiB](https://meta.discourse.org/u/GiorgiB)\
**Replies:** 3\
**Last updated:** [September 6, 2021, 7:33pm UTC](https://meta.discourse.org/t/mail-sending-problem/202406 "2021-09-06T19:33:48Z")

</div>

Hello, I’ve installed Discourse from Google Cloud Marketplace (It’s not Bitnami). First time I’ve start using Bitnami, but mail server do not worked, I’ve started using another template from GCP Marketplace. But there …

---

## [Not getting Discourse Home page](https://meta.discourse.org/t/not-getting-discourse-home-page/202610)

<div class="topic-metadata">

**Author:** [@Abhijit\_Sharma](https://meta.discourse.org/u/Abhijit_Sharma)\
**Replies:** 9\
**Last updated:** [September 6, 2021, 11:07am UTC](https://meta.discourse.org/t/not-getting-discourse-home-page/202610 "2021-09-06T11:07:42Z")

</div>

I have installed Discourse following the steps mentioned in the git hub readme page. When the installation is finished and i try to open the discourse via the domain name, then i am getting the " Welcome to Nginx page in…

---

## [Nginx.http.sock recreated with incorrect selinux context](https://meta.discourse.org/t/nginx-http-sock-recreated-with-incorrect-selinux-context/202602)

<div class="topic-metadata">

**Author:** [@uckelman](https://meta.discourse.org/u/uckelman)\
**Replies:** 2\
**Last updated:** [September 4, 2021, 11:09am UTC](https://meta.discourse.org/t/nginx-http-sock-recreated-with-incorrect-selinux-context/202602 "2021-09-04T11:09:21Z")

</div>

I have a Discourse instance proxied behind Apache and communicating over a socket, as described here. I have SELinux enabled, so in order to give httpd permission to use the socket, I’ve given the socket a context where…

---

## [Upgrade page claims nothing to be done](https://meta.discourse.org/t/upgrade-page-claims-nothing-to-be-done/202554)

<div class="topic-metadata">

**Author:** [@Ed\_S](https://meta.discourse.org/u/Ed_S)\
**Replies:** 2\
**Last updated:** [September 3, 2021, 7:04pm UTC](https://meta.discourse.org/t/upgrade-page-claims-nothing-to-be-done/202554 "2021-09-03T19:04:23Z")

</div>

I was running 2.8.0.beta4, and intended to upgrade to beta 6. The upgrade page allowed me to upgrade docker\_manager, but reports discourse as being up to date. It isn’t! And the dashboard still shows 2.8.0.beta4. dis…

---

## [Discourse setup on aws ec2 doesn't work with default IPv4 DNS](https://meta.discourse.org/t/discourse-setup-on-aws-ec2-doesnt-work-with-default-ipv4-dns/196789)

<div class="topic-metadata">

**Author:** [@ys2843](https://meta.discourse.org/u/ys2843)\
**Replies:** 13\
**Last updated:** [September 3, 2021, 2:44pm UTC](https://meta.discourse.org/t/discourse-setup-on-aws-ec2-doesnt-work-with-default-ipv4-dns/196789 "2021-09-03T14:44:08Z")

</div>

Hi discourse community, I am new to discourse and just testing the setup of discourse on an AWS ec2 instance following discourse/docs/INSTALL-cloud.md at main · discourse/discourse · GitHub. However, I wasn’t able to sp…

---

## [Getting extreme load warning while server resources are not being used](https://meta.discourse.org/t/getting-extreme-load-warning-while-server-resources-are-not-being-used/202490)

<div class="topic-metadata">

**Author:** [@Caliph](https://meta.discourse.org/u/Caliph)\
**Replies:** 5\
**Last updated:** [September 2, 2021, 9:54pm UTC](https://meta.discourse.org/t/getting-extreme-load-warning-while-server-resources-are-not-being-used/202490 "2021-09-02T21:54:42Z")

</div>

We are a game company and use discourse for our community forum. Each time we release a patch to our game and patch notes on the forum we get a spike in traffic. We are using DigitalOcean to host and recently increased…

---

## [Official support for Microsoft Azure AD?](https://meta.discourse.org/t/official-support-for-microsoft-azure-ad/94626)

<div class="topic-metadata">

**Author:** [@cgambino](https://meta.discourse.org/u/cgambino)\
**Replies:** 7\
**Last updated:** [September 2, 2021, 5:59pm UTC](https://meta.discourse.org/t/official-support-for-microsoft-azure-ad/94626 "2021-09-02T17:59:18Z")

</div>

Hi everyone, I am looking for information on if Azure AD is supported through an Official plugin. We have been attempting to use the OAuth2\_Basic plugin, and it’s connecting and coming back, but we get an “unauthorized…

---

## [Discourse installation timed out](https://meta.discourse.org/t/discourse-installation-timed-out/202324)

<div class="topic-metadata">

**Author:** [@tom-richter](https://meta.discourse.org/u/tom-richter)\
**Replies:** 3\
**Last updated:** [September 1, 2021, 6:48pm UTC](https://meta.discourse.org/t/discourse-installation-timed-out/202324 "2021-09-01T18:48:09Z")

</div>

Hi, I want to install discourse. My logs look like this: redis.1 | 410:M 31 Aug 2021 07:34:15.596 # Server initialized redis.1 | 410:M 31 Aug 2021 07:34:15.871 \* DB loaded from append only file: 0.275 seconds redis.1 …

---

## [Discourse Security](https://meta.discourse.org/t/discourse-security/202361)

<div class="topic-metadata">

**Author:** [@cristy](https://meta.discourse.org/u/cristy)\
**Replies:** 6\
**Last updated:** [September 1, 2021, 4:50pm UTC](https://meta.discourse.org/t/discourse-security/202361 "2021-09-01T16:50:53Z")

</div>

Is there an architectural or network diagram available for Discourse? Or are there documents that discuss Discourse security? Which ports are in use? Which services? Anything to convince a security review team that D…

---

## [Discourse-solved broken migration](https://meta.discourse.org/t/discourse-solved-broken-migration/202095)

<div class="topic-metadata">

**Author:** [@Stanzilla](https://meta.discourse.org/u/Stanzilla)\
**Replies:** 4\
**Last updated:** [August 31, 2021, 5:50pm UTC](https://meta.discourse.org/t/discourse-solved-broken-migration/202095 "2021-08-31T17:50:22Z")

</div>

Discourse Version: 2.8.0.beta4 The recent updates (last 7 commits) broke my migrations: /var/www/discourse/plugins/discourse-solved/plugin.rb:702:in \`block in activate!': undefined method \`register\_topic\_list\_preload\_u…

---

## [List of all environment variables](https://meta.discourse.org/t/list-of-all-environment-variables/202200)

<div class="topic-metadata">

**Author:** [@tom-richter](https://meta.discourse.org/u/tom-richter)\
**Replies:** 0\
**Last updated:** [August 31, 2021, 7:37am UTC](https://meta.discourse.org/t/list-of-all-environment-variables/202200 "2021-08-31T07:37:39Z")

</div>

Hi, where do I find a list of all environment variables and their allowed values? For example I would like to know which values I can set for DISCOURSE\_SMTP\_AUTHENTICATION.

---

## [Postgres has 100% CPU for large databases, Discourse 2.7.7](https://meta.discourse.org/t/postgres-has-100-cpu-for-large-databases-discourse-2-7-7/202106)

<div class="topic-metadata">

**Author:** [@dmorlock](https://meta.discourse.org/u/dmorlock)\
**Replies:** 3\
**Last updated:** [August 30, 2021, 1:11pm UTC](https://meta.discourse.org/t/postgres-has-100-cpu-for-large-databases-discourse-2-7-7/202106 "2021-08-30T13:11:28Z")

</div>

Hi, we are running Docker based Discourse 2.7.7 with a very large user base. After upgrading from 2.4.2 to 2.7.7, we are experiencing that some Postgres process are stuck at 100% CPU. Further investigation results that …

---

## [I have error when try to rebuild app](https://meta.discourse.org/t/i-have-error-when-try-to-rebuild-app/202100)

<div class="topic-metadata">

**Author:** [@cmdntd](https://meta.discourse.org/u/cmdntd)\
**Replies:** 0\
**Last updated:** [August 30, 2021, 10:51am UTC](https://meta.discourse.org/t/i-have-error-when-try-to-rebuild-app/202100 "2021-08-30T10:51:12Z")

</div>

I have this error when try to rebuild app. I 've never seen it before I tried to reboot, but then this error is still there $: ./launcher rebuild app HEAD is now at d1db030 cut a new version I, \[2021-08-30T10:45:51.09…

---

## [How do you set net.core.somaxconn in the docker container?](https://meta.discourse.org/t/how-do-you-set-net-core-somaxconn-in-the-docker-container/64577)

<div class="topic-metadata">

**Author:** [@squidboylan](https://meta.discourse.org/u/squidboylan)\
**Replies:** 6\
**Last updated:** [November 12, 2018, 11:32am UTC](https://meta.discourse.org/t/how-do-you-set-net-core-somaxconn-in-the-docker-container/64577 "2018-11-12T11:32:12Z")

</div>

How do you set net.core.somaxconn in the docker container so that Redis doesn’t complain that somaxconn is less than 511? Using sysctl doesnt work inside of the container and setting it on the host doesn’t affect the con…

---

## [Using A Noip Domain To Host Discourse](https://meta.discourse.org/t/using-a-noip-domain-to-host-discourse/202016)

<div class="topic-metadata">

**Author:** [@JCodes](https://meta.discourse.org/u/JCodes)\
**Replies:** 1\
**Last updated:** [August 28, 2021, 10:50pm UTC](https://meta.discourse.org/t/using-a-noip-domain-to-host-discourse/202016 "2021-08-28T22:50:14Z")

</div>

I use NoIp. Is there a way I can host my discourse on there?

---

## [Email Sending Issues Occured on Different Email Provider on notification\_email and reply\_by\_email\_addresses](https://meta.discourse.org/t/email-sending-issues-occured-on-different-email-provider-on-notification-email-and-reply-by-email-addresses/201984)

<div class="topic-metadata">

**Author:** [@sptrf](https://meta.discourse.org/u/sptrf)\
**Replies:** 1\
**Last updated:** [August 28, 2021, 3:13pm UTC](https://meta.discourse.org/t/email-sending-issues-occured-on-different-email-provider-on-notification-email-and-reply-by-email-addresses/201984 "2021-08-28T15:13:59Z")

</div>

Hello, recently I’ve encountered some issues on configuring the email sender as QQ Exmail (a.k.a 腾讯企业邮箱). My email configuration is listed as below: DISCOURSE\_SMTP\_ADDRESS: smtp.exmail.qq.com DISCOURSE\_SMTP\_AUTHENTICATI…

---

## [WARNING: Port 443 of computer](https://meta.discourse.org/t/warning-port-443-of-computer/201932)

<div class="topic-metadata">

**Author:** [@DonBot](https://meta.discourse.org/u/DonBot)\
**Replies:** 1\
**Last updated:** [August 27, 2021, 5:10pm UTC](https://meta.discourse.org/t/warning-port-443-of-computer/201932 "2021-08-27T17:10:14Z")

</div>

WARNING: Port 443 of computer does not appear to be accessible using hostname: community.botsland.us. why? my dns record is added:

---

## [Discourse on postgres 12 breaks upgrades](https://meta.discourse.org/t/discourse-on-postgres-12-breaks-upgrades/201814)

<div class="topic-metadata">

**Author:** [@Wingtip](https://meta.discourse.org/u/Wingtip)\
**Replies:** 16\
**Last updated:** [August 27, 2021, 6:32am UTC](https://meta.discourse.org/t/discourse-on-postgres-12-breaks-upgrades/201814 "2021-08-27T06:32:37Z")

</div>

We’re running postgres v12 as the v13 upgrade requires too much disk space. It looks like compatibility with v12 may have been broken? Is this deliberate? If so it means we can never upgrade Discourse again. Running ./l…

---

## [Which environment variables are mandatory?](https://meta.discourse.org/t/which-environment-variables-are-mandatory/201575)

<div class="topic-metadata">

**Author:** [@tom-richter](https://meta.discourse.org/u/tom-richter)\
**Replies:** 2\
**Last updated:** [August 24, 2021, 6:43pm UTC](https://meta.discourse.org/t/which-environment-variables-are-mandatory/201575 "2021-08-24T18:43:44Z")

</div>

Hi, I want to deploy Discourse on render.com: Docs + Quickstarts | Render. I would like to know which environment variables are mandatory. Do I need the SMTP variables DISCOURSE\_SMTP\_ADDRESS, DISCOURSE\_SMTP\_DOMAIN, DISC…

---

## [Change user's email without verification](https://meta.discourse.org/t/change-users-email-without-verification/66602)

<div class="topic-metadata">

**Author:** [@carlokok](https://meta.discourse.org/u/carlokok)\
**Replies:** 10\
**Last updated:** [August 22, 2021, 11:50pm UTC](https://meta.discourse.org/t/change-users-email-without-verification/66602 "2021-08-22T23:50:55Z")

</div>

Maybe I’m missing something obvious, but I cannot find it. As an admin, can I change someone’s email address without them having to verify it?

---

## [Too many redirects when reverse proxying to Discourse from a different server](https://meta.discourse.org/t/too-many-redirects-when-reverse-proxying-to-discourse-from-a-different-server/101590)

<div class="topic-metadata">

**Author:** [@jaesung2061](https://meta.discourse.org/u/jaesung2061)\
**Replies:** 0\
**Last updated:** [November 8, 2018, 5:27am UTC](https://meta.discourse.org/t/too-many-redirects-when-reverse-proxying-to-discourse-from-a-different-server/101590 "2018-11-08T05:27:46Z")

</div>

I set up Discourse on the domain discuss.example.com and i’m trying to make it so that realsite.com/discuss (different machine) proxies the request to discuss.example.com/discuss. I’ve already set up the subdirectory acc…

---

## [DigitalOcean: Port 443 of computer does not appear to be accessible](https://meta.discourse.org/t/digitalocean-port-443-of-computer-does-not-appear-to-be-accessible/201253)

<div class="topic-metadata">

**Author:** [@tenzan](https://meta.discourse.org/u/tenzan)\
**Replies:** 2\
**Last updated:** [August 21, 2021, 2:07pm UTC](https://meta.discourse.org/t/digitalocean-port-443-of-computer-does-not-appear-to-be-accessible/201253 "2021-08-21T14:07:26Z")

</div>

Hi, I saw there are many posts on the same issue, but they were not helpful. I have installed Discourse using DigitalOcean’s Marketplace. I’m having this error Checking your domain name . . . WARNING: Port 443 of com…

---

## [Taking Too Long To Respond](https://meta.discourse.org/t/taking-too-long-to-respond/201046)

<div class="topic-metadata">

**Author:** [@Jake\_Jacob](https://meta.discourse.org/u/Jake_Jacob)\
**Replies:** 2\
**Last updated:** [August 19, 2021, 10:58pm UTC](https://meta.discourse.org/t/taking-too-long-to-respond/201046 "2021-08-19T22:58:39Z")

</div>

I’m gonna try and give all info needed for this. (IP is ddos protected and on a vps.) Whenever I try to connect to forums.nfcservers.com (where discourse is hosted) it just times out. App.yml: ## this is the all-in-on…

---

## [Can I increase the 1024000 kb limit on attachment?](https://meta.discourse.org/t/can-i-increase-the-1024000-kb-limit-on-attachment/165367)

<div class="topic-metadata">

**Author:** [@Alon1](https://meta.discourse.org/u/Alon1)\
**Replies:** 18\
**Last updated:** [August 19, 2021, 6:48pm UTC](https://meta.discourse.org/t/can-i-increase-the-1024000-kb-limit-on-attachment/165367 "2021-08-19T18:48:57Z")

</div>

I’m using S3 for attachment storage so that can handle up to 160GB. I changed the nginx limit to 0 (unlimited) The app.yml param “upload\_size” is also set to 0

---

## [Failed opening the RDB file dump.rdb (in server root dir /pups) for saving: Permission denied](https://meta.discourse.org/t/failed-opening-the-rdb-file-dump-rdb-in-server-root-dir-pups-for-saving-permission-denied/200938)

<div class="topic-metadata">

**Author:** [@frank.manuel](https://meta.discourse.org/u/frank.manuel)\
**Replies:** 1\
**Last updated:** [August 19, 2021, 11:05am UTC](https://meta.discourse.org/t/failed-opening-the-rdb-file-dump-rdb-in-server-root-dir-pups-for-saving-permission-denied/200938 "2021-08-19T11:05:20Z")

</div>

Hi, I’m having the same problem as this post, but the solution there was to run postgres and redis on separate containers, but I don’t want to do that (yet). This comment from @Falco uggests that I might have manually …

---

## [Discourse loading slowly via reverse proxy](https://meta.discourse.org/t/discourse-loading-slowly-via-reverse-proxy/200881)

<div class="topic-metadata">

**Author:** [@kianwalters05](https://meta.discourse.org/u/kianwalters05)\
**Replies:** 1\
**Last updated:** [August 18, 2021, 7:40pm UTC](https://meta.discourse.org/t/discourse-loading-slowly-via-reverse-proxy/200881 "2021-08-18T19:40:32Z")

</div>

Hi! Im running discourse on Ubuntu 18.04 on a docker container. To access this i am using an apache reverse proxy with a varnish cache infront of it. The site loads and works fine but doesnt have the speed that all othe…

---

## [Rebuild error: Errno::ENOENT: No such file or directory @ rb\_sysopen - /e tc/postgresql/13/main/pg\_hba.conf](https://meta.discourse.org/t/rebuild-error-errno-no-such-file-or-directory-rb-sysopen-e-tc-postgresql-13-main-pg-hba-conf/200800)

<div class="topic-metadata">

**Author:** [@Lew\_Grothe](https://meta.discourse.org/u/Lew_Grothe)\
**Replies:** 5\
**Last updated:** [August 18, 2021, 9:25am UTC](https://meta.discourse.org/t/rebuild-error-errno-no-such-file-or-directory-rb-sysopen-e-tc-postgresql-13-main-pg-hba-conf/200800 "2021-08-18T09:25:37Z")

</div>

I attempted to do a git pull & launcher rebuild on our test server and got stuck on the following error. Replies/solutions to similar posts on meta (e.g. checking .yml files, etc) seem to not help. What’s next to try? \[…

[Previous page](https://meta.discourse.org/c/support/self-hosting/31.md?page=76)

[Next page](https://meta.discourse.org/c/support/self-hosting/31.md?page=78)
