# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=86

[Latest](https://meta.discourse.org/latest.md) · [Categories](https://meta.discourse.org/categories.md) · [Tags](https://meta.discourse.org/tags.md)

**Page:** 87

---

## [Failed upgrade from v2.7.0.beta1 to v2.7.0.beta2](https://meta.discourse.org/t/failed-upgrade-from-v2-7-0-beta1-to-v2-7-0-beta2/176897)

<div class="topic-metadata">

**Author:** [@mig5](https://meta.discourse.org/u/mig5)\
**Replies:** 14\
**Last updated:** [February 1, 2021, 5:32pm UTC](https://meta.discourse.org/t/failed-upgrade-from-v2-7-0-beta1-to-v2-7-0-beta2/176897 "2021-02-01T17:32:29Z")

</div>

Please see this gist gist:86508bebb133a06f79fadaeba345e3d6 · GitHub This is a stock-standard, standalone Discourse install, trying to upgrade from v2.7.0.beta1 to v2.7.0.beta2 Failure is here: uglifyjs '/var/www/disco…

---

## [301 redirect not working after editing app.yml file and rebuilding the app](https://meta.discourse.org/t/301-redirect-not-working-after-editing-app-yml-file-and-rebuilding-the-app/177811)

<div class="topic-metadata">

**Author:** [@Idan](https://meta.discourse.org/u/Idan)\
**Replies:** 1\
**Last updated:** [February 1, 2021, 3:54am UTC](https://meta.discourse.org/t/301-redirect-not-working-after-editing-app-yml-file-and-rebuilding-the-app/177811 "2021-02-01T03:54:29Z")

</div>

I don’t get my old domain to redirect. I provide the entire app.yml (update to remove personal/private data). ## this is the all-in-one, standalone Discourse Docker container template ## ## After making changes to this …

---

## [PEM\_read\_bio\_X509\_AUX() failed (SSL: error:0909006C:PEM routines:get\_name:no start line:Expecting: TRUSTED CERTIFICATE)](https://meta.discourse.org/t/pem-read-bio-x509-aux-failed-ssl-errorpem-routinesno-start-line-trusted-certificate/176546)

<div class="topic-metadata">

**Author:** [@yoko](https://meta.discourse.org/u/yoko)\
**Replies:** 5\
**Last updated:** [January 31, 2021, 2:39pm UTC](https://meta.discourse.org/t/pem-read-bio-x509-aux-failed-ssl-errorpem-routinesno-start-line-trusted-certificate/176546 "2021-01-31T14:39:13Z")

</div>

I tried to set up forum using discourse on ubuntu 20.04 LTS on VPS. But after install I get: nginx: \[emerg\] cannot load certificate "/shared/ssl/domain.org.cer": PEM\_read\_bio\_X509\_AUX() failed (SSL: error:0909006C:PEM r…

---

## [After upgrade, docker cannot communicate with the outside world](https://meta.discourse.org/t/after-upgrade-docker-cannot-communicate-with-the-outside-world/171902)

<div class="topic-metadata">

**Author:** [@agf1997](https://meta.discourse.org/u/agf1997)\
**Replies:** 26\
**Last updated:** [February 1, 2021, 12:36pm UTC](https://meta.discourse.org/t/after-upgrade-docker-cannot-communicate-with-the-outside-world/171902 "2021-02-01T12:36:02Z")

</div>

I woke up this morning to reports that my discourse server was “down”. I was able to ssh into the server without a problem, noticed some security updates needed to be applied, applied them with apt full-upgrade, and res…

---

## [Interactive SVG using \<object\>?](https://meta.discourse.org/t/interactive-svg-using-object/173747)

<div class="topic-metadata">

**Author:** [@craigconstantine](https://meta.discourse.org/u/craigconstantine)\
**Replies:** 11\
**Last updated:** [January 31, 2021, 11:49pm UTC](https://meta.discourse.org/t/interactive-svg-using-object/173747 "2021-01-31T23:49:40Z")

</div>

I’m trying to embed an interactive, SVG-based, data visualization. I’m generating SVG from a separate system, (but still in the same second-level domain as my Discourse installation.) I’ve tried bringing the SVG in using…

---

## [I need advice regarding massive 301 redirects](https://meta.discourse.org/t/i-need-advice-regarding-massive-301-redirects/160361)

<div class="topic-metadata">

**Author:** [@skozz](https://meta.discourse.org/u/skozz)\
**Replies:** 6\
**Last updated:** [January 30, 2021, 5:42pm UTC](https://meta.discourse.org/t/i-need-advice-regarding-massive-301-redirects/160361 "2021-01-30T17:42:09Z")

</div>

Hola! after searching in the Meta and Google I’m not sure what’s the best way to proceed. Background I have a community with 15,8k topics, 967k posts, tons of images linked to S3. The forum is running under a subdomain …

---

## [Is it possible to deploy discourse to heroku?](https://meta.discourse.org/t/is-it-possible-to-deploy-discourse-to-heroku/177711)

<div class="topic-metadata">

**Author:** [@CODEBULBS](https://meta.discourse.org/u/CODEBULBS)\
**Replies:** 1\
**Last updated:** [January 29, 2021, 8:33pm UTC](https://meta.discourse.org/t/is-it-possible-to-deploy-discourse-to-heroku/177711 "2021-01-29T20:33:44Z")

</div>

Is it possible to host discourse on heroku by running postgre SQL and redis on remote machines?

---

## [Upgrade issue with duplicate username in DB](https://meta.discourse.org/t/upgrade-issue-with-duplicate-username-in-db/177664)

<div class="topic-metadata">

**Author:** [@volksman](https://meta.discourse.org/u/volksman)\
**Replies:** 2\
**Last updated:** [January 29, 2021, 2:41pm UTC](https://meta.discourse.org/t/upgrade-issue-with-duplicate-username-in-db/177664 "2021-01-29T14:41:48Z")

</div>

So I tried to upgrade my board this morning and got an error: PG::UniqueViolation: ERROR: duplicate key value violates unique constraint “index\_users\_on\_username” It names a user “MikeC”. So I did some digging and i…

---

## [Rebuilding invalid indexes](https://meta.discourse.org/t/rebuilding-invalid-indexes/177599)

<div class="topic-metadata">

**Author:** [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**Replies:** 3\
**Last updated:** [January 28, 2021, 9:47pm UTC](https://meta.discourse.org/t/rebuilding-invalid-indexes/177599 "2021-01-28T21:47:22Z")

</div>

I just upgraded a 1.8 million post site to 2.7.0.beta2 and with it the PG10 to PG13 upgrade. I saw that beta3 just came out and has “improved database migration performance” so I went ahead and upgraded again. When I tr…

---

## [Discourse Rebuild](https://meta.discourse.org/t/discourse-rebuild/177383)

<div class="topic-metadata">

**Author:** [@Bharat\_singh](https://meta.discourse.org/u/Bharat_singh)\
**Replies:** 14\
**Last updated:** [January 28, 2021, 8:15pm UTC](https://meta.discourse.org/t/discourse-rebuild/177383 "2021-01-28T20:15:26Z")

</div>

Hi All, I am totally new on Discourse but have been looking at one instance in our company which was setup by someone else. One of our team made an update to SSL cert and after that it has been broken from some weeks. D…

---

## [500 5.5.1 Invalid command: Cannot send mail with Discourse on new install but can from command line (on digital ocean)](https://meta.discourse.org/t/500-5-5-1-invalid-command-cannot-send-mail-with-discourse-on-new-install-but-can-from-command-line-on-digital-ocean/147546)

<div class="topic-metadata">

**Author:** [@b4oshany](https://meta.discourse.org/u/b4oshany)\
**Replies:** 12\
**Last updated:** [January 27, 2021, 3:47pm UTC](https://meta.discourse.org/t/500-5-5-1-invalid-command-cannot-send-mail-with-discourse-on-new-install-but-can-from-command-line-on-digital-ocean/147546 "2021-01-27T15:47:18Z")

</div>

I’m getting the following error using ./discourse-docker on Digital Ocean after installation ==================== MAIL TEST ==================== For a robust test, get an address from http://www.mail-tester.com/ Or just…

---

## [2.7.0.beta2 upgrade failed with ERROR: duplicate key](https://meta.discourse.org/t/2-7-0-beta2-upgrade-failed-with-error-duplicate-key/176980)

<div class="topic-metadata">

**Author:** [@Gunnar](https://meta.discourse.org/u/Gunnar)\
**Replies:** 24\
**Last updated:** [January 26, 2021, 9:46pm UTC](https://meta.discourse.org/t/2-7-0-beta2-upgrade-failed-with-error-duplicate-key/176980 "2021-01-26T21:46:08Z")

</div>

I was upgrading from 2.7.0.beta1 and got this error message: 2021-01-22 20:16:22.015 UTC \[4055\] discourse@discourse LOG: duration: 75335.241 ms statement: UPDATE notifications SET processed = true 2021-01-22 20:16:23.…

---

## [2.7.0.beta2 upgrade failed](https://meta.discourse.org/t/2-7-0-beta2-upgrade-failed/176926)

<div class="topic-metadata">

**Author:** [@realcr](https://meta.discourse.org/u/realcr)\
**Replies:** 34\
**Last updated:** [January 26, 2021, 12:05pm UTC](https://meta.discourse.org/t/2-7-0-beta2-upgrade-failed/176926 "2021-01-26T12:05:01Z")

</div>

Hi, I just received an email from discourse, proposing to upgrade from 2.7.0.beta1 to 2.7.0.beta2. I went to the admin page and clicked on upgrade, and it seems like something has failed. As a result, it is not possibl…

---

## [CSFR Error while login behind HA Proxy](https://meta.discourse.org/t/csfr-error-while-login-behind-ha-proxy/177168)

<div class="topic-metadata">

**Author:** [@crospa91](https://meta.discourse.org/u/crospa91)\
**Replies:** 6\
**Last updated:** [January 26, 2021, 10:07am UTC](https://meta.discourse.org/t/csfr-error-while-login-behind-ha-proxy/177168 "2021-01-26T10:07:02Z")

</div>

Hi guys, I hope this is the right section to ask for help about this. I recently changed the reverse proxy I have in front of the discourse server. I have a server with several discourse installed and a reverse proxy o…

---

## [Migration email hosting - SMTP fail](https://meta.discourse.org/t/migration-email-hosting-smtp-fail/177160)

<div class="topic-metadata">

**Author:** [@dj1sklero](https://meta.discourse.org/u/dj1sklero)\
**Replies:** 1\
**Last updated:** [January 25, 2021, 5:59pm UTC](https://meta.discourse.org/t/migration-email-hosting-smtp-fail/177160 "2021-01-25T17:59:53Z")

</div>

My problem started when I changed the hosting panel from ISPConfig to Plesk. I have a discourse forum, in the new panel I created his e-mail address with the same name and password. I tried to send mail from this accoun…

---

## [Creating a duplicate of production environment](https://meta.discourse.org/t/creating-a-duplicate-of-production-environment/61966)

<div class="topic-metadata">

**Author:** [@Henti\_Smith](https://meta.discourse.org/u/Henti_Smith)\
**Replies:** 24\
**Last updated:** [January 24, 2021, 5:40am UTC](https://meta.discourse.org/t/creating-a-duplicate-of-production-environment/61966 "2021-01-24T05:40:03Z")

</div>

I’m desperately trying to work out how to create a duplicate of our production system to allow testing of upgrades etc before taking it live. I’m hoping there is an easily reproducible set of steps to “export” the produc…

---

## [Discourse fails to properly send an email via a local exim4 smtp server](https://meta.discourse.org/t/discourse-fails-to-properly-send-an-email-via-a-local-exim4-smtp-server/176893)

<div class="topic-metadata">

**Author:** [@superman](https://meta.discourse.org/u/superman)\
**Replies:** 2\
**Last updated:** [January 23, 2021, 4:25pm UTC](https://meta.discourse.org/t/discourse-fails-to-properly-send-an-email-via-a-local-exim4-smtp-server/176893 "2021-01-23T16:25:15Z")

</div>

Exim4 cant accept the email from Discourse for some reason. It appears that Discourse has design flaws or bugs that are causing this. After trying to send the initial registration email so that the admin user can be regi…

---

## [502 Bad Gateway after upgrade to 2.7.0beta2](https://meta.discourse.org/t/502-bad-gateway-after-upgrade-to-2-7-0beta2/177030)

<div class="topic-metadata">

**Author:** [@napcok](https://meta.discourse.org/u/napcok)\
**Replies:** 0\
**Last updated:** [January 23, 2021, 12:46pm UTC](https://meta.discourse.org/t/502-bad-gateway-after-upgrade-to-2-7-0beta2/177030 "2021-01-23T12:46:38Z")

</div>

Updated from cli: cd /var/discourse git pull ./launcher rebuild app Everything went ok but I got 502 Bad Gateway error. docker ps CONTAINER ID IMAGE COMMAND CREATED STATUS …

---

## [Problem, rebuild to latest version](https://meta.discourse.org/t/problem-rebuild-to-latest-version/120564)

<div class="topic-metadata">

**Author:** [@tksyfy](https://meta.discourse.org/u/tksyfy)\
**Replies:** 9\
**Last updated:** [January 23, 2021, 12:23am UTC](https://meta.discourse.org/t/problem-rebuild-to-latest-version/120564 "2021-01-23T00:23:38Z")

</div>

Hi, when I try to rebuild app to latest version with this add-ons on: ## see https://meta.discourse.org/t/19157 for details hooks: after\_code: - exec: cd: $home/plugins cmd: - git clone …

---

## [Error: Discourse + NGINX as reverse proxy + Docker =\> TOO\_MANY\_REDIRECTS](https://meta.discourse.org/t/error-discourse-nginx-as-reverse-proxy-docker-too-many-redirects/176940)

<div class="topic-metadata">

**Author:** [@Ingo\_Karstein](https://meta.discourse.org/u/Ingo_Karstein)\
**Replies:** 0\
**Last updated:** [January 22, 2021, 1:12pm UTC](https://meta.discourse.org/t/error-discourse-nginx-as-reverse-proxy-docker-too-many-redirects/176940 "2021-01-22T13:12:06Z")

</div>

Hi all, I need to move my Docker based Discourse server from one host to another. There is a guide that I followed. No problem there. I stopped Discourse on the old server, synced the files to the new server and tried …

---

## [Unable to send emails using local SMTP server](https://meta.discourse.org/t/unable-to-send-emails-using-local-smtp-server/176643)

<div class="topic-metadata">

**Author:** [@superman](https://meta.discourse.org/u/superman)\
**Replies:** 15\
**Last updated:** [January 21, 2021, 12:44am UTC](https://meta.discourse.org/t/unable-to-send-emails-using-local-smtp-server/176643 "2021-01-21T00:44:32Z")

</div>

I have tested the SMTP server with Telnet: Telnet connected to the SMTP server. Telnet allowed me to authenticate into the SMTP server. Telnet allowed me to successfully send an email using the SMTP server, and I used…

---

## [Discourse connects to the SMTP server but fails to send email through it](https://meta.discourse.org/t/discourse-connects-to-the-smtp-server-but-fails-to-send-email-through-it/174501)

<div class="topic-metadata">

**Author:** [@superman](https://meta.discourse.org/u/superman)\
**Replies:** 7\
**Last updated:** [January 22, 2021, 2:23am UTC](https://meta.discourse.org/t/discourse-connects-to-the-smtp-server-but-fails-to-send-email-through-it/174501 "2021-01-22T02:23:55Z")

</div>

Cant get the first user registration email: Discourse doctor says: SMTP server connection successful. Sending mail failed. However: Telnet to mail.domain.com port 587 works and EHLO mailserver command works. How ca…

---

## [Urgent, upgraded build failed UniqueViolation](https://meta.discourse.org/t/urgent-upgraded-build-failed-uniqueviolation/176858)

<div class="topic-metadata">

**Author:** [@vw\_james](https://meta.discourse.org/u/vw_james)\
**Replies:** 23\
**Last updated:** [January 21, 2021, 8:55pm UTC](https://meta.discourse.org/t/urgent-upgraded-build-failed-uniqueviolation/176858 "2021-01-21T20:55:41Z")

</div>

I tried to upgrade discourse and got the following message - I, \[2021-01-21T18:39:25.045454 #1\] INFO -- : \> cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' 2021-01-21 18:39:32.724 UTC \[4051\] disc…

---

## [Disc too full without much data in the forum](https://meta.discourse.org/t/disc-too-full-without-much-data-in-the-forum/176749)

<div class="topic-metadata">

**Author:** [@jshockley](https://meta.discourse.org/u/jshockley)\
**Replies:** 8\
**Last updated:** [January 21, 2021, 5:27pm UTC](https://meta.discourse.org/t/disc-too-full-without-much-data-in-the-forum/176749 "2021-01-21T17:27:57Z")

</div>

Hello. I’m constantly getting low free space issue with my forum that has only 3 users and barely any files uploaded. I’ve run the cleanup and docker cleanup but as you can see we have only 190mb of backups and 27mb of …

---

## [Self-hosting in China any Discouse built-in service blocked](https://meta.discourse.org/t/self-hosting-in-china-any-discouse-built-in-service-blocked/176776)

<div class="topic-metadata">

**Author:** [@Hyan](https://meta.discourse.org/u/Hyan)\
**Replies:** 5\
**Last updated:** [January 21, 2021, 10:17am UTC](https://meta.discourse.org/t/self-hosting-in-china-any-discouse-built-in-service-blocked/176776 "2021-01-21T10:17:49Z")

</div>

We have a significate forum which we like to migrate to Discourse platform. We would like to self-host in Aliyun cloud to avoid GFW issue. I’m concerned and worried if Discourse platform source code has service request t…

---

## [DNS - NameCheap - Mailchimp - sanity check please](https://meta.discourse.org/t/dns-namecheap-mailchimp-sanity-check-please/176593)

<div class="topic-metadata">

**Author:** [@email](https://meta.discourse.org/u/email)\
**Replies:** 1\
**Last updated:** [January 19, 2021, 7:01pm UTC](https://meta.discourse.org/t/dns-namecheap-mailchimp-sanity-check-please/176593 "2021-01-19T19:01:13Z")

</div>

1. Mailgun 2. Namecheap and setting up DNS It’s been more than 24 hours, DNS should be propagated by now? From the troubleshoot post: Troubleshoot email on a new Discourse install If you are using Mailgun, after yo…

---

## [Migrating from Invision Power Board (IPS$) to Discourse](https://meta.discourse.org/t/migrating-from-invision-power-board-ips-to-discourse/176568)

<div class="topic-metadata">

**Author:** [@Алексей\_Батурин](https://meta.discourse.org/u/%D0%90%D0%BB%D0%B5%D0%BA%D1%81%D0%B5%D0%B9_%D0%91%D0%B0%D1%82%D1%83%D1%80%D0%B8%D0%BD)\
**Replies:** 1\
**Last updated:** [January 19, 2021, 3:04pm UTC](https://meta.discourse.org/t/migrating-from-invision-power-board-ips-to-discourse/176568 "2021-01-19T15:04:05Z")

</div>

Добрый день, мне надо перенести форум IPS4 на Discourse. Хотелось бы понять сколько это булет стоить 2 488 Всего тем 14 296 Всего сообщений 6000 Пользователей

---

## [SMTP server connects, mail fails to send](https://meta.discourse.org/t/smtp-server-connects-mail-fails-to-send/135096)

<div class="topic-metadata">

**Author:** [@Callum\_OKane](https://meta.discourse.org/u/Callum_OKane)\
**Replies:** 12\
**Last updated:** [January 19, 2021, 9:54am UTC](https://meta.discourse.org/t/smtp-server-connects-mail-fails-to-send/135096 "2021-01-19T09:54:53Z")

</div>

==================== MAIL TEST ==================== For a robust test, get an address from http://www.mail-tester.com/ Sending mail to REDACTED . . Testing sending to callumokane123@gmail.com using support@maniabots.xy…

---

## [Parts of site are not secure](https://meta.discourse.org/t/parts-of-site-are-not-secure/175588)

<div class="topic-metadata">

**Author:** [@Andro](https://meta.discourse.org/u/Andro)\
**Replies:** 4\
**Last updated:** [January 18, 2021, 7:06am UTC](https://meta.discourse.org/t/parts-of-site-are-not-secure/175588 "2021-01-18T07:06:43Z")

</div>

After a domain name change, my site is thankfully running again. I use nginx reverse proxy with LetsEncrypt certificates on the server, not in Docker but now I get a padlock warning ‘parts of this page are not secure, su…

---

## [Where is user data stored?](https://meta.discourse.org/t/where-is-user-data-stored/176188)

<div class="topic-metadata">

**Author:** [@RhysGoodwin](https://meta.discourse.org/u/RhysGoodwin)\
**Replies:** 1\
**Last updated:** [January 15, 2021, 2:57pm UTC](https://meta.discourse.org/t/where-is-user-data-stored/176188 "2021-01-15T14:57:25Z")

</div>

Kia ora. I’ve installed Discourse on a digital ocean VM using the INSTALL-cloud.md guide. I’m new to Docker but just wanted to confirm - is all user data stored in the /var/discourse install directory? When I say user d…

[Previous page](https://meta.discourse.org/c/support/self-hosting/31.md?page=85)

[Next page](https://meta.discourse.org/c/support/self-hosting/31.md?page=87)
