# Self-hosting

**URL:** https://meta.discourse.org/c/support/self-hosting/31.md?page=87

[Latest](https://meta.discourse.org/latest.md) · [Categories](https://meta.discourse.org/categories.md) · [Tags](https://meta.discourse.org/tags.md)

**Page:** 88

---

## [Digitalocean 1-click Discourse install](https://meta.discourse.org/t/digitalocean-1-click-discourse-install/176181)

<div class="topic-metadata">

**Author:** [@sheldrake](https://meta.discourse.org/u/sheldrake)\
**Replies:** 3\
**Last updated:** [January 15, 2021, 2:19pm UTC](https://meta.discourse.org/t/digitalocean-1-click-discourse-install/176181 "2021-01-15T14:19:09Z")

</div>

I am getting an error while trying to complete the Digitalocean Discourse 1-click install. Checking your domain name . . . WARNING: Port 443 of computer does not appear to be accessible using hostname: discourse.openfa…

---

## [Using DigitalOcean, domain not working](https://meta.discourse.org/t/using-digitalocean-domain-not-working/176098)

<div class="topic-metadata">

**Author:** [@aidan](https://meta.discourse.org/u/aidan)\
**Replies:** 4\
**Last updated:** [January 14, 2021, 4:23pm UTC](https://meta.discourse.org/t/using-digitalocean-domain-not-working/176098 "2021-01-14T16:23:55Z")

</div>

When I use DigitalOcean to host my discourse forum, I input my hostname, and it returns a warning. My proxy status is set to DNS only, using Cloudflare. I look to address this issue in a quick manner, as I need this for …

---

## [Discourse on Google Cloud port issue?](https://meta.discourse.org/t/discourse-on-google-cloud-port-issue/174236)

<div class="topic-metadata">

**Author:** [@ifeabc](https://meta.discourse.org/u/ifeabc)\
**Replies:** 20\
**Last updated:** [January 14, 2021, 2:02am UTC](https://meta.discourse.org/t/discourse-on-google-cloud-port-issue/174236 "2021-01-14T02:02:15Z")

</div>

Hi all! I have tried a couple of times now to get Discourse up and running on Google Cloud. Currently on my third attempt with creating a VM instance (Ubuntu 18.04 minimal), and manually installing Discourse through term…

---

## [Can I use the managed version of Discourse but edit the source code?](https://meta.discourse.org/t/can-i-use-the-managed-version-of-discourse-but-edit-the-source-code/175793)

<div class="topic-metadata">

**Author:** [@Eyal\_Hochman](https://meta.discourse.org/u/Eyal_Hochman)\
**Replies:** 3\
**Last updated:** [January 13, 2021, 9:47am UTC](https://meta.discourse.org/t/can-i-use-the-managed-version-of-discourse-but-edit-the-source-code/175793 "2021-01-13T09:47:38Z")

</div>

Hi, I wanted to ask if I could use and pay for the hosting services that Discourse provides, but deploy my own code to it or supply a path to a Docker image to replace the site’s base image. I want to do it over the or…

---

## [Rebaking old posts won't pull new S3 CDN URL after S3 bucket rename](https://meta.discourse.org/t/rebaking-old-posts-wont-pull-new-s3-cdn-url-after-s3-bucket-rename/175882)

<div class="topic-metadata">

**Author:** [@Brad\_Wood](https://meta.discourse.org/u/Brad_Wood)\
**Replies:** 13\
**Last updated:** [January 12, 2021, 11:20pm UTC](https://meta.discourse.org/t/rebaking-old-posts-wont-pull-new-s3-cdn-url-after-s3-bucket-rename/175882 "2021-01-12T23:20:06Z")

</div>

After installing Discourse (2.7.0.beta1) and importing old Google Groups posts, I added S3 bucket/key configuration (but no CDN URL) and ran rake uploads:migrate\_to\_s3 which seemed to be working great. All the images …

---

## [Rehosting a snapshot under another Discourse](https://meta.discourse.org/t/rehosting-a-snapshot-under-another-discourse/175692)

<div class="topic-metadata">

**Author:** [@srmoore](https://meta.discourse.org/u/srmoore)\
**Replies:** 2\
**Last updated:** [January 10, 2021, 4:47pm UTC](https://meta.discourse.org/t/rehosting-a-snapshot-under-another-discourse/175692 "2021-01-10T16:47:47Z")

</div>

Hello, I have a question about rehosting an old Discourse Forum. A little background, I’m the custodian of an old open source community forum (i.e. I have a snapshot taken from Discourse, shortly before it was shut down…

---

## [Mailgun port 465 with Discourse 2.7.0 beta](https://meta.discourse.org/t/mailgun-port-465-with-discourse-2-7-0-beta/175682)

<div class="topic-metadata">

**Author:** [@sunwei415](https://meta.discourse.org/u/sunwei415)\
**Replies:** 0\
**Last updated:** [January 10, 2021, 3:07pm UTC](https://meta.discourse.org/t/mailgun-port-465-with-discourse-2-7-0-beta/175682 "2021-01-10T15:07:57Z")

</div>

I can send out Emails using mailgun with some Python Script. No luck with Discourse. Why? Trying port 587. It works! Weird!!!

---

## [Mail receiver app](https://meta.discourse.org/t/mail-receiver-app/175561)

<div class="topic-metadata">

**Author:** [@Andro](https://meta.discourse.org/u/Andro)\
**Replies:** 3\
**Last updated:** [January 9, 2021, 2:04pm UTC](https://meta.discourse.org/t/mail-receiver-app/175561 "2021-01-09T14:04:45Z")

</div>

Where is the best place to ask about mail receiver topics? Here, or another forum? Specifically I am after details on what appear to be a pair of port numbers (25 : 25). It’s not clear to me why there are two ports here…

---

## [Help changing domain](https://meta.discourse.org/t/help-changing-domain/175577)

<div class="topic-metadata">

**Author:** [@Andro](https://meta.discourse.org/u/Andro)\
**Replies:** 4\
**Last updated:** [January 9, 2021, 9:50am UTC](https://meta.discourse.org/t/help-changing-domain/175577 "2021-01-09T09:50:45Z")

</div>

To be specific, I want to change the domain I use from discourse.jackril.space to jackrail.space. But after adjusting app.yml and several rebuilds, I just get a 502 gateway not found and error messages: 2021/01/09 05:2…

---

## [Postfix and mail receiver](https://meta.discourse.org/t/postfix-and-mail-receiver/175467)

<div class="topic-metadata">

**Author:** [@Andro](https://meta.discourse.org/u/Andro)\
**Replies:** 4\
**Last updated:** [January 8, 2021, 12:52pm UTC](https://meta.discourse.org/t/postfix-and-mail-receiver/175467 "2021-01-08T12:52:34Z")

</div>

Is it at all possible to run postfix with normal SMTP port 25 active and mail-receiver for Discourse on the same host, somehow, with some clever configuration? Ideally I want to run postfix on the server as per normal, …

---

## [Google G Suite Relay SMTP not working](https://meta.discourse.org/t/google-g-suite-relay-smtp-not-working/175355)

<div class="topic-metadata">

**Author:** [@Neuro](https://meta.discourse.org/u/Neuro)\
**Replies:** 4\
**Last updated:** [January 8, 2021, 3:09am UTC](https://meta.discourse.org/t/google-g-suite-relay-smtp-not-working/175355 "2021-01-08T03:09:03Z")

</div>

Hello, I’m trying to install discourse for the first time on a DigitalOcean Linux VPS. This VPS is running multiple sites on Nginx and I followed the tutorial on how to install discourse on multiple sites here: Run other…

---

## [Discourse for self hosting](https://meta.discourse.org/t/discourse-for-self-hosting/175420)

<div class="topic-metadata">

**Author:** [@unitfactory](https://meta.discourse.org/u/unitfactory)\
**Replies:** 4\
**Last updated:** [January 7, 2021, 9:35pm UTC](https://meta.discourse.org/t/discourse-for-self-hosting/175420 "2021-01-07T21:35:01Z")

</div>

Hey guys, we search a community software and want to use discourse. Some questions: Is it possible to host discourse on our servers with docker? For our Authenticationssystem we use keycloak. Can we use them with disc…

---

## [Email doesn't work on Virtual Server](https://meta.discourse.org/t/email-doesnt-work-on-virtual-server/175292)

<div class="topic-metadata">

**Author:** [@aaronk](https://meta.discourse.org/u/aaronk)\
**Replies:** 5\
**Last updated:** [January 7, 2021, 5:01pm UTC](https://meta.discourse.org/t/email-doesnt-work-on-virtual-server/175292 "2021-01-07T17:01:37Z")

</div>

I use a virtual server from the German Provider Hosteurope. I have no MTA Postfix on the virtual server. The installation was very simple. After ./launcher bootstrap app and ./launcher start app the app starts. I start …

---

## [Digital Ocean Email?](https://meta.discourse.org/t/digital-ocean-email/175382)

<div class="topic-metadata">

**Author:** [@kynic](https://meta.discourse.org/u/kynic)\
**Replies:** 4\
**Last updated:** [January 7, 2021, 3:32pm UTC](https://meta.discourse.org/t/digital-ocean-email/175382 "2021-01-07T15:32:39Z")

</div>

Hi, I installed discourse on the digital ocean but how should I set up an email service? I want my digital ocean to send emails. what should I do? help pls.

---

## [S3 OVH Object Storage](https://meta.discourse.org/t/s3-ovh-object-storage/175368)

<div class="topic-metadata">

**Author:** [@jbd1](https://meta.discourse.org/u/jbd1)\
**Replies:** 5\
**Last updated:** [January 7, 2021, 1:39pm UTC](https://meta.discourse.org/t/s3-ovh-object-storage/175368 "2021-01-07T13:39:26Z")

</div>

Hi, Does anyone use OVH Object Storage (S3) (Stockage d'objets compatible S3 sans frais de sortie | OVHcloud France) ? It is supposed to be S3 compatible, but Discourse (2.6) only show “Aws::S3::Errors::BadRequest” Re…

---

## [FAILED TO BOOTSTRAP on setup](https://meta.discourse.org/t/failed-to-bootstrap-on-setup/174975)

<div class="topic-metadata">

**Author:** [@DursunCan](https://meta.discourse.org/u/DursunCan)\
**Replies:** 11\
**Last updated:** [January 6, 2021, 9:36pm UTC](https://meta.discourse.org/t/failed-to-bootstrap-on-setup/174975 "2021-01-06T21:36:16Z")

</div>

This error on setup Discourse: FAILED -------------------- Pups::ExecError: cd /var/www/discourse && gem update bundler failed with return #\<Process::Status: pid 297 exit 1\> Location of failure: /pups/lib/pups/exec\_comm…

---

## [Is 30GB now too small to upgrade?](https://meta.discourse.org/t/is-30gb-now-too-small-to-upgrade/90435)

<div class="topic-metadata">

**Author:** [@Amicable](https://meta.discourse.org/u/Amicable)\
**Replies:** 2\
**Last updated:** [June 22, 2018, 8:36am UTC](https://meta.discourse.org/t/is-30gb-now-too-small-to-upgrade/90435 "2018-06-22T08:36:05Z")

</div>

I have a Digital Ocean droplet running. I’m currently on v2.1.0.beta1 +149 & was prompted to upgrade docker (successful) before moving onto Discourse. I now can’t upgrade because of lack of space (reports 27GB/30GB & nee…

---

## [Digital Ocean droplet backups or Discourse backups?](https://meta.discourse.org/t/digital-ocean-droplet-backups-or-discourse-backups/175274)

<div class="topic-metadata">

**Author:** [@Nacho\_Caballero](https://meta.discourse.org/u/Nacho_Caballero)\
**Replies:** 1\
**Last updated:** [January 6, 2021, 5:41pm UTC](https://meta.discourse.org/t/digital-ocean-droplet-backups-or-discourse-backups/175274 "2021-01-06T17:41:27Z")

</div>

I had a few hours of downtime in my site today due to some docker/nginx issue and at some point I considered restoring from a backup. Luckily, I was able to get it working again, but it made me wonder what would have be…

---

## [I see Discourse by port number but i couldn't see it to subdomain. (:3001)](https://meta.discourse.org/t/i-see-discourse-by-port-number-but-i-couldnt-see-it-to-subdomain-3001/175279)

<div class="topic-metadata">

**Author:** [@Murto](https://meta.discourse.org/u/Murto)\
**Replies:** 7\
**Last updated:** [January 6, 2021, 4:42pm UTC](https://meta.discourse.org/t/i-see-discourse-by-port-number-but-i-couldnt-see-it-to-subdomain-3001/175279 "2021-01-06T16:42:25Z")

</div>

I installed discourse on the server with Webmin. I can see the discourse when i do this ipadress:3001 but i can’t see it on forum.myadress.com How can I solve this problem? Webmin panel, i don’t use nginx. I’m using ap…

---

## [Post Install Can't complete email verification](https://meta.discourse.org/t/post-install-cant-complete-email-verification/175147)

<div class="topic-metadata">

**Author:** [@Codes9](https://meta.discourse.org/u/Codes9)\
**Replies:** 3\
**Last updated:** [January 5, 2021, 10:07pm UTC](https://meta.discourse.org/t/post-install-cant-complete-email-verification/175147 "2021-01-05T22:07:22Z")

</div>

I’ve installed Discourse on a new VPS. But I’m unable to complete verification and login. I’ve been following along with Troubleshoot email on a new Discourse install The problem from what I can see seems to be Discou…

---

## [Contabo Hosting Provider Price Consideration](https://meta.discourse.org/t/contabo-hosting-provider-price-consideration/149527)

<div class="topic-metadata">

**Author:** [@weallwegot](https://meta.discourse.org/u/weallwegot)\
**Replies:** 4\
**Last updated:** [April 28, 2020, 4:47am UTC](https://meta.discourse.org/t/contabo-hosting-provider-price-consideration/149527 "2020-04-28T04:47:26Z")

</div>

At the risk of opening yet another topic about comparing hosting providers.. :sweat\_smile: I’ve seen recent news that Contabo, which I’ve seen mentioned a few places on this forum as a potential hosting provider, has …

---

## [What happened to Digital Ocean's 1 Click Install?](https://meta.discourse.org/t/what-happened-to-digital-oceans-1-click-install/152714)

<div class="topic-metadata">

**Author:** [@thomasl4](https://meta.discourse.org/u/thomasl4)\
**Replies:** 5\
**Last updated:** [January 4, 2021, 3:23pm UTC](https://meta.discourse.org/t/what-happened-to-digital-oceans-1-click-install/152714 "2021-01-04T15:23:34Z")

</div>

It used to be so simple, I’m a designer (not a coder) and now I can’t even remotely get it to work. Anyone know of a good tutorial or something to follow? Should I destroy the droplet I’ve probably ruined with failed att…

---

## [500 Internal Server Error on various routes](https://meta.discourse.org/t/500-internal-server-error-on-various-routes/174436)

<div class="topic-metadata">

**Author:** [@ballot](https://meta.discourse.org/u/ballot)\
**Replies:** 2\
**Last updated:** [January 4, 2021, 11:39am UTC](https://meta.discourse.org/t/500-internal-server-error-on-various-routes/174436 "2021-01-04T11:39:47Z")

</div>

Hello, I’m trying to debug recurring 500 Internal Server Error. First the setup (I know this is not ideal and not the recommended deployment using docker): discourse 2.3.8 ruby 2.7.2 (using the snap) redis-server 5:4…

---

## [WARNING: Port 443 of computer does not appear to be accessible using hostname: forum.rlv.link](https://meta.discourse.org/t/warning-port-443-of-computer-does-not-appear-to-be-accessible-using-hostname-forum-rlv-link/173700)

<div class="topic-metadata">

**Author:** [@N0chteil](https://meta.discourse.org/u/N0chteil)\
**Replies:** 11\
**Last updated:** [January 3, 2021, 2:25pm UTC](https://meta.discourse.org/t/warning-port-443-of-computer-does-not-appear-to-be-accessible-using-hostname-forum-rlv-link/173700 "2021-01-03T14:25:46Z")

</div>

When I try to install Discourse, I get this error every time: DNS: I’m using CloudFlare I have searched many posts here but have not found a solution (that works for me). I installed Apache2 because it runs the…

---

## [Generating mailing logs for console to check installation?](https://meta.discourse.org/t/generating-mailing-logs-for-console-to-check-installation/90301)

<div class="topic-metadata">

**Author:** [@Zooey](https://meta.discourse.org/u/Zooey)\
**Replies:** 6\
**Last updated:** [June 20, 2018, 2:09pm UTC](https://meta.discourse.org/t/generating-mailing-logs-for-console-to-check-installation/90301 "2018-06-20T14:09:59Z")

</div>

I seem to be running with mailing errors after a local install with docker (I want to tamper with discourse, planning to use it on some sites in the future). The problem is that it requires mail to create admin. I’ve ch…

---

## [Job::ReadTimeout error](https://meta.discourse.org/t/job-readtimeout-error/174776)

<div class="topic-metadata">

**Author:** [@Anjal\_Bam](https://meta.discourse.org/u/Anjal_Bam)\
**Replies:** 1\
**Last updated:** [January 3, 2021, 6:14am UTC](https://meta.discourse.org/t/job-readtimeout-error/174776 "2021-01-03T06:14:11Z")

</div>

Hello, I was setting up discourse to my site and i set up everything as instructed, but the confirmation email never came and got errors like Job::ReadTimeout error, and 504 5.7.4 Unrecognized authentication type \[SJ0PR1…

---

## [After initial setup of DigitalOcean droplet, get Refused to Connect error](https://meta.discourse.org/t/after-initial-setup-of-digitalocean-droplet-get-refused-to-connect-error/45002)

<div class="topic-metadata">

**Author:** [@bolemk](https://meta.discourse.org/u/bolemk)\
**Replies:** 3\
**Last updated:** [January 1, 2021, 7:46pm UTC](https://meta.discourse.org/t/after-initial-setup-of-digitalocean-droplet-get-refused-to-connect-error/45002 "2021-01-01T19:46:21Z")

</div>

I have followed the tutorial found below to set up discourse on a DigitalOcean Droplet. discourse/docs/INSTALL-cloud.md at main · discourse/discourse · GitHub But when I go the the corresponding IP address, I get """T…

---

## [Trouble setting up smtp](https://meta.discourse.org/t/trouble-setting-up-smtp/174646)

<div class="topic-metadata">

**Author:** [@Brecht\_Vermeersch](https://meta.discourse.org/u/Brecht_Vermeersch)\
**Replies:** 4\
**Last updated:** [December 31, 2020, 7:24am UTC](https://meta.discourse.org/t/trouble-setting-up-smtp/174646 "2020-12-31T07:24:18Z")

</div>

I just did a clean install on Digital Ocean but I can’t seem to get my SMTP configured correctly. Using curl I was able to send a mail. I tried adding DISCOURSE\_SMTP\_AUTHENTICATION: login and exec: rails r “SiteSett…

---

## [Yandex smtp mail not send](https://meta.discourse.org/t/yandex-smtp-mail-not-send/174627)

<div class="topic-metadata">

**Author:** [@onecame](https://meta.discourse.org/u/onecame)\
**Replies:** 4\
**Last updated:** [December 30, 2020, 8:26pm UTC](https://meta.discourse.org/t/yandex-smtp-mail-not-send/174627 "2020-12-30T20:26:30Z")

</div>

DISCOURSE\_SMTP\_ADDRESS: smtp.yandex.com.tr DISCOURSE\_SMTP\_PORT: 587 DISCOURSE\_SMTP\_USER\_NAME: admin@form.gelcoz.tk DISCOURSE\_SMTP\_PASSWORD: "pass" DISCOURSE\_SMTP\_ENABLE\_START\_TLS: true # (optional, default true…

---

## [Sendgrid is driving me up the wall!](https://meta.discourse.org/t/sendgrid-is-driving-me-up-the-wall/174539)

<div class="topic-metadata">

**Author:** [@Eman](https://meta.discourse.org/u/Eman)\
**Replies:** 8\
**Last updated:** [December 30, 2020, 4:39am UTC](https://meta.discourse.org/t/sendgrid-is-driving-me-up-the-wall/174539 "2020-12-30T04:39:41Z")

</div>

Hi! I’ve been trying to get Discourse up and running (armed only with Google and no real knowledge of Ubuntu or anything else). The page is up and running, but when I try and register as the admin, I don’t receive the em…

[Previous page](https://meta.discourse.org/c/support/self-hosting/31.md?page=86)

[Next page](https://meta.discourse.org/c/support/self-hosting/31.md?page=88)
