Undefined method `sub!' when visiting `/admin/upgrade`

Standard install, but I admit the site is running since 2018 IIRC, so… but at least it’s docker-based and feels like a standard setup. As I said, so far everything worked as expected.

Plugins:

I rebuilt again, fixed the permissions and ran a few git config --global --add safe.directory … commands, but the /upgrade page is still showing an error and the log says:

NoMethodError (undefined method `sub!' for nil:NilClass)
app/controllers/application_controller.rb:420:in `block in with_resolved_locale'
app/controllers/application_controller.rb:420:in `with_resolved_locale'
lib/middleware/omniauth_bypass_middleware.rb:74:in `call'
lib/content_security_policy/middleware.rb:12:in `call'
lib/middleware/anonymous_cache.rb:389:in `call'
lib/middleware/gtm_script_nonce_injector.rb:10:in `call'
config/initializers/100-quiet_logger.rb:20:in `call'
config/initializers/100-silence_logger.rb:29:in `call'
lib/middleware/enforce_hostname.rb:24:in `call'
lib/middleware/request_tracker.rb:228:in `call'