The user Srujan_Madderla is seeking help to upgrade their on-premise Kore Community instance from version 3.2.0.beta5-dev to 3.5.0.beta7, but encounters a Docker version error requiring an upgrade to at least 20.10.0. nat suggests running git pull origin main --autostash, but Srujan_Madderla reports the --autostash option is not recognized, indicating an outdated Git version, as confirmed by 4 NateDhaliwal. pfaffman advises that the entire system, including the OS, is likely outdated and recommends migrating to a new VM with a modern OS and Docker, restoring a backup, to avoid potential issues with PostgreSQL 15 and ensure a smooth upgrade with minimal downtime.
The easiest thing is to create a new VM with a new OS and a new Docker, install Discourse and restore a backup.
It’s possible that you can upgrade docker and try again, but you’ll still need to deal with the PostgreSQL 15 update. Moving to a new server will require little downtime and zero chance of leaving your system in a broken state.