Hello,
The installation claims I don’t have enough space, but I have

Earlier I have stat error :
![]()
So I think I need to install a special version of stat ?
Host is an Alpine
Hello,
The installation claims I don’t have enough space, but I have

Earlier I have stat error :
![]()
So I think I need to install a special version of stat ?
Host is an Alpine
I think you may be looking in the wrong place for free space, do you see anything different with
df -h /var/lib/docker
if you don’t have enough space there, you can try ./launcher cleanup from /var/discourse to remove old images
Good idea if you can to share text, not screenshots, so these things can be searched on.
This may be why it isn’t working properly then, I think that the launcher script expects you are running on Debian/Ubuntu. It seems like your stat error is from the BusyBox version of stat not recognizing the format flag here:
The command is working fine on my Arch PC so presumably it’s okay on Ubuntu too.
I believed this may have been potentially related to a change I made recently but I maintained the logic from the previous version so it seems to just be a BusyBox thing.

The idea that the docker container isn’t actually portable between distros is confusing as that is what docker is for, works “everywhere docker is”.
Instead of using stat, the launcher script could use df as that outputs identical information on Alpine and Ubuntu.
Fair, because:
discourse/docs/INSTALL-cloud.md at main · discourse/discourse · GitHub suggests 64-bit Linux is the basic requirement (even though Ubuntu is “recommended”)