# 2.6.0 Beta4 update failed with what looks like db errors

**URL:** https://meta.discourse.org/t/2-6-0-beta4-update-failed-with-what-looks-like-db-errors/167661
**Category:** Self-hosting
**Created:** [October 19, 2020, 7:20pm UTC](https://meta.discourse.org/t/2-6-0-beta4-update-failed-with-what-looks-like-db-errors/167661 "2020-10-19T19:20:29Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [October 19, 2020, 7:54pm UTC](https://meta.discourse.org/t/2-6-0-beta4-update-failed-with-what-looks-like-db-errors/167661/2 "2020-10-19T19:54:13Z")

</div>

> [@Gunnar](#):
>
> Discourse resides on AWS EFS

That is a _very_ peculiar choice. Why not use RDS ?

> [@Gunnar](#):
>
> `2020-10-19 18:47:11.818 UTC [91] postgres@discourse FATAL: the database system is starting up`

This happens when the container is not gracefully shutdown, so PostgreSQL will have to perform a recovery process on next start up.

This usually happens very fast, but if your database is big (your case) and/or the disk is slow (really your case) this can be too slow and our rebuild script doesn’t know what to do.

A simple recovery method is starting the container again with `./launcher start app`, letting it run happily for some time (let’s say 1h) and trying a rebuild later.

---

_[View the full topic](https://meta.discourse.org/t/2-6-0-beta4-update-failed-with-what-looks-like-db-errors/167661)._
