# 2 E-Mails von 2026.4.0-latest (5f0d95e1f1) abgelehnt

**URL:** https://meta.discourse.org/t/2-emails-rejected-by-2026-4-0-latest-5f0d95e1f1/400152
**Category:** Self-hosting
**Tags:** mail-receiver
**Created:** [7. April 2026 um 20:37 UTC](https://meta.discourse.org/t/2-emails-rejected-by-2026-4-0-latest-5f0d95e1f1/400152 "2026-04-07T20:37:55Z")
**Posts on this page:** 1
**Showing post:** 1

<div class="post-metadata">

### Author: ![Ethsim2](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ethsim2/32/522255_2.png) [@Ethsim2](https://meta.discourse.org/u/Ethsim2)
#### Post date: [7. April 2026 um 20:37 UTC](https://meta.discourse.org/t/2-emails-rejected-by-2026-4-0-latest-5f0d95e1f1/400152/1 "2026-04-07T20:37:55Z")

</div>

Hallo, ich stelle bei einer selbst gehosteten Site, die `mail-receiver` verwendet, gelegentlich Fehler bei der Verarbeitung eingehender E-Mails fest.

### Was passiert ist

Zwei separate eingehende E-Mails:

- wurden an die richtige Discourse-Adresse zugestellt
- erscheinen in `/admin/email/received`
- erscheinen ebenfalls in `/admin/email/rejected`
- zeigen den allgemeinen Ablehnungstext: „Beim Verarbeiten Ihrer E-Mail ist ein nicht erkannter Fehler aufgetreten, und sie wurde nicht veröffentlicht.“

Gleichzeitig zeigten die Logs `ActiveRecord::Deadlocked` an.

### Warum ich denke, dass dies ein Fehler sein könnte

Ich habe die abgelehnten E-Mails mit einer späteren **erfolgreichen** E-Mail eines sehr ähnlichen Formats verglichen:

- gleiches Absendermuster
- gleicher Microsoft-/Power-Automate-Pfad
- gleiche sichtbare Struktur bei „To:"
- gleicher SMTP-Umschlag-Empfänger an die Discourse-Adresse

Dies sieht also nicht nach einem einfachen Konfigurationsproblem mit `mail-receiver` aus.

### Beweise

Für beide abgelehnten E-Mails:

- es handelte sich um separate Zustellungen mit unterschiedlichen `Message-ID`s
- sie hatten unterschiedliche Postfix-Warteschlangen-IDs
- beide wurden `for <ppyem3.accomodation@discourse.domain.com>` zugestellt

Ich habe ebenfalls `ActiveRecord::Deadlocked` in den Logs um denselben Zeitraum beobachtet.

### Hosting-Kontext

- selbst gehostet
- Verwendung von `mail-receiver`
- kleiner IONOS VPS
- 1 Web-Worker konfiguriert

Mir ist bewusst, dass der einzelne Web-Worker möglicherweise nur ein Hintergrundkontext ist und nicht die Ursache, da es sich hier um eingehende E-Mail-/Hintergrundverarbeitung und nicht um die Bearbeitung von Webanfragen handelt.

Falls hilfreich, kann ich bereitstellen:

- redigierte Header für die 2 abgelehnten E-Mails
- redigierte Header für eine vergleichbare erfolgreiche E-Mail
- den Deadlock-Log-Eintrag

---

_[View the full topic](https://meta.discourse.org/t/2-emails-rejected-by-2026-4-0-latest-5f0d95e1f1/400152)._
