22 failures in specs out-of-box


(Pustovalov Sergey) #1

Hi, all.
I just cloned repo and run autotest. And I got

Finished in 11 minutes 44 seconds (files took 8.74 seconds to load)
4291 examples, 22 failures, 27 pending

Failed examples:

rspec ./spec/components/topic_query_spec.rb:211 # TopicQuery a bunch of topics list_latest sort_order returns the topics in correct order
rspec ./spec/components/topic_query_spec.rb:14 # TopicQuery secure category filters categories out correctly
rspec ./spec/components/search_spec.rb:68 # Search escapes non alphanumeric characters
rspec ./spec/components/search_spec.rb:375 # Search Advanced search can find by status
rspec ./spec/models/topic_spec.rb:830 # Topic scopes #by_most_recently_created returns topics ordered by created_at desc, id desc
rspec ./spec/models/topic_spec.rb:1192 # Topic#listable_count_per_day collect closed interval listable topics count
rspec ./spec/models/top_topic_spec.rb:22 # TopTopic refresh! after calculating should have top topics
rspec ./spec/models/post_spec.rb:663 # Post summary returns the OP and posts above the threshold in summary mode
rspec ./spec/models/post_spec.rb:678 # Post sort_order regular topic defaults to created order
rspec ./spec/components/post_creator_spec.rb:354 # PostCreator existing topic success create correctly
rspec ./spec/components/suggested_topics_builder_spec.rb:91 # SuggestedTopicsBuilder adding results adding topics that are not open adds archived and closed, but not invisible topics
rspec ./spec/components/suggested_topics_builder_spec.rb:101 # SuggestedTopicsBuilder adding results category definition topics doesn't add a category definition topic
rspec ./spec/components/suggested_topics_builder_spec.rb:76 # SuggestedTopicsBuilder adding results adding topics added the result correctly
rspec ./spec/components/onebox/engine/discourse_local_onebox_spec.rb:20 # Onebox::Engine::DiscourseLocalOnebox for a link to a post returns a link if post isn't found
rspec ./spec/components/cooked_post_processor_spec.rb:162 # CookedPostProcessor.post_process_images topic image adds a topic image if there's one in the post
rspec ./spec/models/topic_user_spec.rb:226 # TopicUser can scope by tracking
rspec ./spec/models/report_spec.rb:36 # Report topic report no topics returns an empty report
rspec ./spec/models/report_spec.rb:80 # Report topic report with topics returns total data
rspec ./spec/models/report_spec.rb:36 # Report post report no posts returns an empty report
rspec ./spec/models/report_spec.rb:80 # Report post report with posts returns total data
rspec ./spec/models/report_spec.rb:145 # Report private messages topic report).to not include private messages
rspec ./spec/models/report_spec.rb:153 # Report private messages post report).to not include private messages

Is it normally, or I can fix it and create a PR?


(Régis Hanol) #2

Are you running the very latest version?


(Pustovalov Sergey) #3

Hmmm, I forked it today. I think it is the latest master version


(Sam Saffron) #4

Need more information on these failures, also try nuking your test db and recreating, does it still happen?


(Pustovalov Sergey) #5

I made rake db:test:prepare and all specs are passing ok

Finished in 7 minutes 5 seconds (files took 14.7 seconds to load)
4291 examples, 0 failures, 27 pending

(Régis Hanol) #6