(422) Unprocessable Entity Error - Zapier to Invites via API


#1

Hi,
on and off we are getting errors as per title and image below when Zapier is running an invite via the api - for example the one below ran at 12:07 where as the one before that 17 mins earlier went through ok but this one did not.

I have checked the /logs page and there are no logs coming up at all strangely. I cleared the logs - tried to re-run it and still nothing.

Nothing has changed in the API call all Zapier does is capture the email address out of the mailchimp list and adds it in and then sends it into the API in order to send an invite out to them for the forum.

I have edited out the username and api key and part of the email address - I have checked the email address and it is valid - I have also had the issue with outlook.com email addresses and gmail ones too etc.

Its very odd as two more have gone through since!


(Matt Palmer) #2

What do the Discourse logs have to say on the matter?


#3

Hi @mpalmer
As mentioned above when checking the /logs page there is nothing coming up relative to that issue at all. I even cleared all of the logs tried running it through again and nothing comes up.
Unfortunately I dont have direct access to the server itself so unable to see the nginx or rails logs


(Matt Palmer) #4

You’ll need to engage your hosting provider’s support, then, to see what’s going on.