500 error on move topic


(Matt Taylor) #1

I’m getting a 500 error indication when I select posts from a topic and attempt to move them into a new topic. See this video for demo:


(Jeff Atwood) #2

I can’t repro this on try.discourse.org. Is there anything unusual about the category you are creating the topic in, or the topic you are moving posts from?


(Matt Taylor) #3

The topic I’m moving from is quite long (58 replies). There is nothing special about the destination category except that it is a sub-category.

I just tested:

  • moving post from a different topic into another category (:heavy_check_mark:︎ worked)
  • moving post with replies from a different topic into another category (:heavy_check_mark:︎ worked)
  • moving the post in the video to a different sub-category (✘ did not work)
  • moving the post in the video to a different top-level category (✘ did not work)
  • moving the post in the video and replies to a different sub-category (✘ did not work)

The original post that fails to move contains:

  • links
  • replies
  • one-box

(Sam Saffron) #4

Since its happening on a forum we are hosting, can you let us know the exact repro, so we can try it out on your forum? (link to post that is not moving and where you are trying to move it to)


(Matt Taylor) #5

The first post I would like to move is here. I would like to move it here with the title “Synaptic Pruning”.

Thank you!


(Matt Taylor) #6

Any update on this? I can’t moderate my forum anymore :frowning: .


(Robin Ward) #7

Sorry for the delay, I’ll look into this now.


(Robin Ward) #8

Okay I’ve fixed the issue!

It’s currently deploying. If you try again in 10 minutes on your Discourse it should work again! Thanks for helping us identify it.


(Matt Taylor) #9

You guys are amazing! Thanks so much. :blush:


(Jeff Atwood) #10