500 Internal Server Error when trying to write a new topic


#1

Hello, I keep getting a “500 Internal Server Error” every time I try to start a new topic.
The error-log says the following:

I18n::InvalidPluralizationData (translation data {:topics=>"Themen"} can not be used with :count => 1)
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/i18n-0.7.0/lib/i18n/backend/pluralization.rb:35:in `pluralize'

I’m not using any plugins, just the standard-installation. It has been working already before.

Any hits or tips where I can find the problem?

Would be great. I like the system so much and I want to get started.

Thanks,

Juri


Cannot split topic - see error logs in the topic body
(Jeff Atwood) #2

Looks like a problem with the translations for that language.


#3

I reset all translations which I did manually, but that didn’t change anything.

What can I try?


(Jeff Atwood) #4

@techapj can you assist?


#5

I just tried to switch the language back to english, which seems to work fine so far.
As soon as I switch it back to German it starts producing errors.

Is it possible, that the German localization doesn’t work at all? Did anyone experience similar problems?

The strange thing about it is: I was already working well (even in German!), it suddenly started producing errors.

Any help? Thanks a lot


#6

Is there any way to reinstall the language-packs out of the box?
Maybe that could help.


(Sam Saffron) #7

Its a bug in the localization, we should not be failing out in this way, we will have a look.


#8

Would be amazing if you can offer any help. I’ll keep going on developing my site with the english version now, but I definitely want to use the localization soon - as it’s really good translated and really useful for me.


(Arpit Jalan) #9

Hey @Juri, are you getting the error on this site: http://www.derneuekosmos.de?

I just created a new topic there and it was successfully posted. It’s still using German (Deutsch) locale.


#10

Pretty strange. I tried it just one moment ago and got the same error again.
Yes, on that site.

I also tried two different users - makes no difference.


#11

Okay, I tried again and it worked.
Seems like it works from time to time anyway, but I can’t figure out when.


(Arpit Jalan) #12

Can you try to repro this error in Chrome’s incognito mode?

If you have plugins installed in your browser they may be interfering with AJAX requests and triggering this error.


New Topic: 500 Internal Server Error
(Arpit Jalan) #13

@eviltrout fixed the original issue here:

Closing this in favour of above topic.


(Arpit Jalan) #14