# 500 Oops errors after upgrading

**URL:** https://meta.discourse.org/t/500-oops-errors-after-upgrading/407962
**Category:** Support
**Created:** [July 19, 2026, 12:18am UTC](https://meta.discourse.org/t/500-oops-errors-after-upgrading/407962 "2026-07-19T00:18:36Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![uckelman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/uckelman/32/103854_2.png) [@uckelman](https://meta.discourse.org/u/uckelman)
#### Post date: [July 20, 2026, 6:30am UTC](https://meta.discourse.org/t/500-oops-errors-after-upgrading/407962/2 "2026-07-20T06:30:50Z")

</div>

I have Discourse reverse proxied behind Caddy, and it turns out that the solution was to add

```plaintext
header_up X-Real-IP {remote_host}

```

to the `reverse_proxy` section in my `Caddyfile`, which I hadn’t needed before.

I figured out that `X-Real-IP` was needed due to the similar error message in [this post](https://meta.discourse.org/t/how-to-disable-logging-ip-address/192656/4).

I hope this helps someone having a similar problem.

---

_[View the full topic](https://meta.discourse.org/t/500-oops-errors-after-upgrading/407962)._
