# 501 5.5.4 您不允许从此地址发送

**URL:** <https://meta.discourse.org/t/501-5-5-4-you-are-not-allowed-to-send-from-this-address/293684>\
**Category:** Self-hosting\
**Tags:** email\
**Created:** [2024年一月31日 21:03 UTC](https://meta.discourse.org/t/501-5-5-4-you-are-not-allowed-to-send-from-this-address/293684 "2024-01-31T21:03:22Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![hellekin](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/hellekin/32/51636_2.png) [@hellekin](https://meta.discourse.org/u/hellekin)\
**Post date:** [2024年一月31日 21:03 UTC](https://meta.discourse.org/t/501-5-5-4-you-are-not-allowed-to-send-from-this-address/293684/1 "2024-01-31T21:03:22Z")

</div>

我正在从 Thunderbird 客户端测试 Discourse 的电子邮件设置，可以正常收发电子邮件。但在 Discourse 中，发送电子邮件时出现此错误，但电子邮件并未发送：

`501 5.5.4 You are not allowed to send from this address.`

此错误是什么意思？  
它在哪里生成？根据什么规则？

SPF 记录仅允许 MX 发送电子邮件（配置为 `DISCOURSE_SMTP_ADDRESS`），这似乎不会与其他域产生任何问题，因为 SMTP 客户端会连接到 MX 来发送。

---

<div class="post-metadata">

**Author:** ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**Post date:** [2024年一月31日 21:23 UTC](https://meta.discourse.org/t/501-5-5-4-you-are-not-allowed-to-send-from-this-address/293684/2 "2024-01-31T21:23:24Z")

</div>

> [@hellekin](#):
>
> 这个错误是什么意思？

这（可能）意味着 Thunderbird 正在从类似 `user@example.com` 的地址发送邮件，而您的论坛是从 `user@forum.example.com` 发送的。您可能需要更改您的 `notification_email` 地址。

您是否正在使用任何用于发送事务性电子邮件的服务？

请参阅 [在新安装的 Discourse 中排除电子邮件故障](https://meta.discourse.org/t/troubleshoot-email-on-a-new-discourse-install/16326)

---

<div class="post-metadata">

**Author:** ![hellekin](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/hellekin/32/51636_2.png) [@hellekin](https://meta.discourse.org/u/hellekin)\
**Post date:** [2024年二月1日 00:26 UTC](https://meta.discourse.org/t/501-5-5-4-you-are-not-allowed-to-send-from-this-address/293684/3 "2024-02-01T00:26:40Z")

</div>

错误消息的意思是 _发件人_ 地址不允许。可能是因为它没有出现在邮件服务器的允许发件人配置中。

嗯，在你的帮助下，@pfaffman，我找到了我的错误。

错误消息中的“地址”指的是 _发件人_ 地址。我一直关注 IP 地址，所以被误导了。

当我检查通知地址（`containers/app.yml` 中的 `DISCOURSE_NOTIFICATION_EMAIL`）时，我意识到我的 _邮件服务器_ 缺少该发件人的条目：添加别名解决了问题。

---

<div class="post-metadata">

**Author:** ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)\
**Post date:** [2024年三月2日 00:27 UTC](https://meta.discourse.org/t/501-5-5-4-you-are-not-allowed-to-send-from-this-address/293684/4 "2024-03-02T00:27:26Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
