# Ошибка 504 Gateway после запуска нового экземпляра AWS

**URL:** https://meta.discourse.org/t/504-gateway-error-after-launching-new-aws-instance/207521
**Category:** Support
**Created:** [29.Октябрь.2021 10:26:38 UTC](https://meta.discourse.org/t/504-gateway-error-after-launching-new-aws-instance/207521 "2021-10-29T10:26:38Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![cokestroke](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cokestroke/32/242007_2.png) [@cokestroke](https://meta.discourse.org/u/cokestroke)
#### Post date: [29.Октябрь.2021 10:26:38 UTC](https://meta.discourse.org/t/504-gateway-error-after-launching-new-aws-instance/207521/1 "2021-10-29T10:26:38Z")

</div>

Я создал новый экземпляр Discourse из существующего образа EC2 в AWS и изменил домен в файле app.yml. Архитектура и остальные настройки остались прежними. Однако при переходе по ссылке в браузере возникает ошибка 504. Нужно ли что-то ещё изменить?

Образ был взят с [forum.mystrokeguide.com](http://forum.mystrokeguide.com), а домен я изменил на [forum-dev.mystrokeguide.com](http://forum-dev.mystrokeguide.com).

Спасибо,  
C

---

<div class="post-metadata">

### Author: ![IAmGav](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/iamgav/32/235598_2.png) [@IAmGav](https://meta.discourse.org/u/IAmGav)
#### Post date: [29.Октябрь.2021 10:42:40 UTC](https://meta.discourse.org/t/504-gateway-error-after-launching-new-aws-instance/207521/2 "2021-10-29T10:42:40Z")

</div>

Вот пост, который вы можете проверить, он может вам помочь

> [@Change the domain name or rename your Discourse](https://meta.discourse.org/t/change-the-domain-name-or-rename-my-discourse/16098):
>
> bookmark This guide explains how-to change the domain name of your Discourse site, and includes information about setting up DNS changes, editing configuration files, updating site settings, and correcting social logins and post content to reflect your new domain name. warning This guide is for self-hosted Discourse instances that were installed using our [installation guide on GitHub](https://github.com/discourse/discourse/blob/main/docs/INSTALL-cloud.md). If you are [hosted by Discourse](https://www.discourse.org/pricing), please see [Configure your domain name for hosted Discourse](https://meta.discourse.org/t/configure-your-domain-name-for-hosted-discourse/21827) for specific …

---

<div class="post-metadata">

### Author: ![cokestroke](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cokestroke/32/242007_2.png) [@cokestroke](https://meta.discourse.org/u/cokestroke)
#### Post date: [29.Октябрь.2021 11:07:49 UTC](https://meta.discourse.org/t/504-gateway-error-after-launching-new-aws-instance/207521/3 "2021-10-29T11:07:49Z")

</div>

Спасибо. Я выполнил все шаги из статьи, но всё ещё получаю ошибку 504.

---

<div class="post-metadata">

### Author: ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)
#### Post date: [29.Октябрь.2021 11:24:01 UTC](https://meta.discourse.org/t/504-gateway-error-after-launching-new-aws-instance/207521/4 "2021-10-29T11:24:01Z")

</div>

Ваш домен указывает на несколько IP-адресов? Я только что проверил распространение ваших DNS-записей, и там указаны два IP-адреса. Возможно, это и есть причина конфликта?

---

<div class="post-metadata">

### Author: ![cokestroke](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cokestroke/32/242007_2.png) [@cokestroke](https://meta.discourse.org/u/cokestroke)
#### Post date: [29.Октябрь.2021 11:27:50 UTC](https://meta.discourse.org/t/504-gateway-error-after-launching-new-aws-instance/207521/5 "2021-10-29T11:27:50Z")

</div>

Это только для forum-dev? У меня к нему привязан статический IP-адрес и настроено правило от балансировщика нагрузки AWS. Так что мне стоит открепить статический IP и проверить?

---

<div class="post-metadata">

### Author: ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)
#### Post date: [29.Октябрь.2021 11:35:26 UTC](https://meta.discourse.org/t/504-gateway-error-after-launching-new-aws-instance/207521/6 "2021-10-29T11:35:26Z")

</div>

Я выполнил этот DNS-запрос - [https://www.whatsmydns.net/#A/forum-dev.mystrokeguide.com](https://www.whatsmydns.net/#A/forum-dev.mystrokeguide.com)

Боюсь, у меня недостаточно опыта работы с DNS, чтобы точно сказать, является ли это проблемой (надеюсь, кто-нибудь ещё подключится к обсуждению 🤞).

---

<div class="post-metadata">

### Author: ![cokestroke](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cokestroke/32/242007_2.png) [@cokestroke](https://meta.discourse.org/u/cokestroke)
#### Post date: [29.Октябрь.2021 11:37:08 UTC](https://meta.discourse.org/t/504-gateway-error-after-launching-new-aws-instance/207521/7 "2021-10-29T11:37:08Z")

</div>

Спасибо, это полезно. Я изучу и проверю это.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [29.Октябрь.2021 11:57:13 UTC](https://meta.discourse.org/t/504-gateway-error-after-launching-new-aws-instance/207521/8 "2021-10-29T11:57:13Z")

</div>

Если вы используете стандартную установку, вам нужно указать только ec2. Размещение балансировщика нагрузки перед ним довольно сложно.

Если вы выполняли много пересборок, при которых DNS указывал на несколько адресов, у вас может не быть действительного сертификата, и вы не сможете получить новый из-за ограничений по частоте запросов. В таком случае используйте другое имя или подождите неделю.

---

<div class="post-metadata">

### Author: ![cokestroke](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cokestroke/32/242007_2.png) [@cokestroke](https://meta.discourse.org/u/cokestroke)
#### Post date: [29.Октябрь.2021 14:32:52 UTC](https://meta.discourse.org/t/504-gateway-error-after-launching-new-aws-instance/207521/9 "2021-10-29T14:32:52Z")

</div>

Можно ли установить сертификат, выпущенный AWS, прямо в приложение? Я обычно использую балансировщик нагрузки для добавления сертификатов на экземпляры EC2. Или мне закомментировать строки Let’s Encrypt в app.yml?

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [29.Октябрь.2021 15:04:03 UTC](https://meta.discourse.org/t/504-gateway-error-after-launching-new-aws-instance/207521/10 "2021-10-29T15:04:03Z")

</div>

Я рекомендую начать с чистой установки, а затем перейти к настройке балансировщика нагрузки. Единственная поддерживаемая установка здесь — это базовый вариант, следуя руководству. Слишком много вещей может пойти не так при добавлении балансировщика нагрузки, чтобы угадать, в чём ваша проблема.

Если вы всё же хотите использовать балансировщик нагрузки, то вам нужно пропустить `discourse-setup` и удалить шаблоны ssl и letsencrypt.
