A few different issues on iPhone


(Brad Huber) #1

Our users have noticed a few issues that seem prevalent across most of them using iPhones (a variety of 4, 4s, and 5)

One issue is that sometimes when going to the Latest tab (/categories is our default), it doesnt actually show the most recent posts. They might be posts from a few hours ago, when there are several more recent. I noticed this myself when I went into a specific category and made a topic, then went back to the homepage, and went to the specific category from the “all categories” dropdown. The new topic I had created wasnt there. I waited a good 3 minutes to see if the message bus would pick it up. Going back to /latest or /categories, then back into this category never makes it show up. I have to do a refresh on the page. This issue I think only happens when on 3G or 4G. I havent seen it when connected to WiFi

A second issue us that we’re noticing about 1/3rd of the time, image uploads will never go past 0%. When this happens (and also sometimes if you hit “Cancel” on the upload), it doesnt actually remove the “uploading 0%, Cancel” text, even if you abandon the reply, and try to reply somewhere else on the site. It seems like it just has to time out on its own at some point. This has happened when on 3G, 4G and WiFi.

Is any one else having issues on iPhones with image uploads freezing at 0% and page data not being current?


(Jeff Atwood) #2

Where is your Discourse hosted? Do you have repeatable repro steps for any of that using try.discourse.org?

Possible related to categories page being the homepage would be my guess. So start at /categories when attempting to repro.


(Brad Huber) #3

I was just able to reproduce it on try.discourse, with my iphone 4s, on 3G

I had to switch to wifi to log in, since google or twitter auth wasnt working on 3G - it would just hang on a white screen after putting in my info on Google. (This isnt an issue for us, though, since we use SSO only. Just pointing it out)

I went in to the discourse category and created a test post. First image upload didnt complete after 5 minutes, but the cancel button worked. Second image upload worked, and I posted my topic.

I went back to latest, and the topic was there, as well as at /categories. However, when selecting the “Discourse” category from the dropdown, my topic wasnt in the list. I could switch between Top, then back to Latest, and it still wasnt in there.

If I hit the main logo to go back to /Latest it was in that list, but choosing the “Discourse” category by clicking the badge in my post again loaded the stale /latest for the discourse category


(Jeff Atwood) #4

See if you can repro this on your iPhone @neil or @zogstrip.


(Jeff Atwood) #5

I do not think we were able to repro this. Are you still seeing issues?


(Neil Lalonde) #6

I can’t repro this problem. I followed the same steps, and saw my topic in all the lists.


(Jeff Atwood) #7