Ad blocker blocks ad plugin in admin. Disable ad blockers to fix

(Jeff Vienneau) #1

Just installed the advertising plugin and it does not seem to be working.

I am getting this when I navigate to admin plugins for house ads:

Network Error

while trying to load /admin/plugins/adplugin/house_ads.json

Please check your connection.

Basically, I added it to the app.yml and did the git pull & rebuild app step.

Am I missing something?

(Rafael dos Santos Silva) #2

Are you using any type of ad block extension?

4 Likes
(Jeff Vienneau) #3

I am but… would that block even the admin settings?

(Rafael dos Santos Silva) #4

As you just found out, they will.

4 Likes
(Jeff Vienneau) #5

Thanks. I’ll check after this rebuild finishes.

(Neil Lalonde) #6

It has “ads” in the url, so that’s enough for an ad blocker to block it. :laughing:

6 Likes
(Jeff Vienneau) #7

How crude!

That fixed it, thanks!

3 Likes
(Neil Lalonde) closed #8
#9

Thanks for adding this! I’m now trying to change from custom CSS to using this.

I’m getting a network error when opening the House Ads tab from the plugins page though.

Discourse Version: 2.2.5 (current stable version)
Force HTTPS: On
Using Cloudflare with their flexible SSL (attempted in development mode also, no firewall enabled). Tried with both www subdomain and non-www.

If I manually go to the json file specified in the error message below, it loads fine. Just get this error from opening the House Ads tab on the plugins page:

House Ads in the official Ad Plugin
House Ads in the official Ad Plugin
(David Taylor) #10

Try turning off your ad-blocker, then reload the page

6 Likes
#12

That fixed it! :heart: Thanks @david

2 Likes