/admin/upgrade Not updating "Checking for new version..."


(N3tNinj4) #1

My install at /admin/upgrade isn’t updating and just hangs for hours at “Checking for new version”:

Any help would be greatly appreciated.
Peace.


(Kane York) #2

That seems to imply it can’t contact Github. Try a container rebuild?


(N3tNinj4) #3

Thanks for your reply. Do you know of hand what ports it uses to contact Github and do they need to be open?
Thanks


(Jeff Atwood) #4

Is this our standard Docker install?


(N3tNinj4) #5

Yes, Ubuntu Server 14.04.1. I followed the most recent install guide exactly. I configured my own firewall with IPTables so I thought maybe I added a rule that’s conflicting because the only port incoming that is open is 80 (obviously). Does there need to be an incoming port open for updates?
Thanks.


(Sam Saffron) #6

try a rebuild

cd /var/discourse
git pull
./launcher rebuild app

(N3tNinj4) #7

The rebuild went well and everything is updated but when I go to check /admin/upgrade it still hangs at “Checking for new version…”


(Rodolfo) #8

@sam I’m having the same issue, it is stuck in Checking for new version...

screen cap #1 here
screen cap #2 bug


(Jeff Atwood) #9

See the post above yours. SSH in and do that at the command line.


(Rodolfo) #10

That worked.
Thanks.


(Joshua Madin) #11

Hello. This issue won’t disappear for me. I’ve had to SSH in and update as per Sam’s instructions (above) for the last 10 updates or so. We’re now on 1.3.0.beta1. When I get the new version emails, it would be great to just use the admin/upgrade functionality like I was before.

Any other thoughts on why this might keep happening?

(Other than this very minor inconvenience, everything is working great! We love discourse.)


(Jeff Atwood) #12

Are you on a standard Docker install? Have you modified anything about the install or the machine or the Docker image that is not listed in our install doc?


(Jim Ehrlich) #13

Running 1.2.0.beta4 on a plain cookbook docker installation on Digital Ocean. The Admin page of my site does not show an upgrade button, though it says an upgrade is available.

Clicking the link on the notification email tries to load http://discourse.mydomain/admin/upgrade which yields a blank page. Loading mydomain/admin/upgrade (without the ‘discourse.’) does get me an upgrade page from which I first had to upgrade docker_manager. Then I reloaded the page to un-gray-out the button for discourse, which is now upgraded successfully to 1.3.0.beta1.

Maybe there is a problem with building the upgrade URL?


(Sam Saffron) #14
cd /var/docker 
git pull
./launcher rebuild app

(Dylan) #15

The ping to find latest upgrade hasn’t seemed to of worked for me since beta8 > beta9 of 1.2

I usually wait a day or two after you guys announce an update before upgrading, but it wouldn’t show there is a new version, I just ssh in and do git pull to upgrade instead for the last couple of updates.