# Admin upgrade page is blank and /admin/plugins won't load either

**URL:** https://meta.discourse.org/t/admin-upgrade-page-is-blank-and-admin-plugins-wont-load-either/77055
**Category:** Support
**Created:** [Janvier 1, 2018, 2:35 UTC](https://meta.discourse.org/t/admin-upgrade-page-is-blank-and-admin-plugins-wont-load-either/77055 "2018-01-01T14:35:32Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Vespura](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/vespura/32/206564_2.png) [@Vespura](https://meta.discourse.org/u/Vespura)
#### Post date: [Janvier 1, 2018, 2:35 UTC](https://meta.discourse.org/t/admin-upgrade-page-is-blank-and-admin-plugins-wont-load-either/77055/1 "2018-01-01T14:35:32Z")

</div>

Continuing the discussion from [Cannot upgrade from admin interface](https://meta.discourse.org/t/cannot-upgrade-from-admin-interface/40766):

I have similar issues from the topic above, however there are some important differences, hence why I decided to create a new topic instead.

Anytime I have this plugin (linked below) installed the /admin/upgrade page just remains blank and I get the following errors in the browser log.

**Blank page screenshot**

> ![image](https://global.discourse-cdn.com/meta/original/3X/f/3/f365fc734c4984a1deff89c4804e9d7117dbd62e.jpg)

**Errors that appear in the browser console**

> [@](#):
>
> ```plaintext
> docker/repos Failed to load resource: the server responded with a status of 500 ()
> docker-manager-vendor-69993a285f235a9550dea5fbb48df8eb27cc48ffb65d68a942744a95ce673fb8.js:9 Error: Request was rejected due to server error
> at p.n (docker-manager-vendor-69993a285f235a9550dea5fbb48df8eb27cc48ffb65d68a942744a95ce673fb8.js:22)
> at new p (docker-manager-vendor-69993a285f235a9550dea5fbb48df8eb27cc48ffb65d68a942744a95ce673fb8.js:22)
> at i.handleResponse (docker-manager-vendor-69993a285f235a9550dea5fbb48df8eb27cc48ffb65d68a942744a95ce673fb8.js:22)
> at Object.e.error (docker-manager-vendor-69993a285f235a9550dea5fbb48df8eb27cc48ffb65d68a942744a95ce673fb8.js:22)
> at l (docker-manager-vendor-69993a285f235a9550dea5fbb48df8eb27cc48ffb65d68a942744a95ce673fb8.js:3)
> at Object.fireWith [as rejectWith] (docker-manager-vendor-69993a285f235a9550dea5fbb48df8eb27cc48ffb65d68a942744a95ce673fb8.js:3)
> at r (docker-manager-vendor-69993a285f235a9550dea5fbb48df8eb27cc48ffb65d68a942744a95ce673fb8.js:5)
> at XMLHttpRequest.<anonymous> (docker-manager-vendor-69993a285f235a9550dea5fbb48df8eb27cc48ffb65d68a942744a95ce673fb8.js:5)
> a @ docker-manager-vendor-69993a285f235a9550dea5fbb48df8eb27cc48ffb65d68a942744a95ce673fb8.js:9
> 
> ```

**The Plugin** that causes this works fine without any problems but it just prevents some admin pages from loading. The source to the plugin can be found here: [https://github.com/TomGrobbe/hide-devs-test](https://github.com/TomGrobbe/hide-devs-test)

**Plugins page**  
The /admin/plugins page also fails to load and it shows the following error on the screen:

> ![](https://global.discourse-cdn.com/meta/original/3X/d/f/dfd94daa2481214bde78465b936b3aff578a41ef.png)

I didn’t make the plugin myself, I copied it from another source. I’m not sure what’s wrong with it. If anyone can help me out/point me in the right direction when it comes to figuring out what I did wrong please let me know.

Thanks.

**EDIT** I forgot to mention that updating discourse using the `./launcher rebuild app` in the Linux terminal still works. It’s just the web pages that are broken. Also if this is in the wrong category, I’m sorry

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [Janvier 1, 2018, 7:34 UTC](https://meta.discourse.org/t/admin-upgrade-page-is-blank-and-admin-plugins-wont-load-either/77055/2 "2018-01-01T19:34:53Z")

</div>

> [@Vespura](#):
>
> The Plugin that causes this works fine without any problems but it just prevents some admin pages from loading.

Then the plugin is broken, remove it and rebuild.

---

<div class="post-metadata">

### Author: ![Vespura](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/vespura/32/206564_2.png) [@Vespura](https://meta.discourse.org/u/Vespura)
#### Post date: [Janvier 1, 2018, 8:20 UTC](https://meta.discourse.org/t/admin-upgrade-page-is-blank-and-admin-plugins-wont-load-either/77055/3 "2018-01-01T20:20:33Z")

</div>

Hmm that’s a shame, its only a few lines of code and I’m really not sure what’s wrong. Anyway thanks for the help.  
nvm figured it out. Messed up the file 🤦‍♂️

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [Janvier 1, 2018, 9:45 UTC](https://meta.discourse.org/t/admin-upgrade-page-is-blank-and-admin-plugins-wont-load-either/77055/4 "2018-01-01T21:45:04Z")

</div>


