Advanced search weird category behaviour


(Richard - DiscourseHosting.com) #1

When doing an advanced search, the category search filter behaves weird.

  1. when there are no results the category filter is ignored. This could be on purpose but it would make more sense to return no results.

  2. when you change the category filter, the old category re-appears in the search.

A screen capture shows it better than I will ever be able to describe. First issue at 0:18, second at 0:28.


(cpradio) #2

No, that isn’t what is happening, the default for searching a category is to include sub-categories now.

See

To limit it to only the parent category you have to use a new syntax of #=howto


(Joshua Rosenfeld) #3

To follow up on this, can the Advanced Search UI be updated to support this? Something like “Dont’s include subcategories” as a checkbox underneath the category box?


(Erlend Sogge Heggen) #4

Yeah, should probably include an option for this in Advanced search.

Also, we may want to consider spelling out the complete category hierarchy in search results, as we’re not as cramped for space here as we are in a topic list. See the top result:

That’d make it immediately clear that you are indeed still within the confines of the #howto category.


(Jeff Atwood) #5

Yeah you should amend advanced search UI to correct this @sam


(Sam Saffron) #6

Completed UX change per:

If we need another topic here to track the: should probably include an option for this in Advanced search, please create one @jomaxro and @erlend_sh


(Joshua Rosenfeld) #7

Topic created: Advanced Search UI option to "exclude subcategories"