Afatal: unable to access 'https://github.com/SamSaffron/pups.git/': Could not resolve host: github.com


(Fabian Heredia) #1

I am trying to rebuild my Discourse forum after changing app.yml, however it fails with

afatal: unable to access ‘GitHub - discourse/pups: Simple yaml based bootstrapper for Linux machines’: Could not resolve host: github.com
bf667edfd48e85444840c7a1255240c01bb11ff820a834e65308aabf0728c7e1 every single time.

I already rebooted, searched for updates and similar issues.

Running on Fedora 20, DigitalOcean SF1. Is there a way to updated ENV without rebuilding or a way to fix the github resolution?


Troubleshooting email on a new Discourse install
(Jeff Atwood) #2

It is simply a networking problem between you and GitHub of some kind.


(Sof) #3

Maybe you should have a look at my similar pb described here


(Tuan Anh Tran) #4

change your name servers in resolv.conf and you’re good to go


(Fabian Heredia) #5

Weird thing is that networking was fine, I was able to resolve and connect to remote hosts outside the launcher.

I destroyed the droplet and will start from zero.


How to configure ipv4 / ipv6 settings
(Liam McArdle) #6

I get the same problem. I am able to clone the repo directly, i.e. git clone GitHub - discourse/pups: Simple yaml based bootstrapper for Linux machines, however within launcher bootstrap app I get the same error. I am behind a proxy, which is configured in my machines .bash_profile and also configured in /etc/default/docker. Should I configure it somewhere else as well?


(Captainshar) #7

I just solved this error. Docker itself can’t resolve github.com, even though the server can (I could ping github.com and manually clone the repo).

Edit /etc/default/docker and uncomment this line:

DOCKER_OPTS="--dns 8.8.8.8 --dns 8.8.4.4"

This lets Docker use Google’s DNS.

Restart Docker:

service docker restart

Then try bootstrapping again.

I got to this solution from StackOverflow.


Unable to access github
Failed to Bootstrap Ping is working to github
Twitter auth not working (nginx bad gateway)
(Benjaminh) #9

Your solution doesn’t work for me :confused:
Also I configured my proxy both in /etc/default/docker and in systemd according to https://docs.docker.com/engine/admin/systemd/#httphttps-proxy

But still the same issue. This is quite frustrating


(Régis Hanol) #10

@captainshar’s answer is 3 year old… Docker Moby has changed a lot in that timeframe.


(Benjaminh) #11

Woops, didn’t realize the post was so old.
So should I start a new post ? Because I have this exact same issue although I’m using recent version of docker (17) and this guide https://github.com/discourse/discourse/blob/master/docs/INSTALL-cloud.md doesn’t seem outdated.


(Régis Hanol) #12

I was merely warning you that the solution might have changed.

If it’s the same issue, then I’d keep it in this topic.


(Mitchell Krog) #13

Thank you @captainshar that worked a treat, much obliged.


(John) #14

@captainshar answer worked for me too!. Had to reboot to fix ipv6 from kernel update and website received an Error 522. Tried to rebuild and receive the same error message. Thanks