# After a clean install : Sidekiq error

**URL:** https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387
**Category:** Bug
**Created:** [December 7, 2015, 12:06pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387 "2015-12-07T12:06:59Z")
**Posts on this page:** 19
**Page:** 1

<div class="post-metadata">

### Author: ![Alankrit\_Choudh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/alankrit_choudh/32/119698_2.png) [@Alankrit\_Choudh](https://meta.discourse.org/u/Alankrit_Choudh)
#### Post date: [December 7, 2015, 12:06pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/1 "2015-12-07T12:06:59Z")

</div>

I am using a linode 1gb ram setup

The installation/upgrade process goes clean but i get this error in [mysite.com/admin](http://mysite.com/admin) (dashboard)

 ![](https://global.discourse-cdn.com/meta/original/4X/a/8/b/a8b7e4fc2440dfd9292cb568c1c17a58cdf18a42.png)

---

<div class="post-metadata">

### Author: ![tgxworld](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/tgxworld/32/106117_2.png) [@tgxworld](https://meta.discourse.org/u/tgxworld)
#### Post date: [December 7, 2015, 12:11pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/2 "2015-12-07T12:11:30Z")

</div>

Can you post the full logs from `./launcher start yourapp`? Need more information to figure out what is going on 😉

---

<div class="post-metadata">

### Author: ![Alankrit\_Choudh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/alankrit_choudh/32/119698_2.png) [@Alankrit\_Choudh](https://meta.discourse.org/u/Alankrit_Choudh)
#### Post date: [December 7, 2015, 12:15pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/3 "2015-12-07T12:15:12Z")

</div>

i did ./launcher logs app  
and got this

```plaintext
run-parts: executing /etc/runit/1.d/00-ensure-links
run-parts: executing /etc/runit/1.d/anacron
run-parts: executing /etc/runit/1.d/cleanup-pids
Cleaning stale PID files
run-parts: executing /etc/runit/1.d/copy-env
run-parts: executing /etc/runit/1.d/ensure-web-nginx-read
Started runsvdir, PID is 29
sh: echo: I/O error
ok: run: redis: (pid 43) 0s
ok: run: postgres: (pid 42) 0s
rsyslogd: invalid or yet-unknown config file command 'KLogPermitNonKernelFacility' - have you forgotten to load a module? [try http://www.rsyslog.com/e/3003]
rsyslogd: warning: ~ action is deprecated, consider using the 'stop' statement instead [try http://www.rsyslog.com/e/2307]
43:M 07 Dec 11:56:08.479 * Redis 3.0.5 (00000000/0) 64 bit, standalone mode, port 6379, pid 43 ready to start.
43:M 07 Dec 11:56:08.483 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
43:M 07 Dec 11:56:08.484 # Server started, Redis version 3.0.5
43:M 07 Dec 11:56:08.484 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
Server listening on 0.0.0.0 port 22.
Server listening on :: port 22.
rsyslogd: Could no open output pipe '/dev/xconsole': No such file or directory [try http://www.rsyslog.com/e/2039]
2015-12-07 11:56:08 UTC [58-1] LOG: database system was shut down at 2015-12-07 11:54:41 UTC
2015-12-07 11:56:08 UTC [58-2] LOG: MultiXact member wraparound protections are now enabled
2015-12-07 11:56:08 UTC [42-1] LOG: database system is ready to accept connections
2015-12-07 11:56:08 UTC [62-1] LOG: autovacuum launcher started
43:M 07 Dec 11:56:08.664 * DB loaded from disk: 0.179 seconds
43:M 07 Dec 11:56:08.664 * The server is now ready to accept connections on port 6379
supervisor pid: 40 unicorn pid: 64
43:M 07 Dec 12:01:09.029 * 10 changes in 300 seconds. Saving...
43:M 07 Dec 12:01:09.029 * Background saving started by pid 8288
8288:C 07 Dec 12:01:09.176 * DB saved on disk
8288:C 07 Dec 12:01:09.177 * RDB: 1 MB of memory used by copy-on-write
43:M 07 Dec 12:01:09.230 * Background saving terminated with success
43:M 07 Dec 12:06:10.055 * 10 changes in 300 seconds. Saving...
43:M 07 Dec 12:06:10.056 * Background saving started by pid 15521
15521:C 07 Dec 12:06:10.262 * DB saved on disk
15521:C 07 Dec 12:06:10.262 * RDB: 1 MB of memory used by copy-on-write
43:M 07 Dec 12:06:10.357 * Background saving terminated with success
Shutting Down
run-parts: executing /etc/runit/3.d/01-nginx
ok: down: nginx: 0s, normally up
run-parts: executing /etc/runit/3.d/02-unicorn
exiting
ok: down: unicorn: 0s, normally up
run-parts: executing /etc/runit/3.d/10-redis
43:signal-handler (1449490107) Received SIGTERM scheduling shutdown...
43:M 07 Dec 12:08:27.075 # User requested shutdown...
43:M 07 Dec 12:08:27.081 * Saving the final RDB snapshot before exiting.
43:M 07 Dec 12:08:27.522 * DB saved on disk
43:M 07 Dec 12:08:27.524 # Redis is now ready to exit, bye bye...
ok: down: redis: 0s, normally up
run-parts: executing /etc/runit/3.d/99-postgres
2015-12-07 12:08:27 UTC [42-2] LOG: received smart shutdown request
2015-12-07 12:08:27 UTC [62-2] LOG: autovacuum launcher shutting down
2015-12-07 12:08:27 UTC [59-1] LOG: shutting down
2015-12-07 12:08:27 UTC [59-2] LOG: database system is shut down
ok: down: postgres: 1s, normally up
run-parts: executing /etc/runit/3.d/99-ssh
Received signal 15; terminating.
ok: down: sshd: 0s, normally up
run-parts: executing /etc/runit/1.d/00-ensure-links
run-parts: executing /etc/runit/1.d/anacron
run-parts: executing /etc/runit/1.d/cleanup-pids
Cleaning stale PID files
run-parts: executing /etc/runit/1.d/copy-env
run-parts: executing /etc/runit/1.d/ensure-web-nginx-read
Started runsvdir, PID is 21
sh: echo: I/O error
ok: run: redis: (pid 38) 0s
ok: run: postgres: (pid 35) 0s
rsyslogd: invalid or yet-unknown config file command 'KLogPermitNonKernelFacility' - have you forgotten to load a module? [try http://www.rsyslog.com/e/3003]
rsyslogd: warning: ~ action is deprecated, consider using the 'stop' statement instead [try http://www.rsyslog.com/e/2307]
38:M 07 Dec 12:08:45.187 * Redis 3.0.5 (00000000/0) 64 bit, standalone mode, port 6379, pid 38 ready to start.
rsyslogd: Could no open output pipe '/dev/xconsole': No such file or directory [try http://www.rsyslog.com/e/2039]
38:M 07 Dec 12:08:45.189 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
38:M 07 Dec 12:08:45.190 # Server started, Redis version 3.0.5
38:M 07 Dec 12:08:45.190 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
Server listening on 0.0.0.0 port 22.
Server listening on :: port 22.
2015-12-07 12:08:45 UTC [50-1] LOG: database system was shut down at 2015-12-07 12:08:27 UTC
2015-12-07 12:08:45 UTC [50-2] LOG: MultiXact member wraparound protections are now enabled
2015-12-07 12:08:45 UTC [35-1] LOG: database system is ready to accept connections
2015-12-07 12:08:45 UTC [54-1] LOG: autovacuum launcher started
38:M 07 Dec 12:08:45.396 * DB loaded from disk: 0.206 seconds
38:M 07 Dec 12:08:45.401 * The server is now ready to accept connections on port 6379
supervisor pid: 32 unicorn pid: 56
```

---

<div class="post-metadata">

### Author: ![Alankrit\_Choudh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/alankrit_choudh/32/119698_2.png) [@Alankrit\_Choudh](https://meta.discourse.org/u/Alankrit_Choudh)
#### Post date: [December 7, 2015, 1:37pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/4 "2015-12-07T13:37:37Z")

</div>

I am getting this with the latest update! on a Digital ocean 2GB cloud as well.  
Updated discourse via ./launcher rebuild app

---

<div class="post-metadata">

### Author: ![Alankrit\_Choudh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/alankrit_choudh/32/119698_2.png) [@Alankrit\_Choudh](https://meta.discourse.org/u/Alankrit_Choudh)
#### Post date: [December 7, 2015, 4:07pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/5 "2015-12-07T16:07:01Z")

</div>

Here is my latest update version

 ![](https://global.discourse-cdn.com/meta/original/4X/8/d/6/8d6c7e41febfd7df5b0bda935d32ec5e3fbf126c.png)

---

<div class="post-metadata">

### Author: ![cpradio](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cpradio/32/4970_2.png) [@cpradio](https://meta.discourse.org/u/cpradio)
#### Post date: [December 7, 2015, 4:21pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/6 "2015-12-07T16:21:47Z")

</div>

What plugins do you have installed?

---

<div class="post-metadata">

### Author: ![Alankrit\_Choudh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/alankrit_choudh/32/119698_2.png) [@Alankrit\_Choudh](https://meta.discourse.org/u/Alankrit_Choudh)
#### Post date: [December 7, 2015, 4:23pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/7 "2015-12-07T16:23:39Z")

</div>

![](https://global.discourse-cdn.com/meta/original/4X/6/e/4/6e45a4d2daec88ec778e0b67d0186612973c36fb.png)  
@cpradio  
 ![](https://global.discourse-cdn.com/meta/original/4X/d/6/1/d61c41b37b93f9d4fc6d730590408bb3a2deccb9.png)  
This is the new one after i removed every plugin except discourse tagging, still getting the same issue with sidekiq

---

<div class="post-metadata">

### Author: ![cpradio](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cpradio/32/4970_2.png) [@cpradio](https://meta.discourse.org/u/cpradio)
#### Post date: [December 7, 2015, 4:57pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/8 "2015-12-07T16:57:39Z")

</div>

Okay, that makes me feel better. I couldn’t see anything with the plugins you listed that would denote any issues, but I wasn’t sure.

---

<div class="post-metadata">

### Author: ![Alankrit\_Choudh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/alankrit_choudh/32/119698_2.png) [@Alankrit\_Choudh](https://meta.discourse.org/u/Alankrit_Choudh)
#### Post date: [December 7, 2015, 5:00pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/9 "2015-12-07T17:00:50Z")

</div>

I guess this is a new update bug?

---

<div class="post-metadata">

### Author: ![cpradio](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cpradio/32/4970_2.png) [@cpradio](https://meta.discourse.org/u/cpradio)
#### Post date: [December 7, 2015, 5:04pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/10 "2015-12-07T17:04:46Z")

</div>

Maybe, as it works on +94. Give me 30 minutes to upgrade and we’ll find out!

---

<div class="post-metadata">

### Author: ![cpradio](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cpradio/32/4970_2.png) [@cpradio](https://meta.discourse.org/u/cpradio)
#### Post date: [December 7, 2015, 5:17pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/11 "2015-12-07T17:17:35Z")

</div>

Seems okay to me

 ![](https://global.discourse-cdn.com/meta/original/3X/0/3/034353b8ebd7cc507eaf220729dc142f85ec56a9.png)

Visiting /sidekiq works too.

My instances has literally zero activity though.

---

<div class="post-metadata">

### Author: ![bogdan](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/bogdan/32/122062_2.png) [@bogdan](https://meta.discourse.org/u/bogdan)
#### Post date: [December 7, 2015, 5:20pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/12 "2015-12-07T17:20:55Z")

</div>

I also get this after upgrading a few minutes ago:

 ![](https://global.discourse-cdn.com/meta/original/3X/f/e/fe4cbae348ddf4d03e5a718a95630b3fd634b242.png)

Visiting /sidekiq works

---

<div class="post-metadata">

### Author: ![Yuun](https://avatars.discourse-cdn.com/v4/letter/y/977dab/32.png) [@Yuun](https://meta.discourse.org/u/Yuun)
#### Post date: [December 7, 2015, 5:23pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/13 "2015-12-07T17:23:34Z")

</div>

I’m getting this on my server as well (on commit fa66878 from this morning). /sidekiq is still there, but jobs are queueing up without being completed.

@codinghorror, @eviltrout (sorry not sure who on the team handles this sort of thing), just want to make sure you guys know this isn’t just a new installation issue. If the categories page is any indication, it’s happening here on Meta as well.

---

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [December 7, 2015, 6:16pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/14 "2015-12-07T18:16:49Z")

</div>

So thats why latest page on meta doesn’t update participants pictures!

---

<div class="post-metadata">

### Author: ![Alankrit\_Choudh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/alankrit_choudh/32/119698_2.png) [@Alankrit\_Choudh](https://meta.discourse.org/u/Alankrit_Choudh)
#### Post date: [December 7, 2015, 7:32pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/15 "2015-12-07T19:32:47Z")

</div>

Did any one get a fix for this?

---

<div class="post-metadata">

### Author: ![eviltrout](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/eviltrout/32/5275_2.png) [@eviltrout](https://meta.discourse.org/u/eviltrout)
#### Post date: [December 7, 2015, 7:34pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/16 "2015-12-07T19:34:05Z")

</div>

I’m looking into it right now.

---

<div class="post-metadata">

### Author: ![eviltrout](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/eviltrout/32/5275_2.png) [@eviltrout](https://meta.discourse.org/u/eviltrout)
#### Post date: [December 7, 2015, 8:12pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/17 "2015-12-07T20:12:10Z")

</div>

Okay looks like a recent commit broke a forked version of sidekiq.

I’ve reverted the commit and it’s working again now on `tests-passed`. The commit will be fixed before being un-reverted.

---

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [December 7, 2015, 8:17pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/18 "2015-12-07T20:17:01Z")

</div>

My bad… I renamed a bunch of files and forgot one spot:

[https://github.com/discourse/discourse/commit/a3ba564b03c3390de9761787f479fb81dda03c34](https://github.com/discourse/discourse/commit/a3ba564b03c3390de9761787f479fb81dda03c34)

Apologies

---

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [December 7, 2015, 8:17pm UTC](https://meta.discourse.org/t/after-a-clean-install-sidekiq-error/36387/19 "2015-12-07T20:17:05Z")

</div>


