# After initial setup of DigitalOcean droplet, get Refused to Connect error

**URL:** https://meta.discourse.org/t/after-initial-setup-of-digitalocean-droplet-get-refused-to-connect-error/45002
**Category:** Self-hosting
**Created:** [30.Май.2016 17:37:47 UTC](https://meta.discourse.org/t/after-initial-setup-of-digitalocean-droplet-get-refused-to-connect-error/45002 "2016-05-30T17:37:47Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![bolemk](https://avatars.discourse-cdn.com/v4/letter/b/7bcc69/32.png) [@bolemk](https://meta.discourse.org/u/bolemk)
#### Post date: [30.Май.2016 17:37:48 UTC](https://meta.discourse.org/t/after-initial-setup-of-digitalocean-droplet-get-refused-to-connect-error/45002/1 "2016-05-30T17:37:48Z")

</div>

I have followed the tutorial found below to set up discourse on a DigitalOcean Droplet.

[discourse/docs/INSTALL-cloud.md at main · discourse/discourse · GitHub](https://github.com/discourse/discourse/blob/master/docs/INSTALL-cloud.md)

But when I go the the corresponding IP address, I get

```
"""This site can’t be reached
192.241. ***.*** refused to connect."""

```

What are the possible reasons for a refused to connect error? Could this be related to SSL certificates?

Thanks!  
Ben

---

<div class="post-metadata">

### Author: ![DeanMarkTaylor](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/deanmarktaylor/32/102462_2.png) [@DeanMarkTaylor](https://meta.discourse.org/u/DeanMarkTaylor)
#### Post date: [30.Май.2016 18:01:45 UTC](https://meta.discourse.org/t/after-initial-setup-of-digitalocean-droplet-get-refused-to-connect-error/45002/3 "2016-05-30T18:01:45Z")

</div>

Those instructions don’t include SSL setup so unless you have done something extra - probably not an SSL issue.

The most common setup to complete is for a “domain name” not an IP address…  
… I would suggest starting again following the instructions and using a domain name from a domain you control / own.

---

<div class="post-metadata">

### Author: ![lucasbasquerotto](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/lucasbasquerotto/32/133376_2.png) [@lucasbasquerotto](https://meta.discourse.org/u/lucasbasquerotto)
#### Post date: [26.Июнь.2019 23:53:05 UTC](https://meta.discourse.org/t/after-initial-setup-of-digitalocean-droplet-get-refused-to-connect-error/45002/4 "2019-06-26T23:53:05Z")

</div>

Just to point out something that happened to me. I used a testing server whose setup is entirely done by ansible, and after I use the site, I destroy it (ansible handles the destruction of the droplets, digital ocean spaces and so on, so that I’m not charged when not using).

What happened is that LetsEncrypt have **rate limits** , and my domain exceeded, so I started receiving the error that the page couldn’t be reached and it was a bit hard to track the reason to the rate limit of certificates (first I thought should be something about IPv6 or SSL + IPv6).

Running `./launcher logs app` I saw a huge number of errors, basically saying:

```
nginx: [emerg] cannot load certificate "/shared/ssl/mydomain.com.cer": PEM_read_bio_X509_AUX() failed (SSL: error:0906D06C:PEM routines:PEM_read_bio:no start line:Expecting: TRUSTED CERTIFICATE)

```

lots and lots of times…

In the very beggining of the logs (thankfully the number of lines to be displayed in the terminal was not exceeded) there was the reason:

```
Create new order error. Le_OrderFinalize not found. {
  "type": "urn:ietf:params:acme:error:rateLimited",
  "detail": "Error creating new order :: too many certificates already issued for exact set of domains: mydomain.com: see https://letsencrypt.org/docs/rate-limits/",
  "status": 429
}

```

So for anyone that face it in the future, make sure to not exceed the rate limit (in my case, for these test sites that I create several times per week, I can just not use ssl to avoid this problem).

---

<div class="post-metadata">

### Author: ![Jack51](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jack51/32/201652_2.png) [@Jack51](https://meta.discourse.org/u/Jack51)
#### Post date: [01.Январь.2021 19:46:21 UTC](https://meta.discourse.org/t/after-initial-setup-of-digitalocean-droplet-get-refused-to-connect-error/45002/5 "2021-01-01T19:46:21Z")

</div>

Спасибо, Лукас — это меня спасло.

«Исправил», закомментировав два SSL-шаблона в файле конфигурации приложения и пересобрав его. Всё ещё придётся попытаться получить новый сертификат через 7 дней.
