# After Rebuild got error: postgres:10/main, Causes CPU to go high

**URL:** https://meta.discourse.org/t/after-rebuild-got-error-postgres-10-main-causes-cpu-to-go-high/214307
**Category:** Self-hosting
**Tags:** server-resources
**Created:** [January 9, 2022, 4:49pm UTC](https://meta.discourse.org/t/after-rebuild-got-error-postgres-10-main-causes-cpu-to-go-high/214307 "2022-01-09T16:49:20Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![hokod](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/hokod/32/239410_2.png) [@hokod](https://meta.discourse.org/u/hokod)
#### Post date: [January 9, 2022, 4:49pm UTC](https://meta.discourse.org/t/after-rebuild-got-error-postgres-10-main-causes-cpu-to-go-high/214307/1 "2022-01-09T16:49:20Z")

</div>

I use htop command,  
I noticed the CPU goes too high.  
I get the error: postgres: 10/main  
How to handle this error?

 ![image](https://global.discourse-cdn.com/meta/original/3X/0/6/0659bd214b79738a25acede5486df5052e0015d7.png)

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [January 10, 2022, 9:44pm UTC](https://meta.discourse.org/t/after-rebuild-got-error-postgres-10-main-causes-cpu-to-go-high/214307/2 "2022-01-10T21:44:15Z")

</div>

I think that PG 10 is no longer supported. See [PostgreSQL 13 update](https://meta.discourse.org/t/postgresql-13-update/172563).

But if you did an upgrade and didn’t get an error, then it’s probably OK (but you should upgrade to PG13). The PG13 upgrade was pushed because it improves some performance issues that might include the one that you’re seeing.

---

<div class="post-metadata">

### Author: ![supermathie](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/supermathie/32/507518_2.png) [@supermathie](https://meta.discourse.org/u/supermathie)
#### Post date: [January 10, 2022, 9:51pm UTC](https://meta.discourse.org/t/after-rebuild-got-error-postgres-10-main-causes-cpu-to-go-high/214307/3 "2022-01-10T21:51:06Z")

</div>

This is not, strictly speaking, an error. But a large is running which may be a scheduled job or migration.

Regardless, this is a good suggestion:

> [@pfaffman](#):
>
> I think that PG 10 is no longer supported. See [PostgreSQL 13 update](https://meta.discourse.org/t/postgresql-13-update/172563).

I would allow it some time to settle after the upgrade; you do have a lot of CPU still available. After it settles down, back up your data and go through the update procedure, it’ll likely increase performance.

---

<div class="post-metadata">

### Author: ![hokod](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/hokod/32/239410_2.png) [@hokod](https://meta.discourse.org/u/hokod)
#### Post date: [January 11, 2022, 10:02pm UTC](https://meta.discourse.org/t/after-rebuild-got-error-postgres-10-main-causes-cpu-to-go-high/214307/4 "2022-01-11T22:02:58Z")

</div>

I guess so, and that’s why I want to stop Jobs::PeriodicalUpdates ([Jobs::PeriodicalUpdates is the cause of high CPU (over 100%) - #7 by hokod](https://meta.discourse.org/t/jobs-periodicalupdates-is-the-cause-of-high-cpu-over-100/214291/7))
