# 更新后，网站无法打开，并且备份数据库未加载

**URL:** https://meta.discourse.org/t/after-the-update-the-site-did-not-open-and-the-backup-database-was-not-loaded/295786
**Category:** Self-hosting
**Created:** [2024年二月18日 12:58 UTC](https://meta.discourse.org/t/after-the-update-the-site-did-not-open-and-the-backup-database-was-not-loaded/295786 "2024-02-18T12:58:13Z")
**Posts on this page:** 1
**Showing post:** 5

<div class="post-metadata">

### Author: ![kuaza](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kuaza/32/264151_2.png) [@kuaza](https://meta.discourse.org/u/kuaza)
#### Post date: [2024年二月19日 17:08 UTC](https://meta.discourse.org/t/after-the-update-the-site-did-not-open-and-the-backup-database-was-not-loaded/295786/5 "2024-02-19T17:08:01Z")

</div>

运行此命令时，它似乎在工作，但实际上问题在于 Web 服务器未正常运行，我们无法以此方式理解。当我们进入容器并运行此代码时，我们可以看到 nginx 是否正在运行：

```plaintext
nginx -t

```

但是，我想通过复制您消息中的解决方案来回答此主题中的问题。nginx 问题完全不同，我正在一个具有全新安装的独立域上进行测试。如果再次出现错误，我将打开一个单独的问题并进行报告。

主题中备份无法工作的根本原因是某个不再使用的表或记录。我认为这是聊天机器人插件不再使用的记录，但在更新过程中并未删除。我认为插件作者朋友已经解决了这个问题，您可以放心 🙂 我删除了错误行，重新打包并从管理员面板安装，它运行正常。或者您也可以从服务器下载：

**解释如何修复损坏的插件文件：**

- 解压备份：`tar -xvzf foo.tar.gz`
- 解压 dump.sql 文件
- 删除构建不需要索引的错误行：

```plaintext
--
-- TOC entry 8020 (class 1259 OID 84313)
-- Name: hnsw_index_on_chatbot_post_embeddings; Type: INDEX; Schema: public; Owner: -
--

CREATE INDEX hnsw_index_on_chatbot_post_embeddings ON public.chatbot_post_embeddings_old USING hnsw (embedding) WITH (dims='1536', m='64', efconstruction='64', efsearch='64');

```

- 重新压缩 dump.sql 文件
- 将其与您的 uploads 文件夹放在同一个目录中
- 将整个内容重新打包
- 手动恢复此文件

* * *

如果出现不同表的错误，我认为通过上述方法删除包含该记录的表即可解决。

我辛辛苦苦建立并开始发展的网站停运了两天。别忘了还有不眠之夜和白天。我们总有可能发生此类事件。不要忘记进行备份并检查备份是否正常工作。我想感谢我的兄弟 @merefield 在此过程中帮助了我。我们一起学到了新东西。

---

_[View the full topic](https://meta.discourse.org/t/after-the-update-the-site-did-not-open-and-the-backup-database-was-not-loaded/295786)._
