After update to version 1.1.0.beta2 banner shows [missing %{posts} value]


(lid) #1

The issue

After I upgraded I noticed an issue with the banner message similar to the topic linked below

Continuing the discussion from [missing %{posts} value]:

Also I am not sure why the indicated version commit id is:
4b46bf5438e147865df20f032f841003a25a68fe

but my instance indicate that I am on
f95611aba10d505d4513a51e8afd98080521104e

###And what is this about?


(cpradio) #2

Jokingly:

@codinghorror got mad and threw the table?


(Robin Ward) #3

This is very weird, because I tried with the beta branch locally and don’t see either of these things?


(lid) #4

This is what I think went wrong.

I tried to upgrade couple times with around 1GB memory and no swap. I wanted to make sure it fails I didn’t want to restart the machine. then finally when I saw the error is consistent, I shutdown the machine and allocated 2GB

At this point I am not sure if I actually pressed the update button again and that previous attempt failed but registered as success after restarting. I am not sure what is the likelihood of that.

or I clicked update and for some reason previous failed attempts affected the last successful attempt.

This what helped me fix it locally.

git pull 
rake assets:precompile
rake db:migrate

And there are no logs saved for the update / upgrade process as far as i can tell.