# AI module does not take proxy settings

**URL:** https://meta.discourse.org/t/ai-module-does-not-take-proxy-settings/311913
**Category:** Self-hosting
**Tags:** ai
**Created:** [June 13, 2024, 1:09pm UTC](https://meta.discourse.org/t/ai-module-does-not-take-proxy-settings/311913 "2024-06-13T13:09:07Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![peyrusse](https://avatars.discourse-cdn.com/v4/letter/p/8dc957/32.png) [@peyrusse](https://meta.discourse.org/u/peyrusse)
#### Post date: [June 13, 2024, 1:09pm UTC](https://meta.discourse.org/t/ai-module-does-not-take-proxy-settings/311913/1 "2024-06-13T13:09:07Z")

</div>

Hello,

i have an intranet installation and i use the AI extension.

I have set up configuration from docker so that proxy settings are passed to my container when it runs. I can check for instance Discourse update and they appear and i can apply them. So from Discourse the proxy settings are correctly passed otherwise it should not work.

The problem is that requests from the AI module are failing and i feel that this module does not take at all my proxy settings. All request does not pass the proxy and fails …

As anyone one experiencing this problem ?  
Any help would be great !!  
Thanks.

---

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [June 13, 2024, 3:45pm UTC](https://meta.discourse.org/t/ai-module-does-not-take-proxy-settings/311913/2 "2024-06-13T15:45:44Z")

</div>

Are you running the models yourself on the intranet in another server? Or are those calls to third parties outside your network? If so, which sites?

---

<div class="post-metadata">

### Author: ![peyrusse](https://avatars.discourse-cdn.com/v4/letter/p/8dc957/32.png) [@peyrusse](https://meta.discourse.org/u/peyrusse)
#### Post date: [June 25, 2024, 10:06am UTC](https://meta.discourse.org/t/ai-module-does-not-take-proxy-settings/311913/3 "2024-06-25T10:06:20Z")

</div>

Mainely inside on an intranet server …

If often have these errors :

- Job exception: FinalDestination: all resolved IPs were disallowed
- Job exception: FinalDestination: lookup failed
