Amazon onebox still failing on my discourse instance on Digitalocean


(Non-technical User) #1

Continuing the discussion from Amazon onebox fails on my site, but works here:

I have this problem of Amazon.com, Amazon.fr and Amazon.in not oneboxing on my discourse instance on DO though it works well here on meta.

On searching I found this topic but see there has been a bug fix but it doesn’t seem to work in my case. When I do curl to amazon.com it shows 301 redirect and when I do curl to a amazon.com product link it returns blank.


(Alan Tan) #2

Have you updated to the latest version of Discourse?


#3

Hi, I also have the same problem. I am running latest version of discourse and hosted at digitaloean. I get 404 error when oneboxing amazon, slideshare links.


(Non-technical User) #4

Yes, I have updated to the latest discourse version. There’s a problem between DO and Amazon.com I guess.


(Jeff Atwood) #5

Perhaps your server’s DNS is broken or non-functional, somehow? Or Amazon is blocking all DO IP ranges?


(Non-technical User) #6

If DNS is broken, would it not mean other sites will also fail to be oneboxed? That is not the case. So I suspect Amazon is somehow blocking DO.


(Jeff Atwood) #7

Maybe, but I just tested on my DO droplet Discourse site at discourse.codinghorror.com and Amazon oneboxes work fine there.


(Régis Hanol) #8

Also, are you testing the same URL over and over again or are you trying to onebox different URLs every time? This might be a cache issue too.


(Non-technical User) #9

I have tried different URLs. From Amazon.com, .fr, .in all of them fail to Onebox. I also tried a amazon “pure url” - one that’s stripped of all parameters and tokens passed in the URL, doesn’t work.

Is there anything else I need do check on my droplet? it is in singapore. And oh, am using cloudflare!


#10

Hi,
I discussed the same with digitalocean team, but they are saying there is no problem with DNS servers. I get the following output when I try to curl the slideshare url.

HTTP/1.1 999 Request denied
Date: Sat, 14 May 2016 05:39:07 GMT
X-Li-Pop: prod-lva1
Content-Length: 1629
Content-Type: text/html

And Amazon is giving a MethodNotAllowed error.


(Non-technical User) #11

Yes, now i remember, slideshare too has been a problem. SMT, do you use cloudflare? And where is your droplet hosted geographically?


#12

I am not using a cloudfare and my droplet is hosted at NYC.